Putting cyrus-future code in CVS. Also, code style

2010-06-27 Thread Bron Gondwana
Hi All, I'm going to start pushing all my cyrus-future code in to CVS over the next couple of days - so expect pretty massive commits! Also, a question about coding style. Is it codified somewhere? There are a few different styles throughout the code, but there seems to be a fairly consistent st

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-28 Thread Ken Murchison
I think the style is mixed because of different authors and different editors. Is isn't written down anywhere, but I agree that we should just stick with the most prevalent existing style. Bron Gondwana wrote: Hi All, I'm going to start pushing all my cyrus-future code in to CVS over the ne

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-28 Thread Matt Selsky
We should document the rules for the prevalent style and put it in the wiki. Who can do that? (time and access-wise) On Jun 28, 2010, at 9:30 AM, Ken Murchison wrote: > I think the style is mixed because of different authors and different > editors. Is isn't written down anywhere, but I ag

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-28 Thread Bron Gondwana
On Mon, Jun 28, 2010 at 11:59:54AM -0400, Matt Selsky wrote: > We should document the rules for the prevalent style and put it in the wiki. > Who can do that? (time and access-wise) Also, the file doc/internal/hacking in CVS should probably include the rules. Off the top of my head: * spacing

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-28 Thread Wesley Craig
On 28 Jun 2010, at 18:21, Bron Gondwana wrote: Parantheses cuddle close This is not how I write C (as you know...), tho I recognize that the majority of Cyrus is written this way. I also "over space" statements like: HASH || DASH because I've been burned trying to find cases whe

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-28 Thread Bron Gondwana
On Mon, Jun 28, 2010 at 08:55:57PM -0400, Wesley Craig wrote: > On 28 Jun 2010, at 18:21, Bron Gondwana wrote: > >Parantheses cuddle close > > This is not how I write C (as you know...), tho I recognize that the > majority of Cyrus is written this way. Yeah, I know. That's what I'm having a whin

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-29 Thread Patrick Goetz
Bron Gondwana wrote: > Also, a question about coding style. Is it codified somewhere? > There are a few different styles throughout the code, but there > seems to be a fairly consistent style in most of the code. > Having spent many hours recently looking over Cyrus C/perl code (and not having h

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-29 Thread Patrick Goetz
Wesley Craig wrote: >> * braces are optional if meaning is clear >> if (foo) >> function(); >> else >> other_function(); > > Personally, I always include the brace, with the exception of > one-liners, e.g.: > Perl requires the use of braces no matter what, and after years of coding pe

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-29 Thread Patrick Goetz
Bron Gondwana wrote: > > How do you feel about: > > if (a) function_one(a); > else function_two(); > This is hard to read. My rule is one liner only if it's really a one liner. Otherwise: if (a) { function_one(a); } else {function_two();} is a reasonable compromise between brevity

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-29 Thread Bron Gondwana
On Tue, 29 Jun 2010 12:22 -0500, "Patrick Goetz" wrote: > Bron Gondwana wrote: > > Also, a question about coding style. Is it codified somewhere? > > There are a few different styles throughout the code, but there > > seems to be a fairly consistent style in most of the code. > > > > Having spe

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-29 Thread Bron Gondwana
On Tue, 29 Jun 2010 12:43 -0500, "Patrick Goetz" wrote: > Bron Gondwana wrote: > > > > How do you feel about: > > > > if (a) function_one(a); > > else function_two(); > > > > This is hard to read. My rule is one liner only if it's really a one > liner. Otherwise: > > if (a) > { >

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-29 Thread Wesley Craig
On 29 Jun 2010, at 21:13, Bron Gondwana wrote: I think we're bikeshedding here. Let's codify what's there rather than trying to invent out favourite style. I don't know what bikeshedding is, but I understood defining what's here to be the exercise. In limited cases it might make sense to

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-29 Thread Wesley Craig
On 28 Jun 2010, at 21:35, Bron Gondwana wrote: HASH || DASH Agreed. Spacing around double bars is correct IMHO. HASH|DASH And no sparcing around single bars. I'm happy with that. I'd say space around | and ||, both. Similarly, space around mathematical operators. Ye

Re: Putting cyrus-future code in CVS. Also, code style

2010-06-29 Thread Bron Gondwana
On Tue, 29 Jun 2010 22:09 -0400, "Wesley Craig" wrote: > On 29 Jun 2010, at 21:13, Bron Gondwana wrote: > > I think we're bikeshedding here. Let's codify what's there rather > > than > > trying to invent out favourite style. > > I don't know what bikeshedding is, but I understood defining what