On Thu, 13 Jun 2002, Tim Bunce wrote:
>
>Don't forget that all driver-private attribute and functions should
>start with the driver prefix. So backend_pid should be called pg_backend_pid

1. Just to double check, is this correct?

    $dbh->func(  $some_flags
              ,  { $NO_PREFIX_attr_name => 3 }
              ,  $PREFIX_function_name
              );

    $dbh->{ $PREFIX_attr_name }; # use sparingly

    $dbh = DBI->connect(
        "dbi:...$NO_PREFIX_attr",...,{$PREFIX_attr}
     );

Or would it be cleaner to name even the truly private $NO_PREFIX 
attributes with the prefix as well?

2. Can we add sql_ as a prefix.  It could be used for SQL::Statement 
related settings that might get set from a variety of DBDs.

-- 
Jeff

Reply via email to