Re: Gstreamer e DCCP: issues related to ccid-3

2007-10-31 Thread Łeandro Sales
2007/10/25, Ian McDonald <[EMAIL PROTECTED]>: > On 10/25/07, Gerrit Renker <[EMAIL PROTECTED]> wrote: > > /* something like (but do have a look at the paraslash sources) > > do { > > wrote = send (socket, (const char *) buf + bytes_written, > > count - bytes

[PATCH 23/25] Include ccid-4 to be visible for the DCCP feature negotiation mechanism

2007-10-31 Thread Leandro
[CCID-4] Include ccid-4 to be visible for the DCCP feature negotiation mechanism This patch follow instructions announced by Gerrit and explained in http://www.mail-archive.com/dccp@vger.kernel.org/msg02613.html Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/include

[PATCH 24/25] Final adjustments to probe.c to use tfrc_ccids

2007-10-31 Thread Leandro
[DCCP] Final adjustments to probe.c to use ccid34_lib According to the chosen strategy explained in [PATCH 15/25], some defines become unnecessary. This patch removes them and adjusts probe.c to use ccid34_lib definitions directly Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index:

[PATCH 22/25] Minor adjustments to probe.c to use tfrc_ccids

2007-10-31 Thread Leandro
[DCCP] Minor adjustments to probe.c to use ccid34_lib This will also facilitate the implementation of ccid-4 debug. Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/probe.c === --- leandro.new.ori

[PATCH 21/25] Share ccid3_rx_state_name function via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share ccid3_rx_state_name function via tfrc_ccids Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid3.c === --- leandro.new.orig/net/dccp/ccids/ccid3.c +++ leandro.new/net/dccp/

[PATCH 18/25] Share rfc3390_initial_rate function via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share rfc3390_initial_rate function via tfrc_ccids Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid3.c === --- leandro.new.orig/net/dccp/ccids/ccid3.c +++ leandro.new/net/dccp

[PATCH 19/25] Share ccid3_hc_tx_idle_rtt function via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share ccid3_hc_tx_idle_rtt function via tfrc_ccids Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid3.c === --- leandro.new.orig/net/dccp/ccids/ccid3.c +++ leandro.new/net/dccp

[PATCH 20/25] Share ccid3_hc_tx_update_win_count function via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share ccid3_hc_tx_update_win_count function via tfrc_ccids Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid3.c === --- leandro.new.orig/net/dccp/ccids/ccid3.c +++ leandro.new/

[PATCH 16/25] Share ccid3_hc_rx_sock struct and ccid3_hc_rx_sk function via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share ccid3_hc_rx_sock and ccid3_hc_rx_sk via tfrc_ccids ccid3_hc_rx_sock is now tfrc_hc_rx_sock ccid3_hc_rx_sk is now tfrc_hc_rx_sk Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/lib/tfrc_ccids.h

[PATCH 17/25] Share ccid3_tx_state_name function via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share ccid3_tx_state_name function via tfrc_ccids ccid3_tx_state_name is now tfrc_tx_state_name Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid3.c === --- leandro.new.orig/n

[PATCH 14/25] Basic implementation for ccid-4 dropped packet option

2007-10-31 Thread Leandro
[CCID-4] Basic implementation for ccid-4 dropped packet option as per ccid-4 draft Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/lib/tfrc_ccids.h === --- leandro.new.orig/net/dccp/ccids/l

[PATCH 15/25] Share ccid3_hc_tx_sock struct and ccid3_hc_tx_sk function via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share ccid3_hc_tx_sock struct and ccid3_hc_tx_sk function via tfrc_ccids ccid3_hc_tx_sock is now tfrc_hc_tx_sock ccid3_hc_tx_sk is now tfrc_hc_tx_sk Since it is a big change, I adopted the strategy of change the ccid-3 and ccid-4 coding by phases, and for each phase have the ccid-3 a

[PATCH 10/25] Share ccid-3 options enum and struct via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share ccid-3 options enum and struct via tfrc_ccids Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.c === --- leandro.new.orig/net/dccp/ccids/ccid4.c +++ leandro.new/net/dcc

[PATCH 13/25] Share TFRC feedback types struct via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share TFRC feedback types struct via tfrc_ccids Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid3.c === --- leandro.new.orig/net/dccp/ccids/ccid3.c +++ leandro.new/net/dccp/cc

[PATCH 11/25] Share TFRC sender states via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share TFRC sender states via tfrc_ccids Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid3.c === --- leandro.new.orig/net/dccp/ccids/ccid3.c +++ leandro.new/net/dccp/ccids/ccid

[PATCH 12/25] Share TFRC receiver states via tfrc_ccids

2007-10-31 Thread Leandro
[CCID-3/4] Share TFRC receiver states via tfrc_ccids Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.c === --- leandro.new.orig/net/dccp/ccids/ccid4.c +++ leandro.new/net/dccp/ccids/cc

[PATCH 8/25] Share common header files and defines between ccid-3/ccid-4

2007-10-31 Thread Leandro
[CCID-3/4] Share common header files between ccid-3/ccid-4 Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.h === --- leandro.new.orig/net/dccp/ccids/ccid4.h +++ leandro.new/net/dccp/cc

[PATCH 9/25] Adapt CCID-4 according to the latest changes to CCID-3

2007-10-31 Thread Leandro
[CCID-4] Adapt CCID-4 according to the latest changes to CCID-3 Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.c === --- leandro.new.orig/net/dccp/ccids/ccid4.c +++ leandro.new/net/dc

[PATCH 7/25] Initial lib for sharing common code between ccid-3/ccid-4

2007-10-31 Thread Leandro
[CCID-3/4 lib] Initial lib for sharing common code between ccid-3/ccid-4 The lib is called tfrc_ccids.o Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/lib/Makefile === --- leandro.new.orig

[PATCH 5/25] Enforces a minimum interval of 10 milliseconds as per CCID-4 draft

2007-10-31 Thread Leandro
[CCID-4] Enforces a minimum interval of 10 milliseconds as per CCID-4 draft Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Signed-off-by: Tommi Saviranta <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.c === ---

[PATCH 6/25] Reduce allowed sending rate by a factor that accounts for packet header size

2007-10-31 Thread Leandro
[CCID-4] Reduce allowed sending rate by a factor that accounts for packet header size Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Signed-off-by: Tommi Saviranta <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.c

[PATCH 3/25] Adjustments of the ccid-4 copyright and kernel module authors

2007-10-31 Thread Leandro
[CCID-4] Adjustments of the ccid-4 copyright and kernel module authors Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Signed-off-by: Tommi Saviranta <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.c === --- lean

[PATCH 4/25] Set packet size to 1460 as per ccid-4 draft

2007-10-31 Thread Leandro
[CCID-4] Set packet size to 1460 as per ccid-4 draft Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Signed-off-by: Tommi Saviranta <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.c === --- leandro.new.orig/net/d

[PATCH 1/25] CCID-4 Kconfig and Makefile

2007-10-31 Thread Leandro
[CCID-4] CCID-4 Kconfig and Makefile Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Signed-off-by: Tommi Saviranta <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/Kconfig === --- leandro.new.orig/net/dccp/ccids/Kconfi

[PATCH 2/25] Create initial ccid-4 code based on ccid-3

2007-10-31 Thread Leandro
[CCID-4] Create initial ccid-4 code based on ccid-3 Signed-off-by: Leandro Melo de Sales <[EMAIL PROTECTED]> Signed-off-by: Tommi Saviranta <[EMAIL PROTECTED]> Index: leandro.new/net/dccp/ccids/ccid4.c === --- /dev/null +++ leandro.n

[PATCH 0/25] Towards CCID3/CCID4 code integration

2007-10-31 Thread Leandro
Hi Gerrit, based on conversations with you, Arnaldo and Ian, please consider the following patches related to ccid-4 initial implementation and code share with ccid-3. Also, please reset the ccid4 branch to have the latest dccp branch code before apply these patches series. It would be intere

Re: [PATCH 13/25] Share TFRC feedback types struct via ccid34_lib

2007-10-31 Thread Łeandro Sales
2007/10/31, Gerrit Renker <[EMAIL PROTECTED]>: > Leandro, > > following Arnaldo's reply, can you please you the suggested naming scheme (it > is also > already used in packet_history.c and loss_interval.c): I will be looking into > merging > the patches with the CCID3 set of patches, to reduce wo

Re: [PATCH 13/25] Share TFRC feedback types struct via ccid34_lib

2007-10-31 Thread Gerrit Renker
Leandro, following Arnaldo's reply, can you please you the suggested naming scheme (it is also already used in packet_history.c and loss_interval.c): I will be looking into merging the patches with the CCID3 set of patches, to reduce work and duplication. The whole lot of CCID3 patches will the

Re: [PATCH 13/25] Share TFRC feedback types struct via ccid34_lib

2007-10-31 Thread Arnaldo Carvalho de Melo
Em Wed, Oct 31, 2007 at 09:59:14AM +, Gerrit Renker escreveu: > I have a suggestion regarding types, names, and things shared between > CCID3 and CCID4 via dccp_tfrc_lib: > > I think it would be best to name all such shared structures / names, > when they are to appear in the dccp_tfrc_lib, as

Re: [PATCH 13/25] Share TFRC feedback types struct via ccid34_lib

2007-10-31 Thread Gerrit Renker
I have a suggestion regarding types, names, and things shared between CCID3 and CCID4 via dccp_tfrc_lib: I think it would be best to name all such shared structures / names, when they are to appear in the dccp_tfrc_lib, as `tfrc_xxx' instead of `ccid34_xxx' For example, enum tfrc_fback_type { //