[jira] [Created] (ARROW-6366) [Java] Make field vectors final explicitly

2019-08-26 Thread Liya Fan (Jira)
Liya Fan created ARROW-6366: --- Summary: [Java] Make field vectors final explicitly Key: ARROW-6366 URL: https://issues.apache.org/jira/browse/ARROW-6366 Project: Apache Arrow Issue Type: Improvement

Re: [Discuss][Java] Refactor code for time related vectors

2019-08-26 Thread Fan Liya
Hi Jacques, Thanks for the valuable feedback. I agree that it is a good idea to explicitly make field vectors final. However, I think there are still lots of duplicated code for getInt/getLong/setInt/setLong/setIntSafe/setLongSafe. In addition, we have a large number of time related vector class

Re: [Discuss][Java] Refactor code for time related vectors

2019-08-26 Thread Jacques Nadeau
I think you'd have to refractor differently since one of the patterns is get(index, object holder) is consistently matched. That means you should never subclass a field vector I believe. In fact we should probably just formally finalize them. Once you do that, I'm not sure how much duplicated code

[jira] [Created] (ARROW-6365) [R] Should be able to coerce numeric to integer with schema

2019-08-26 Thread Neal Richardson (Jira)
Neal Richardson created ARROW-6365: -- Summary: [R] Should be able to coerce numeric to integer with schema Key: ARROW-6365 URL: https://issues.apache.org/jira/browse/ARROW-6365 Project: Apache Arrow

[jira] [Created] (ARROW-6364) [R] Handling unexpected input to time64() et al

2019-08-26 Thread Neal Richardson (Jira)
Neal Richardson created ARROW-6364: -- Summary: [R] Handling unexpected input to time64() et al Key: ARROW-6364 URL: https://issues.apache.org/jira/browse/ARROW-6364 Project: Apache Arrow Issu

[jira] [Created] (ARROW-6363) [R] segfault in Table__from_dots with unexpected schema

2019-08-26 Thread Neal Richardson (Jira)
Neal Richardson created ARROW-6363: -- Summary: [R] segfault in Table__from_dots with unexpected schema Key: ARROW-6363 URL: https://issues.apache.org/jira/browse/ARROW-6363 Project: Apache Arrow

[jira] [Created] (ARROW-6362) [C++] S3: more flexible credential options

2019-08-26 Thread Antoine Pitrou (Jira)
Antoine Pitrou created ARROW-6362: - Summary: [C++] S3: more flexible credential options Key: ARROW-6362 URL: https://issues.apache.org/jira/browse/ARROW-6362 Project: Apache Arrow Issue Type:

[jira] [Created] (ARROW-6361) sbt docker publish fails due to Arrow dependecies

2019-08-26 Thread Boris V.Kuznetsov (Jira)
Boris V.Kuznetsov created ARROW-6361: Summary: sbt docker publish fails due to Arrow dependecies Key: ARROW-6361 URL: https://issues.apache.org/jira/browse/ARROW-6361 Project: Apache Arrow

[jira] [Created] (ARROW-6360) [R] Update support for compression

2019-08-26 Thread Neal Richardson (Jira)
Neal Richardson created ARROW-6360: -- Summary: [R] Update support for compression Key: ARROW-6360 URL: https://issues.apache.org/jira/browse/ARROW-6360 Project: Apache Arrow Issue Type: Impro

[jira] [Created] (ARROW-6359) [C++] Raw data equality in arrays vs. semantic value equality

2019-08-26 Thread Wes McKinney (Jira)
Wes McKinney created ARROW-6359: --- Summary: [C++] Raw data equality in arrays vs. semantic value equality Key: ARROW-6359 URL: https://issues.apache.org/jira/browse/ARROW-6359 Project: Apache Arrow

[jira] [Created] (ARROW-6358) [C++] FileSystem::DeleteDir should make it optional to delete the directory itself

2019-08-26 Thread Antoine Pitrou (Jira)
Antoine Pitrou created ARROW-6358: - Summary: [C++] FileSystem::DeleteDir should make it optional to delete the directory itself Key: ARROW-6358 URL: https://issues.apache.org/jira/browse/ARROW-6358 Pr

[jira] [Created] (ARROW-6357) [C++] S3: allow for background writes

2019-08-26 Thread Antoine Pitrou (Jira)
Antoine Pitrou created ARROW-6357: - Summary: [C++] S3: allow for background writes Key: ARROW-6357 URL: https://issues.apache.org/jira/browse/ARROW-6357 Project: Apache Arrow Issue Type: Impr

[Discuss][Java] Refactor code for time related vectors

2019-08-26 Thread Fan Liya
Dear all, Currently, we have two classes of time related vectors. One class are named TimeXXVector, while the other class are named TimeStampXXVector. We found there are some redundant code for these classes, so we want to do some refactorings for them. 1. For TimeXXVector, all classes extend Bas

[jira] [Created] (ARROW-6356) [Java] Avro adapter implement Enum type and nested Record type

2019-08-26 Thread Ji Liu (Jira)
Ji Liu created ARROW-6356: - Summary: [Java] Avro adapter implement Enum type and nested Record type Key: ARROW-6356 URL: https://issues.apache.org/jira/browse/ARROW-6356 Project: Apache Arrow Issue

[jira] [Created] (ARROW-6355) [Java] Make range equal visitor reusable

2019-08-26 Thread Liya Fan (Jira)
Liya Fan created ARROW-6355: --- Summary: [Java] Make range equal visitor reusable Key: ARROW-6355 URL: https://issues.apache.org/jira/browse/ARROW-6355 Project: Apache Arrow Issue Type: Improvement

[jira] [Created] (ARROW-6354) [C++] Building without Parquet fails

2019-08-26 Thread Antoine Pitrou (Jira)
Antoine Pitrou created ARROW-6354: - Summary: [C++] Building without Parquet fails Key: ARROW-6354 URL: https://issues.apache.org/jira/browse/ARROW-6354 Project: Apache Arrow Issue Type: Bug

[jira] [Created] (ARROW-6353) [Python] Allow user to select compression level in pyarrow.parquet.write_table

2019-08-26 Thread Igor Yastrebov (Jira)
Igor Yastrebov created ARROW-6353: - Summary: [Python] Allow user to select compression level in pyarrow.parquet.write_table Key: ARROW-6353 URL: https://issues.apache.org/jira/browse/ARROW-6353 Projec