Re: ToString Method Name

2017-02-10 Thread Jesse Anderson
Ok will create a JIRA and PR. On Fri, Feb 10, 2017 at 11:23 AM Eugene Kirpichov wrote: > Yup, this is the part of the style guide I had in mind. As you probably > know from the PR, I'm in favor of "elements" :) > Note that here we're naming a family of transforms - elements, kvs and > iterables

Re: ToString Method Name

2017-02-10 Thread Eugene Kirpichov
Yup, this is the part of the style guide I had in mind. As you probably know from the PR, I'm in favor of "elements" :) Note that here we're naming a family of transforms - elements, kvs and iterables (potentially more in the future), so the naming should be consistent between the different version

ToString Method Name

2017-02-10 Thread Jesse Anderson
The ToString.of() violates the new transform rules and we need to choose a new name. Here is the method for reference: /** * Returns a {@code PTransform>} which transforms each * element of the input {@link PCollection} to a {@link String} using the * {@link Object#toString} method.