Re: CordovaPlugin lifecycle differs from Activity lifecycle

2015-09-07 Thread Kai Schlamp
Opened the issues: https://issues.apache.org/jira/browse/CB-9620 https://issues.apache.org/jira/browse/CB-9621 2015-08-28 0:19 GMT+02:00 Kai Schlamp : > Wouldn't it make sense to have "onCreate" and "onRestart" also in > CordovaPlugin? We could then interact on the full

Re: CordovaPlugin lifecycle differs from Activity lifecycle

2015-08-27 Thread Kai Schlamp
https://issues.apache.org/jira/browse/CB-9570 2015-08-25 3:04 GMT+02:00 Joe Bowser bows...@gmail.com: They used to be called on the Activity, but I think this was lost on a recent refactor and nobody reported it until now. This is odd, because a lot of things do rely on that code working,

Re: CordovaPlugin lifecycle differs from Activity lifecycle

2015-08-27 Thread Kai Schlamp
Wouldn't it make sense to have onCreate and onRestart also in CordovaPlugin? We could then interact on the full lifecyle of an activity without overwriting the MainActivity itself (I even don't know how I would do that). 2015-08-28 0:13 GMT+02:00 Kai Schlamp schl...@gmx.de:

Re: CordovaPlugin lifecycle differs from Activity lifecycle

2015-08-24 Thread Shazron
Sorry not much of an Android expert -- but seeing as no one has replied -- is this a bug, since it appears to be not working as expected? If so, please file an issue at issues.cordova.io On Sun, Aug 23, 2015 at 1:35 PM, Kai Schlamp schl...@gmx.de wrote: The CordovaPlugin has the same onStart

Re: CordovaPlugin lifecycle differs from Activity lifecycle

2015-08-24 Thread Joe Bowser
Sorry, I was sick for a couple of days. That sounds like a bug. onStart and onResume should be called on the plugins, and this most likely got broken when the last refactor. Do you have an issue open in JIRA for this? On Sun, Aug 23, 2015 at 1:35 PM Kai Schlamp schl...@gmx.de wrote: The

Re: CordovaPlugin lifecycle differs from Activity lifecycle

2015-08-24 Thread Joe Bowser
They used to be called on the Activity, but I think this was lost on a recent refactor and nobody reported it until now. This is odd, because a lot of things do rely on that code working, like garbage collection on plugins. I'd still file an issue to get more people to look at it. On Mon, Aug

Re: CordovaPlugin lifecycle differs from Activity lifecycle

2015-08-24 Thread Andrew Grieve
I noted this as weird as well, but it's just always been this way in Cordova. I think it came from the fact that on iOS you only get a resume after a pause. You can always use

CordovaPlugin lifecycle differs from Activity lifecycle

2015-08-23 Thread Kai Schlamp
The CordovaPlugin has the same onStart and onResume callback methods as Androids Activity class. Unfortunately those differ from the Activity Lifecycle (see http://developer.android.com/reference/android/app/Activity.html#ActivityLifecycle ). The onStart and onResume methods of CordovaPlugin are