[dpdk-dev] [PATCH v2] test_cryptodev_perf: IV and digest should be stored at a DMAeble address

2016-10-07 Thread akhil.go...@nxp.com
From: Akhil Goyal For physical crypto devices, IV and digest are processed by the crypto device which need the contents to be written on some DMA able address. So in order to do that, IV and digest are accomodated in the packet. Signed-off-by: Akhil Goyal v2: patch

[dpdk-dev] [PATCH] examples/ipsec-secgw: Update checksum while decrementing ttl

2016-10-07 Thread De Lara Guarch, Pablo
> -Original Message- > From: Akhil Goyal [mailto:akhil.goyal at nxp.com] > Sent: Tuesday, October 04, 2016 11:33 PM > To: De Lara Guarch, Pablo; Gonzalez Monroy, Sergio; dev at dpdk.org > Subject: Re: [PATCH] examples/ipsec-secgw: Update checksum while > decrementing ttl > > On 10/5/2016

[dpdk-dev] [PATCH 1/3] eal/drivers: prefix driver REGISTER macros with EAL

2016-10-07 Thread Shreyansh Jain
Hi David, Thomas, On Friday 07 October 2016 07:03 PM, Shreyansh Jain wrote: > DRIVER_REGISTER_PCI -> EAL_REGISTER_PCI > DRIVER_REGISTER_PCI_TABLE -> EAL_REGISTER_PCI_TABLE > > Signed-off-by: Shreyansh Jain > --- > doc/guides/prog_guide/dev_kit_build_system.rst | 2 +- >

[dpdk-dev] [PATCH 3/3] eal/drivers: prefix driver param REGISTER macro with EAL

2016-10-07 Thread Shreyansh Jain
Signed-off-by: Shreyansh Jain --- drivers/crypto/aesni_gcm/aesni_gcm_pmd.c | 2 +- drivers/crypto/aesni_mb/rte_aesni_mb_pmd.c | 2 +- drivers/crypto/kasumi/rte_kasumi_pmd.c | 2 +- drivers/crypto/null/null_crypto_pmd.c | 2 +- drivers/crypto/snow3g/rte_snow3g_pmd.c | 2 +-

[dpdk-dev] [PATCH 2/3] eal/drivers: prefix VDEV driver REGISTER macro with EAL

2016-10-07 Thread Shreyansh Jain
Signed-off-by: Shreyansh Jain --- drivers/crypto/aesni_gcm/aesni_gcm_pmd.c | 2 +- drivers/crypto/aesni_mb/rte_aesni_mb_pmd.c | 2 +- drivers/crypto/kasumi/rte_kasumi_pmd.c | 2 +- drivers/crypto/null/null_crypto_pmd.c | 2 +- drivers/crypto/snow3g/rte_snow3g_pmd.c | 2 +-

[dpdk-dev] [PATCH 1/3] eal/drivers: prefix driver REGISTER macros with EAL

2016-10-07 Thread Shreyansh Jain
DRIVER_REGISTER_PCI -> EAL_REGISTER_PCI DRIVER_REGISTER_PCI_TABLE -> EAL_REGISTER_PCI_TABLE Signed-off-by: Shreyansh Jain --- doc/guides/prog_guide/dev_kit_build_system.rst | 2 +- drivers/crypto/qat/rte_qat_cryptodev.c | 4 ++-- drivers/net/bnx2x/bnx2x_ethdev.c | 8

[dpdk-dev] [PATCH] net/virtio: add missing driver name

2016-10-07 Thread Shreyansh Jain
On Friday 07 October 2016 06:33 PM, David Marchand wrote: > The driver name has been lost with the eal rework. > Restore it. > > Fixes: c830cb295411 ("drivers: use PCI registration macro") > > Signed-off-by: David Marchand > --- > drivers/net/virtio/virtio_ethdev.c | 3 +++ > 1 file changed, 3

[dpdk-dev] [PATCH v5 8/8] app/testpmd: hide segsize when unrelevant in csum engine

2016-10-07 Thread Olivier Matz
When TSO is not asked, hide the segment size. Signed-off-by: Olivier Matz --- app/test-pmd/csumonly.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/app/test-pmd/csumonly.c b/app/test-pmd/csumonly.c index 2057633..d5eb260 100644 --- a/app/test-pmd/csumonly.c +++

[dpdk-dev] [PATCH v5 7/8] app/testpmd: don't use tso if packet is too small

2016-10-07 Thread Olivier Matz
Asking for TSO (TCP Segmentation Offload) on packets that are already smaller than (headers + MSS) does not work, for instance on ixgbe. Fix the csumonly engine to only set the TSO flag when a segmentation offload is really required, i.e. when packet is large enough. Signed-off-by: Olivier Matz

[dpdk-dev] [PATCH v5 6/8] app/testpmd: display Rx port in csum engine

2016-10-07 Thread Olivier Matz
This information is useful when debugging, especially with bidirectional traffic. Signed-off-by: Olivier Matz --- app/test-pmd/csumonly.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/app/test-pmd/csumonly.c b/app/test-pmd/csumonly.c index eeb67db..19c8099 100644 ---

[dpdk-dev] [PATCH v5 5/8] app/testpmd: do not change ip addrs in csum engine

2016-10-07 Thread Olivier Matz
The csum forward engine was updated to change the IP addresses in the packet data in commit 51f694dd40f5 ("app/testpmd: rework checksum forward engine") This was done to ensure that the checksum is correctly reprocessed when using hardware checksum offload. But the functions

[dpdk-dev] [PATCH v5 4/8] app/testpmd: add option to enable lro

2016-10-07 Thread Olivier Matz
Introduce a new argument '--enable-lro' to ask testpmd to enable the LRO feature on enabled ports, like it's done for '--enable-rx-cksum' for instance. Signed-off-by: Olivier Matz --- app/test-pmd/parameters.c | 4 doc/guides/testpmd_app_ug/run_app.rst | 4 2 files

[dpdk-dev] [PATCH v5 3/8] app/testpmd: dump Rx flags in csum engine

2016-10-07 Thread Olivier Matz
Signed-off-by: Olivier Matz --- app/test-pmd/csumonly.c | 22 -- 1 file changed, 12 insertions(+), 10 deletions(-) diff --git a/app/test-pmd/csumonly.c b/app/test-pmd/csumonly.c index 5ca5702..e7ee0b3 100644 --- a/app/test-pmd/csumonly.c +++ b/app/test-pmd/csumonly.c @@

[dpdk-dev] [PATCH v5 2/8] app/testpmd: use new function to dump offload flags

2016-10-07 Thread Olivier Matz
Use the functions introduced in the previous commit to dump the offload flags. Signed-off-by: Olivier Matz --- app/test-pmd/csumonly.c | 27 +++ app/test-pmd/rxonly.c | 15 ++- 2 files changed, 5 insertions(+), 37 deletions(-) diff --git

[dpdk-dev] [PATCH v5 1/8] mbuf: add function to dump ol flag list

2016-10-07 Thread Olivier Matz
The functions rte_get_rx_ol_flag_name() and rte_get_tx_ol_flag_name() can dump one flag, or set of flag that are part of the same mask (ex: PKT_TX_UDP_CKSUM, part of PKT_TX_L4_MASK). But they are not designed to dump the list of flags contained in mbuf->ol_flags. This commit introduce new

[dpdk-dev] [PATCH v5 0/8] Misc enhancements in testpmd

2016-10-07 Thread Olivier Matz
This patchset introduces several enhancements or minor fixes in testpmd. It is targetted for v16.11, and applies on top of software ptype v2 patchset [1]. These patches are useful to validate the virtio offload patchset [2] (to be rebased). [1]

[dpdk-dev] [PATCH v3] mbuf: add function to dump ol flag list

2016-10-07 Thread Olivier Matz
Hi Pablo, On 10/07/2016 05:51 AM, De Lara Guarch, Pablo wrote: > > >> -Original Message- >> From: Olivier Matz [mailto:olivier.matz at 6wind.com] >> Sent: Thursday, October 06, 2016 1:43 AM >> To: dev at dpdk.org; De Lara Guarch, Pablo >> Subject: [PATCH v3] mbuf: add function to dump

[dpdk-dev] [RFC v2] latencystats: added new library for latency stats

2016-10-07 Thread Reshma Pattan
Library is designed to calculate latency stats and report them to the application when queried. Library measures minimum, average, maximum latencies and jitter in nano seconds. Current implementation supports global latency stats, i.e. per application stats. Added new field to mbuf struct to mark

[dpdk-dev] [PATCH v6 1/2] librte_ether: modify internal callback function

2016-10-07 Thread Iremonger, Bernard
Hi Thomas, > Subject: Re: [dpdk-dev] [PATCH v6 1/2] librte_ether: modify internal callback > function > > 2016-10-06 17:48, Bernard Iremonger: > > @@ -2508,7 +2508,7 @@ rte_eth_dev_callback_unregister(uint8_t > port_id, > > > > void > > _rte_eth_dev_callback_process(struct rte_eth_dev *dev,

[dpdk-dev] [PATCH 1/3] eal/drivers: prefix driver REGISTER macros with EAL

2016-10-07 Thread Thomas Monjalon
2016-10-07 19:11, Shreyansh Jain: > --- a/mk/internal/rte.compile-pre.mk > +++ b/mk/internal/rte.compile-pre.mk > @@ -87,7 +87,7 @@ endif > PMDINFO_GEN = $(RTE_SDK_BIN)/app/dpdk-pmdinfogen $@ $@.pmd.c > PMDINFO_CC = $(CC) $(CPPFLAGS) $(CFLAGS) -c -o $@.pmd.o $@.pmd.c > PMDINFO_LD =

[dpdk-dev] [PATCH 1/3] eal/drivers: prefix driver REGISTER macros with EAL

2016-10-07 Thread Thomas Monjalon
2016-10-07 19:03, Shreyansh Jain: > DRIVER_REGISTER_PCI -> EAL_REGISTER_PCI > DRIVER_REGISTER_PCI_TABLE -> EAL_REGISTER_PCI_TABLE Why not RTE_ prefix instead of EAL_? Why 3 patches? As there is no specific comment in each, I think you can squash.

[dpdk-dev] [PATCH] net/mlx: align drivers to latest naming convention

2016-10-07 Thread Adrien Mazarguil
On Fri, Oct 07, 2016 at 03:04:13PM +0200, David Marchand wrote: > Fixes: 2f45703c17ac ("drivers: make driver names consistent") > > Signed-off-by: David Marchand > --- > drivers/net/mlx4/mlx4.h | 2 +- > drivers/net/mlx5/mlx5_defs.h | 2 +- > 2 files changed, 2 insertions(+), 2

[dpdk-dev] [PATCH] net/virtio: add missing driver name

2016-10-07 Thread David Marchand
The driver name has been lost with the eal rework. Restore it. Fixes: c830cb295411 ("drivers: use PCI registration macro") Signed-off-by: David Marchand --- drivers/net/virtio/virtio_ethdev.c | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/net/virtio/virtio_ethdev.c

[dpdk-dev] [PATCH 2/2] ethdev: fix vendor id in debug message

2016-10-07 Thread David Marchand
Fixes: af75078fece3 ("first public release") Signed-off-by: David Marchand --- lib/librte_ether/rte_ethdev.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/lib/librte_ether/rte_ethdev.c b/lib/librte_ether/rte_ethdev.c index 24029f0..88fa382 100644 ---

[dpdk-dev] [PATCH 1/2] ethdev: fix hotplug attach

2016-10-07 Thread David Marchand
If a pci probe operation creates a port but, for any reason, fails to finish this operation and decides to delete the newly created port, then the last created port id can not be trusted anymore and any subsequent attach operations will fail. This problem was noticed while working on a vm that

[dpdk-dev] [PATCH v6 1/2] librte_ether: modify internal callback function

2016-10-07 Thread Thomas Monjalon
2016-10-06 17:48, Bernard Iremonger: > @@ -2508,7 +2508,7 @@ rte_eth_dev_callback_unregister(uint8_t port_id, > > void > _rte_eth_dev_callback_process(struct rte_eth_dev *dev, > - enum rte_eth_event_type event) > + enum rte_eth_event_type event, void *cb_arg) > { > struct

[dpdk-dev] [PATCH v6 2/2] net/ixgbe: add callback to user app on VF to PF mbox msg

2016-10-07 Thread Thomas Monjalon
2016-10-06 17:48, Bernard Iremonger: > call _rte_eth_dev_callback_process from ixgbe_rcv_msg_from_vf function. > > The callback asks the user application if it is allowed to perform > the function. > If the cb_param.retval is RTE_PMD_IXGBE_MB_EVENT_PROCEED then continue, > if 0, do nothing and

[dpdk-dev] [PATCH] app/test: fix crypto mbuf pool size

2016-10-07 Thread Piotr Azarewicz
This patch fix that created pool for crypto mbufs may be too big in some environments. To avoid the issue, mbuf pool is reverted to its previous size. Moreover, here is added additional small pool with one large mbuf, what is needed in large data test scenarios. Fixes: 2070f885b76d ("app/test:

[dpdk-dev] Facing issue in encryption/decryption with QAT library

2016-10-07 Thread Pankaj Joshi
Hello All, I am using QAT library, and getting the error as below : ?[error] LacSymCb_ProcessDpCallback() - : Response status value not as expected? Observation are as below : 1. While running encryption only, everything working fine 2. While running decryption only, everything working fine 3.

[dpdk-dev] [PATCH v5 1/2] librte_ether: add protection against overwrite device data

2016-10-07 Thread Kerlin, MarcinX
Hi Thomas, > -Original Message- > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > Sent: Thursday, October 06, 2016 4:53 PM > To: Kerlin, MarcinX > Cc: dev at dpdk.org; De Lara Guarch, Pablo > Subject: Re: [PATCH v5 1/2] librte_ether: add protection against overwrite >

[dpdk-dev] [PATCH v6 2/2] net/ixgbe: add callback to user app on VF to PF mbox msg

2016-10-07 Thread Iremonger, Bernard
Hi Thomas, > Subject: Re: [dpdk-dev] [PATCH v6 2/2] net/ixgbe: add callback to user app > on VF to PF mbox msg > > 2016-10-06 17:48, Bernard Iremonger: > > call _rte_eth_dev_callback_process from ixgbe_rcv_msg_from_vf > function. > > > > The callback asks the user application if it is allowed

[dpdk-dev] [PATCH v7 2/2] app/test_pmd: add tests for new API's

2016-10-07 Thread Bernard Iremonger
add test for set vf vlan anti spoof add test for set vf mac anti spoof add test for set vf vlan stripq add test for set vf vlan insert add test for set tx loopback add test for set all queues drop enable bit add test for set vf split drop enable bit add test for set vf mac address add new API's to

[dpdk-dev] [PATCH v7 1/2] net/ixgbe: add API's for VF management

2016-10-07 Thread Bernard Iremonger
Add API's to configure and manage VF's on an Intel 82559 NIC. add rte_pmd_ixgbe_set_vf_vlan_anti_spoof function. add rte_pmd_ixgbe_set_vf_mac_anti_spoof function. add rte_pmd_ixgbe_set_vf_stripq function. Signed-off-by: Alex Zelezniak add rte_pmd_ixgbe_set_vf_vlan_insert function. add

[dpdk-dev] [PATCH v7 0/2] add API's for VF management

2016-10-07 Thread Bernard Iremonger
This patchset contains new DPDK API's for use with the Virtual Function Daemon (VFD). The need to configure and manage VF's on a NIC has grown to the point where a DPDK based tool, VFD, has been developed to do this. This patch set adds API extensions to DPDK for VF configuration. Eight new

[dpdk-dev] [PATCH] test_cryptodev_perf: IV and digest should be stored at a DMAeble address

2016-10-07 Thread Akhil Goyal
Hi Arek, Ok. I would rebase the patch. Regarding changes required to qat_snow3g, I do not have setup to test on qat and the hardware that I test, currently snow3g support is not added. I can send the patches for snow3g at some later stage. Regards, Akhil -Original Message- From:

[dpdk-dev] [RFC] libeventdev: event driven programming model framework for DPDK

2016-10-07 Thread Hemant Agrawal
Hi Jerin/Narender, Thanks for the proposal and discussions. I agree with many of the comment made by Narender. Here are some additional comments. 1. rte_event_schedule - should support option for bulk dequeue. The size of bulk should be a property of device, how much depth

[dpdk-dev] [PATCH 1/3] eal/drivers: prefix driver REGISTER macros with EAL

2016-10-07 Thread Neil Horman
On Fri, Oct 07, 2016 at 03:51:44PM +0200, Thomas Monjalon wrote: > 2016-10-07 19:11, Shreyansh Jain: > > --- a/mk/internal/rte.compile-pre.mk > > +++ b/mk/internal/rte.compile-pre.mk > > @@ -87,7 +87,7 @@ endif > > PMDINFO_GEN = $(RTE_SDK_BIN)/app/dpdk-pmdinfogen $@ $@.pmd.c > > PMDINFO_CC =

[dpdk-dev] [PATCH v2 10/12] virtio: add Tx checksum offload support

2016-10-07 Thread Maxime Coquelin
Hi Olivier, On 10/03/2016 11:00 AM, Olivier Matz wrote: > Signed-off-by: Olivier Matz > --- > drivers/net/virtio/virtio_ethdev.c | 7 + > drivers/net/virtio/virtio_ethdev.h | 1 + > drivers/net/virtio/virtio_rxtx.c | 57 > +- > 3 files changed, 45

[dpdk-dev] [PATCH v7] net/virtio: add set_mtu in virtio

2016-10-07 Thread Stephen Hemminger
I think current patch is fine. If someone has later problem with it on some scenario we can fix the bug then. Please merge

[dpdk-dev] [PATCH V2 2/2] virtio: support IOMMU platform

2016-10-07 Thread Michael S. Tsirkin
On Wed, Sep 28, 2016 at 04:25:12PM +0800, Jason Wang wrote: > Negotiate VIRTIO_F_IOMMU_PLATFORM to have IOMMU support. > > Signed-off-by: Jason Wang > --- > Changes from v1: > - remove unnecessary NEED_MAPPING flag One thing we probably should do is enable this flag with VFIO but not with UIO

[dpdk-dev] [PATCH 1/1] testpmd_ug: update userguide with xstats commands

2016-10-07 Thread Mcnamara, John
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Maryam Tahhan > Sent: Wednesday, September 7, 2016 11:46 AM > To: dev at dpdk.org > Cc: Tahhan, Maryam > Subject: [dpdk-dev] [PATCH 1/1] testpmd_ug: update userguide with xstats > commands > > Update the

[dpdk-dev] [PATCH] examples/l3fwd: em path hash offload to machine

2016-10-07 Thread Hemant Agrawal
Hi Jerin, Thanks for the review, I will send a v2 with the suggestions made Regards, Hemant > -Original Message- > From: Jerin Jacob [mailto:jerin.jacob at caviumnetworks.com] > Sent: Wednesday, October 05, 2016 5:23 PM > To: Hemant Agrawal > Cc: dev at dpdk.org > Subject: Re:

[dpdk-dev] [PATCH] doc: fix typo in SNOW3G documentation

2016-10-07 Thread Jain, Deepak K
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Pablo de Lara > Sent: Thursday, October 6, 2016 9:55 PM > To: dev at dpdk.org > Cc: De Lara Guarch, Pablo > Subject: [dpdk-dev] [PATCH] doc: fix typo in SNOW3G documentation > > Fixes: 1d0c90e6cf0b ("doc:

[dpdk-dev] [PATCH v3] mbuf: add function to dump ol flag list

2016-10-07 Thread De Lara Guarch, Pablo
> -Original Message- > From: Olivier Matz [mailto:olivier.matz at 6wind.com] > Sent: Thursday, October 06, 2016 1:43 AM > To: dev at dpdk.org; De Lara Guarch, Pablo > Subject: [PATCH v3] mbuf: add function to dump ol flag list > > The functions rte_get_rx_ol_flag_name() and

[dpdk-dev] [PATCH 1/1] testpmd_ug: update userguide with xstats commands

2016-10-07 Thread De Lara Guarch, Pablo
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Maryam Tahhan > Sent: Wednesday, September 07, 2016 3:46 AM > To: dev at dpdk.org > Cc: Tahhan, Maryam > Subject: [dpdk-dev] [PATCH 1/1] testpmd_ug: update userguide with xstats > commands > > Update the

[dpdk-dev] [PATCH 1/2] app/test: fix vdev names

2016-10-07 Thread De Lara Guarch, Pablo
> -Original Message- > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > Sent: Thursday, October 06, 2016 3:34 AM > To: De Lara Guarch, Pablo > Cc: dev at dpdk.org > Subject: [PATCH 1/2] app/test: fix vdev names > > The vdev eth_ring has been renamed to net_ring. > Some unit

[dpdk-dev] [PATCH 2/2] app/testpmd: use consistent vdev names

2016-10-07 Thread De Lara Guarch, Pablo
> -Original Message- > From: Thomas Monjalon [mailto:thomas.monjalon at 6wind.com] > Sent: Thursday, October 06, 2016 3:34 AM > To: De Lara Guarch, Pablo > Cc: dev at dpdk.org > Subject: [PATCH 2/2] app/testpmd: use consistent vdev names > > The vdev eth_bond has been renamed to

[dpdk-dev] [PATCH v7] net/virtio: add set_mtu in virtio

2016-10-07 Thread Dey, Souvik
Hi Stephen, As I am new to this patch submission, I did not get what you exactly meant my ?Please merge?, do you mean that you Ack the patch and it can be upstreamed or you want me submit a new version or something. Sorry for my ignorance. Thanks -- Souvik From: Stephen

[dpdk-dev] [PATCH v3 0/4] remove hard-coding of crypto num qps and cleanup

2016-10-07 Thread De Lara Guarch, Pablo
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of De Lara Guarch, > Pablo > Sent: Thursday, October 06, 2016 5:30 PM > To: Trahe, Fiona; dev at dpdk.org > Cc: Trahe, Fiona; akhil.goyal at nxp.com > Subject: Re: [dpdk-dev] [PATCH v3 0/4] remove hard-coding of

[dpdk-dev] [PATCH v3 0/4] remove hard-coding of crypto num qps and cleanup

2016-10-07 Thread De Lara Guarch, Pablo
> -Original Message- > From: dev [mailto:dev-bounces at dpdk.org] On Behalf Of Fiona Trahe > Sent: Thursday, October 06, 2016 10:34 AM > To: dev at dpdk.org > Cc: De Lara Guarch, Pablo; Trahe, Fiona; akhil.goyal at nxp.com > Subject: [dpdk-dev] [PATCH v3 0/4] remove hard-coding of crypto

[dpdk-dev] [PATCH] test: fix hash multiwriter test

2016-10-07 Thread Pablo de Lara
Hash multiwriter test consists of two subtests. If the any of the subtests fails, the overall test should fail, but the overall test only passed if the second subtest passed, because the return of the first subtest was being overwritten. Fixes: be856325cba3 ("hash: add scalable multi-writer