Re: [dpdk-dev] [PATCH v1 0/8] mlx5 PMD multi OS support

2020-06-07 Thread Raslan Darawsheh
Hi, > -Original Message- > From: Ophir Munk > Sent: Wednesday, June 3, 2020 6:06 PM > To: dev@dpdk.org; Matan Azrad ; Raslan > Darawsheh > Cc: Ophir Munk > Subject: [PATCH v1 0/8] mlx5 PMD multi OS support > > This patch series is part of preparing mlx5 PMD to compile and run under > m

[dpdk-dev] [PATCH 0/2] Support EAL debug functions on Windows

2020-06-07 Thread talshn
From: Tal Shnaiderman This patchset adds support for the EAL debug function on Windows by implementing backtracing in rte_dump_stack and cleanup calls in rte_eal_cleanup. Additionally, the functions rte_exit, __rte_panic and rte_dump_registers were moved to a common file to avoid code duplicatio

[dpdk-dev] [PATCH 1/2] eal: move OS common debug functions to single file

2020-06-07 Thread talshn
From: Tal Shnaiderman Move common functions between Unix and Windows to eal_common_debug.c. Those functions are rte_exit, __rte_panic and rte_dump_registers which has the same implementation on Unix and Windows. Signed-off-by: Tal Shnaiderman --- lib/librte_eal/common/eal_common_debug.c | 56

[dpdk-dev] [PATCH 2/2] eal/windows: support debug calls

2020-06-07 Thread talshn
From: Tal Shnaiderman Support the debug functions in eal_common_debug.c for Windows. Implementation of rte_dump_stack to get a backtrace similarly to Unix and of rte_eal_cleanup in eal.c. Signed-off-by: Tal Shnaiderman --- config/meson.build | 1 + lib/librte_eal/common/meson

Re: [dpdk-dev] [PATCH v1 08/12] net/ice: add queue config in DCF

2020-06-07 Thread Ye Xiaolong
On 06/05, Ting Xu wrote: >From: Qi Zhang > >Add queues and Rx queue irqs configuration during device start >in DCF. The setup is sent to PF via virtchnl. > >Signed-off-by: Qi Zhang >--- > drivers/net/ice/ice_dcf.c| 109 +++ > drivers/net/ice/ice_dcf.h| 6 +

Re: [dpdk-dev] [PATCH v1 10/12] net/ice: enable stats for DCF

2020-06-07 Thread Ye Xiaolong
On 06/05, Ting Xu wrote: >From: Qi Zhang > >Add support to get and reset Rx/Tx stats in DCF. Query stats >from PF. > >Signed-off-by: Qi Zhang >--- > drivers/net/ice/ice_dcf.c| 27 > drivers/net/ice/ice_dcf.h| 4 ++ > drivers/net/ice/ice_dcf_ethdev.c | 102 +++

Re: [dpdk-dev] [PATCH 9/9] vhost: only use vDPA config workaround if needed

2020-06-07 Thread Matan Azrad
Hi Maxime Thanks for the huge work. Please see a suggestion inline. From: Maxime Coquelin: > Sent: Thursday, May 14, 2020 11:02 AM > To: xiaolong...@intel.com; Shahaf Shuler ; Matan > Azrad ; amore...@redhat.com; > xiao.w.w...@intel.com; Slava Ovsiienko ; > dev@dpdk.org > Cc: jasow...@redhat.com;

[dpdk-dev] Handling missing export functions in MSVC linkage

2020-06-07 Thread Tal Shnaiderman
Hi, I was wondering if there is a known solution for the following problem: Whenever building a DPDK library using clang/MSVC there is an linkage issue if the rte_*_version.map names a function that isn't being compiled. For example, in librte_metrics several files in the lib build depend on th

Re: [dpdk-dev] [PATCH v1 09/12] net/ice: add queue start and stop for DCF

2020-06-07 Thread Ye Xiaolong
On 06/05, Ting Xu wrote: >From: Qi Zhang > >Add queue start and stop in DCF. Support queue enable and disable >through virtual channel. Add support for Rx queue mbufs allocation >and queue reset. There is one i40e patch [1] from qiming to correct the queue behavior as "when one queue fails to sta

Re: [dpdk-dev] [PATCH v3] test: test patch for checking patchwork auto delegation feature

2020-06-07 Thread Ali Alnubani
> -Original Message- > From: Ferruh Yigit > Sent: Wednesday, June 3, 2020 8:54 PM > To: Ali Alnubani ; Jerin Jacob > Cc: dev@dpdk.org > Subject: Re: [dpdk-dev] [PATCH v3] test: test patch for checking patchwork > auto delegation feature > > On 6/3/2020 5:39 PM, Ali Alnubani wrote: > > Hi

[dpdk-dev] [PATCH] node: add pkt classifier node

2020-06-07 Thread Nithin Dabilpuram
This node classifies pkts based on packet type and sends them to appropriate next node. This is node helps in distribution of packets from ethdev_rx node to different next node with a constant overhead for all packet types. Currently all except non fragmented IPV4 packets are marked to be sent to

[dpdk-dev] [PATCH 0/9] Rename blacklist/whitelist to blocklist/allowlist

2020-06-07 Thread Stephen Hemminger
The terms blacklist and whitelist are often seen as reminders of the divisions in society. Instead, use more exact terms for handling of which devices are used in DPDK. This is a proposed change for DPDK 20.08 to replace the names blacklist and whitelist in API and command lines. The first three

[dpdk-dev] [PATCH 2/9] mk: replace reference to blacklist/whitelist

2020-06-07 Thread Stephen Hemminger
Use BLOCKLIST and ALLOWLIST in the make variable names. Signed-off-by: Stephen Hemminger --- mk/rte.sdktest.mk | 14 +++--- 1 file changed, 7 insertions(+), 7 deletions(-) diff --git a/mk/rte.sdktest.mk b/mk/rte.sdktest.mk index 803018ba3a70..6777e0c0f603 100644 --- a/mk/rte.sdktest.mk

[dpdk-dev] [PATCH 3/9] check_maintainers: change variable names

2020-06-07 Thread Stephen Hemminger
Use blocklist where blacklist was used and allowlist where whitelist was used. Signed-off-by: Stephen Hemminger --- devtools/check-maintainers.sh | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/devtools/check-maintainers.sh b/devtools/check-maintainers.sh index 85a300

[dpdk-dev] [PATCH 1/9] rte_ethdev: change comment to rte_dev_eth_mac_addr_add

2020-06-07 Thread Stephen Hemminger
The comment used the term whitelist and was awkardly written. Replace it with simpler direct description of adding a new address. No code or API changes for this. Signed-off-by: Stephen Hemminger --- lib/librte_ethdev/rte_ethdev.h | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --g

[dpdk-dev] [PATCH 5/9] drivers: replace references to blacklist

2020-06-07 Thread Stephen Hemminger
Use the new terminolgy BLOCKLIST to describe when devices are excluded from being used. Signed-off-by: Stephen Hemminger --- drivers/bus/dpaa/dpaa_bus.c| 7 +++ drivers/bus/fslmc/fslmc_bus.c | 9 - drivers/bus/fslmc/fslmc_vfio.c | 8 drivers/bus/pci/pci_c

[dpdk-dev] [PATCH 7/9] doc: replace references to blacklist/whitelist

2020-06-07 Thread Stephen Hemminger
The terms blacklist and whitelist are no longer used. Replace them in the documentation. Most of this was automatic replacement, but in a couple of places the language was awkward before and have tried to improve the readabilty. Signed-off-by: Stephen Hemminger --- doc/guides/cryptodevs/dpaa2_s

[dpdk-dev] [PATCH 6/9] eal: replace pci-whitelist/pci-blacklist options

2020-06-07 Thread Stephen Hemminger
Replace pci-whitelist with pci-allowlist and pci-blacklist with pci-blocklist. Allow the old options for now, but make sure help and all tests will use the new options. The short flags are more commonly used and changing them would impact more documentation and applications. The -b flag can be des

[dpdk-dev] [PATCH 8/9] app/test: use new allowlist and blocklist

2020-06-07 Thread Stephen Hemminger
Test the renamed pci-blocklist and pci-allowlist arguments. Use new terms in test variable names as well. Signed-off-by: Stephen Hemminger --- app/test/autotest.py| 16 ++-- app/test/autotest_runner.py | 18 ++--- app/test/test.c | 2 +- app/test/test_eal_fla

[dpdk-dev] [PATCH 4/9] eal: replace usage of blacklist/whitelist in enum

2020-06-07 Thread Stephen Hemminger
This patch renames the enum values in the EAL include files. As a backward compatiable temporary migration tool, define a replacement mapping for old values. The old names relating to blacklist and whitelist are replaced by blocklist and allowlist, but applications may be using the older compatiab

[dpdk-dev] [PATCH 9/9] doc: add note about blacklist/whitelist changes

2020-06-07 Thread Stephen Hemminger
The blacklist/whitelist changes to API will not be a breaking change for applications in this release but worth adding a note to encourage migration. Signed-off-by: Stephen Hemminger --- doc/guides/rel_notes/release_20_08.rst | 5 + 1 file changed, 5 insertions(+) diff --git a/doc/guides/re

Re: [dpdk-dev] [PATCH 4/9] eal: replace usage of blacklist/whitelist in enum

2020-06-07 Thread Gaëtan Rivet
Hi, On 07/06/20 10:01 -0700, Stephen Hemminger wrote: > This patch renames the enum values in the EAL include files. > As a backward compatiable temporary migration tool, define > a replacement mapping for old values. > > The old names relating to blacklist and whitelist are replaced > by blockli

Re: [dpdk-dev] Handling missing export functions in MSVC linkage

2020-06-07 Thread Dmitry Kozlyuk
On Sun, 7 Jun 2020 12:26:56 + Tal Shnaiderman wrote: > In clang build the .map file is converted into Module-Definition (.Def) File. If you create a .def manually, it will override the generation from .map. Of cause, this adds manual work and ideally all .def files should be generated. > I

Re: [dpdk-dev] [PATCH 2/2] eal/windows: support debug calls

2020-06-07 Thread Dmitry Kozlyuk
On Sun, 7 Jun 2020 12:35:29 +0300 tal...@mellanox.com wrote: > From: Tal Shnaiderman > > Support the debug functions in eal_common_debug.c for Windows. > > Implementation of rte_dump_stack to get a backtrace similarly to Unix > and of rte_eal_cleanup in eal.c. > > Signed-off-by: Tal Shnaiderm

Re: [dpdk-dev] [PATCH 0/3] Add interrupt-only mode to l3fwd-power

2020-06-07 Thread Wang, Yinan
Tested-by: Wang, Yinan > -Original Message- > From: dev On Behalf Of Anatoly Burakov > Sent: 2020年5月28日 17:14 > To: dev@dpdk.org > Cc: Hunt, David ; Ma, Liang J ; > Pattan, Reshma > Subject: [dpdk-dev] [PATCH 0/3] Add interrupt-only mode to l3fwd-power > > Since 20.05, l3fwd-power has

Re: [dpdk-dev] [PATCH] maintainers: add Xavier for bonding

2020-06-07 Thread Charles (Chas) Williams
On 5/18/2020 9:00 AM, Ferruh Yigit wrote: On 5/18/2020 12:20 PM, Wei Hu (Xavier) wrote: Adding Xavier as additional maintainer to bonding. Signed-off-by: Wei Hu (Xavier) --- MAINTAINERS | 1 + 1 file changed, 1 insertion(+) diff --git a/MAINTAINERS b/MAINTAINERS index 6a14622..46b6535 10

Re: [dpdk-dev] [PATCH 49/52] net/ice/base: fix uninitialized flag

2020-06-07 Thread Yang, Qiming
Hi, Qi > -Original Message- > From: Zhang, Qi Z > Sent: Wednesday, June 3, 2020 10:40 > To: Yang, Qiming > Cc: dev@dpdk.org; Ye, Xiaolong ; Zhang, Qi Z > ; sta...@dpdk.org; Zhao1, Wei > ; Stillwell Jr, Paul M > Subject: [PATCH 49/52] net/ice/base: fix uninitialized flag > > This patch

[dpdk-dev] [PATCH v4 1/3] lib/lpm: integrate RCU QSBR

2020-06-07 Thread Ruifeng Wang
Currently, the tbl8 group is freed even though the readers might be using the tbl8 group entries. The freed tbl8 group can be reallocated quickly. This results in incorrect lookup results. RCU QSBR process is integrated for safe tbl8 group reclaim. Refer to RCU documentation to understand various

[dpdk-dev] [PATCH v4 0/3] RCU integration with LPM library

2020-06-07 Thread Ruifeng Wang
This patchset integrates RCU QSBR support with LPM library. Resource reclaimation implementation was splitted from the original series, and has already been part of RCU library. Rework the series to base LPM integration on RCU reclaimation APIs. New API rte_lpm_rcu_qsbr_add is introduced for appl

[dpdk-dev] [PATCH v4 2/3] test/lpm: add LPM RCU integration functional tests

2020-06-07 Thread Ruifeng Wang
Add positive and negative tests for API rte_lpm_rcu_qsbr_add. Also test LPM library behavior when RCU QSBR is enabled. Signed-off-by: Ruifeng Wang Reviewed-by: Honnappa Nagarahalli --- app/test/test_lpm.c | 293 +++- 1 file changed, 292 insertions(+), 1 d

[dpdk-dev] [PATCH v4 3/3] test/lpm: add RCU integration performance tests

2020-06-07 Thread Ruifeng Wang
From: Honnappa Nagarahalli Add performance tests for RCU integration. The performance difference with and without RCU integration is very small (~1% to ~2%) on both Arm and x86 platforms. Signed-off-by: Honnappa Nagarahalli Reviewed-by: Ruifeng Wang --- app/test/test_lpm_perf.c | 492

[dpdk-dev] [PATCH] test/ring_perf: fix error statistics in bulk enq/dequeue

2020-06-07 Thread Feifei Wang
In size 32 bulk ring enq/dequeue performance test, the "Total count" statistics is incorrect. For example, running the test on lcore 25 and lcore 26, the output is as follows: The test command: $sudo ./arm64-armv8a-linuxapp-gcc/app/test -l 25-26 RTE>>ring_perf_autotest Bulk enq/dequeue count on s