Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2019-11-06 Thread Terry Wang
Hi Jark, Thanks for your suggestion! Change the title and wait for more comments. Best, Terry Wang > 2019年11月6日 15:52,Jark Wu 写道: > > Hi Terry, > > I would suggest to change the title a bit. > For example, "Improve & Refactor TableEnvironment APIs". > Or more specifically, "Improve & Refact

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-11 Thread godfreyhe
Hi everyone, I'd like to resume the discussion for FlIP-84 [0]. I had updated the document, the mainly changes are: 1. about "`void sqlUpdate(String sql)`" section a) change "Optional executeSql(String sql) throws Exception" to "ResultTable executeStatement(String statement, String jobName) thr

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-12 Thread Jingsong Li
Hi Godfrey, Thanks for updating. +1 sketchy. I have no idea to change "sqlQuery" to "fromQuery", I think "sqlQuery" is OK, It's not that confusing with return values. Can we change the "DmlBatch" to "Inserts"? I don't see any other needs. "Dml" seems a little weird. It is better to support "Ins

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-13 Thread Jark Wu
I agree with Jingsong. +1 to keep `sqlQuery`, it's clear from the method name and return type that it accepts a SELECT query and returns a logic representation `Table`. The `fromQuery` is a little confused users with the `Table from(String tableName)` method. Regarding to the `DmlBatch`, I agree

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-13 Thread Kurt Young
Regarding to "fromQuery" is confusing users with "Table from(String tableName)", I have a just opposite opinion. I think this "fromXXX" pattern can make users quite clear when they want to get a Table from TableEnvironment. Similar interfaces will also include like "fromElements". Regarding to the

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-13 Thread godfrey he
hi kurt,jark,jingsong Regarding to "fromQuery", I agree with kurt. In addition, I think `Table from(String tableName)` should be renamed to `Table fromCatalog(String tableName)`. Regarding to the "DmlBatch", DML contains "INSERT", "UPDATE", "DELETE", and they can be executed in a same batch in th

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-14 Thread Jark Wu
Thanks Kurt and Godfrey for the explanation, It makes sense to me that renaming `from(tableName)` to `fromCatalog(tableName)`. However, I still think `sqlQuery(query)` is clear and works well. Is it necessary to change it? We removed `sql(query)` and introduced `sqlQuery(query)`, we removed `scan

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-15 Thread Kurt Young
I don't think we should change `from` to `fromCatalog`, especially `from` is just introduced in 1.10. I agree with Jark we should change interface only when necessary, e.g. the semantic is broken or confusing. So I'm +1 to keep `sqlQuery` as it is. Best, Kurt On Sat, Feb 15, 2020 at 3:59 PM Jark

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-15 Thread Jingsong Li
Hi Kurt and Godfrey, Thank you for your explanation. Regarding to the "DmlBatch", I see there are some description for JDBC Statement.addBatch in the document. What do you think about introducing "addBatch" to the TableEnv instead of introducing a new class? The advantage is: - Consistent with JD

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-18 Thread godfrey he
Thanks Kurt and Jark for explanation, I now also think we should make the TableEnvironment interface more statable and should not change "sqlQuery" method and "from" method. Hi Jingsong. Regarding to the "DmlBatch", I totally agree with advantages of "addBatch" method. However, there are two more

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-28 Thread Benchao Li
Hi Terry, Thanks for the propose, and sorry for joining the party late. I have one question about this FLIP: executeStatement accepts DML, what if it's a streaming DML ? does it submit the job to cluster directly and blocks forever? what's the behavior for the next statements? nit: there's

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-28 Thread godfrey he
Hi Benchao, > I have one question about this FLIP: > executeStatement accepts DML, what if it's a streaming DML ? >does it submit the job to cluster directly and blocks forever? what's > the behavior for the next statements? `executeStatement` is a synchronous method, will execute the stateme

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-02-28 Thread Benchao Li
Hi godfrey, Thanks for your explanation. Do we need to clarify this in the FLIP? Maybe this confuses other users as well. godfrey he 于2020年2月28日周五 下午4:54写道: > Hi Benchao, > > > I have one question about this FLIP: > > executeStatement accepts DML, what if it's a streaming DML ? > >does it

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-03-01 Thread godfrey he
Hi Benchao, I think the document has contained both parts: the behavior is explained when introducing `executeStatement` method, and asynchronous execution methods is explained in the appendix. Bests, Godfrey Benchao Li 于2020年2月28日周五 下午10:09写道: > Hi godfrey, > > Thanks for your explanation. >

Re: [DISCUSS] FLIP-84: Improve & Refactor execute/sqlQuery/sqlUpdate APIS of TableEnvironment

2020-03-01 Thread Benchao Li
hi godfrey, Thanks for your information, I didn't see that part before. Now the FLIP LGTM, thanks for driving this effort. godfrey he 于2020年3月2日周一 上午9:51写道: > Hi Benchao, > > I think the document has contained both parts: the behavior is explained > when introducing `executeStatement` method, a