Martin Junghanns created FLINK-3618: ---------------------------------------
Summary: Rename abstract UDF classes in Scatter-Gather implementation Key: FLINK-3618 URL: https://issues.apache.org/jira/browse/FLINK-3618 Project: Flink Issue Type: Improvement Components: Gelly Affects Versions: 1.1.0, 1.0.1 Reporter: Martin Junghanns Priority: Minor We now offer three Vertex-centric computing abstractions: * Pregel * Gather-Sum-Apply * Scatter-Gather Each of these abstractions provides abstract classes that need to be implemented by the user: * Pregel: {{ComputeFunction}} * GSA: {{GatherFunction}}, {{SumFunction}}, {{ApplyFunction}} * Scatter-Gather: {{MessagingFunction}}, {{VertexUpdateFunction}} In Pregel and GSA, the names of those functions follow the name of the abstraction or the name suggested in the corresponding papers. For consistency of the API, I propose to rename {{MessageFunction}} to {{ScatterFunction}} and {{VertexUpdateFunction}} to {{GatherFunction}}. Also for consistency, I would like to change the parameter order in {{Graph.runScatterGatherIteration(VertexUpdateFunction f1, MessagingFunction f2}} to {{Graph.runScatterGatherIteration(ScatterFunction f1, GatherFunction f2}} (like in {{Graph.runGatherSumApplyFunction(...)}}) -- This message was sent by Atlassian JIRA (v6.3.4#6332)