Re: Refactor gfsh parser

2017-04-20 Thread Jared Stewart
+1 for the suggested aliases > On Apr 20, 2017, at 3:02 PM, Jinmei Liao wrote: > > We should add option alias to to those options like "member(s)", > "group(s)", "jar(s)", so that the command will accept either singular or > plural. SpringShell parser does allow us to add

Re: Refactor gfsh parser

2017-04-20 Thread Jinmei Liao
We should add option alias to to those options like "member(s)", "group(s)", "jar(s)", so that the command will accept either singular or plural. SpringShell parser does allow us to add option aliases. On Thu, Apr 20, 2017 at 2:40 PM, Bruce Schuchardt wrote: > +1 > What

Re: Refactor gfsh parser

2017-04-20 Thread Bruce Schuchardt
+1 What other options like "member" exist that need to be modified? Le 4/20/2017 à 1:37 PM, Jinmei Liao a écrit : In the effort of adding option validation to gfsh commands (GEODE-1597) and simplifying gfsh parsing, I started this exercise of only using SpringShell's parser instead of a

Re: Refactor gfsh parser

2017-04-20 Thread Swapnil Bawaskar
+1 On Thu, Apr 20, 2017 at 2:34 PM Kirk Lund wrote: > These changes look great. Thanks! > > On Thu, Apr 20, 2017 at 1:37 PM, Jinmei Liao wrote: > > > In the effort of adding option validation to gfsh commands (GEODE-1597) > and > > simplifying gfsh parsing,

Re: Refactor gfsh parser

2017-04-20 Thread Kirk Lund
These changes look great. Thanks! On Thu, Apr 20, 2017 at 1:37 PM, Jinmei Liao wrote: > In the effort of adding option validation to gfsh commands (GEODE-1597) and > simplifying gfsh parsing, I started this exercise of only using > SpringShell's parser instead of a

Re: Refactor gfsh parser

2017-04-20 Thread Michael Stolz
I see no issues with these changes. -- Mike Stolz Principal Engineer - Gemfire Product Manager Mobile: 631-835-4771 On Apr 20, 2017 4:38 PM, "Jinmei Liao" wrote: > In the effort of adding option validation to gfsh commands (GEODE-1597) and > simplifying gfsh parsing, I

Re: Refactor gfsh parser

2017-04-20 Thread John Blum
+1, I agree with Jens; The option could be renamed to '--members' and mean 1 or more. On Thu, Apr 20, 2017 at 2:00 PM, Jens Deppe wrote: > IMO I much prefer having: > > --member=member1,member2 > > vs: > > --member=member1 --member=member2 > > The latter can leave me

Re: Refactor gfsh parser

2017-04-20 Thread Jens Deppe
IMO I much prefer having: --member=member1,member2 vs: --member=member1 --member=member2 The latter can leave me wondering if subsequent values are additive or actually override prior ones. --Jens On Thu, Apr 20, 2017 at 1:37 PM, Jinmei Liao wrote: > In the effort of

Refactor gfsh parser

2017-04-20 Thread Jinmei Liao
In the effort of adding option validation to gfsh commands (GEODE-1597) and simplifying gfsh parsing, I started this exercise of only using SpringShell's parser instead of a combination of springshell's, joptsimple's and our own parsers. The end result is a lot more manageable code base, and the