[ 
https://issues.apache.org/jira/browse/JCR-1538?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Jukka Zitting resolved JCR-1538.
--------------------------------

    Resolution: Fixed
      Assignee: Jukka Zitting

Completed in revision 698402. All ItemImpl descendants now have toString() 
methods that return a string like "<type> <path>" using safeGetJCRPath for the 
path part.

Also, I replaced all calls to safeGetJCRPath() with the toString() method in 
diagnostics output. The result is more readable, for example:

    "failed to add property " + name + " to " + safeGetJCRPath()

vs.

    "failed to add property " + name + " to " + this



> [patch] add toString for NodeImpl and PropertyImpl
> --------------------------------------------------
>
>                 Key: JCR-1538
>                 URL: https://issues.apache.org/jira/browse/JCR-1538
>             Project: Jackrabbit
>          Issue Type: Improvement
>          Components: jackrabbit-core
>    Affects Versions: core 1.4.2
>            Reporter: Dave Brosius
>            Assignee: Jukka Zitting
>            Priority: Trivial
>             Fix For: 1.5
>
>         Attachments: node_and_property_toString.patch
>
>   Original Estimate: 0h
>  Remaining Estimate: 0h
>
> add toString for NodeImpl and PropertyImpl with new format. see how it is 
> liked, before adding more.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.

Reply via email to