Hello Richard, Xavier:
I think I am convinced my your arguments. How about keeping all() as is and
rename "range" to "fetchAll" then?
Guozhang
On Thu, Oct 26, 2017 at 9:21 AM, Xavier Léauté wrote:
> I don't feel this worth holding up the vote for, if no one else shares my
> concerns.
> On W
I don't feel this worth holding up the vote for, if no one else shares my
concerns.
On Wed, Oct 25, 2017 at 15:59 Richard Yu wrote:
> Xavier: There has been two pluses on the voting thread. Are you fine with
> the current formation?
>
> On Tue, Oct 24, 2017 at 4:26 PM, Richard Yu
> wrote:
>
> >
Xavier: There has been two pluses on the voting thread. Are you fine with
the current formation?
On Tue, Oct 24, 2017 at 4:26 PM, Richard Yu
wrote:
> I think we can come up with this compromise: range(long timeFrom, long
> timeTo) will be changed to getKeys(long timeFrom, long timeTo). Sounds fa
I think we can come up with this compromise: range(long timeFrom, long
timeTo) will be changed to getKeys(long timeFrom, long timeTo). Sounds fair?
On Tue, Oct 24, 2017 at 10:44 AM, Xavier Léauté wrote:
> >
> > Generally I think having `all / range` is better in terms of consistency
> > with ke
>
> Generally I think having `all / range` is better in terms of consistency
> with key-value windows. I.e. queries with key are named as `get / fetch`
> for kv / window stores, and queries without key are named as `range / all`.
>
For kv stores, range takes a range of keys, and with this proposal
Thanks Richard for updating the wiki.
Made another pass over it, overall it LGTM. Just a few minor comments:
1) Could you update the title to reflect the function names accordingly?
Generally I think having `all / range` is better in terms of consistency
with key-value windows. I.e. queries with
Soliciting more feedback before vote.
On Wed, Oct 18, 2017 at 8:26 PM, Richard Yu
wrote:
> Is this KIP close to completion? Because we could start working on the
> code itself now. (Its at about this stage).
>
> On Mon, Oct 16, 2017 at 7:37 PM, Richard Yu
> wrote:
>
>> As Guozhang Wang mentione
Is this KIP close to completion? Because we could start working on the code
itself now. (Its at about this stage).
On Mon, Oct 16, 2017 at 7:37 PM, Richard Yu
wrote:
> As Guozhang Wang mentioned earlier, we want to mirror the structure of
> similar Store class (namely KTable). The WindowedStore
As Guozhang Wang mentioned earlier, we want to mirror the structure of
similar Store class (namely KTable). The WindowedStore class might be
unique in itself as it uses fetch() methods, but in my opinion, uniformity
should be better suited for simplicity.
On Mon, Oct 16, 2017 at 11:54 AM, Xavier L
Thank you Richard! Do you or Guozhang have any thoughts on my suggestions
to use fetchAll() and fetchAll(timeFrom, timeTo) and reserve the "range"
keyword for when we query a specific range of keys?
Xavier
On Sat, Oct 14, 2017 at 2:32 PM Richard Yu
wrote:
> Thanks for the clarifications, Xavier
Thanks for the clarifications, Xavier.
I have removed most of the methods except for keys() and all() which has
been renamed to Guozhang Wang's suggestions.
Hope this helps.
On Fri, Oct 13, 2017 at 3:28 PM, Xavier Léauté wrote:
> Thanks for the KIP Richard, this is a very useful addition!
>
> A
Thanks for the KIP Richard, this is a very useful addition!
As far as the API changes, I just have a few comments on the methods that
don't seem directly related to the KIP title, and naming of course :).
On the implementation, see my notes further down that will hopefully
clarify a few things.
R
Richard, Matthias:
0. Could you describe a bit what are the possible use cases of `allLatest`,
`minKey` and `maxKey`? I'd prefer keeping the APIs to add at a minimum
necessary amount, to avoid a swamp of new APIs that no one would really use
but just complicated the internal code base.
1. One min
We should split KAFKA-4499 into several sub-issues with 4499 being the
parent issue.
Adding the implementation to CachingWindowStore, RocksDBWindowStore, etc
will each require the addition of a test and implementing the methods which
is not trivial.
This way, it should be easier to manage the progr
Thanks for driving this and sorry for late response. With release
deadline it was pretty busy lately.
Can you please add a description for the suggested method, what they are
going to return? It's a little unclear to me atm.
It would also be helpful to discuss, for which use case each method is
u
Hello, I would like to solicit review and comment on this issue (link
below):
https://cwiki.apache.org/confluence/display/KAFKA/KIP-205%3A+Add+getAllKeys%28%29+API+to+ReadOnlyWindowStore
16 matches
Mail list logo