> -----Original Message-----
> From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]
> Sent: Tuesday, June 17, 2003 6:18 AM
> To: [EMAIL PROTECTED]
> Subject: Re: cvs commit: maven/src/plugins-build/artifact/src/plugin-
> resources/templates manifest.vm
> 
> >   Generic code for:
> >
> >    -  deployment of artifact to remote repositry
> >
> >     - installaton of artifact to local repository
> >
> This seems like code that is duplicating the repository and deploy
> plugins. Why do we want a third way of doing this????
> 

This one is developed in pure Java + supports deployment to various types
of repositories. Soon it will support deployment to multiple repositories.

And I think it is easier to use it then other ones + the code is more
centralized. I hope to test it with junit. This was rather hard in case of 
"old" plugins.

> Can you please change the others to use this code if it works?

It is not yet fully finished. Once I will be sure that it works I am
planning to change other plugins. 
For the moment I use war plugin as demonstration how this is supposed
to work from the point of other plugins, so if any body has some remarks...
let me know.

FYI:

package org.apache.maven.artifact.deployer.deploy;

is meant to be refactored. I think the best will be to make a "sister"
component of "fetch" in maven-new.

This code is not depending on any maven apis, and can be possibly reused
like does "fetch" component.


Package org.apache.maven.artifact.deployer;

Contains higher level API, which uses maven API and it is supposed to be
used in plugins.



[OT]

I am thinking about deploying java sources and javadocs to repository.

Any idea about naming convention of those artifacts? With maven-new it 
will be easy to control, with maven-old it is not so easy.

I am thinking about:

/${groupId}/apis/${artitifactId}_api-${version}.jar  (for javadocs)
/${groupId}/srcs/${artitifactId}_src-${version}.jar  (for sources).



Any better ideas? 

Other question is where is the best place for such functionality?
I think for javadoc it is javadoc plugin. But for sources?


Any hints what else can we deploy?


Other idea:

We have;

jar:jar
war:war
ear:ear

etc..

Wouldn't it be more consistent to have:


jar:archive
war:archive
ear:archive
javadoc:archive
java:src-archive

etc?


regards

Michal

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to