Wouldn't it be better to set the default value of third parameter to
"false"?
I am not sure if we will need to have a method with 2 parameters but for
compatibility with existing code imo "false" is better.


Michal

   
>   +    public MavenProject build( File projectDescriptor, 
> boolean useParentPom )
>   +        throws ProjectBuildingException
>   +    {
>   +        return build( project, useParentPom, true );
>   +    }
>   +
>        public MavenProject build( File projectDescriptor, 
> boolean useParentPom, boolean followTransitiveDeps )
>            throws ProjectBuildingException
>        {
>   
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to