Olivier,
What are the advantages of using an interface in this particular case?
Abstract class will allow core to add new callback methods without
breaking all existing participants, assuming participants honour
beforeXXX/afterXXX naming convention.
--
Regards,
Igor
Olivier Lamy wrote:
Wh
Why an abstract class (abstract class
AbstractMavenLifecycleParticipant) and not an interface ?
Perso, I'd prefer to
lifecycleListeners = container.lookupList( MavenLifecycleParticipant.class );
instead of
lifecycleListeners = container.lookupList(
AbstractMavenLifecycleParticipant.class );
--