Re: [TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-18 Thread Simon Lessard
Sounds acceptable then. ~ Simon On Sun, May 17, 2009 at 9:09 PM, Blake Sullivan blake.sulli...@oracle.comwrote: Simon Lessard said the following On 5/17/2009 6:19 AM PT: Hi Blake, *Prefer the same what? Are you talking about the ExternalContext?* I meant placing register the listeners

Re: [TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-17 Thread Simon Lessard
Hi Blake, *Prefer the same what? Are you talking about the ExternalContext?* I meant placing register the listeners the Window itself, not the Manager, same as isNew. ~ Simon On Sat, May 16, 2009 at 1:18 AM, Blake Sullivan blake.sulli...@oracle.comwrote: Simon Lessard said the following

Re: [TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-17 Thread Blake Sullivan
Simon Lessard said the following On 5/17/2009 6:19 AM PT: Hi Blake, /Prefer the same what? Are you talking about the ExternalContext?/ I meant placing register the listeners the Window itself, not the Manager, same as isNew. The difference between isNew() and the addition of the listeners is

Re: [TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-16 Thread Blake Sullivan
Here are the changes: WindowNavigateEvent: rename to WindowLifecycleNavigateEvent WindowListener: rename to WindowLifecycleListener change to interface and extend EventListener rename processWindowEvent to processWindowLifecylce WindowManager: replace isCurrentWindowNew() with Window.isNew()

Re: [TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-16 Thread Matthias Wessendorf
sounds good! -M On Sat, May 16, 2009 at 10:14 AM, Blake Sullivan blake.sulli...@oracle.com wrote: Here are the changes: WindowNavigateEvent: rename to WindowLifecycleNavigateEvent WindowListener: rename to WindowLifecycleListener change to interface and extend EventListener rename

[TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-15 Thread Blake Sullivan
Here is the proposed api: package org.apache.myfaces.trinidad.context; /** * Represents a Window in the current user's Session. Windows are created and vended * by the Session's WindowManager and the Window for the current request is * available from codeWindowManager.getCurrentWindow/code

Re: [TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-15 Thread Simon Lessard
Hi Blake, I'm + 1 with the idea and the general API, but I have some concerns: 1. I don't really like the API to expose a read only map through WindowManager.getWindows, I would prefer WindowManager.getWindowIds(ExternalContext) and WindowManager.getWindow(ExternalContext, String);

Re: [TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-15 Thread Matthias Wessendorf
Sent from my iPod. On 15.05.2009, at 21:35, Simon Lessard simon.lessar...@gmail.com wrote: Hi Blake, I'm + 1 with the idea and the general +1 good idea! API, but I have some concerns: I don't really like the API to expose a read only map through WindowManager.getWindows, I would

Re: [TRINIDAD][API] JIRA-1474 Add Window abstraction to Trinidad

2009-05-15 Thread Blake Sullivan
Simon Lessard said the following On 5/15/2009 12:35 PM PT: Hi Blake, I'm + 1 with the idea and the general API, but I have some concerns: 1. I don't really like the API to expose a read only map through WindowManager.getWindows, I would prefer