Re: os_eventq_get() + timeout

2016-04-04 Thread marko kiiskila
> On Apr 4, 2016, at 11:33 AM, Sterling Hughes wrote: > >> I don’t think the select() kind of mask is a good idea. eventq_XXX is more >> like kqueue() rather than select(). I don’t think there are that many places >> where you’d want to mask out some events and not others.

Re: os_eventq_get() + timeout

2016-04-04 Thread will sanfilippo
Sounds good to me +1 > On Apr 4, 2016, at 9:16 AM, Sterling Hughes > wrote: > > > >> On Apr 4, 2016, at 9:13 AM, will sanfilippo wrote: >> >> I would not break BC; I would add a different function. Not sure what I >> would call it but

Re: os_eventq_get() + timeout

2016-04-04 Thread will sanfilippo
I would not break BC; I would add a different function. Not sure what I would call it but wouldnt it just have a timeout, in ticks, associated with it? For example: os_eventq_wait(_evq, timeout_in_os_ticks). What is the purpose of the mask btw? Something to do with returning an error if it