Re: PWM API

2016-04-04 Thread p...@wrada.com
Thanks for your patience everyone. I went to write the PWM drivers for Arduino Zero and learned a lot that I wanted to share. 1) First, I agree that we should set duty cycle in fractional 16-bit. I experimented with it and found your observations correct. 2) Arduino (SAMD21G) has two different

Re: Testing rhe libs/shell

2016-04-04 Thread Nges B
Ok .I got it. Thanks On 4/5/16, Sterling Hughes wrote: > >> >> FROM: >> >> repository.apache-mynewt-core: >> type: github >> vers: 0-latest >> user: apache >> repo: incubator-mynewt-core >> >> TO: >> >>

Re: Testing rhe libs/shell

2016-04-04 Thread Christopher Collins
On Mon, Apr 04, 2016 at 11:55:54PM +0100, Nges B wrote: > in a new created project , the newt test all fails the libs/json . > the jlibs/json was not corrected on that repository. > Thanks It looks like this particular fix was already pushed to the develop branch on 2016-03-21

Re: Testing rhe libs/shell

2016-04-04 Thread Nges B
in a new created project , the newt test all fails the libs/json . the jlibs/json was not corrected on that repository. Thanks On 4/4/16, Nges B wrote: > you can do it. > also when you run tree in a newly created project, you have > 6directoies and 11filles not 10files as

Re: Testing rhe libs/shell

2016-04-04 Thread Nges B
you can do it. also when you run tree in a newly created project, you have 6directoies and 11filles not 10files as in DOcumentation :) On 4/4/16, Nges B wrote: > But it seems to be magic :) > I would I have love too but it seems more complicated that I taught. > Thanks > >

Re: Testing rhe libs/shell

2016-04-04 Thread Nges B
But it seems to be magic :) I would I have love too but it seems more complicated that I taught. Thanks On 4/4/16, Aditi wrote: > Indeed. I can change that. Or you can generate a pull request on the github > mirror if you want to test run the patch process for documentation. >

Re: Image signatures

2016-04-04 Thread Aditi
EC operations would be significantly smaller. They key size equivalent to RSA 2048 but would be 256 bits in EC. So that could be another option. Thanks, Aditi Sent from my iPhone > On Apr 4, 2016, at 12:49 PM, marko kiiskila wrote: > > Hi, > > I started work on signed

Re: Testing rhe libs/shell

2016-04-04 Thread Aditi
Indeed. I can change that. Or you can generate a pull request on the github mirror if you want to test run the patch process for documentation. Thanks, Aditi Sent from my iPhone > On Apr 4, 2016, at 2:15 PM, Nges B wrote: > > we can put something like 'newt test

Re: Image signatures

2016-04-04 Thread marko kiiskila
> On Apr 4, 2016, at 12:49 PM, marko kiiskila wrote: > > Hi, > > I started work on signed images, and there’s few things I’m wondering how to > go about. > > The way this would work is that you would start by creating a RSA key-pair > (2048 bits). > > You’d sign the image

Testing rhe libs/shell

2016-04-04 Thread Nges B
Hi everyone. There seems to be no test for libs/shell But in Documentation , tutorials for beginners give 'test newt test @apache-mynewt-core/libs/shell' as an example. I think it will e better if we can change it , It can confuse newbies. Thanks -- "A Gal is a Dream with a Plan and a

Image signatures

2016-04-04 Thread marko kiiskila
Hi, I started work on signed images, and there’s few things I’m wondering how to go about. The way this would work is that you would start by creating a RSA key-pair (2048 bits). You’d sign the image by computing RSA signature over the image hash (SHA256), and store it a TLV at the end of

flash circular buffer

2016-04-04 Thread marko kiiskila
Hi, I implemented this and want to know what you guys think of the interface. FCB is a facility that allows you to store blobs of data in flash a bit like a FIFO. You always append things in the end, and you start reading things from beginning. This is to be used when you want to e.g. keep a

Re: os_eventq_get() + timeout

2016-04-04 Thread marko kiiskila
> On Apr 4, 2016, at 11:33 AM, Sterling Hughes wrote: > >> I don’t think the select() kind of mask is a good idea. eventq_XXX is more >> like kqueue() rather than select(). I don’t think there are that many places >> where you’d want to mask out some events and not others.

Re: os_eventq_get() + timeout

2016-04-04 Thread will sanfilippo
Sounds good to me +1 > On Apr 4, 2016, at 9:16 AM, Sterling Hughes > wrote: > > > >> On Apr 4, 2016, at 9:13 AM, will sanfilippo wrote: >> >> I would not break BC; I would add a different function. Not sure what I >> would call it but

Re: os_eventq_get() + timeout

2016-04-04 Thread will sanfilippo
I would not break BC; I would add a different function. Not sure what I would call it but wouldnt it just have a timeout, in ticks, associated with it? For example: os_eventq_wait(_evq, timeout_in_os_ticks). What is the purpose of the mask btw? Something to do with returning an error if it