Re: javascript readability..

2011-08-02 Thread Phillip Rhodes
On Tue, Aug 2, 2011 at 1:46 AM, Craig McClanahan wrote: > Yes, I understand all about rapidly evolving code, > but I'd be happy with enough documentation that magicians (not even > necessarily mere mortals) that haven't memorized the codebase might get an > idea what is possible already :-).  Can

RE: javascript readability..

2011-07-29 Thread Ciancetta, Jesse E.
is public", calculateBar: calculateBar }; })()); exportJs("shindig.some.emptyNamespace", {}); shindig.some.emptyNamespace.xyz = "ABC"; --Jesse >-Original Message- >From: John Hjelmstad [mailto:fa...@google.com] >Sent: Thursday, July 28, 2011

Re: javascript readability..

2011-07-28 Thread John Hjelmstad
> shindig.namespace("shindig.util", (function() { >var privateFunction = function() { >console.log("calculateBar called"); >}; > >var calculateBar = function() { > privateFunction(); >}; > >return { >publicData: "this is public&q

Re: javascript readability..

2011-07-28 Thread John Hjelmstad
> shindig.namespace("shindig.util", (function() { >var privateFunction = function() { >console.log("calculateBar called"); >}; > >var calculateBar = function() { > privateFunction(); >}; > >return { >publicData: "this is public&q

RE: javascript readability..

2011-07-28 Thread Ciancetta, Jesse E.
---- >From: Michael Hermanto [mailto:mherma...@gmail.com] >Sent: Tuesday, July 26, 2011 6:15 PM >To: dev@shindig.apache.org >Subject: Re: javascript readability.. > >What didn't work for me with -- > shindig.foo = function() { > return { 'bar': ... }; >

Re: javascript readability..

2011-07-26 Thread Michael Hermanto
; > > > function(){ > > > FooClass.prototype.method = function() { } > > > FooClass.prototype.method2 = function() { } > > > }(); > > > > > > to get a local scope. > > > > > > I think this makes it easier to audit w

Re: javascript readability..

2011-07-26 Thread ๏̯͡๏ Jasvir Nagra
{ } > > FooClass.prototype.method2 = function() { } > > }(); > > > > to get a local scope. > > > > I think this makes it easier to audit what must be included in an export. > > And when you come up for air soon, maybe we can talk about AMD

Re: javascript readability..

2011-07-26 Thread John Hjelmstad
or air soon, maybe we can talk about AMD format and > what that brings to the table. :) > > > > From: John Hjelmstad > To: dev@shindig.apache.org, > Date: 07/26/2011 04:43 PM > Subject:Re: javascript readability.. > > > > I still prefer statu

Re: javascript readability..

2011-07-26 Thread Dan Dumont
talk about AMD format and what that brings to the table. :) From: John Hjelmstad To: dev@shindig.apache.org, Date: 07/26/2011 04:43 PM Subject:Re: javascript readability.. I still prefer status quo, as it reads more like a proper class to me, while being less verbose and

Re: javascript readability..

2011-07-26 Thread John Hjelmstad
to read. > > -Ryan > > Email: rjbax...@us.ibm.com > Phone: 978-899-3041 > developerWorks Profile > > > > From: Dan Dumont/Westford/IBM@Lotus > To: dev@shindig.apache.org, > Date: 07/26/2011 09:00 AM > Subject:Re: javascript readability

Re: javascript readability..

2011-07-26 Thread Ryan J Baxter
+1 As well, I think its easier to read. -Ryan Email: rjbax...@us.ibm.com Phone: 978-899-3041 developerWorks Profile From: Dan Dumont/Westford/IBM@Lotus To: dev@shindig.apache.org, Date: 07/26/2011 09:00 AM Subject:Re: javascript readability.. +1 From: Paul Lindner To

Re: javascript readability..

2011-07-26 Thread Dan Dumont
+1 From: Paul Lindner To: dev@shindig.apache.org, Date: 07/26/2011 02:51 AM Subject:javascript readability.. Hi, I'm curious to know what people think about some of the idioms in the JS code you find in shindig. There's an awful lot of stuff like this: s

Re: javascript readability..

2011-07-26 Thread Ian Boston
In a parallel project with almost all the UI coded in JS we use fully qualified names in preference to nesting. I think it has evolved that way partially as an attempt to make it easier for the casual reader and newcomer to get in the code. It certainly makes it easier to get the context of a frag

javascript readability..

2011-07-25 Thread Paul Lindner
Hi, I'm curious to know what people think about some of the idioms in the JS code you find in shindig. There's an awful lot of stuff like this: shindig.foo = function(){ //... var myFunction = function() { } return {'foo': myFunction, 'bar': function() { re