Re: [PATCH V3] staging: nvec: remove use of clk_get_sys

2013-01-11 Thread Greg Kroah-Hartman
On Fri, Jan 11, 2013 at 02:03:54PM -0700, Stephen Warren wrote: > From: Prashant Gaikwad > > As clock information is added to device tree clock can be looked up > using clk_get. Remove use of clk_get_sys. > > Signed-off-by: Prashant Gaikwad > [swarren: updated TODO file to remove entry that req

[PATCH 6/6] staging: line6: avoid CamelCase POD_* enums in pod.c

2013-01-11 Thread Stefan Hajnoczi
Fix the following checkpatch.pl warnings: WARNING: Avoid CamelCase: #4512: FILE: staging/line6/pod.c:41: + POD_monitor_level = 0x04, WARNING: Avoid CamelCase: #4513: FILE: staging/line6/pod.c:42: + POD_system_invalid = 0x1 Signed-off-by: Stefan Hajnoczi --- drive

[PATCH 5/6] staging: line6: drop ToneportSourceInfo CamelCase name

2013-01-11 Thread Stefan Hajnoczi
Fix the following checkpatch.pl warning: WARNING: Avoid CamelCase: #5383: FILE: staging/line6/toneport.c:90: +struct ToneportSourceInfo { Since the struct is only used to define the global toneport_source_info[] table, I have chosen to make the struct anonymous and part of the table defini

[PATCH 4/6] staging: line6: wrap lines to 80 chars in pod.c

2013-01-11 Thread Stefan Hajnoczi
Fix the following checkpatch.pl warnings: WARNING: line over 80 characters #4508: FILE: staging/line6/pod.c:37: + /* POD_SYSEX_DUMPMEM2 = 0x76 */ /* dumps entire internal memory of PODxt Pro */ WARNING: line over 80 characters #4630: FILE: staging/line6/pod.c:159: +

[PATCH 3/6] staging: line6: use pr_err() instead of printk(KERN_ERR, ...)

2013-01-11 Thread Stefan Hajnoczi
Fix the following checkpatch.pl warning: WARNING: Prefer netdev_err(netdev, ... then dev_err(dev, ... then pr_err(... to printk(KERN_ERR ... #1861: FILE: staging/line6/driver.h:56: + printk(KERN_ERR "line6usb driver bug: missing case in %s:%d\n", \ Signed-off-by: Stefan Hajnoczi --

[PATCH 2/6] staging: line6: wrap comment to 80 chars in driver.c

2013-01-11 Thread Stefan Hajnoczi
Fix the following checkpatch.pl warning: WARNING: line over 80 characters #1107: FILE: staging/line6/driver.c:523: + /* Wait for data length. We'll get a couple of 0xff until length arrives. */ Signed-off-by: Stefan Hajnoczi --- drivers/staging/line6/driver.c | 2 +- 1 file changed

[PATCH 1/6] staging: line6: rename MidiBuffer to avoid CamelCase

2013-01-11 Thread Stefan Hajnoczi
Fix checkpatch.pl warnings related to MidiBuffer: WARNING: Avoid CamelCase: #947: FILE: staging/line6/driver.c:363: + struct MidiBuffer *mb = &line6->line6midi->midibuf_in; Rename MidiBuffer to midi_buffer. Note that "midibuf" would be another good name but sound/oss/midibuf.c alrea

[PATCH 0/6] staging: line6: more checkpatch.pl warnings fixes

2013-01-11 Thread Stefan Hajnoczi
This series addresses the remaining checkpatch.pl warnings that are easy to fix. This takes the line6 driver another step closer to getting merged as an ALSA driver. Stefan Hajnoczi (6): staging: line6: rename MidiBuffer to avoid CamelCase staging: line6: wrap comment to 80 chars in driver.c

[PATCH V3] staging: nvec: remove use of clk_get_sys

2013-01-11 Thread Stephen Warren
From: Prashant Gaikwad As clock information is added to device tree clock can be looked up using clk_get. Remove use of clk_get_sys. Signed-off-by: Prashant Gaikwad [swarren: updated TODO file to remove entry that requested this change] Signed-off-by: Stephen Warren --- Note: This patch needs

Re: [PATCH] staging/omapdrm: garbage collect OMAP_DSS_DISPLAY_SUSPENDED

2013-01-11 Thread Paolo Pisati
On Thu, Jan 10, 2013 at 09:42:27PM +0100, Paolo Pisati wrote: > Compilation fix - leftover from: > > commit 998c336d4c7183301ed6a6ca93952f63e3cf694f > Author: Tomi Valkeinen > Date: Wed May 30 13:26:00 2012 +0300 > > OMAPDSS: remove omap_dss_device's suspend/resume > > Cc: stable # v3.7