[Development] Qt 5.12 new features

2018-08-14 Thread Jani Heikkinen
Hi, Qt 5.12 Feature Freeze will be in effect Mon 20th August and we should have already now pretty good understanding what is new in Qt 5.12. So please update 5.12 new features page here: https://wiki.qt.io/New_Features_in_Qt_5.12 br, Jani ___

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Tor Arne Vestbø
> On 14 Aug 2018, at 15:29, Allan Sandfeld Jensen wrote: > > I agree, at least in most cases. There are still cases where I would prefer > unscoped enums. For instance in my recent QColorSpace patch, I ended up using > both types of enums under QColorSpace. The enum that represented

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Tor Arne Vestbø
I’ve lost track of what you are arguing for here  To bring the discussion back, here are my main points: 1. Scoped enums (enum class) for the sake of avoiding name clashes is useful for global enums, but when the enum lives inside a class, the chance that we’ll see a naming clash is minor,

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Allan Sandfeld Jensen
On Dienstag, 14. August 2018 14:27:27 CEST Alex Blasche wrote: > > -Original Message- > > From: Tor Arne Vestbø > > > > > > To quote the policy: > > > > > > > > > > > > "By comparison the following example illustrates the dangers of missing > > > type > > > safety and giving general

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Eike Ziller
> On 14. Aug 2018, at 13:18, Tor Arne Vestbø wrote: > > >> On 14 Aug 2018, at 13:13, Eike Ziller wrote: >> >> http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2007/n2347.pdf states the >> problems that were the driver for creating strongly typed enums: >> >> 1. Implicit conversion to

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Alex Blasche
> -Original Message- > From: Tor Arne Vestbø > > To quote the policy: > > > > "By comparison the following example illustrates the dangers of missing type > safety and giving general names to conventional enum values:" > > ... > > " One guideline for naming enum types is to repeat at

[Development] HEADS-UP: Branching from 'dev' to '5.12' started

2018-08-14 Thread Jani Heikkinen
Hi! We have soft branched '5.12' from 'dev' today. We are planning to have final downmerge and Qt 5.12 Feature Freeze Monday 20.8.2018. So there is still time to finalize ongoing task in 'dev' and start using '5.12' for new changes targeted to Qt 5.12 release. br, Jani Heikkinen Release

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Tor Arne Vestbø
> On 14 Aug 2018, at 13:13, Eike Ziller wrote: > > http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2007/n2347.pdf states the > problems that were the driver for creating strongly typed enums: > > 1. Implicit conversion to integer > 2. Inability to specify underlying type

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Eike Ziller
> On 14. Aug 2018, at 12:30, Tor Arne Vestbø wrote: > >> >> On 14 Aug 2018, at 12:13, Alex Blasche wrote: >> >> >> >>> -Original Message- >>> From: Tor Arne Vestbø >>> That circular logic  Or at least arguing that we should maintain the >>> policy not >>> because it makes sense,

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Tor Arne Vestbø
> On 14 Aug 2018, at 12:13, Alex Blasche wrote: > > > >> -Original Message- >> From: Tor Arne Vestbø >> That circular logic  Or at least arguing that we should maintain the policy >> not >> because it makes sense, but just because we’ve done so in the past. >> >> You are not

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Alex Blasche
> -Original Message- > From: Tor Arne Vestbø > That circular logic  Or at least arguing that we should maintain the policy > not > because it makes sense, but just because we’ve done so in the past. > > You are not questioning _why_ we have done so in the past (for decades as you >

[Development] Redeploying hosts with original kernel

2018-08-14 Thread Tony Sarajärvi
Hi It seems like a culprit for our extremely odd behaving windows VMs might be the custom kernel we are applying (that tried to fix an NFS issue). After using the original kernel again, it seems at least for now we can run full speed on a host again. So I'll redeploy all hosts (some done

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Tor Arne Vestbø
> On 14 Aug 2018, at 09:16, Alex Blasche wrote: > >> I >> do not think that using class enums inside existing classes is a win for code >> readability/writability: >> >> When you have >> >> switch (point->state()) { >> >> It's pretty obvious what case QQuickEventPoint::Pressed: refers to.

Re: [Development] Naming convention for (scoped) enums

2018-08-14 Thread Alex Blasche
> -Original Message- > From: Tor Arne Vestbø > Sent: Monday, 13 August 2018 16:40 > To: Alex Blasche > Cc: development@qt-project.org; Simon Hausmann > Subject: Re: [Development] Naming convention for (scoped) enums > > Bringing this up again in light of e.g. https://codereview.qt- >