Re: [Development] Signal naming convention (was: A modest proposal: disable lower-case keywords...)

2020-02-28 Thread Benjamen Meyer via Development
Honestly, a naming convention may solve the issue within the Qt code-base, but I don't think it would necessarily be adopted by all users of Qt. Personally, I in my Qt projects I just use the Q_EMIT macro, and I do find that helpful. The downside of the naming convention aspect is that Lambdas ma

Re: [Development] Signal naming convention (was: A modest proposal: disable lower-case keywords...)

2020-02-28 Thread Vasily Pupkin
Prefixing identifiers is a slippery slope. In a fit of unifying coding style everything will get prefixed. There will be slot_, m_, property_, setter_/getter_ and so on. Type name prefixing worth mentioning - unbelieably ugly convention https://docs.microsoft.com/en-us/windows/win32/stg/coding-styl

Re: [Development] Signal naming convention (was: A modest proposal: disable lower-case keywords...)

2020-02-28 Thread Max Paperno
I humbly suggest, in general, that a signal name could be prefixed with "sig", "sig_", "signal" or "signal_". "sigEmptied()" doesn't look horrible IMHO, and should work semantically with any verb. Using prefixes to signify meaning already has some precedence in C/C++ world as well. And lastl