Move all dreamplug-specific code out of board-dt.c and into
board-dreamplug.c. This way new boards that are added during the
conversion to fdt don't clutter up board-dt.c.
Signed-off-by: Jason Cooper
---
Changes from v1:
- This code was broken out into a separate patch so that it could app
Signed-off-by: Andrew Lunn
Signed-off-by: Jason Cooper
Acked-by: Grant Likely
Acked-by: Arnd Bergmann
---
Changes from v2:
- Corrected authorship to myself. The author was inadvertently changed to
Andrew Lunn with a wayward 'commit --amend' during a 'rebase -i' to split
the w
We need to absorb kirkwood_init() into kirkwood_dt_init() so that as we
convert drivers, we can remove the platform call, eg
kirkwood_rtc_init(). This maintains compatibility with non-fdt
configurations because they still call kirkwood_init() in common.c.
As drivers are converted, we will reinsta
Signed-off-by: Jason Cooper
Acked-by: Arnd Bergmann
---
arch/arm/boot/dts/kirkwood.dtsi |6 ++
arch/arm/mach-kirkwood/board-dt.c |1 -
arch/arm/mach-kirkwood/common.c |2 +-
arch/arm/mach-kirkwood/common.h |1 -
4 files changed, 7 insertions(+), 3 deletions(-)
diff --g
Trivial conversion to devicetree.
Signed-off-by: Jason Cooper
---
Changes from v1:
- added 'trivial conversion' patch description.
drivers/rtc/rtc-mv.c |9 +
1 files changed, 9 insertions(+), 0 deletions(-)
diff --git a/drivers/rtc/rtc-mv.c b/drivers/rtc/rtc-mv.c
index 768e2e
Define both uarts in kirkwood.dtsi as they are common to all kirkwood
SoCs. Each board may enable all or none of them, so they are disabled
by default. uart0 is enabled for the dreamplug.
tclk can vary for each board, so we leave it undefined in the kirkwood
dtsi. Each board can then set it as
From: Andrew Lunn
It is not used anywhere in the sound driver.
Signed-off-by: Andrew Lunn
Signed-off-by: Jason Cooper
---
arch/arm/mach-kirkwood/common.c |1 -
arch/arm/plat-orion/include/plat/audio.h |1 -
2 files changed, 0 insertions(+), 2 deletions(-)
diff --git a/arch/a
Also, use inclusive register size for uart0.
Signed-off-by: Jason Cooper
---
arch/arm/boot/dts/kirkwood-dreamplug.dts |4 ++--
arch/arm/boot/dts/kirkwood.dtsi |2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/arch/arm/boot/dts/kirkwood-dreamplug.dts
b/arch/a
This series continues the process of converting all of the drivers initialized
from kirkwood_init() to devicetree.
The first three patches are code cleanup from Andrew Lunn and myself.
The next three patches are cleanup and prep to facilitate adding new boards
during the transition to devicetree.
From: Andrew Lunn
Signed-off-by: Andrew Lunn
Signed-off-by: Jason Cooper
Acked-by: Grant Likely
---
drivers/spi/spi-orion.c |5 -
include/linux/spi/orion_spi.h |1 -
2 files changed, 0 insertions(+), 6 deletions(-)
diff --git a/drivers/spi/spi-orion.c b/drivers/spi/spi-orio
On 3/15/2012 5:10 PM, Arnd Bergmann wrote:
> I don't have the data sheet, so the bus hierarchy above is completely made up,
> but I guess you get the idea. If each bus has its own local register range, it
> may be helpful to use the ranges property to remap the reg properties in the
> way that I di
On Thu, Mar 15, 2012 at 07:24:19PM +0800, s.ha...@pengutronix.de wrote:
> On Thu, Mar 15, 2012 at 06:59:28PM +0800, Dong Aisheng wrote:
> > On Thu, Mar 15, 2012 at 02:53:29PM +0800, Lothar Waßmann wrote:
> > > Hi,
> > >
> > > Dong Aisheng writes:
> > > > On Wed, Mar 14, 2012 at 10:16:43PM +0800, s
On Thu, Mar 15, 2012 at 07:22:04PM +0800, Lothar Waßmann wrote:
> Hi,
>
> Dong Aisheng writes:
> > On Thu, Mar 15, 2012 at 02:53:29PM +0800, Lothar Waßmann wrote:
> > > Hi,
> > >
> > > Dong Aisheng writes:
> > > > On Wed, Mar 14, 2012 at 10:16:43PM +0800, s.ha...@pengutronix.de wrote:
> > > > > O
On Wed, Mar 14, 2012 at 09:40:13AM -0600, Stephen Warren wrote:
> On 03/14/2012 08:46 AM, David Gibson wrote:
> > So, in order to actually make progress on the dtc expressions / macros
> > / whatnot stuff, I really think I should dust off my integer (constant)
> > expressions patch, and we can appl
On Thu, 15 Mar 2012, Russell King - ARM Linux wrote:
> I really don't like these behind-the-scenes discussions which never then
> get followed up in public, and people then start quoting what was "agreed"
> as that's the way things must be done.
>
> It's a bit like folk at the recent Linaro Conne
On Thu, Mar 15, 2012 at 10:39:12PM +0100, Cousson, Benoit wrote:
> On 3/15/2012 9:41 PM, Arnd Bergmann wrote:
>> On Thursday 15 March 2012, Russell King - ARM Linux wrote:
>>> On Thu, Mar 15, 2012 at 05:30:49PM +0100, Cousson, Benoit wrote:
This was done like IRQ on purpose, because an Interru
On 3/15/2012 9:41 PM, Arnd Bergmann wrote:
On Thursday 15 March 2012, Russell King - ARM Linux wrote:
On Thu, Mar 15, 2012 at 05:30:49PM +0100, Cousson, Benoit wrote:
This was done like IRQ on purpose, because an Interrupt ReQuest line and
a DMA Request line are really similar for the HW point
On Thursday 15 March 2012, Russell King - ARM Linux wrote:
> On Thu, Mar 15, 2012 at 05:30:49PM +0100, Cousson, Benoit wrote:
> > This was done like IRQ on purpose, because an Interrupt ReQuest line and
> > a DMA Request line are really similar for the HW point of view at IP
> > level.
>
> I'm
On Thu, Mar 15, 2012 at 05:30:49PM +0100, Cousson, Benoit wrote:
> This was done like IRQ on purpose, because an Interrupt ReQuest line and
> a DMA Request line are really similar for the HW point of view at IP
> level.
I'm not sure about that at all levels. Sure, at hardware level they're
the
Cc: Rajendra Nayak
Cc: Benoit Cousson
Cc: Grant Likely
Signed-off-by: Aneesh V
---
v2:
- Addressed comments from Grant Likely:
Converted occurences of __init to __init_or_module
Removed un-necessary instances of #ifdef CONFIG_OF
- Rebased to v2 of EMIF driver series
v1:
- Rebased to the la
Device tree data for the EMIF sdram controllers in OMAP4
and LPDDR2 memory devices attached to OMAP4 boards.
Cc: Rajendra Nayak
Cc: Benoit Cousson
Cc: Grant Likely
Signed-off-by: Aneesh V
---
v1:
- Removed DDR3 only parameters from
elpida_ecb240abacn.dtsi
---
arch/arm/boot/dts/elpida_ecb240
EMIF - External Memory Interface - is an SDRAM controller used in
TI SoCs. EMIF supports, based on the IP revision, one or more of
DDR2/DDR3/LPDDR2 protocols. This binding describes a given instance
of the EMIF IP and memory parts attached to it.
Cc: Rajendra Nayak
Cc: Benoit Cousson
Cc: Grant L
device tree bindings for LPDDR2 SDRAM memories compliant
to JESD209-2 standard.
The 'lpddr2' binding in-turn uses another binding 'lpddr2-timings'
for specifying the AC timing parameters of the memory device at
different speed-bins.
Cc: Rajendra Nayak
Cc: Benoit Cousson
Cc: Grant Likely
Signed
This series adds device tree support for TI EMIF SDRAM controller
driver. For this, a binding has been added for representing AC timing
parameters and other details of LPDDR2 memories.
This series depends v2 of my series for adding EMIF driver [1]
[1] http://marc.info/?l=linux-omap&m=133183554007
On 03/15/2012 04:37 AM, Dan Carpenter wrote:
There are a couple issues here caused by confusion between sizeof()
and ARRAY_SIZE(). "table_size" should be the number of elements, but we
should allocate it with kcalloc() so that we allocate the correct number
of bytes.
In max17042_init_model() we
On 03/14/2012 09:32 PM, Dong Aisheng wrote:
> On Wed, Mar 14, 2012 at 03:27:26AM +0800, Stephen Warren wrote:
>> On 03/12/2012 09:20 PM, Dong Aisheng wrote:
...
>>> I can't see why we still need a special compatible flag to tell driver.
>>> Just do not define pinctrl-* properties for that devices i
On 03/15/2012 10:51 AM, Linus Walleij wrote:
...
> Hm, both you guys agree, then I will be happy that we merge this.
> Acked-by: Linus Walleij
Great. I'll repost a new version very soon based on the feedback (just a
couple of grammar issues and an added example).
> Since it's just toching DT dir
On 03/15/2012 04:37 AM, Dan Carpenter wrote:
There are a couple issues here caused by confusion between sizeof()
and ARRAY_SIZE(). "table_size" should be the number of elements, but we
should allocate it with kcalloc() so that we allocate the correct number
of bytes.
In max17042_init_model() we
On 15.03.2012 13:56, Mark Brown wrote:
> On Thu, Mar 15, 2012 at 11:04:56AM +0100, Karol Lewandowski wrote:
>
>> Introducing separate type (TYPE_S3C2440_HDMIPHY) has been our original
>> attempt to solve this issue. However, this required adding explicit
>> checks to driver code all over the pla
On Wed, Mar 14, 2012 at 10:26 PM, Tony Lindgren wrote:
> * Stephen Warren [120309 10:17]:
>> The core pin controller bindings define:
>> * The fact that pin controllers expose pin configurations as nodes in
>> device tree.
>> * That the bindings for those pin configuration nodes is defined by t
On 3/15/2012 10:22 AM, Arnd Bergmann wrote:
On Thursday 15 March 2012, Nicolas Ferre wrote:
Add some basic helpers to retrieve a DMA controller device_node and the
DMA request specifications. By making DMA controllers register a generic
translation function, we allow the management of any type o
To achieve DT support, we need to populate a custom platform_data in a
private struct from DT information. To simplify code, the adapter and
algorithm are also put into the private struct.
Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
Acked-by: Grant Likely
Acked-by: Rob Herring
Acked-by: Wol
On 20:01 Wed 14 Mar , Stefan Roese wrote:
> On Wednesday 14 March 2012 18:24:35 Jean-Christophe PLAGNIOL-VILLARD wrote:
> > > > > diff --git a/arch/arm/boot/dts/spear600-evb.dts
> > > > > b/arch/arm/boot/dts/spear600-evb.dts new file mode 100644
> > > > > index 000..cbfda8d
> > > > > --- /d
On 03:54 Thu 15 Mar , Grant Likely wrote:
> On Tue, 13 Mar 2012 18:48:23 +0100, Jean-Christophe PLAGNIOL-VILLARD
> wrote:
> > of_property_read_bool
> >
> > Search for a property in a device node.
> > Returns true if the property exist false otherwise.
> >
> > Signed-off-by: Jean-Christophe
On Tue, 13 Mar 2012 18:48:23 +0100, Jean-Christophe PLAGNIOL-VILLARD
wrote:
> of_property_read_bool
>
> Search for a property in a device node.
> Returns true if the property exist false otherwise.
>
> Signed-off-by: Jean-Christophe PLAGNIOL-VILLARD
> Acked-by: Rob Herring
> Acked-by: Arnd Be
On Thursday 15 March 2012, Stefan Roese wrote:
> On Thursday 15 March 2012 10:00:27 Viresh Kumar wrote:
> > On 3/15/2012 2:18 PM, Stefan Roese wrote:
> > >>> > > +static const struct of_device_id vic_of_match[] __initconst = {
> > >>> > > + { .compatible = "arm,pl190-vic", .data = vic_of_init,
On Thu, Mar 15, 2012 at 11:04:56AM +0100, Karol Lewandowski wrote:
> Introducing separate type (TYPE_S3C2440_HDMIPHY) has been our original
> attempt to solve this issue. However, this required adding explicit
> checks to driver code all over the place (if (type == S3C2400 ||
> type == S3c2440_HD
On Thursday 15 March 2012, Mark Brown wrote:
> Similar code is going in for regulators in 3.4 along with the core
> -EPROBE_DEFER change (though not OF specific) and I sent a similar patch
> for GPIOs too, hopefully Grant will ack it in time for it to make it in.
>
> My theory is that since you ne
On Thursday 15 March 2012, Viresh Kumar wrote:
> On 3/15/2012 4:20 PM, Stefan Roese wrote:
>
> > diff --git a/arch/arm/boot/dts/spear600.dtsi
> > b/arch/arm/boot/dts/spear600.dtsi
>
> > +/ {
> > + compatible = "st,spear600";
> > +
> > + cpus {
> > + cpu@0 {
> > +
On Thu, Mar 15, 2012 at 06:59:28PM +0800, Dong Aisheng wrote:
> On Thu, Mar 15, 2012 at 02:53:29PM +0800, Lothar Waßmann wrote:
> > Hi,
> >
> > Dong Aisheng writes:
> > > On Wed, Mar 14, 2012 at 10:16:43PM +0800, s.ha...@pengutronix.de wrote:
> > > > On Wed, Mar 14, 2012 at 08:45:23PM +0800, Dong
Hi,
Dong Aisheng writes:
> On Thu, Mar 15, 2012 at 02:53:29PM +0800, Lothar Waßmann wrote:
> > Hi,
> >
> > Dong Aisheng writes:
> > > On Wed, Mar 14, 2012 at 10:16:43PM +0800, s.ha...@pengutronix.de wrote:
> > > > On Wed, Mar 14, 2012 at 08:45:23PM +0800, Dong Aisheng wrote:
> > > > > On Wed, Mar
On 3/15/2012 4:20 PM, Stefan Roese wrote:
> diff --git a/arch/arm/boot/dts/spear600.dtsi b/arch/arm/boot/dts/spear600.dtsi
> +/ {
> + compatible = "st,spear600";
> +
> + cpus {
> + cpu@0 {
> + compatible = "arm,arm926ejs";
> + };
> +
On Thu, Mar 15, 2012 at 02:53:29PM +0800, Lothar Waßmann wrote:
> Hi,
>
> Dong Aisheng writes:
> > On Wed, Mar 14, 2012 at 10:16:43PM +0800, s.ha...@pengutronix.de wrote:
> > > On Wed, Mar 14, 2012 at 08:45:23PM +0800, Dong Aisheng wrote:
> > > > On Wed, Mar 14, 2012 at 01:23:51AM +0800, Grant Lik
This patch adds a generic target for SPEAr600 board that can be
configured via the device-tree. Currently the following devices
are supported via the devicetree:
- VIC interrupts
- PL011 UART
- PL061 GPIO
- Synopsys DW I2C
- Synopsys DW ethernet
Other peripheral devices (e.g. SMI flash, FSMC NAND
On 3/15/2012 4:08 PM, Stefan Roese wrote:
> I still don't think its worth it. But please feel free to send an add-on
> patch, to "clean this up".
Ok. I will do it.
--
viresh
___
devicetree-discuss mailing list
devicetree-discuss@lists.ozlabs.org
https
On Thursday 15 March 2012 10:00:27 Viresh Kumar wrote:
> On 3/15/2012 2:18 PM, Stefan Roese wrote:
> >>> > > +static const struct of_device_id vic_of_match[] __initconst = {
> >>> > > + { .compatible = "arm,pl190-vic", .data = vic_of_init, },
> >>> > > + { /* Sentinel */ }
> >>> > > +};
> >
On Thu, Mar 15, 2012 at 08:40:42AM +, Arnd Bergmann wrote:
> On Wednesday 14 March 2012, Thierry Reding wrote:
> > +static struct pwm_chip *of_node_to_pwmchip(struct device_node *np)
> > +{
> > + return ERR_PTR(-EPROBE_DEFER);
> > +}
> EPROBE_DEFER doesn't exist yet in my kernel, and I won
* Arnd Bergmann wrote:
> On Thursday 15 March 2012, Nicolas Ferre wrote:
[...]
> > + i2c1: i2c@1 {
> > + ...
> > + dma-request = <&sdma 2 &sdma 3>;
> > + dma-request-names = "tx", "rx";
> > + ...
> > + };
>
> This is slightly different from how the propo
On Thursday 15 March 2012, Russell King - ARM Linux wrote:
> On Thu, Mar 15, 2012 at 09:22:06AM +, Arnd Bergmann wrote:
> > On Thursday 15 March 2012, Nicolas Ferre wrote:
> > > Add some basic helpers to retrieve a DMA controller device_node and the
> > > DMA request specifications. By making D
On 14.03.2012 18:29, Mark Brown wrote:
> On Tue, Mar 13, 2012 at 05:54:38PM +0100, Karol Lewandowski wrote:
>
>> - replace s3c24xx_i2c_type enum with plain unsigned int that can
>>hold not only device type but also hw revision-specific quirks
>
> Would it not be clearer to just have explici
On Thu, Mar 15, 2012 at 10:21:34AM +0100, Thierry Reding wrote:
> * Sascha Hauer wrote:
> > On Thu, Mar 15, 2012 at 07:56:31AM +0100, Thierry Reding wrote:
> > > Actually I wasn't planning on keeping this patch at all. Sascha already
> > > has
> > > the existing PWM providers converted to his orig
On 3/15/2012 2:18 PM, Stefan Roese wrote:
>>> > > +static const struct of_device_id vic_of_match[] __initconst = {
>>> > > + { .compatible = "arm,pl190-vic", .data = vic_of_init, },
>>> > > + { /* Sentinel */ }
>>> > > +};
>>> > > +
>>> > > +static void __init spear6xx_dt_init_irq(void)
On Thu, Mar 15, 2012 at 09:22:06AM +, Arnd Bergmann wrote:
> On Thursday 15 March 2012, Nicolas Ferre wrote:
> > Add some basic helpers to retrieve a DMA controller device_node and the
> > DMA request specifications. By making DMA controllers register a generic
> > translation function, we allo
On Thursday 15 March 2012, Nicolas Ferre wrote:
> Add some basic helpers to retrieve a DMA controller device_node and the
> DMA request specifications. By making DMA controllers register a generic
> translation function, we allow the management of any type of DMA requests
> specification.
> The voi
* Sascha Hauer wrote:
> On Thu, Mar 15, 2012 at 07:56:31AM +0100, Thierry Reding wrote:
> > Actually I wasn't planning on keeping this patch at all. Sascha already has
> > the existing PWM providers converted to his original framework and offered
> > to
> > rebase them onto this series once the du
On Thu, Mar 15, 2012 at 07:56:31AM +0100, Thierry Reding wrote:
> * Ryan Mallon wrote:
> > On 15/03/12 02:56, Thierry Reding wrote:
> >
> > > Signed-off-by: Thierry Reding
> > > ---
> > > Changes in v3:
> > > - update PWM ops for changes in patch 2
> >
> > Couple of quick notes, mostly for fut
On Wednesday 14 March 2012, Thierry Reding wrote:
> +
> + pwm = of_pwm_request(node, "pwm", 0);
> + if (IS_ERR(pwm))
> + return PTR_ERR(pwm);
It's interesting that the (so far) only user of of_pwm_request() doesn't
actually give a meaningful argument as the name of the pw
Viresh,
On Wednesday 14 March 2012 08:05:05 Viresh Kumar wrote:
> > +static const char *spear600_dt_board_compat[] = {
> > + "st,spear600-evb",
> > + NULL
> > +};
> > +
> > +static const struct of_device_id vic_of_match[] __initconst = {
> > + { .compatible = "arm,pl190-vic", .data = vic_of_
On 3/15/2012 2:11 PM, Stefan Roese wrote:
> So why don't we make an even bigger "cut", and remove the non-DT SPEAr600
> files/data completely now? If you give me your ACK on this, I'll squash this
> into my patch as well, resulting in a nice diffstat.
My ack is already with you :)
Just go ahead
On Wednesday 14 March 2012, Thierry Reding wrote:
> This patch adds helpers to support device tree bindings for the generic
> PWM API. Device tree binding documentation for PWM controllers is also
> provided.
>
> Signed-off-by: Thierry Reding
> ---
> Changes in v4:
> - add OF-specific code remo
Hi Viresh,
On Thursday 15 March 2012 09:19:54 Viresh Kumar wrote:
> Hi Stefan,
>
> Thanks for your patch. :)
You are welcome. :)
> I have looked carefully at the patch, regarding addresses and irq numbers,
> and they look fine. Just few minor comments below:
>
> On 3/14/2012 8:30 PM, Stefan R
Add some basic helpers to retrieve a DMA controller device_node and the
DMA request specifications. By making DMA controllers register a generic
translation function, we allow the management of any type of DMA requests
specification.
The void * output of an of_dma_xlate() function that will be impl
Hi Stefan,
Thanks for your patch. :)
I have looked carefully at the patch, regarding addresses and irq numbers,
and they look fine. Just few minor comments below:
On 3/14/2012 8:30 PM, Stefan Roese wrote:
> diff --git a/arch/arm/boot/dts/spear600.dtsi b/arch/arm/boot/dts/spear600.dtsi
> +
Hi,
Dong Aisheng writes:
> On Wed, Mar 14, 2012 at 10:16:43PM +0800, s.ha...@pengutronix.de wrote:
> > On Wed, Mar 14, 2012 at 08:45:23PM +0800, Dong Aisheng wrote:
> > > On Wed, Mar 14, 2012 at 01:23:51AM +0800, Grant Likely wrote:
[...]
> > > But it seems this needs pass mac address to fec drive
64 matches
Mail list logo