Re: magic-removal Q: tagging/auditing functionality -- howto

2006-02-25 Thread ChaosKCW
Hi I have been thinking about doing something like this, and it seems you probably would have to use the new save() method. However you would still need a model for each history table. Although I was toying with a genric history table (more akin to a log) where you could then easly code it up onc

tracking people

2006-02-25 Thread Mary Adel
is their a way to track the people that visit my website using Django cause i know that Turbogears has this functionality --~--~-~--~~~---~--~~ You received this message because you are subscribed to the Google Groups "Django developers" group. To post to this gr

Re: tracking people

2006-02-25 Thread Luke Plant
On Saturday 25 February 2006 12:52, Mary Adel wrote: > is their a way to track the people that visit my website using Django > cause i know that Turbogears has this functionality I'm not aware of any builtin functionality for this, but you could write a middleware to do it, and it shouldn't be

Re: using model classes without a server

2006-02-25 Thread Michael Twomey
On 23/02/06, Adrian Holovaty <[EMAIL PROTECTED]> wrote: > That's exactly what we're discussing in the "validation-aware models" thread. > :) > Ack, now I see that thread :) thanks, Michael --~--~-~--~~~---~--~~ You received this message because you are subscrib

Re: [Changeset] r2386 - django/branches/magic-removal/django/core

2006-02-25 Thread Daniel Poelzleithner
Adrian Holovaty wrote: > django-admin.py startproject foo > > # generated settings file contains INSTALLED_APPS with the basics, > # such as sessions, auth, etc.. Advanced users can remove any or all of > that > # if they don't want to use it. > > python foo/manage.py synch

Re: are TinyMCE + other HTML input editors safe to use.

2006-02-25 Thread akaihola
I admit there's nothing you can do on the client side to avoid the need for server-side validation. But allowing only a tight subset of tags in TinyMCE does solve many user experience problems when pasting formatted text. --~--~-~--~~~---~--~~ You received this me

Re: [Changeset] r2386 - django/branches/magic-removal/django/core

2006-02-25 Thread Adrian Holovaty
On 2/25/06, Daniel Poelzleithner <[EMAIL PROTECTED]> wrote: > my patch is a extended version of #1371 which allows also simple > depedencies to other apps. in myapp/default_settings.py you could write > DEPENDS_ON=('somethingelse.app',) which would be automaticly appended to > INSTALLED_APPS if it

Re: tracking people

2006-02-25 Thread Max Battcher
Mary Adel wrote: > is their a way to track the people that visit my website using Django > cause i know that Turbogears has this functionality If you are running on top of Apache, why reinvent the wheel? Grab an Apache log viewer like AWStats. -- --Max Battcher-- http://www.worldmaker.net/ -

Generic View - Proposed Patch for 'template_model_name'

2006-02-25 Thread ChaosKCW
Hi I have raised the following ticket: http://code.djangoproject.com/ticket/1399 I propose adding a new paramter to the list_detail.py generic view to allow you to name your model/objects to something other than 'object' or 'object_list'. I prospose and feel that more meaning names make templat

{% recurse %} Tag

2006-02-25 Thread Armin Ronacher
Hiho :-) Yesterday I tried to implement a sitemap with jinja and i encountered a missing tag :-) The {% recurse %} tag. So whats this all about? A small example is here: http://wsgiarea.pocoo.org/trac/browser/jinja/trunk/unittests/tec/recurse.py The generated output is here: http://wsgiarea.poc

Re: Jinja Template Engine

2006-02-25 Thread ChaosKCW
Hi I realise this is still in the early stages of development, but I had one question on performance. Have you done any performance comparisons with django's template system? --~--~-~--~~~---~--~~ You received this message because you are subscribed to the Google

Re: Generic View - Proposed Patch for 'template_model_name'

2006-02-25 Thread Tom Tobin
On 2/25/06, ChaosKCW <[EMAIL PROTECTED]> wrote: > > Hi > > I have raised the following ticket: > http://code.djangoproject.com/ticket/1399 > > I propose adding a new paramter to the list_detail.py generic view to > allow you to name your model/objects to something other than 'object' > or 'object_l

Re: Generic View - Proposed Patch for 'template_model_name'

2006-02-25 Thread Luke Plant
On Saturday 25 February 2006 22:46, Tom Tobin wrote: > Err . . . they *are* supposed to be *generic* views, right? :-) > This would *subtract* from the usefulness of a given template using > this; your particular object's name is hardcoded into the template, > making reuse harder. The views ar

Re: Generic View - Proposed Patch for 'template_model_name'

2006-02-25 Thread Tom Tobin
On 2/25/06, Luke Plant <[EMAIL PROTECTED]> wrote: > > How likely is it that you will reuse that for a different type of > object? Even if you do, it is pretty likely that any object which has > the same interface as my 'person' example could be called > 'person' (even if it was really 'Customer',

Re: Generic View - Proposed Patch for 'template_model_name'

2006-02-25 Thread Luke Plant
On Saturday 25 February 2006 23:51, Tom Tobin wrote: > I tend towards generic names simply because it makes swapping out and > reusing template bits, and/or renaming models, easier. OK, I can see generic names get more useful when composing templates out of various bits. I don't tend to do tha

Re: Generic View - Proposed Patch for 'template_model_name'

2006-02-25 Thread ChaosKCW
Yes Generic VIEWS. Where does the word veiw imply template? The view is generic the template is specific. My proposal is make the views even more generic and templates even more usefull. --~--~-~--~~~---~--~~ You received this message because you are subscribed t

Re: Generic View - Proposed Patch for 'template_model_name'

2006-02-25 Thread ChaosKCW
I can see how on occasion you might swap out one template for another, but its more a rarity (in my experience). I agree with Luke, in that templates are alsmot always specific. Why not help make them more readable and easier to use? If you go along with the idea that template designers are not c

Re: Generic View - Proposed Patch for 'template_model_name'

2006-02-25 Thread ChaosKCW
Also one more point, which Tom did point out. This is a use it if you want it feature. If you like generic names this wont change anythign your currently doing. So you increasing the flexibility of Django. Giving more features not less. --~--~-~--~~~---~--~~ You

Fwd: [Changeset] r2401 - django/branches/magic-removal/django/core

2006-02-25 Thread Ian Holsman
With the removal of content types from the core framework, you will no longer be able to things like the comment application, which relies on the content-type-id to figure out what class the object belongs to. Is there any plan on putting this kind of functionality back? I personally think that t

Re: bug in bulk delete

2006-02-25 Thread Russell Keith-Magee
On 2/25/06, Luke Plant <[EMAIL PROTECTED]> wrote: > > On Friday 24 February 2006 23:34, Russell Keith-Magee wrote: > > Can you confirm that your problem is also resolved? > > Thanks for working on this, but unfortunately it's still not resolved. > However, I've found I've got the same problem wit

Re: [Changeset] r2401 - django/branches/magic-removal/django/core

2006-02-25 Thread Adrian Holovaty
On 2/25/06, Ian Holsman <[EMAIL PROTECTED]> wrote: > With the removal of content types from the core framework, you will no > longer be able to things like the comment application, which relies on > the content-type-id to figure out what class the object belongs to. > > Is there any plan on puttin