Re: Signals sent by the cache framework?

2009-03-29 Thread Malcolm Tredinnick
On Sun, 2009-03-29 at 17:15 -0700, Oliver Beattie wrote: > I figured that might be the case. I am wrapping the backend now in > tests, I just hate monkey patching :) There should be no monkey-patching involved. Using a separate settings file for tests so that it points to its own cache isn't

Re: Signals sent by the cache framework?

2009-03-29 Thread Oliver Beattie
I figured that might be the case. I am wrapping the backend now in tests, I just hate monkey patching :) Anyway, thanks for answering, I'm glad it got a definite response. On Mar 30, 1:01 am, Malcolm Tredinnick wrote: > On Sun, 2009-03-29 at 16:28 -0700, Oliver

Re: Signals sent by the cache framework?

2009-03-29 Thread Malcolm Tredinnick
On Sun, 2009-03-29 at 16:28 -0700, Oliver Beattie wrote: > Hey Everyone, > > I just wanted to poll opinion on a feature request I'm considering > posting a ticket for (and obviously write a patch for). Basically, I > want the cache framework to send signals whenever it interacts with > the cache

Re: Dynamic urlconf

2009-03-29 Thread Malcolm Tredinnick
On Sun, 2009-03-29 at 16:06 -0500, Jeremy Dunck wrote: > I have a need for dynamic URL definition, but I see that > RegexURLResolver.reverse uses a cache, _reverse_dict. > > Option 1): >Make a RegexURLResolver subclass which sets _reverse_dict back to > an empty MultiValueDict when a URL is

Re: GSoC Proposal: Serialization Enhancements

2009-03-29 Thread Russ Amos
Oliver, examining unique and unique_together attributes is exactly what I have in mind for attempting to follow relationships when deserializing. I realize it needs to be dealt with carefully in the inner workings of Django, to provide consistency, but anything you're willing to provide, I'm

Signals sent by the cache framework?

2009-03-29 Thread Oliver Beattie
Hey Everyone, I just wanted to poll opinion on a feature request I'm considering posting a ticket for (and obviously write a patch for). Basically, I want the cache framework to send signals whenever it interacts with the cache (things like cache_hit, cache_miss, cache_set, cache_deleted). I

Re: GSoC Proposal: Serialization Enhancements

2009-03-29 Thread Oliver Beattie
I'll admit that I haven't read your whole post (sorry), but one part caught my eye… the bit about storing relationships not just as primary keys. If I am right in thinking that you are wanting to do some sort of "relationship following" I think I can probably help by providing some initial (but a

GSoC Proposal: Serialization Enhancements

2009-03-29 Thread Russ
My apologies for the length! Concisely, I intend to provide the Django user with some granular control of the data to be serialized without sacrificing backwards compatibility for old code, or for users who need the straightforward, current functionality. Any serialized Model contains only

Re: DDN on #9284

2009-03-29 Thread Joseph Kocherhans
On Mon, Mar 23, 2009 at 7:17 PM, Malcolm Tredinnick < malc...@pointy-stick.com> wrote: > > The approach looks better. I'd be tempted to lift a couple of those > leading-underscore methods up to just being normal methods. Found myself > having to override a few of those things lately when wanting

Re: Dynamic urlconf

2009-03-29 Thread Alex Gaynor
On Sun, Mar 29, 2009 at 4:06 PM, Jeremy Dunck wrote: > > I have a need for dynamic URL definition, but I see that > RegexURLResolver.reverse uses a cache, _reverse_dict. > > Option 1): > Make a RegexURLResolver subclass which sets _reverse_dict back to > an empty

Dynamic urlconf

2009-03-29 Thread Jeremy Dunck
I have a need for dynamic URL definition, but I see that RegexURLResolver.reverse uses a cache, _reverse_dict. Option 1): Make a RegexURLResolver subclass which sets _reverse_dict back to an empty MultiValueDict when a URL is added or removed Option 2) Make me do it in my app ;-) Which do

(Discussion) Ticket 9986: CACHE_BACKEND argument name doesn't match code

2009-03-29 Thread Kurt Grandis
http://code.djangoproject.com/ticket/9986 This ticket proposes reconciling the code's parameter name, cull_frequency, with the docs' cull_probability; the ticket proposes standardizing on cull_probability, which I think would be misleading. The code where cull_frequency actually does its magic

Re: [GSoC] Proposal for discussion about Serialization requirements and requesting for Review

2009-03-29 Thread Madhusudan C.S
Hello all, Also I would like to add again that, I am madrazr on #django-dev. Whenever I tried to ask something I haven't got any response till now. I am not complaining, I understand it is mainly because of timezone problems. I just want to inform anyone who wants to tell me directly on my

Re: [GSoC] Proposal for discussion about Serialization requirements and requesting for Review

2009-03-29 Thread Madhusudan C.S
Hi Russell, I am extremely thankful to you for spending your invaluable time for doing a review (err... should I say post-mortem? ;-) ) of my complete proposal. I had kept my fingers crossed for someone who knew about the technical aspects of it to do it since most of my friends did only a

Re: "Delete selected objects" in admin batch edit

2009-03-29 Thread Zachary Voase
Don't forget, a lot of people also use a custom method of deletion on their models; they may not want to remove a record from the database, but instead set a 'deleted' flag; having deletion also there by default means they would have two deletion actions. I'd say that deletion should be there if