Re: problem writing a unittest

2010-12-10 Thread Kenneth Gonsalves
On Fri, 2010-12-10 at 00:19 -0800, Daniel Roseman wrote: > The setup method should be spelled "setUp". Unittest is a descendant > of Java's jUnit and inherits its naming conventions, unfortunately. thanks - reminder to self: never type anything when it is possible to copy-paste -- regards Kenne

Re: problem writing a unittest

2010-12-10 Thread Daniel Roseman
On Dec 10, 6:53 am, Kenneth Gonsalves wrote: > hi, > > I am trying to write a unittest, but am getting an error. > > django version - trunk > model: > > class Nums(models.Model): > >     num1 = models.IntegerField("First number") >     num2 = models.IntegerField("Second number") >     def addit(se

problem writing a unittest

2010-12-09 Thread Kenneth Gonsalves
hi, I am trying to write a unittest, but am getting an error. django version - trunk model: class Nums(models.Model): num1 = models.IntegerField("First number") num2 = models.IntegerField("Second number") def addit(self): return self.num1+self.num2 test: from django.u