Re: [PATCH] drm/vc4: dsi: Only register our component once a DSI device is attached

2021-06-19 Thread Laurent Pinchart
Hi Maxime, I'm testing this, and I'm afraid it causes an issue with all the I2C-controlled bridges. I'm focussing on the newly merged ti-sn65dsi83 driver at the moment, but other are affected the same way. With this patch, the DSI component is only added when the DSI device is attached to the

[drm-intel:drm-intel-gt-next 2/8] drivers/gpu/drm/i915/selftests/i915_buddy.c:777:5: error: no previous prototype for 'i915_buddy_mock_selftests'

2021-06-19 Thread kernel test robot
tree: git://anongit.freedesktop.org/drm-intel drm-intel-gt-next head: 13c2ceb6addb6b14468e09b75832c98909eed8e7 commit: 88be9a0a06b73ecd85a688a7c174c941e9692e92 [2/8] drm/i915/ttm: add ttm_buddy_man config: x86_64-allyesconfig (attached as .config) compiler: gcc-9 (Debian 9.3.0-22) 9.3.0

Re: [PATCH] drm/atmel-hlcdc: Allow async page flips

2021-06-19 Thread Sam Ravnborg
Hi Nicolas, Dan On Tue, May 25, 2021 at 11:29:15AM +0200, Nicolas Ferre wrote: > On 09/04/2021 at 12:58, Ludovic Desroches - M43218 wrote: > > On Tue, Mar 30, 2021 at 08:17:20AM -0700, Dan Sneddon wrote: > > > The driver is capable of doing async page flips so we need to tell the > > > core to

Re: [PATCH] drm/gma500/oaktrail_lvds: replace continue with break

2021-06-19 Thread Patrik Jakobsson
On Sat, Jun 19, 2021 at 3:40 PM Dan Carpenter wrote: > > On Fri, Jun 18, 2021 at 07:35:24PM +0100, Colin King wrote: > > From: Colin Ian King > > > > Currently a loop scans through the connector list checking > > for connectors that do not match a specific criteria. The > > use of the continue

Re: [RESEND PATCH] drm/panel: ld9040: reference spi_device_id table

2021-06-19 Thread Sam Ravnborg
Hi Krzysztof On Wed, May 26, 2021 at 08:30:02AM -0400, Krzysztof Kozlowski wrote: > Reference the spi_device_id table to silence W=1 warning: > > drivers/gpu/drm/panel/panel-samsung-ld9040.c:377:35: > warning: ‘ld9040_ids’ defined but not used [-Wunused-const-variable=] > > This also

Re: [PATCH v1 0/4] Mainline imx6 based SKOV boards

2021-06-19 Thread Sam Ravnborg
Hi Oleksij On Wed, Jun 09, 2021 at 02:10:46PM +0200, Oleksij Rempel wrote: > Mainline imx6 based DTs for SKOV A/S boards > > Oleksij Rempel (3): > dt-bindings: display: simple: add some Logic Technologies and > Multi-Inno panels > dt-bindings: vendor-prefixes: Add an entry for SKOV A/S >

Re: [PATCH] drm:atmel: Enable the crtc vblank prior to crtc usage.

2021-06-19 Thread Sam Ravnborg
Hi Nicolas/Dan, On Fri, Jun 18, 2021 at 10:05:11AM +0200, Nicolas Ferre wrote: > Hi Daniel, Sam, > > On 02/06/2021 at 18:08, Dan Sneddon wrote: > > 'commit eec44d44a3d2 ("drm/atmel: Use drm_atomic_helper_commit")' > > removed the home-grown handling of atomic commits and exposed an issue > > in

[PATCH v3 1/8] ext4/xfs: add page refcount helper

2021-06-19 Thread Alex Sierra
From: Ralph Campbell There are several places where ZONE_DEVICE struct pages assume a reference count == 1 means the page is idle and free. Instead of open coding this, add a helper function to hide this detail. v3: [AS]: rename dax_layout_is_idle_page func to dax_page_unused Signed-off-by:

Re: [PATCH 2/3] find: micro-optimize for_each_{set,clear}_bit()

2021-06-19 Thread Yury Norov
On Sat, Jun 19, 2021 at 05:24:15PM +0100, Marc Zyngier wrote: > On Fri, 18 Jun 2021 20:57:34 +0100, > Yury Norov wrote: > > > > The macros iterate thru all set/clear bits in a bitmap. They search a > > first bit using find_first_bit(), and the rest bits using find_next_bit(). > > > > Since

Re: [PATCH 2/3] find: micro-optimize for_each_{set,clear}_bit()

2021-06-19 Thread Marc Zyngier
On Fri, 18 Jun 2021 20:57:34 +0100, Yury Norov wrote: > > The macros iterate thru all set/clear bits in a bitmap. They search a > first bit using find_first_bit(), and the rest bits using find_next_bit(). > > Since find_next_bit() is called shortly after find_first_bit(), we can > save few

Re: [PATCH v3 1/8] ext4/xfs: add page refcount helper

2021-06-19 Thread Sierra Guiza, Alejandro (Alex)
On 6/17/2021 6:52 PM, Dave Chinner wrote: On Thu, Jun 17, 2021 at 10:16:58AM -0500, Alex Sierra wrote: From: Ralph Campbell There are several places where ZONE_DEVICE struct pages assume a reference count == 1 means the page is idle and free. Instead of open coding this, add a helper

Re: [PATCH] drm/gma500/oaktrail_lvds: replace continue with break

2021-06-19 Thread Dan Carpenter
On Fri, Jun 18, 2021 at 07:35:24PM +0100, Colin King wrote: > From: Colin Ian King > > Currently a loop scans through the connector list checking > for connectors that do not match a specific criteria. The > use of the continue statement is a little unintuitive and > can confuse static analysis

[Bug 213391] AMDGPU retries page fault with some specific processes amdgpu and sometimes followed [gfxhub0] retry page fault until *ERROR* ring gfx timeout, but soft recovered

2021-06-19 Thread bugzilla-daemon
https://bugzilla.kernel.org/show_bug.cgi?id=213391 --- Comment #20 from Michel Dänzer (mic...@daenzer.net) --- (In reply to dimitris from comment #19) > Question, don't I also need to update the initrd? Yes you do, if it didn't happen automatically. -- You may reply to this email to add a

Re: [PATCH] drm:atmel: Enable the crtc vblank prior to crtc usage.

2021-06-19 Thread Nicolas Ferre
Hi Daniel, Sam, On 02/06/2021 at 18:08, Dan Sneddon wrote: 'commit eec44d44a3d2 ("drm/atmel: Use drm_atomic_helper_commit")' removed the home-grown handling of atomic commits and exposed an issue in the crtc atomic commit handling where vblank is expected to be enabled but hasn't yet, causing

Re: [PATCH] dt-bindings: Drop redundant minItems/maxItems

2021-06-19 Thread Suman Anna
Hi Rob, On 6/15/21 2:15 PM, Rob Herring wrote: > If a property has an 'items' list, then a 'minItems' or 'maxItems' with the > same size as the list is redundant and can be dropped. Note that is DT > schema specific behavior and not standard json-schema behavior. The tooling > will fixup the

Re: [PATCH 3/3] Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

2021-06-19 Thread Andy Shevchenko
On Sat, Jun 19, 2021 at 01:49:58PM +0300, Andy Shevchenko wrote: > On Fri, Jun 18, 2021 at 12:57:35PM -0700, Yury Norov wrote: > > A couple of kernel functions call for_each_*_bit_from() with start > > bit equal to 0. Replace them with for_each_*_bit(). > > > > No functional changes, but might

Re: [PATCH 1/3] include/linux: move for_each_bit() macros from bitops.h to find.h

2021-06-19 Thread Andy Shevchenko
On Fri, Jun 18, 2021 at 12:57:33PM -0700, Yury Norov wrote: > for_each_bit() macros depend on find_bit() machinery, and so the > proper place for them is the find.h header. Fine with me. Reviewed-by: Andy Shevchenko > Signed-off-by: Yury Norov > --- > include/linux/bitops.h | 34

Re: [PATCH 2/3] find: micro-optimize for_each_{set,clear}_bit()

2021-06-19 Thread Andy Shevchenko
On Fri, Jun 18, 2021 at 12:57:34PM -0700, Yury Norov wrote: > The macros iterate thru all set/clear bits in a bitmap. They search a > first bit using find_first_bit(), and the rest bits using find_next_bit(). > > Since find_next_bit() is called shortly after find_first_bit(), we can > save few

Re: [PATCH 3/3] Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

2021-06-19 Thread Andy Shevchenko
On Fri, Jun 18, 2021 at 12:57:35PM -0700, Yury Norov wrote: > A couple of kernel functions call for_each_*_bit_from() with start > bit equal to 0. Replace them with for_each_*_bit(). > > No functional changes, but might improve on readability. ... > --- a/drivers/hwmon/ltc2992.c > +++

[v7 5/5] drm/panel-simple: Add Samsung ATNA33XC20

2021-06-19 Thread Rajeev Nandan
Add Samsung 13.3" FHD eDP AMOLED panel. Signed-off-by: Rajeev Nandan Reviewed-by: Douglas Anderson --- Changes in v4: - New Changes in v5: - Remove "uses_dpcd_backlight" property, not required now. (Douglas) Changes in v7: - Update disable_to_power_off and power_to_enable delays. (Douglas)

[v7 2/5] drm/panel-simple: Support DP AUX backlight

2021-06-19 Thread Rajeev Nandan
If there is no backlight specified in the device tree and the panel has access to the DP AUX channel then create a DP AUX backlight if supported by the panel. Signed-off-by: Rajeev Nandan Reviewed-by: Douglas Anderson --- (no changes since v5) This patch depends on the previous patch (2/5) of

[v7 4/5] dt-bindings: display: simple: Add Samsung ATNA33XC20

2021-06-19 Thread Rajeev Nandan
Add Samsung 13.3" FHD eDP AMOLED panel. Signed-off-by: Rajeev Nandan Reviewed-by: Douglas Anderson Acked-by: Rob Herring --- (no changes since v4) Changes in v4: - New Documentation/devicetree/bindings/display/panel/panel-simple.yaml | 2 ++ 1 file changed, 2 insertions(+) diff --git

[v7 0/5] drm: Support basic DPCD backlight in panel-simple and add a new panel ATNA33XC20

2021-06-19 Thread Rajeev Nandan
This series adds the support for the eDP panel that needs the backlight controlling over the DP AUX channel using DPCD registers of the panel as per the VESA's standard. This series also adds support for the Samsung eDP AMOLED panel that needs DP AUX to control the backlight, and introduces new

[v7 1/5] drm/panel: add basic DP AUX backlight support

2021-06-19 Thread Rajeev Nandan
Some panels support backlight control over DP AUX channel using VESA's standard backlight control interface. Using new DRM eDP backlight helpers, add support to create and register a backlight for those panels in drm_panel to simplify the panel drivers. The panel driver with access to "struct

[v7 3/5] drm/panel-simple: Support for delays between GPIO & regulator

2021-06-19 Thread Rajeev Nandan
Some panels datasheets may specify a delay between the enable GPIO and the regulator. Support this in panel-simple. Signed-off-by: Rajeev Nandan Reviewed-by: Douglas Anderson --- (no changes since v6) Changes in v4: - New Changes in v5: - Update description (Douglas) - Warn if

[PATCH 3/3] Replace for_each_*_bit_from() with for_each_*_bit() where appropriate

2021-06-19 Thread Yury Norov
A couple of kernel functions call for_each_*_bit_from() with start bit equal to 0. Replace them with for_each_*_bit(). No functional changes, but might improve on readability. Signed-off-by: Yury Norov --- arch/x86/kernel/apic/vector.c | 4 ++-- drivers/gpu/drm/etnaviv/etnaviv_gpu.c |

[PATCH 2/3] find: micro-optimize for_each_{set,clear}_bit()

2021-06-19 Thread Yury Norov
The macros iterate thru all set/clear bits in a bitmap. They search a first bit using find_first_bit(), and the rest bits using find_next_bit(). Since find_next_bit() is called shortly after find_first_bit(), we can save few lines of I-cache by not using find_first_bit(). Signed-off-by: Yury

[PATCH 1/3] include/linux: move for_each_bit() macros from bitops.h to find.h

2021-06-19 Thread Yury Norov
for_each_bit() macros depend on find_bit() machinery, and so the proper place for them is the find.h header. Signed-off-by: Yury Norov --- include/linux/bitops.h | 34 -- include/linux/find.h | 34 ++ 2 files changed, 34

Re: [PATCH] dt-bindings: Drop redundant minItems/maxItems

2021-06-19 Thread Arnaud POULIQUEN
Hello ROb, On 6/15/21 9:15 PM, Rob Herring wrote: > If a property has an 'items' list, then a 'minItems' or 'maxItems' with the > same size as the list is redundant and can be dropped. Note that is DT > schema specific behavior and not standard json-schema behavior. The tooling > will fixup the

[PATCH 0/3] for_each_*_bit: move to find.h and reconsider

2021-06-19 Thread Yury Norov
for_each_bit() macro family uses find_bit() functions, so it's better to have for_each_bit() and find_bit() functions in the same header. This series puts for_each_bit() to a proper place and optimizes its usage over the kernel. The series is based on this:

[PATCH 4/4] drm/radeon: delete useless return values

2021-06-19 Thread Bernard Zhao
Function radeon_fence_driver_init always returns success, the function type maybe coule be changed to void. Signed-off-by: Bernard Zhao --- drivers/gpu/drm/radeon/radeon.h | 2 +- drivers/gpu/drm/radeon/radeon_fence.c | 5 + 2 files changed, 2 insertions(+), 5 deletions(-) diff --git

[PATCH 2/4] drm/radeon: remove meaningless if(r) check code

2021-06-19 Thread Bernard Zhao
Function radeon_fence_driver_init always returns success, remove meaningless if(r) check code. Signed-off-by: Bernard Zhao --- drivers/gpu/drm/radeon/r100.c | 4 +--- drivers/gpu/drm/radeon/r300.c | 4 +--- drivers/gpu/drm/radeon/r420.c | 5 + drivers/gpu/drm/radeon/r520.c | 4 +---

[PATCH 3/4] drm/radeon: remove meaningless if(r) check code

2021-06-19 Thread Bernard Zhao
Function radeon_fence_driver_init always returns success, remove meaningless if(r) check code. Signed-off-by: Bernard Zhao --- drivers/gpu/drm/radeon/rs400.c | 4 +--- drivers/gpu/drm/radeon/rs600.c | 4 +--- drivers/gpu/drm/radeon/rs690.c | 4 +--- drivers/gpu/drm/radeon/rv515.c | 4 +---

[PATCH 1/4] drm/radeon: remove meaningless if(r) check code

2021-06-19 Thread Bernard Zhao
Function radeon_fence_driver_init always returns success, remove meaningless if(r) check code. Signed-off-by: Bernard Zhao --- drivers/gpu/drm/radeon/cik.c | 4 +--- drivers/gpu/drm/radeon/evergreen.c | 4 +--- drivers/gpu/drm/radeon/ni.c| 4 +--- drivers/gpu/drm/radeon/si.c

[PATCH 0/4] delete useless function return values & remove meaningless if(r) check code

2021-06-19 Thread Bernard Zhao
Function radeon_fence_driver_init always returns success, the function type maybe coule be changed to void. This patch series will first delete the check of the return value of the function call radeon_fence_driver_init, then, optimise the function declaration and function to void type.