Using DEFINE_SIMPLE_ATTRIBUTE macro with the debugfs_create_file()
function adds the overhead of introducing a proxy file operation
functions to wrap the original read/write inside file removal protection
functions. This adds significant overhead in terms of introducing and
managing the proxy facto
For previous MediaTek SoCs, such as MT8173, there are 2 display HW
pipelines binding to 1 mmsys with the same power domain, the same
clock driver and the same mediatek-drm driver.
For MT8195, VDOSYS0 and VDOSYS1 are 2 display HW pipelines binding to
2 different power domains, different clock drive
After mmsys and drm change DITHER enum to DDP_COMPONENT_DITHER0,
mmsys header can remove the useless DDP_COMPONENT_DITHER enum.
Signed-off-by: Jason-JH.Lin
Reviewed-by: AngeloGioacchino Del Regno
Reviewed-by: Rex-BC Chen
Acked-by: Matthias Brugger
---
include/linux/soc/mediatek/mtk-mmsys.h |
Because compatible of mt8195 is changing from "mediatek,mt8195-mmsys"
to "mediatek,mt8195-vdosys0".
We have to revert the multiple compatible finding function and
add driver data of mt8195 vdosys0 to mediatek-drm and the sub driver.
Signed-off-by: Jason-JH.Lin
---
drivers/gpu/drm/mediatek/mtk_d
On 26/12/2022 14:49, Javier Martinez Canillas wrote:
> Add device tree bindings for panels based on the Himax HX8394 controller,
> such as the HannStar HSD060BHW4 720x1440 TFT LCD panel that is connected
> through a MIPI-DSI video interface.
>
> Signed-off-by: Javier Martinez Canillas
> Reviewed-
On Mon, Dec 26, 2022 at 11:32:26PM +0200, Oded Gabbay wrote:
> Move the habanalabs.h uapi file from include/uapi/misc to
> include/uapi/drm, and rename it to habanalabs_accel.h.
>
> This is required before moving the actual driver to the accel
> subsystem.
What requires this? Isn't this going to
The error message suggests that the height of the src rect must be at
least 1. Reject source with height of 0.
Signed-off-by: Drew Davenport
---
I was investigating some divide-by-zero crash reports on ChromeOS which
pointed to the intel_adjusted_rate function. Further prodding showed
that I cou
Hi, Xinlei:
於 2022年10月24日 週一 上午10:05寫道:
>
> From: Xinlei Lee
>
> Add the compatible because use edge_cfg_in_mmsys in mt8186.
Applied to mediatek-drm-next [1], thanks.
[1]
https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next
Regards,
Chun-Kuang.
>
>
Hi, Xinlei:
於 2022年10月24日 週一 上午10:05寫道:
>
> From: Xinlei Lee
>
> Dpi output needs to adjust the output format to dual edge for MT8186.
Applied to mediatek-drm-next [1], thanks.
[1]
https://git.kernel.org/pub/scm/linux/kernel/git/chunkuang.hu/linux.git/log/?h=mediatek-drm-next
Regards,
Chun-K
On Mon, 26 Dec 2022 14:49:06 +0100, Javier Martinez Canillas wrote:
> Add device tree bindings for panels based on the Himax HX8394 controller,
> such as the HannStar HSD060BHW4 720x1440 TFT LCD panel that is connected
> through a MIPI-DSI video interface.
>
> Signed-off-by: Javier Martinez Cani
Move the habanalabs.h uapi file from include/uapi/misc to
include/uapi/drm, and rename it to habanalabs_accel.h.
This is required before moving the actual driver to the accel
subsystem.
Update MAINTAINERS file accordingly.
Signed-off-by: Oded Gabbay
---
MAINTAINERS
https://bugzilla.kernel.org/show_bug.cgi?id=216780
--- Comment #7 from Elmar Stellnberger (estel...@elstel.org) ---
Did not re-test the acpi_sleep modes from above with kernel 6.1.0-desktop586,
where the screen content was preserved directly after resume. kernel 6.1.1 no
more exposes this feature.
Hello Sam,
On 12/26/22 16:05, Sam Ravnborg wrote:
> Hi Javier.
>
> On Mon, Dec 26, 2022 at 02:49:05PM +0100, Javier Martinez Canillas wrote:
>> From: Kamil Trzciński
>>
>> The driver is for panels based on the Himax HX8394 controller, such as the
>> HannStar HSD060BHW4 720x1440 TFT LCD panel tha
This patch broke drm/msm in 6.2-rc1 for me. drm_sched_entity_destroy()
never returns when exiting a process from gdb if it has a drm/msm fd
opened (if the fd is closed normally then it doesn't have this problem).
Replace the use of drm_debugfs_create_files() with the new
drm_debugfs_add_files() function, which center the debugfs files
management on the drm_device instead of drm_minor. Moreover, remove the
debugfs_init hook and add the debugfs files directly on qxl_pci_probe(),
before drm_dev_register().
Si
The current debugfs structure was introduced at f64122c1f6ad and it was
never used by the driver. Considering the addition of more
device-centered functions to the DRM core, remove the current debugfs
structure.
Signed-off-by: Maíra Canal
---
drivers/gpu/drm/qxl/qxl_debugfs.c | 29 --
Replace the use of drm_debugfs_create_files() with the new
drm_debugfs_add_files() function, which center the debugfs files
management on the drm_device instead of drm_minor. Moreover, remove the
debugfs_init hook and add the debugfs files directly on omapdrm_init(),
before drm_dev_register().
Sig
Replace the use of drm_debugfs_create_files() with the new
drm_debugfs_add_files() function, which center the debugfs files
management on the drm_device instead of drm_minor. Moreover, remove the
debugfs_init hook and add the debugfs files directly on virtio_gpu_probe(),
before drm_dev_register().
Replace the use of drm_debugfs_create_files() with the new
drm_debugfs_add_file() function, which center the debugfs files
management on the drm_device instead of drm_minor. Moreover, remove the
debugfs_init hook and add the debugfs files directly on arcpgu_probe(),
before drm_dev_register().
Sign
Replace the use of drm_debugfs_create_files() with the new
drm_debugfs_add_file() function, which center the debugfs files
management on the drm_device instead of drm_minor. Moreover, remove the
debugfs_init hook and add the debugfs files directly on pl111_amba_probe(),
before drm_dev_register().
Replace the use of drm_debugfs_create_files() with the new
drm_debugfs_add_files() function, which center the debugfs files
management on the drm_device instead of drm_minor. Moreover, remove the
debugfs_init hook and add the debugfs files directly on hdlcd_drm_bind(),
before drm_dev_register().
S
Replace the use of drm_debugfs_create_files() with the new
drm_debugfs_add_file() function, which center the debugfs files
management on the drm_device instead of drm_minor. Moreover, remove the
debugfs_init hook and add the debugfs files directly on gud_probe(),
before drm_dev_register().
Signed-
Replace the use of drm_debugfs_create_files() with the new
drm_debugfs_add_files() function, which center the debugfs files
management on the drm_device instead of drm_minor. Moreover, remove the
debugfs_init hook and add the debugfs files directly on etnaviv_bind(),
before drm_dev_register().
Sig
The commit 1c9cacbea880 ("drm/debugfs: create device-centered debugfs
functions")
introduced new device-centered debugfs functions, which center the debugfs files
management on the drm_device instead of drm_minor. Therefore, this patchset
converts 8 drivers to this new debugfs device-centered stru
Hi Javier.
On Mon, Dec 26, 2022 at 02:49:05PM +0100, Javier Martinez Canillas wrote:
> From: Kamil Trzciński
>
> The driver is for panels based on the Himax HX8394 controller, such as the
> HannStar HSD060BHW4 720x1440 TFT LCD panel that uses a MIPI-DSI interface.
>
> Signed-off-by: Kamil Trzci
Hi Tomi,
(CC'ing Daniel and Dave)
On Wed, Dec 21, 2022 at 11:24:41AM +0200, Tomi Valkeinen wrote:
> From: Tomi Valkeinen
>
> Hi,
>
> These add new pixel formats for Renesas V3U and V4H SoCs.
>
> As the display pipeline is split between DRM and V4L2 components, this
> series touches both subsy
Hi Tomi,
Thank you for the patch.
On Wed, Dec 21, 2022 at 11:24:46AM +0200, Tomi Valkeinen wrote:
> Add new pixel formats: RGBX1010102, RGBA1010102, ARGB2101010, Y210 and
> Y212.
>
> Signed-off-by: Tomi Valkeinen
Reviewed-by: Laurent Pinchart
> ---
> .../media/platform/renesas/vsp1/vsp1_pip
Hi Tomi,
Thank you for the patch.
On Wed, Dec 21, 2022 at 11:24:44AM +0200, Tomi Valkeinen wrote:
> V3U is actually gen4, not gen3. The same IP is also used in the
> (not-yet-supported) V4H.
>
> Change VI6_IP_VERSION_MODEL_VSPD_V3U to VI6_IP_VERSION_MODEL_VSPD_GEN4,
> to represent the model corr
Hi Tomi,
Thank you for the patch.
On Wed, Dec 21, 2022 at 11:24:43AM +0200, Tomi Valkeinen wrote:
> Add Y210, Y212 and Y216 formats.
>
> Signed-off-by: Tomi Valkeinen
Reviewed-by: Laurent Pinchart
> ---
> .../media/v4l/pixfmt-packed-yuv.rst | 49 ++-
> drivers/medi
Hi Tomi,
Thank you for the patch.
On Wed, Dec 21, 2022 at 11:24:42AM +0200, Tomi Valkeinen wrote:
> Add XBGR2101010, ABGR2101010 and BGRA1010102 formats.
You forgot to rename the formats in the commit message.
> Signed-off-by: Tomi Valkeinen
> ---
> .../userspace-api/media/v4l/pixfmt-rgb.rst
Hi Tomi,
Thank you for the patch.
On Wed, Dec 21, 2022 at 11:24:48AM +0200, Tomi Valkeinen wrote:
> Add new pixel formats: RGBX1010102, RGBA1010102, ARGB2101010, Y210 and
Reviewed-by: Laurent Pinchart
> Y212.
>
> Signed-off-by: Tomi Valkeinen
> ---
> drivers/gpu/drm/rcar-du/rcar_du_kms.c |
This series add support for the display present in the PinePhone Pro.
Patch #1 adds a driver for panels using the Himax HX8394 panel controller,
such as the HSD060BHW4 720x1440 TFT LCD panel present in the PinePhone Pro.
Patch #2 adds a devicetree binding schema for this driver and patch #3 adds
Add device tree bindings for panels based on the Himax HX8394 controller,
such as the HannStar HSD060BHW4 720x1440 TFT LCD panel that is connected
through a MIPI-DSI video interface.
Signed-off-by: Javier Martinez Canillas
Reviewed-by: Krzysztof Kozlowski
---
Changes in v2:
- Drop redundant "bi
From: Kamil Trzciński
The driver is for panels based on the Himax HX8394 controller, such as the
HannStar HSD060BHW4 720x1440 TFT LCD panel that uses a MIPI-DSI interface.
Signed-off-by: Kamil Trzciński
Co-developed-by: Ondrej Jirman
Signed-off-by: Ondrej Jirman
Co-developed-by: Javier Martin
Hi Krzysztof,
On Mon, Nov 28, 2022 at 5:02 AM Krzysztof Kozlowski
wrote:
>
> On 24/11/2022 11:20, Pin-yen Lin wrote:
> > ITE IT6505 can be used in systems to switch the DP traffic between
> > two downstreams, which can be USB Type-C DisplayPort alternate mode
> > lane or regular DisplayPort outpu
Hi Krzysztof,
Thanks for the review.
On Mon, Nov 28, 2022 at 4:58 AM Krzysztof Kozlowski
wrote:
>
> On 24/11/2022 11:20, Pin-yen Lin wrote:
> > Analogix 7625 can be used in systems to switch the DP traffic between
> > two downstreams, which can be USB Type-C DisplayPort alternate mode
> > lane o
dell wyse 3040 doesn't peform poweroff properly, but instead remains in
turned power on state. Additional mutex_lock and
intel_crtc_wait_for_next_vblank
feature 6.2 kernel resolve this trouble.
cc: sta...@vger.kernel.org
original commit Link: https://patchwork.freedesktop.org/patch/508926/
fixe
From: Wen Yang
The following errors occurred when using gcc 7.5.0-3ubuntu1~18.04:
drivers/gpu/drm/amd/amdgpu/../display/dc/core/dc_stream.c: In function
‘dc_stream_remove_writeback’:
drivers/gpu/drm/amd/amdgpu/../display/dc/core/dc_stream.c:543:55: warning:
array subscript is above array bounds
39 matches
Mail list logo