Re: [PATCH] backlight: led_bl: Add support for an "enable" GPIO

2021-11-02 Thread LABBE Corentin
Le Tue, Nov 02, 2021 at 11:25:14AM +, Daniel Thompson a écrit : > On Tue, Nov 02, 2021 at 11:19:42AM +, Daniel Thompson wrote: > > On Tue, Nov 02, 2021 at 10:04:55AM +, Corentin LABBE wrote: > > > From: Jean-Jacques Hiblot > > > > > > This patch adds support for an "enable GPIO". > >

Re: [PATCH] dt-bindings: display: convert faraday,tve200 to YAML

2021-05-18 Thread LABBE Corentin
Le Mon, May 17, 2021 at 07:26:24PM -0500, Rob Herring a écrit : > On Tue, May 11, 2021 at 04:54:48PM +, Corentin Labbe wrote: > > Converts display/faraday,tve200.txt to yaml. > > > > Signed-off-by: Corentin Labbe > > --- > > .../bindings/display/faraday,tve200.txt | 54 --- > >

Re: [PATCH v3 0/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64

2018-11-16 Thread LABBE Corentin
On Thu, Nov 15, 2018 at 09:33:48AM +, Russell King - ARM Linux wrote: > On Thu, Nov 15, 2018 at 10:30:34AM +0100, LABBE Corentin wrote: > > On Wed, Oct 24, 2018 at 09:57:00AM +0100, Russell King - ARM Linux wrote: > > > On Wed, Oct 24, 2018 at 07:35:46AM +, Co

Re: [PATCH v3 0/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64

2018-11-16 Thread LABBE Corentin
On Wed, Oct 24, 2018 at 09:57:00AM +0100, Russell King - ARM Linux wrote: > On Wed, Oct 24, 2018 at 07:35:46AM +, Corentin Labbe wrote: > > This patchset adds a new set of functions which are open-coded in lot of > > place. > > Basicly the pattern is always the same, "read, modify a bit,

Re: [PATCH v2 2/7] include: add setbits32/clrbits32/clrsetbits32/setbits64/clrbits64/clrsetbits64 in linux/setbits.h

2018-09-27 Thread LABBE Corentin
On Tue, Sep 25, 2018 at 07:05:00AM +0200, Christophe LEROY wrote: > > > Le 24/09/2018 à 21:04, Corentin Labbe a écrit : > > This patch adds setbits32/clrbits32/clrsetbits32 and > > setbits64/clrbits64/clrsetbits64 in linux/setbits.h header. > > Fix the patch subject and description. > > > > >

Re: [PATCH v2 1/7] powerpc: rename setbits32/clrbits32 to setbits32_be/clrbits32_be

2018-09-27 Thread LABBE Corentin
On Tue, Sep 25, 2018 at 06:56:23AM +0200, Christophe LEROY wrote: > Fix the patch title. > > > Le 24/09/2018 à 21:04, Corentin Labbe a écrit : > > Since setbits32/clrbits32 work on be32, it's better to remove ambiguity on > > the used data type. > > > > Signed-off-by: Corentin Labbe > > --- >

[PATCH v2] gpu: ipu-v3: fix a possible NULL dereference

2016-08-24 Thread LABBE Corentin
necessary for avoiding a second NULL deref later on devtype. Signed-off-by: LABBE Corentin --- Changes in v2: - Add a test on devtype for avoiding a second NULL deref. drivers/gpu/ipu-v3/ipu-common.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/ipu-v3

[PATCH] gpu: ipu-v3: fix a possible NULL dereference

2016-08-16 Thread LABBE Corentin
of_match_device could return NULL, and so cause a NULL pointer dereference later. For fixing this problem, we use of_device_get_match_data(), this will simplify the code a little by using a standard function for getting the match data. Signed-off-by: LABBE Corentin --- drivers/gpu/ipu-v3/ipu

[PATCH] drm: modes: add missing [drm] to message printing

2016-02-04 Thread LABBE Corentin
The warning message in drm_mode_parse_command_line_for_connector miss the [drm] at beginning. This patch add it and take the opportunity to convert printk(KERN_WARNING to pr_warn() Signed-off-by: LABBE Corentin --- drivers/gpu/drm/drm_modes.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions

[PATCH] drm: modes: Revert cc344980c767 "replace simple_strtoul by kstrtouint"

2015-12-11 Thread LABBE Corentin
conclusion that the best solution is to revert my commit cc344980c76748e57c9c03100c2a14d36ab00334. Signed-off-by: LABBE Corentin --- drivers/gpu/drm/drm_modes.c | 16 +--- 1 file changed, 5 insertions(+), 11 deletions(-) diff --git a/drivers/gpu/drm/drm_modes.c b/drivers/gpu/drm/drm_mod

[PATCH v2 1/1] drm: modes: fix DRM modes analysis regression

2015-12-09 Thread LABBE Corentin
fic buffer. Fixes: 52157a4ca396 ("drm: modes: replace simple_strtoul by kstrtouint") Reported-by: Kuninori Morimoto Signed-off-by: LABBE Corentin --- drivers/gpu/drm/drm_modes.c | 28 +--- 1 file changed, 21 insertions(+), 7 deletions(-) diff --git a/drivers/g

[PATCH v2 0/1] drm: modes: fix DRM modes analysis regression

2015-12-09 Thread LABBE Corentin
Hello Changes since v1 - Fix a memory leak when returning after an error of kstrtox LABBE Corentin (1): drm: modes: fix DRM modes analysis regression drivers/gpu/drm/drm_modes.c | 28 +--- 1 file changed, 21 insertions(+), 7 deletions(-) -- 2.4.10

[PATCH] drm: modes: replace simple_strtoul by kstrtouint

2015-11-05 Thread LABBE Corentin
The simple_strtoul function is marked as obsolete. This patch replace it by kstrtouint. Signed-off-by: LABBE Corentin --- drivers/gpu/drm/drm_modes.c | 16 +++- 1 file changed, 11 insertions(+), 5 deletions(-) diff --git a/drivers/gpu/drm/drm_modes.c b/drivers/gpu/drm/drm_modes.c