[PATCH] backlight: mp3309c: Use pwm_apply_might_sleep()

2024-01-28 Thread Sean Young
pwm_apply_state() is deprecated since commit c748a6d77c06a ("pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()"). This is the final user in the tree. Signed-off-by: Sean Young --- drivers/video/backlight/mp3309c.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-)

Re: (subset) linux-next: build failure after merge of the pwm tree

2024-01-04 Thread Sean Young
On Thu, Jan 04, 2024 at 05:02:41PM +0700, Bagas Sanjaya wrote: > [also add Jingoo (additional backlight maintainer) and Linus] > > On Thu, Dec 21, 2023 at 07:34:57PM +0100, Thierry Reding wrote: > > On Thu, Dec 21, 2023 at 12:58:01PM +, Lee Jones wrote: > > > On Thu, 21 Dec 2023, Lee Jones

[PATCH v10 1/6] pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()

2023-12-19 Thread Sean Young
pwm_apply_state(), a following commit will introduce the pwm_apply_atomic() function. Acked-by: Uwe Kleine-König Acked-by: Guenter Roeck Acked-by: Mark Brown Acked-by: Dmitry Torokhov # for input Acked-by: Hans de Goede Acked-by: Jani Nikula Acked-by: Lee Jones Signed-off-by: Sean Young

[PATCH v9 1/6] pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()

2023-12-18 Thread Sean Young
pwm_apply_state(), a following commit will introduce the pwm_apply_atomic() function. Acked-by: Uwe Kleine-König Acked-by: Guenter Roeck Acked-by: Mark Brown Acked-by: Dmitry Torokhov # for input Acked-by: Hans de Goede Acked-by: Jani Nikula Acked-by: Lee Jones Signed-off-by: Sean Young

[PATCH v8 1/6] pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()

2023-12-12 Thread Sean Young
pwm_apply_state(), a following commit will introduce the pwm_apply_atomic() function. Acked-by: Dmitry Torokhov # for input Acked-by: Hans de Goede Acked-by: Jani Nikula Acked-by: Lee Jones Signed-off-by: Sean Young --- Documentation/driver-api/pwm.rst | 8 +++--- MAINTAINERS

Re: [PATCH v6 1/4] pwm: rename pwm_apply_state() to pwm_apply_might_sleep()

2023-12-11 Thread Sean Young
On Sat, Dec 09, 2023 at 02:57:42PM +0100, Uwe Kleine-König wrote: > On Wed, Nov 29, 2023 at 09:13:34AM +0000, Sean Young wrote: > > In order to introduce a pwm api which can be used from atomic context, > > we will need two functions for applying pwm changes: > > > >

[PATCH v7 1/4] pwm: Rename pwm_apply_state() to pwm_apply_might_sleep()

2023-12-11 Thread Sean Young
pwm_apply_state(), a following commit will introduce the pwm_apply_atomic() function. Acked-by: Dmitry Torokhov # for input Acked-by: Hans de Goede Acked-by: Jani Nikula Acked-by: Lee Jones Signed-off-by: Sean Young --- Documentation/driver-api/pwm.rst | 8 +++--- MAINTAINERS

[PATCH v6 1/4] pwm: rename pwm_apply_state() to pwm_apply_might_sleep()

2023-11-29 Thread Sean Young
pwm_apply_state(), a following commit will introduce the pwm_apply_atomic() function. Acked-by: Hans de Goede Acked-by: Jani Nikula Acked-by: Lee Jones Signed-off-by: Sean Young --- Documentation/driver-api/pwm.rst | 8 +++--- .../gpu/drm/i915/display/intel_backlight.c| 6

Re: [PATCH v5 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()

2023-11-29 Thread Sean Young
On Fri, Nov 24, 2023 at 02:31:18PM +0100, Thierry Reding wrote: > On Sat, Nov 18, 2023 at 04:16:17PM +0000, Sean Young wrote: > > In order to introduce a pwm api which can be used from atomic context, > > we will need two functions for applying pwm changes: > > > >

[PATCH v5 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()

2023-11-18 Thread Sean Young
pwm_apply_state(), a following commit will introduce the pwm_apply_atomic() function. Acked-by: Hans de Goede Acked-by: Jani Nikula Signed-off-by: Sean Young --- Documentation/driver-api/pwm.rst | 8 +++--- .../gpu/drm/i915/display/intel_backlight.c| 6 ++-- drivers/gpu/drm

[PATCH v4 1/4] pwm: rename pwm_apply_state() to pwm_apply_cansleep()

2023-10-27 Thread Sean Young
pwm_apply_state(), a following commit will introduce the pwm_apply_atomic() function. Acked-by: Hans de Goede Acked-by: Jani Nikula Signed-off-by: Sean Young --- Documentation/driver-api/pwm.rst | 8 +++--- .../gpu/drm/i915/display/intel_backlight.c| 6 ++-- drivers/gpu/drm

Re: [PATCH v3 1/3] pwm: make it possible to apply pwm changes in atomic context

2023-10-25 Thread Sean Young
On Mon, Oct 23, 2023 at 02:34:17PM +0100, Daniel Thompson wrote: > On Sun, Oct 22, 2023 at 11:46:22AM +0100, Sean Young wrote: > > On Sat, Oct 21, 2023 at 11:08:22AM +0200, Hans de Goede wrote: > > > On 10/19/23 12:51, Uwe Kleine-König wrote: > > > > On Wed, Oct 18,

Re: [PATCH v3 1/3] pwm: make it possible to apply pwm changes in atomic context

2023-10-22 Thread Sean Young
Hi Hans, On Sat, Oct 21, 2023 at 11:08:22AM +0200, Hans de Goede wrote: > On 10/19/23 12:51, Uwe Kleine-König wrote: > > On Wed, Oct 18, 2023 at 03:57:48PM +0200, Hans de Goede wrote: > >> On 10/17/23 11:17, Sean Young wrote: > >>> Some drivers require sleeping,

[PATCH v3 1/3] pwm: make it possible to apply pwm changes in atomic context

2023-10-17 Thread Sean Young
the pwm_can_sleep() function. Signed-off-by: Sean Young --- Documentation/driver-api/pwm.rst | 16 +++- .../gpu/drm/i915/display/intel_backlight.c| 6 +- drivers/gpu/drm/solomon/ssd130x.c | 2 +- drivers/hwmon/pwm-fan.c | 8 +- drivers/input/misc/da7280

Re: [PATCH 000/141] Fix fall-through warnings for Clang

2020-11-26 Thread Sean Young
On Mon, Nov 23, 2020 at 07:58:06AM -0800, James Bottomley wrote: > On Mon, 2020-11-23 at 15:19 +0100, Miguel Ojeda wrote: > > On Sun, Nov 22, 2020 at 11:36 PM James Bottomley > > wrote: > > > It's not about the risk of the changes it's about the cost of > > > implementing them. Even if you

Re: [RFC PATCH 00/12] i2c: replace i2c_new_probed_device with an ERR_PTR variant

2019-11-06 Thread Sean Young
read over the years. So, for those: Acked-by: Sean Young > > Core changes tested on a Renesas Salvator-XS board (R-Car M3-N), driver > patches build tested by me and buildbot. > > Wolfram Sang (12): > i2c: replace i2c_new_probed_device with an ERR_PTR variant > i2c

Re: [PATCH v3 05/10] pwm: add PWM mode to pwm_config()

2018-02-23 Thread Sean Young
On Thu, Feb 22, 2018 at 02:01:16PM +0200, Claudiu Beznea wrote: > Add PWM mode to pwm_config() function. The drivers which uses pwm_config() > were adapted to this change. > > Signed-off-by: Claudiu Beznea > --- -snip- > diff --git a/drivers/media/rc/ir-rx51.c

Re: [PATCH v4] drm/bridge/sii8620: add remote control support

2017-10-10 Thread Sean Young
Hi, On Thu, Sep 21, 2017 at 12:46:04PM +0100, Sean Young wrote: > On Mon, Sep 18, 2017 at 04:37:52PM +0200, Hans Verkuil wrote: > > On 09/18/2017 04:15 PM, Maciej Purski wrote: > > > Hi Hans, > > > some time ago in reply to your email I described what messages does &

Re: [PATCH v4] drm/bridge/sii8620: add remote control support

2017-09-22 Thread Sean Young
On Mon, Sep 18, 2017 at 04:37:52PM +0200, Hans Verkuil wrote: > On 09/18/2017 04:15 PM, Maciej Purski wrote: > > Hi Hans, > > some time ago in reply to your email I described what messages does > > the MHL driver receive and at what time intervals. > > Regarding that information, do you think that

Re: [PATCH v4] drm/bridge/sii8620: add remote control support

2017-08-27 Thread Sean Young
nges in v4: > - usage of rc-core API compatible with upcoming changes > - fix error handling in init_rcp > - fix commit message Looks good. Acked-by: Sean Young <s...@mess.org> > --- > drivers/gpu/drm/bridge/Kconfig | 2 +- > drivers/gpu/drm/bridge/sil-sii8620.c | 96

Re: [PATCH v3] drm/bridge/sii8620: add remote control support

2017-08-23 Thread Sean Young
Hi, Some review comments below. On Wed, Aug 23, 2017 at 09:03:18AM +0200, Hans Verkuil wrote: > Maciej, > > I'm cross-posting this to linux-media and the rc maintainer Sean Young. > > Note that various RC defines have been renamed in the upcoming 4.14. It might > be > bet

Re: [PATCH] drm/bridge/sii8620: add remote control support

2017-08-06 Thread Sean Young
C specification or is it completely > separate? > > I'm CC-ing Sean Young and the linux-media mailinglist as well since Sean > maintains the rc subsystem. Which you probably should use, but I'm not the > expert on that. Yes, I agree. Using rc core the keymap can be changed from user s

[PATCH v6 06/11] cec: add HDMI CEC framework

2015-05-13 Thread Sean Young
On Mon, May 04, 2015 at 07:32:59PM +0200, Kamil Debski wrote: > From: Hans Verkuil > > The added HDMI CEC framework provides a generic kernel interface for > HDMI CEC devices. > > Signed-off-by: Hans Verkuil -snip- > +int cec_create_adapter(struct cec_adapter *adap, const char *name, u32

[RFC v2 3/7] cec: add new framework for cec support.

2015-03-08 Thread Sean Young
Hi Kamil, On Fri, Mar 06, 2015 at 05:14:50PM +0100, Kamil Debski wrote: > 3) As you suggested - load an empty keymap whenever the pass through mode is > enabled. > I am not that familiar with the RC core. Is there a simple way to switch to > an empty map > from the kernel? There is the

[RFC v2 3/7] cec: add new framework for cec support.

2015-01-23 Thread Sean Young
On Thu, Jan 22, 2015 at 05:04:35PM +0100, Kamil Debski wrote: > Add the CEC framework. -snip- > +Remote control handling > +--- > + > +The CEC framework provides two ways of handling the key messages of remote > +control. In the first case, the CEC framework will handle these

[RFC 1/6] cec: add new driver for cec support.

2014-12-30 Thread Sean Young
On Tue, Dec 23, 2014 at 03:32:17PM +0100, Kamil Debski wrote: > +There are still a few todo's, the main one being the remote control support > +feature of CEC. I need to research if that should be implemented via the > +standard kernel remote control support. I guess a new rc driver type