Re: [PATCH] drm/rcar-du: Convert drm_atomic_helper_suspend/resume()

2018-07-28 Thread Vaishali Thakkar
On Sat, Jul 28, 2018 at 9:10 PM, Souptick Joarder wrote: > convert drm_atomic_helper_suspend/resume() to use > drm_mode_config_helper_suspend/resume(). Hi Souptick, Thanks for your patch. > Signed-off-by: Souptick Joarder > Signed-off-by: Ajit Negi > --- > drivers/gpu/drm/rcar-du/rcar_du_drv

Re: [Intel-gfx] [PATCH] drm/core: Remove drm_dev_unref() and it's uses

2018-04-26 Thread Vaishali Thakkar
On Thu, Apr 26, 2018 at 6:15 PM, Laurent Pinchart wrote: > Hi Daniel, > > On Thursday, 26 April 2018 15:36:15 EEST Daniel Vetter wrote: >> On Thu, Apr 26, 2018 at 03:58:19PM +0530, Vaishali Thakkar wrote: >> > It's been a while since we introduced drm_dev{get/p

[PATCH] drm/core: Remove drm_dev_unref() and it's uses

2018-04-26 Thread Vaishali Thakkar
s used for mass-patching. Signed-off-by: Vaishali Thakkar --- drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c| 4 ++-- drivers/gpu/drm/arc/arcpgu_drv.c | 4 ++-- drivers/gpu/drm/armada/armada_drv.c| 6 +++--- drivers/gpu/drm/atmel-hlcdc/atmel_hlcdc_dc.c

Re: [PATCH] drm: rcar-du: Use drm_dev_put

2018-04-25 Thread Vaishali Thakkar
On Wed, Apr 25, 2018 at 7:02 PM, Laurent Pinchart wrote: > Hi Vaishali, > > Thank you for the patch. > > On Wednesday, 25 April 2018 15:10:36 EEST Vaishali Thakkar wrote: >> As specified in drm_drv.c, drm_dev_unref is a compatibility alias >> for drm_dev_put and should

[PATCH] drm: rcar-du: Use drm_dev_put

2018-04-25 Thread Vaishali Thakkar
As specified in drm_drv.c, drm_dev_unref is a compatibility alias for drm_dev_put and shouldn't be used in new code. So, use drm_dev_put instead. Signed-off-by: Vaishali Thakkar --- drivers/gpu/drm/rcar-du/rcar_du_drv.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/dr

[PATCH] drm/vc4: make function vc4_allocate_bin_bo static

2018-04-25 Thread Vaishali Thakkar
Sparse complains with following warning: drivers/gpu/drm/vc4/vc4_v3d.c:222:1: warning: symbol 'vc4_allocate_bin_bo' was not declared. Should it be static? Make vc4_allocate_bin static as it is not used outside of vc4_v3d.c. Signed-off-by: Vaishali Thakkar --- drivers/gpu/drm/vc4/vc4

Re: [PATCH] drm: rcar-du: of: Include header to define prototypes

2018-04-25 Thread Vaishali Thakkar
encoder > nodes") > Signed-off-by: Kieran Bingham Reviewed-by: Vaishali Thakkar > --- > drivers/gpu/drm/rcar-du/rcar_du_of.c | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/drivers/gpu/drm/rcar-du/rcar_du_of.c > b/drivers/gpu/drm/rcar-du/rcar_du_of.c >

Re: [PATCH] drm: rcar-du: Use NULL for table initialisation

2018-04-25 Thread Vaishali Thakkar
drivers/gpu/drm/rcar-du/rcar_du_kms.o Hi Kieran, Change looks ok to me. > Fixes: 3e81374e2014 ("drm: rcar-du: Support multiple sources from the same > VSP") > Signed-off-by: Kieran Bingham Reviewed-by: Vaishali Thakkar > --- > drivers/gpu/drm/rcar-du/rcar_du_kms.c

Use of copy_from_user in msm_gem_submit.c while holding a spin_lock

2016-08-17 Thread Vaishali Thakkar
Hello, I was wondering about the call to copy_from_user in function submit_lookup_objects for drive /gpu/drm/msm/msm_gem_submit.c It calls copy_from_user[1] in a spin_lock, which is not normally allowed, due to the possibility of a deadlock. Is there some reason that I am overlooking why it

[PATCH] drm/msm: Move call to PTR_ERR_OR_ZERO after reassignment

2016-04-28 Thread Vaishali Thakkar
On Thursday 28 April 2016 06:23 PM, Eric Engestrom wrote: > On Wed, Apr 27, 2016 at 04:51:37PM +0530, Vaishali Thakkar wrote: >> Here, a location is reset to NULL before being passed to PTR_ERR. >> So, PTR_ERR should be called before its argument is reassigned >> to NULL

[PATCH v2] drm/msm: Move call to PTR_ERR_OR_ZERO after reassignment

2016-04-28 Thread Vaishali Thakkar
Here, a location is reset to NULL before being passed to PTR_ERR. So, PTR_ERR should be called before its argument is reassigned to NULL. Further to simplify things use PTR_ERR_OR_ZERO instead of PTR_ERR and IS_ERR. Problem found using Coccinelle. Signed-off-by: Vaishali Thakkar Reviewed-by

[PATCH] drm/msm: Move call to PTR_ERR_OR_ZERO after reassignment

2016-04-27 Thread Vaishali Thakkar
Here, a location is reset to NULL before being passed to PTR_ERR. So, PTR_ERR should be called before its argument is reassigned to NULL. Further to simplify things use PTR_ERR_OR_ZERO instead of PTR_ERR and IS_ERR. Problem found using Coccinelle. Signed-off-by: Vaishali Thakkar --- drivers