Re: [PATCH v4 01/34] component: Introduce struct aggregate_device

2022-01-05 Thread Stephen Boyd
Quoting Greg Kroah-Hartman (2021-12-21 01:29:59) > > @@ -471,9 +477,17 @@ int component_master_add_with_match(struct device > > *parent, > > if (!master) > > return -ENOMEM; > > > > + id = ida_alloc(_ida, GFP_KERNEL); > > + if (id < 0) { > > +

Re: [PATCH v4 01/34] component: Introduce struct aggregate_device

2022-01-05 Thread Stephen Boyd
Quoting Greg Kroah-Hartman (2021-12-21 01:28:10) > On Thu, Dec 02, 2021 at 02:26:59PM -0800, Stephen Boyd wrote: > > Replace 'struct master' with 'struct aggregate_device' and then rename > > 'master' to 'adev' everywhere in the code. While we're here, put a > > struct device inside the aggregate

Re: [PATCH v4 01/34] component: Introduce struct aggregate_device

2021-12-21 Thread Greg Kroah-Hartman
On Thu, Dec 02, 2021 at 02:26:59PM -0800, Stephen Boyd wrote: > Replace 'struct master' with 'struct aggregate_device' and then rename > 'master' to 'adev' everywhere in the code. While we're here, put a > struct device inside the aggregate device so that we can register it > with a bus_type in

Re: [PATCH v4 01/34] component: Introduce struct aggregate_device

2021-12-21 Thread Greg Kroah-Hartman
On Thu, Dec 02, 2021 at 02:26:59PM -0800, Stephen Boyd wrote: > Replace 'struct master' with 'struct aggregate_device' and then rename > 'master' to 'adev' everywhere in the code. While we're here, put a > struct device inside the aggregate device so that we can register it > with a bus_type in

[PATCH v4 01/34] component: Introduce struct aggregate_device

2021-12-02 Thread Stephen Boyd
Replace 'struct master' with 'struct aggregate_device' and then rename 'master' to 'adev' everywhere in the code. While we're here, put a struct device inside the aggregate device so that we can register it with a bus_type in the next patch. The diff is large but that's because this is mostly a