[PATCH] Staging: dwc2: core: coding style - indentation should use tabs

2013-09-25 Thread Luis Ortega Perez de Villar
Fixed coding style issue where lines are indented with spaces instead of tabs. Signed-off-by: Luis Ortega Perez de Villar luior...@upv.es --- drivers/staging/dwc2/core.c |4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/dwc2/core.c

Re: [PATCH] add exFAT driver

2013-09-25 Thread Benjamin Valentin
Am Fri, 30 Aug 2013 08:42:05 -0700 schrieb Greg Kroah-Hartman gre...@linuxfoundation.org: For staging drivers I need a maintainer that is going to take the time to shephard it into the core kernel tree. See other TODO files for how that person is defined. Are you going to be willing to do

Re: [PATCH 5/6] staging: dgap: tty.c: removes smatch warnings potential null dereference

2013-09-25 Thread Lidza Louina
On Tue, Sep 24, 2013 at 3:20 PM, Dan Carpenter dan.carpen...@oracle.com wrote: On Tue, Sep 24, 2013 at 02:40:10PM -0400, Lidza Louina wrote: Instead of writing: brd-SerialDriver = alloc_tty_driver(MAXPORTS); if (!brd-SerialDriver){ goto free_stuff;

Re: [PATCH 5/6] staging: dgap: tty.c: removes smatch warnings potential null dereference

2013-09-25 Thread Dan Carpenter
On Wed, Sep 25, 2013 at 01:22:08PM -0400, Lidza Louina wrote: I looked at other uses of the function alloc_tty_driver() in the kernel and none of them seem to follow up with a call to kfree(). Read my first response again. I showed how to do this. Your setting up a bunch of things in a

Re: [PATCH] add exFAT driver

2013-09-25 Thread Matthew Garrett
On Wed, Sep 25, 2013 at 10:27:04AM -0700, Greg Kroah-Hartman wrote: Who did you contact at Samsung? I'll be visiting there in a week so I can try to track some people done in person. I really want their signed-off-by: on the patch, as it is their code to start with, and it's a bit rude to

Re: [PATCH] add exFAT driver

2013-09-25 Thread Greg Kroah-Hartman
On Wed, Sep 25, 2013 at 09:28:56PM +0200, Alexander Holler wrote: Am 25.09.2013 20:45, schrieb Greg Kroah-Hartman: On Wed, Sep 25, 2013 at 07:32:36PM +0100, Matthew Garrett wrote: On Wed, Sep 25, 2013 at 10:27:04AM -0700, Greg Kroah-Hartman wrote: Who did you contact at Samsung? I'll be

Re: [PATCH] add exFAT driver

2013-09-25 Thread Greg Kroah-Hartman
On Wed, Sep 25, 2013 at 10:44:15PM +0100, Anton Altaparmakov wrote: Hi, On 25 Sep 2013, at 21:21, Greg Kroah-Hartman gre...@linuxfoundation.org wrote: On Wed, Sep 25, 2013 at 09:28:56PM +0200, Alexander Holler wrote: Maybe a silly question, but isn't exFAT protected by some MS owned

Re: [PATCH 5/6] staging: dgap: tty.c: removes smatch warnings potential null dereference

2013-09-25 Thread Lidza Louina
On Wed, Sep 25, 2013 at 2:34 PM, Dan Carpenter dan.carpen...@oracle.com wrote: On Wed, Sep 25, 2013 at 01:22:08PM -0400, Lidza Louina wrote: I looked at other uses of the function alloc_tty_driver() in the kernel and none of them seem to follow up with a call to kfree(). Read my first

Re: [PATCH] add exFAT driver

2013-09-25 Thread Anton Altaparmakov
Hi, On 25 Sep 2013, at 21:21, Greg Kroah-Hartman gre...@linuxfoundation.org wrote: On Wed, Sep 25, 2013 at 09:28:56PM +0200, Alexander Holler wrote: Maybe a silly question, but isn't exFAT protected by some MS owned patents which might drive Linux users into the hand of MS lawyers as

Re: [PATCH 5/6] staging: dgap: tty.c: removes smatch warnings potential null dereference

2013-09-25 Thread Dan Carpenter
On Wed, Sep 25, 2013 at 06:13:47PM -0400, Lidza Louina wrote: On Wed, Sep 25, 2013 at 2:34 PM, Dan Carpenter dan.carpen...@oracle.com wrote: On Wed, Sep 25, 2013 at 01:22:08PM -0400, Lidza Louina wrote: I looked at other uses of the function alloc_tty_driver() in the kernel and none of

Re: [PATCH] add exFAT driver

2013-09-25 Thread Alexander Holler
Am 26.09.2013 00:10, schrieb Greg Kroah-Hartman: Please stick to technical discussions about the code on the kernel mailing lists. Legal discussions can be left up to the lawyers, of which we are not. Hmm, but I would like to know if someone has to fear getting owned by Microsoft if he would

[PATCH 00/19] staging: comedi: pcl726: cleanup driver

2013-09-25 Thread H Hartley Sweeten
Cleanup another comedi driver. Add support for the external interrupt on the ACL-6126 board. H Hartley Sweeten (19): staging: comedi: pcl726: convert boardinfo declaration to C99 format staging: comedi: core: introduce comedi_chan_range_is_{bi,uni}polar() staging: comedi: pcl726: remove

[PATCH 02/19] staging: comedi: core: introduce comedi_chan_range_is_{bi, uni}polar()

2013-09-25 Thread H Hartley Sweeten
Introduce two helper functions to check if a subdevice range_table_list for a given channel/range is bipolar or unipolar. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org ---

[PATCH 03/19] staging: comedi: pcl726: remove 'bipolar' from the private data

2013-09-25 Thread H Hartley Sweeten
These flags are set in the private data during the attach to indicate if the range for each channel is bipolar or unipolar. Use the helper function conedi_chan_range_is_bipolar() to determine this by checking the range_table_list directly. Signed-off-by: H Hartley Sweeten

[PATCH 04/19] staging: comedi: pcl726: tidy up pcl726_ao_insn()

2013-09-25 Thread H Hartley Sweeten
For aesthetics, rename the function to help with greps. The offset binary value from the core should be saved for read back. Move the saving of the value in the private data so it occurs before the value is possibly munged for bipolar outputs. Use the comedi_offset_munge() helper to munge the

[PATCH 05/19] staging: comedi: pcl726: tidy up pcl726_ao_insn_read()

2013-09-25 Thread H Hartley Sweeten
Tidy up this function to follow the normal form for analog output read back functions. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/pcl726.c | 14 --

[PATCH 08/19] staging: comedi: pcl726: fix the analog output range_table_list initialization

2013-09-25 Thread H Hartley Sweeten
The analog output channels use jumpers on the board to individually set the range used. This driver uses the configuration options passed to the (*attach) function to setup the analog output subdevice range_table_list for each channel. The configuration options should be 'it-options[2 + i]' for

[PATCH 07/19] staging: comedi: pcl726: enable the interrupt support code

2013-09-25 Thread H Hartley Sweeten
Tidy up and enable the interrupt support code for the external trigger source interrupt on the ACL-6126 board. The interrupt handler is currently just a stub function. Once the async command support is added this function will be completed. Signed-off-by: H Hartley Sweeten

[PATCH 11/19] staging: comedi: pcl726: tidy up the comedi_lrange code

2013-09-25 Thread H Hartley Sweeten
For aesthetics, declare the comedi_lrange tables with one entry per line. Since the range data in the boardinfo is only for the analog outputs, rename the variables to make this clearer. Use ARRAY_SIZE to initialize the 'ao_num_ranges' member instead of open coding the value. Signed-off-by: H

[PATCH 14/19] staging: comedi: pcl726: remove the *_SIZE defines

2013-09-25 Thread H Hartley Sweeten
The *_SIZE defines are only used to initialize the 'io_range' members in the boardinfo. Remove the defines and just open code the values. For aesthetics, change the type of the 'io_range' and rename it to better match the 'len' parameter to comedi_request_region(). Signed-off-by: H Hartley

Re: [PATCH 5/6] staging: dgap: tty.c: removes smatch warnings potential null dereference

2013-09-25 Thread Lidza Louina
On Wed, Sep 25, 2013 at 6:29 PM, Dan Carpenter dan.carpen...@oracle.com wrote: On Wed, Sep 25, 2013 at 06:13:47PM -0400, Lidza Louina wrote: On Wed, Sep 25, 2013 at 2:34 PM, Dan Carpenter dan.carpen...@oracle.com wrote: On Wed, Sep 25, 2013 at 01:22:08PM -0400, Lidza Louina wrote: I

[PATCH 16/19] staging: comedi: pcl726: add support for the external interrupt signal

2013-09-25 Thread H Hartley Sweeten
The ACL-6126 board supports an external interrupt signal on pin 17 of its I/O connector (CN3). Add a new subdevice to this driver to support asynchronous commands with this input. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman

[PATCH 18/19] staging: comedi: pcl726: update MODULE_DESCRIPTION

2013-09-25 Thread H Hartley Sweeten
Change the MODULE_DESCRIPTION to something useful instead of the generic Comedi low-level driver. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/pcl726.c | 2 +- 1

[PATCH 19/19] staging: comedi: pcl726: rename 'boardtypes'

2013-09-25 Thread H Hartley Sweeten
'boardtypes' is pretty generic, rename this static const variable. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/pcl726.c | 6 +++--- 1 file changed, 3

Re: [PATCH] add exFAT driver

2013-09-25 Thread Matthew Garrett
On Thu, Sep 26, 2013 at 12:29:03AM +0200, Alexander Holler wrote: Am 26.09.2013 00:10, schrieb Greg Kroah-Hartman: Please stick to technical discussions about the code on the kernel mailing lists. Legal discussions can be left up to the lawyers, of which we are not. Hmm, but I would

Re: Reworking dm-writeboost [was: Re: staging: Add dm-writeboost]

2013-09-25 Thread Greg KH
On Tue, Sep 24, 2013 at 09:20:50PM +0900, Akira Hayakawa wrote: Hi, Mike I am now working on redesigning and implementation of dm-writeboost. Ok, I'm dropping your original patch, please resend when you have something you want merged into drivers/staging/ thanks, greg k-h

[PATCH v2 1/5] staging: dgap: driver.c: removes smatch warning redundant null check

2013-09-25 Thread Lidza Louina
This patch removes these smatch warnings from dgap_driver.c: redundant null check on dgap_config_buf calling kfree() redundant null check on brd-flipbuf calling kfree() redundant null check on brd-flipflagbuf calling kfree() Signed-off-by: Lidza Louina lidza.lou...@gmail.com ---

Re: [PATCH v3 6/7] staging: dgnc: changes arguments in sizeof

2013-09-25 Thread Greg KH
On Mon, Sep 09, 2013 at 03:01:27PM -0400, Lidza Louina wrote: The arguments that were passed into sizeof were generic. This patch changes this by putting the actual item that we need a size of instead. For example: - kzalloc(sizeof(struct dgnc_board), GFP_KERNEL); +

[PATCH v2 4/5] staging: dgap: tty.c: changes error handing to tty driver allocations

2013-09-25 Thread Lidza Louina
This patch changes error handling to the tty_driver allocations in dgap_tty_register. Before, it didn't handle the possibility of an alloc_tty_driver failure. This patch makes dgap_register_driver return -ENOMEM if that fails. This patch also adds handling to the possibility that the

Re: [PATCH v3 6/7] staging: dgnc: changes arguments in sizeof

2013-09-25 Thread Lidza Louina
On Wed, Sep 25, 2013 at 7:08 PM, Greg KH gre...@linuxfoundation.org wrote: On Mon, Sep 09, 2013 at 03:01:27PM -0400, Lidza Louina wrote: The arguments that were passed into sizeof were generic. This patch changes this by putting the actual item that we need a size of instead. For example: -

Re: [PATCH] staging: dgrp: Convert to use device_create_with_groups

2013-09-25 Thread Guenter Roeck
On Wed, Sep 25, 2013 at 04:02:44PM -0700, Greg Kroah-Hartman wrote: On Sat, Aug 31, 2013 at 03:56:06PM -0700, Guenter Roeck wrote: Use device_create_with_groups to create sysfs attributes together with device. Also create class attribute together with class registration. This simplifies

[PATCH 01/19] staging: comedi: pcl726: convert boardinfo declaration to C99 format

2013-09-25 Thread H Hartley Sweeten
Convert the boardinfo declaration to C99 format to make it less error prone and easier to maintain. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/pcl726.c | 76

[PATCH 09/19] staging: comedi: pcl726: tidy up pcl726_attach()

2013-09-25 Thread H Hartley Sweeten
For aesthetics, add some whitespace to the subdevice initialization. Only allocate, and initialize, the digital input and output subdevices if the boardinfo indicates that they exist on the board. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc:

[PATCH 12/19] staging: comedi: pcl726: rename boardinfo 'IRQbits'

2013-09-25 Thread H Hartley Sweeten
Rename this CamelCase variable in the boardinfo. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/pcl726.c | 6 +++--- 1 file changed, 3 insertions(+), 3

[PATCH 10/19] staging: comedi: pcl726: remove digital i/o register offsets from boardinfo

2013-09-25 Thread H Hartley Sweeten
The PCL-727 board uses different register offsets for the digital input and output ports. Instead of having all the register offsets in the boardinfo, replace them with a simple bit-field flag, 'is_pcl727'. Use that flag in the (*insn_bits) functions to determine what registers need to be used.

[PATCH v2 5/5] staging: dgap: tty.c: removes smatch warning unsigned '--un-un_open_count' is never less than zero

2013-09-25 Thread Lidza Louina
This patch removes this smatch warning: unsigned '--un-un_open_count' is never less than zero The code decremented the un_open_count variable and tested to see if it was less than zero. Because un_open_count is unsigned and can't be below zero, this test didn't work. Signed-off-by: Lidza Louina

Re: [PATCH] Staging: android: Fix timed_gpio_probe() 'ret' value in case of NULL platform_data

2013-09-25 Thread Greg KH
On Sat, Sep 14, 2013 at 02:21:03PM +0300, Elad Wexler wrote: From: Elad Wexler elad.wex...@gmail.com 'timed_gpio_probe()' shall return -ENXIO (no such address or device) in case of NULL platform data. Care to wrap your lines in the future? :) Anyway, how can platform data be NULL? Have

Re: [PATCH v4] imx-drm: Fix probe failure

2013-09-25 Thread Fabio Estevam
Hi Greg, On Tue, Sep 17, 2013 at 4:55 PM, Greg KH gre...@linuxfoundation.org wrote: Greg, The offending commit that causes the regression is in 3.12-rc1 now, so this patch could go via your staging tree. Thanks for this, I'll take it now. Do you think this one can reach 3.12-rc3? Thanks,

Re: [PATCHv2 0/11] staging: usbip: Userland crypto and ACLs

2013-09-25 Thread Greg Kroah-Hartman
On Fri, Sep 13, 2013 at 11:55:50AM +0200, Dominik Paulus wrote: Hi, this patch series includes an updated version of the IPv6 support patch (a call to freeaddrinfo() was missing) as well as: - The client/server authentication support using GnuTLS Tobias already announced on the

Re: [PATCH v2 08/24] Staging: winbond: reg: changed sleep function from msleep to usleep

2013-09-25 Thread Greg KH
On Mon, Sep 16, 2013 at 03:43:28PM +0200, Iker Pedrosa wrote: According to the documentation it is not recommended to use msleep for 1ms - 20ms because it may sleep longer than 20ms. So, it is recommended to use usleep instead. In the first revision Greg KH pointed out that this change

Re: [PATCH v4] imx-drm: Fix probe failure

2013-09-25 Thread Greg KH
On Wed, Sep 25, 2013 at 08:20:22PM -0300, Fabio Estevam wrote: Hi Greg, On Tue, Sep 17, 2013 at 4:55 PM, Greg KH gre...@linuxfoundation.org wrote: Greg, The offending commit that causes the regression is in 3.12-rc1 now, so this patch could go via your staging tree. Thanks for

Re: [PATCH] Staging / quickstart: remove reduplicate if(acpi_disabled) check

2013-09-25 Thread Toshi Kani
On Sun, 2013-09-22 at 11:05 +, Hanjun Guo wrote: In acpi_bus_register_driver(), there is an if (acpi_disabled) check, so the if(acpi_disabled) before it is reduplicate, remove it. Signed-off-by: Hanjun Guo hanjun@linaro.org Acked-by: Toshi Kani toshi.k...@hp.com -Toshi ---

Re: [PATCH v3 21/24] Staging: winbond: wb35tx: Replace printk with netdev

2013-09-25 Thread Pavel Machek
On Wed 2013-09-25 16:39:29, Iker Pedrosa wrote: The previously used printk lacked the warning level, now we've got a more accurate way to know the error. Signed-off-by: Iker Pedrosa ikerpedro...@gmail.com Acked-by: Pavel Machek pa...@ucw.cz -- (english)

Re: Reworking dm-writeboost [was: Re: staging: Add dm-writeboost]

2013-09-25 Thread Akira Hayakawa
Hi, Mike I have made another progress yesterday: Splitting the monolithic source code into meaningful pieces is done. It will follow in the next mail. Yes, please share your plan. Anything that can simplify the code layout is best done earlier to simplfy code review. Sorry, should have been

Re: Reworking dm-writeboost [was: Re: staging: Add dm-writeboost]

2013-09-25 Thread Dave Chinner
On Tue, Sep 24, 2013 at 09:20:50PM +0900, Akira Hayakawa wrote: * Deferring ACK for barrier writes Barrier flags such as REQ_FUA and REQ_FLUSH are handled lazily. Immediately handling these bios badly slows down writeboost. It surveils the bios with these flags and forcefully flushes them at