[PATCH] staging: lustre: Remove typedef and update cfs_hash_bucket struct

2013-10-21 Thread Lisa Nguyen
Remove typedef keyword and rename the cfs_hash_bucket_t struct to cfs_hash_bucket in libcfs_hash.h. These changes resolve the Do not add new typedefs warning generated by checkpatch.pl and meet kernel coding style. The struct variables in hash.c are updated to reflect this change as well.

[PATCH] drivers: staging: bcm: removed a developer debug message per the TODO list.

2013-10-21 Thread Chuong Ngo
Removed a debug message as outlined in the TODO list. --- drivers/staging/bcm/Bcmchar.c |2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/bcm/Bcmchar.c b/drivers/staging/bcm/Bcmchar.c index f91bc1f..526594b 100644 --- a/drivers/staging/bcm/Bcmchar.c +++

Re: [PATCH v2] Staging: zram: Fix variable dereferenced before check

2013-10-21 Thread Minchan Kim
On Sat, Oct 19, 2013 at 01:59:05PM -0700, Greg KH wrote: On Sat, Oct 19, 2013 at 10:01:42PM +0530, Rashika Kheria wrote: This patch fixes the following Smatch warning in zram_drv.c- ~/git/kernels/linux/drivers/staging/zram/zram_drv.c:663 reset_store() warn: variable dereferenced before

[PATCH v2 08/11] staging: comedi: s626: make CRA and CRB setup conversions more readable

2013-10-21 Thread Ian Abbott
Use the new macros defined in s626.h for constructing and decomposing 'CRA', 'CRB' and standardized encoder setup values to make the conversions between standardized encoder setup values, and CRA/CRB register values easier to follow. There is some messing about with the 'IndxSrc' values which are

[PATCH v2 11/11] staging: comedi: s626: replace S626_MULT_X? values

2013-10-21 Thread Ian Abbott
Replace the use of the `S626_MULT_X1`, `S626_MULT_X2` and `S626_MULT_X4` clock multiplier values with the equivalent `S626_CLKMULT_1X`, `S626_CLKMULT_2X` and `S626_CLKMULT_4X` values to avoid duplication. Replace the use of `S626_MULT_X0` with a new macro `S626_CLKMULT_SPECIAL` (this is treated

[PATCH v3] Staging: zram: Fix variable dereferenced before check

2013-10-21 Thread Rashika Kheria
This patch fixes the following Smatch warning in zram_drv.c- drivers/staging/zram/zram_drv.c:663 reset_store() warn: variable dereferenced before check 'bdev' (see line 652) drivers/staging/zram/zram_drv.c:899 destroy_device() warn: variable dereferenced before check 'zram-disk' (see line 896)

[PATCH 2/3] staging: lustre: Remove typedef and update cfs_hash_bd struct

2013-10-21 Thread Lisa Nguyen
Remove typedef keyword and rename the cfs_hash_bd_t struct to cfs_hash_bd in libcfs_hash.h. These changes resolve the Do not add new typedefs warning generated by checkpatch.pl and meet kernel coding style. Struct variables in other header and source files that depend on libcfs_hash.h are updated

[PATCH 1/3] staging: lustre: Remove typedef and update cfs_debug_limit_state struct

2013-10-21 Thread Lisa Nguyen
Removed typedef keyword and rename the cfs_debug_limit_state_t struct to cfs_debug_limit_state in libcfs_debug.h. These changes resolve the Do not add new typedefs warning generated by checkpatch.pl and meet kernel coding style. Struct variables in other header and source files that depend on

[PATCH 1/3] staging: lustre: lnet: Remove unnecessary spaces in lib-lnet.h

2013-10-21 Thread Lisa Nguyen
Remove spaces between function names and open parentheses to meet kernel coding style and eliminate extra space warnings generated by checkpatch.pl Signed-off-by: Lisa Nguyen l...@xenapiadmin.com --- .../staging/lustre/include/linux/lnet/lib-lnet.h | 78 +++--- 1 file changed,

[PATCH 3/3] staging: lustre: lnet: Reformat pointer variable in lib-lnet.h

2013-10-21 Thread Lisa Nguyen
Reformat a pointer variable in lib-lnet.h to meet kernel coding style and eliminate pointer format warning generated by checkpatch.pl Signed-off-by: Lisa Nguyen l...@xenapiadmin.com --- drivers/staging/lustre/include/linux/lnet/lib-lnet.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)