Re: [PATCH 1/4] Staging: comedi: addi-data: cleanup comments in hwdrv_apci1564.c

2014-02-19 Thread Dan Carpenter
On Wed, Feb 19, 2014 at 01:36:46AM -0600, Chase Southwood wrote: > hwdrv_apci1564.c had a lot of commented out conditional statements that > were often identical to other un-commented out statements nearby, so it > should be safe to just delete all of these commented out lines. This > patch also c

Microsoft gebruiker aandacht.

2014-02-19 Thread Darleen Ragland
Geachte Webmail Gebruiker, Uw twee inkomende mails over de hangende toestand geplaatst als gevolg van de recente upgrade in onze database, in volgorde te ontvangen uw berichten KLIK HIER Login met uw juiste Webmail informatie en wachten op

Re: [PATCH 1/4] Staging: comedi: addi-data: cleanup comments in hwdrv_apci1564.c

2014-02-19 Thread Ian Abbott
On 2014-02-19 07:36, Chase Southwood wrote: hwdrv_apci1564.c had a lot of commented out conditional statements that were often identical to other un-commented out statements nearby, so it should be safe to just delete all of these commented out lines. This patch also converts the remaining comme

Re: [PATCH 3/4] Staging: comedi: addi-data: replace printk() with dev_err() in hwdrv_apci1564.c

2014-02-19 Thread Ian Abbott
On 2014-02-19 07:37, Chase Southwood wrote: There were a small handful of printk() calls in hwdrv_apci1564.c. It is generally better to use dev_err() for error messages instead, so I switched all the printk() calls out, as well as cleaned up the error strings. Signed-off-by: Chase Southwood

Re: [PATCH 2/4] Staging: comedi: addi-data: cleanup brace usage in hwdrv_apci1564.c

2014-02-19 Thread Ian Abbott
On 2014-02-19 07:37, Chase Southwood wrote: hwdrv_apci1564.c had many single statments wrapped in braces, so we can delete these. Also, some else statements were improperly placed, fix these too. Signed-off-by: Chase Southwood Reviewed-by: Ian Abbott -- -=( Ian Abbott @ MEV Ltd.E-mail:

Re: [PATCH 4/4] Staging: comedi: addi-data: don't initialize a static variable to 0

2014-02-19 Thread Ian Abbott
On 2014-02-19 07:38, Chase Southwood wrote: In hwdrv_apci1564.c, one static variable is zero initialized. This is unneeded and redundant, so we remove the initialization. Signed-off-by: Chase Southwood Reviewed-by: Ian Abbott -- -=( Ian Abbott @ MEV Ltd.E-mail: )=- -=( Tel: +44

Re: [PATCH] et131x: fix allocation failures

2014-02-19 Thread One Thousand Gnomes
On Wed, 19 Feb 2014 09:14:19 +0800 "Zhao\, Gang" wrote: > Alan, thanks for resending this patch. But it seems you overlooked > something we discussed earlier. > > On Mon, 2014-02-17 at 22:13:08 +0800, Alan wrote: > > We should check the ring allocations don't fail. > > If we get a fail we need t

[PATCH 00/12] staging: comedi: pcl816: cleanup driver

2014-02-19 Thread H Hartley Sweeten
One of the patches (31/87) was dropped in my previous series to cleanup the pcl812/816/818 drivers. This resulted in a some of the remaining patches not applying (33, 34, 35, 64, 67, 73, 75, 77, 79, 81, 84, and 86). This is just a repost of those patches with Ian Abbotts Reviewed-by applied. H Ha

[PATCH 05/12] staging: comedi: pcl816: use subdevice (*cancel)

2014-02-19 Thread H Hartley Sweeten
Use the subdevice (*cancel) operation to remove the need for a forward declaration. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c | 8 +++- 1 file changed, 3 insertions(+), 5 deletions(-) diff --git a/drivers/st

[PATCH 01/12] staging: comedi: pcl816: remove 'ai_ns_min' from boardinfo

2014-02-19 Thread H Hartley Sweeten
This member of the boardinfo is the same for all board types. Remove this data from the boardinfo. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c | 16 +--- 1 file changed, 5 insertions(+), 11 deletions(-)

[PATCH 08/12] staging: comedi: pcl816: kzalloc'ed memory does not need to be cleared

2014-02-19 Thread H Hartley Sweeten
The private data is kzalloc'ed in the (*attach). There is no need to initialize any of the members to 0. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/sta

[PATCH 02/12] staging: comedi: pcl816: remove 'n_aochan' from boardinfo

2014-02-19 Thread H Hartley Sweeten
This member of the boardinfo is the same for all board types. Remove this data from the boardinfo. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c | 5 + 1 file changed, 1 insertion(+), 4 deletions(-) diff --git a

[PATCH 03/12] staging: comedi: pcl816: clarify irq request in pcl816_attach()

2014-02-19 Thread H Hartley Sweeten
All the board types can use IRQ 2-7 for async command support. Remove the 'IRQbits', which is a mask of the valid IRQs, from the boardinfo and refactor pcl816_attach(). Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c |

[PATCH 10/12] staging: comedi: pcl816: remove unnecessary 'dev->irq' check

2014-02-19 Thread H Hartley Sweeten
If the dev->irq is not valid the interrupt function will not be hooked up during the attach. Remove the unnecessary check. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c | 2 +- 1 file changed, 1 insertion(+), 1 delet

[PATCH 06/12] staging: comedi: pcl816: remove 'ai_act_chanlist_{len, pos}' from private data

2014-02-19 Thread H Hartley Sweeten
These members of the private data don't do anything usefull. Just remove them. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c | 13 - 1 file changed, 13 deletions(-) diff --git a/drivers/staging/comedi/dr

[PATCH 04/12] staging: comedi: pcl816: don't calc the timer divisors twice

2014-02-19 Thread H Hartley Sweeten
The timer divisors are calculated in the (*do_cmdtest) before the (*do_cmd) is called by the comedi core. The extra sanity checks in the (*do_cmd) are not necessary, the values returned from i8253_cascade_ns_to_timer() will be greater than 1. Save the values in the private data so they don't need t

[PATCH 11/12] staging: comedi: pcl816: remove unnecessary function separation comments

2014-02-19 Thread H Hartley Sweeten
These comments are just added cruft. Remove them. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c | 40 - 1 file changed, 40 deletions(-) diff --git a/drivers/staging/comedi/drivers/pcl

[PATCH 12/12] staging: comedi: pcl816: tidy up pcl818_check()

2014-02-19 Thread H Hartley Sweeten
This function probes a number of the boards registers during the (*attach) to verify that it is actually a PCL-816 compatible board. For aesthetics, move the function closer to the (*attach). To better match the pcl818 driver, allocate the private data before calling pcl816_check(). Refactor the

[PATCH 07/12] staging: comedi: pcl816: convert private data flags to bit-fields

2014-02-19 Thread H Hartley Sweeten
The 'irq_was_now_closed' member is actually a flag, devpriv->int816_mode will always be > 0 when it's used to set irq_was_now_closed in the cancel function. Convert the flags in the private data to bit-fields to save a bit of space. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: G

[PATCH 09/12] staging: comedi: pcl816: rename 'irq_blocked' in private data

2014-02-19 Thread H Hartley Sweeten
This member in the private data is a flag that indicates that an analog input async command is currently running. Rename it to make this clear. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/pcl816.c | 12 ++-- 1 file

[PATCH 12/19] Merge dgap_conf.h into dgap_driver.h

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_conf.h | 289

[PATCH 14/19] Merge dgap_kcompat.h into dgap_driver.h

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.h | 33

[PATCH V3 00/19] staging: dgap: Digi International dgap driver

2014-02-19 Thread Mark Hounschell
This patch series whittles down the drivers/staging/dgap directory to just 4 files (dgap_driver.c, dgap_driver.h, Makefile, and Kconfig). This was done because there is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that ma

[PATCH 09/19] Merge dgap_sysfs.h into dgap_driver.c

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.c | 22 +

[PATCH 08/19] Merge dgap_tty.h into dgap_driver.c

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.c | 9 - dr

[PATCH 17/19] Make merged and local functions and variables static

2014-02-19 Thread Mark Hounschell
This patch makes all merged and original functions static to dgap.c. Doing so has revealed more dead code via gcc warnings. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.c | 159 + drivers/staging/dgap/dgap_driver

[PATCH 13/19] Merge dgap_parse.h into dgap_driver.h

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.c | 12 +++-

[PATCH 16/19] Merge digi.h into dgap_driver.h

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.h | 353

[PATCH 10/19] Merge dgap_fep5.h into dgap_driver.h

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.c | 1 - drivers/s

[PATCH 01/19] Remove CVS ID tags

2014-02-19 Thread Mark Hounschell
This patch removes all the original CVS tags because they are in my way Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_conf.h | 1 - drivers/staging/dgap/dgap_downld.h | 1 - drivers/staging/dgap/dgap_driver.c | 1 - drivers/staging/dgap/dgap_fep5.c | 1

[PATCH 02/19] Remove userland source code files

2014-02-19 Thread Mark Hounschell
This patch removes userland source code files downld.c and dgap_downld.h Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_downld.h | 68 drivers/staging/dgap/downld.c | 797 - 2 files changed, 865 deletions(-) de

[PATCH 15/19] Merge dgap_types.h into dgap_driver.h

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.c | 1 - drivers/st

[PATCH 07/19] Remove unneeded dgap_trace.c and dgap_trace.h

2014-02-19 Thread Mark Hounschell
Removes unneeded files dgap_trace.c and dgap_trace.h Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/Makefile | 3 +- drivers/staging/dgap/dgap_driver.c | 1 - drivers/staging/dgap/dgap_trace.c | 185 - drivers/staging

[PATCH 05/19] Merge dgap_sysfs.c into dgap_driver.c

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/Makefile | 3 +- drivers

[PATCH 19/19] Add in-kernel firmware loading support

2014-02-19 Thread Mark Hounschell
This patch adds in-kernel firmware loading support and removes support for the original userland firmware loading process. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap.c | 540 +++- 1 file changed, 338 insertions(+),

[PATCH 11/19] Merge dgap_pci.h into dgap_driver.h

2014-02-19 Thread Mark Hounschell
There is a lot of cleanup work to do on these digi drivers and merging as much as is possible will make it easier. I also notice that many merged drivers are single source and header. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap_driver.c | 1 - drivers/st

Re: [PATCH 19/19] Add in-kernel firmware loading support

2014-02-19 Thread Dan Carpenter
This one has white space problems. Run scripts/checkpatch.pl on your patches before sending. Comments below. On Wed, Feb 19, 2014 at 01:12:15PM -0500, Mark Hounschell wrote: > +static int dgap_firmware_load(struct pci_dev *pdev, int card_type) > +{ > + struct board_t *brd = dgap_Board[dgap_N

Re: [PATCH V3 00/19] staging: dgap: Digi International dgap driver

2014-02-19 Thread Dan Carpenter
Please redo the last patch. You don't need to resend the first 18 for that (unless Greg finds a problem obviously). regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driv

Re: [PATCH 19/19] Add in-kernel firmware loading support

2014-02-19 Thread Mark Hounschell
On 02/19/2014 03:17 PM, Dan Carpenter wrote: > This one has white space problems. Run scripts/checkpatch.pl on your > patches before sending. Comments below. > > On Wed, Feb 19, 2014 at 01:12:15PM -0500, Mark Hounschell wrote: >> +static int dgap_firmware_load(struct pci_dev *pdev, int card_type

Re: [PATCH net-next] hyperv: Add latest NetVSP versions to auto negotiation

2014-02-19 Thread David Miller
From: Haiyang Zhang Date: Tue, 18 Feb 2014 12:28:54 -0800 > + u32 ver_list[] = {NVSP_PROTOCOL_VERSION_1, NVSP_PROTOCOL_VERSION_2, > + NVSP_PROTOCOL_VERSION_4, NVSP_PROTOCOL_VERSION_5}; Please put a space after "{" and before "}". > + int i, num_ver = 4; /* number of differen

[PATCH 19/19] [v4] Add in-kernel firmware loading support

2014-02-19 Thread Mark Hounschell
This patch adds in-kernel firmware loading support and removes support for the original userland firmware loading process. Signed-off-by: Mark Hounschell Cc: Greg Kroah-Hartman --- drivers/staging/dgap/dgap.c | 529 +++- 1 file changed, 327 insertions(+),

[PATCH net-next, v2] hyperv: Add latest NetVSP versions to auto negotiation

2014-02-19 Thread Haiyang Zhang
It auto negotiates the highest NetVSP version supported by both guest and host. Signed-off-by: Haiyang Zhang Reviewed-by: K. Y. Srinivasan --- drivers/net/hyperv/hyperv_net.h | 53 +++ drivers/net/hyperv/netvsc.c | 25 +++-- drivers/net/hy

RE: [PATCH net-next] hyperv: Add latest NetVSP versions to auto negotiation

2014-02-19 Thread Haiyang Zhang
> -Original Message- > From: David Miller [mailto:da...@davemloft.net] > Sent: Wednesday, February 19, 2014 4:23 PM > To: Haiyang Zhang > Cc: net...@vger.kernel.org; KY Srinivasan; o...@aepfle.de; > jasow...@redhat.com; linux-ker...@vger.kernel.org; driverdev- > de...@linuxdriverproject.o

Re: [PATCH net-next,v2] hyperv: Add latest NetVSP versions to auto negotiation

2014-02-19 Thread David Miller
From: Haiyang Zhang Date: Wed, 19 Feb 2014 15:49:45 -0800 > It auto negotiates the highest NetVSP version supported by both guest and > host. > > Signed-off-by: Haiyang Zhang > Reviewed-by: K. Y. Srinivasan Applied, thanks. ___ devel mailing list d

Re: [PATCH] et131x: fix allocation failures

2014-02-19 Thread Zhao, Gang
On Wed, 2014-02-19 at 19:43:15 +0800, One Thousand Gnomes wrote: > On Wed, 19 Feb 2014 09:14:19 +0800 > "Zhao\, Gang" wrote: > >> Alan, thanks for resending this patch. But it seems you overlooked >> something we discussed earlier. >> >> On Mon, 2014-02-17 at 22:13:08 +0800, Alan wrote: >> > We s