Re: [PATCH v2] staging/media/rtl2832u_sdr: fix coding style problems by adding blank lines

2014-06-03 Thread Dan Carpenter
On Mon, Jun 02, 2014 at 05:38:06PM -0700, Ovidiu Toader wrote: This minor patch fixes all WARNING:SPACING style warnings in rtl2832_sdr.c The new version of the file pleases checkpatch.pl when run with --ignore LONG_LINE. Looks good. Thanks. regards, dan carpenter

[PATCH] staging: rts5139: remove unnecessary parenthesis

2014-06-03 Thread Sam Bobroff
Remove some unnecessary parenthesis as recommended by checkpatch.pl. Signed-off-by: Sam Bobroff sam.bobr...@au1.ibm.com --- drivers/staging/rts5139/rts51x_scsi.c |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rts5139/rts51x_scsi.c

[PATCH 1/4] staging: dgap: pass dgap_numboards as a paramter to dgap_found_board()

2014-06-03 Thread Daeseok Youn
- Pass dgap_numboards to dgap_found_board() instead of using a global variable. Signed-off-by: Daeseok Youn daeseok.y...@gmail.com --- drivers/staging/dgap/dgap.c | 14 +++--- 1 files changed, 7 insertions(+), 7 deletions(-) diff --git a/drivers/staging/dgap/dgap.c

[PATCH 2/4] staging: dgap: pass brd as a paramter to dgap_after_config_loaded()

2014-06-03 Thread Daeseok Youn
Pass brd to dgap_after_config_loaded() instead of passing dgap_numboards and looking up brd again. Signed-off-by: Daeseok Youn daeseok.y...@gmail.com --- drivers/staging/dgap/dgap.c |8 +--- 1 files changed, 5 insertions(+), 3 deletions(-) diff --git a/drivers/staging/dgap/dgap.c

[PATCH 3/4] staging: dgap: rename dgap_finalize_board_init() to dgap_request_irq()

2014-06-03 Thread Daeseok Youn
Signed-off-by: Daeseok Youn daeseok.y...@gmail.com --- drivers/staging/dgap/dgap.c |6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/staging/dgap/dgap.c b/drivers/staging/dgap/dgap.c index 7a07a9b..b331108 100644 --- a/drivers/staging/dgap/dgap.c +++

[PATCH 4/4] staging: dgap: rename dgap_tty_uninit() to dgap_cleanup_tty()

2014-06-03 Thread Daeseok Youn
- dgap_tty_uninit() doesn't match dgap_tty_init() at all. so rename it. It is just used for cleanup when this module is exited or failed to initialize by dgap_init_module. Signed-off-by: Daeseok Youn daeseok.y...@gmail.com --- drivers/staging/dgap/dgap.c |8 1 files changed, 4

Re: [PATCH 2/4] staging: dgap: pass brd as a paramter to dgap_after_config_loaded()

2014-06-03 Thread Dan Carpenter
On Tue, Jun 03, 2014 at 03:27:28PM +0900, Daeseok Youn wrote: -static int dgap_after_config_loaded(int board) +static int dgap_after_config_loaded(struct board_t *brd) { + int board = brd-boardnum; + We don't need to use board in this function. We can replaced dgap_board[board]- with

Re: [PATCH 4/4] staging: dgap: rename dgap_tty_uninit() to dgap_cleanup_tty()

2014-06-03 Thread Dan Carpenter
These all look great except for 2/4. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

Re: [PATCH 2/4] staging: dgap: pass brd as a paramter to dgap_after_config_loaded()

2014-06-03 Thread DaeSeok Youn
2014-06-03 16:22 GMT+09:00 Dan Carpenter dan.carpen...@oracle.com: On Tue, Jun 03, 2014 at 03:27:28PM +0900, Daeseok Youn wrote: -static int dgap_after_config_loaded(int board) +static int dgap_after_config_loaded(struct board_t *brd) { + int board = brd-boardnum; + We don't need to

[PATCH 2/4 V2] staging: dgap: pass brd as a paramter to dgap_after_config_loaded()

2014-06-03 Thread Daeseok Youn
Pass brd to dgap_after_config_loaded() instead of passing dgap_numboards and looking up brd again. Signed-off-by: Daeseok Youn daeseok.y...@gmail.com --- V2: replace dgap_board[board]- with brd-. drivers/staging/dgap/dgap.c | 18 +- 1 files changed, 9 insertions(+), 9

Re: [PATCH 2/4] Staging: rtl8192u: r8192U_wx.c Removed all C99 comments

2014-06-03 Thread Geert Uytterhoeven
Hi Chaitanya, On Mon, Jun 2, 2014 at 6:11 PM, Chaitanya Hazarey c...@24.io wrote: To address the error - ERROR: do not use C99 // comments Removed all C99 comments. IMHO, blindly converting C99 comments is a good idea... --- a/drivers/staging/rtl8192u/r8192U_wx.c +++

Re: [PATCH] staging: comedi: style - use kmalloc_array(n, s, ...) instead of kmalloc(n*s, ...)

2014-06-03 Thread Ian Abbott
On 2014-06-02 21:48, Wolfgang Ocker wrote: Fix a style issue reported by checkpatch.pl for the Eudyptula challenge Signed-off-by: Wolfgang Ocker w...@weo1.de --- drivers/staging/comedi/comedi_fops.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git

[PATCH] Staging: dgnc: fixed brace coding style issue in dgnc_driver.c

2014-06-03 Thread Vincent Heuken
This is a patch to the dgnc_driver.c file that fixes the following error: ERROR: open brace '{' following function declarations go on the next line Signed-off-by: Vincent Heuken m...@vincentheuken.com --- drivers/staging/dgnc/dgnc_driver.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-)

[PATCH] staging: android: timed_output: fix use after free of dev

2014-06-03 Thread Yi Zhang
tdev-dev has been freed in device_destroy(), it's not right to use dev_set_drvdata() after that; Signed-off-by: Yi Zhang yizh...@marvell.com --- drivers/staging/android/timed_output.c |1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/android/timed_output.c

[PATCH] Staging: unisys Remove BROKEN from Kconfig to allow compilation

2014-06-03 Thread Ken Cox
The unisys drivers now properly check to make sure they are running on the s-Par platform before they will initialize. This was fixed in commit fcd0157ece so it is safe to allow the unisys drivers to be built. This has been tested in the same qemu environment that originally produced the panic

[PATCH net-next] hyper-v: make uuid_le const

2014-06-03 Thread Stephen Hemminger
The uuid structure could be managed as a const in several places. Signed-off-by: Stephen Hemminger step...@networkplumber.org --- Patch against net-next because that is where most recent hyper-v related changes are. --- a/drivers/hv/channel_mgmt.c 2014-02-12 08:21:54.627887619 -0800 +++

Re: [PATCH] Staging: unisys Remove BROKEN from Kconfig to allow compilation

2014-06-03 Thread Greg KH
On Tue, Jun 03, 2014 at 09:43:35AM -0500, Ken Cox wrote: The unisys drivers now properly check to make sure they are running on the s-Par platform before they will initialize. This was fixed in commit fcd0157ece so it is safe to allow the unisys drivers to be built. This has been tested in

Re: [PATCH 2/4] Staging: rtl8192u: r8192U_wx.c Removed all C99 comments

2014-06-03 Thread Dan Carpenter
On Tue, Jun 03, 2014 at 10:12:23AM +0200, Geert Uytterhoeven wrote: What do other people think? In staging we just automatically delete commented code. It's in the git log if you need it. It always feels much better after the dead code is gone. regards, dan carpenter

[PATCH] fix coding style issues

2014-06-03 Thread Nicolas Koch
Done as task 10 of the eudyptula challenge. Signed-off-by: Nicolas Koch nioko1...@googlemail.com --- drivers/staging/octeon/ethernet-mem.c | 11 +++ 1 file changed, 7 insertions(+), 4 deletions(-) diff --git a/drivers/staging/octeon/ethernet-mem.c

Re: [PATCH] fix coding style issues

2014-06-03 Thread Dan Carpenter
On Tue, Jun 03, 2014 at 09:21:18PM +0200, Nicolas Koch wrote: Done as task 10 of the eudyptula challenge. There is no subject prefix. The subject should be: [patch] Staging: octeon: minor style cleanups Otherwise the patch is ok. regards, dan carpenter

[patch] Staging: octeon: minor style cleanups

2014-06-03 Thread Nicolas Koch
Done as task 10 of the eudyptula challenge. Signed-off-by: Nicolas Koch nioko1...@googlemail.com --- drivers/staging/octeon/ethernet-mem.c | 11 +++ 1 file changed, 7 insertions(+), 4 deletions(-) diff --git a/drivers/staging/octeon/ethernet-mem.c

Re: [PATCH 2/4] Staging: rtl8192u: r8192U_wx.c Removed all C99 comments

2014-06-03 Thread Chaitanya Hazarey
On Tue, Jun 3, 2014 at 11:36 AM, Dan Carpenter dan.carpen...@oracle.com wrote: It always feels much better after the dead code is gone. So patches are still good ? No change required for my side, right ? I just need to wait for Greg's needle to come to this point and pick them up. Best,

Re: [PATCH v2 1/4] dma-mapping: Add devm_ interface for dma_map_single()

2014-06-03 Thread Shuah Khan
On 06/01/2014 01:01 AM, Eli Billauer wrote: dmam_map_single() and dmam_unmap_single() are the managed counterparts for the respective dma_* functions. Note that dmam_map_single() returns a status value rather than the DMA handle. The DMA handle is passed to the caller through a pointer in the

Re: [PATCH 2/4] Staging: rtl8192u: r8192U_wx.c Removed all C99 comments

2014-06-03 Thread Greg KH
On Tue, Jun 03, 2014 at 02:34:55PM -0700, Chaitanya Hazarey wrote: On Tue, Jun 3, 2014 at 11:36 AM, Dan Carpenter dan.carpen...@oracle.com wrote: It always feels much better after the dead code is gone. So patches are still good ? No change required for my side, right ? I just need to

[PATCH 0/1] staging-next: rtl8723au: Fix wrong mask when determining 40MHz channel location

2014-06-03 Thread Jes . Sorensen
From: Jes Sorensen jes.soren...@redhat.com Greg, One of the patches in my last set had a bad bug which made the driver mask out the bits used to determine the correct location of the 40MHz channel location. This one needs to go on top. Thanks, Jes Jes Sorensen (1): staging: rtl8723au:

[PATCH 1/1] staging: rtl8723au: rtw_update_ht_cap23a(): Use correct mask when determining 40MHz channel location

2014-06-03 Thread Jes . Sorensen
From: Jes Sorensen jes.soren...@redhat.com commit 2dc5e6e90892d7247fbe8c25714dba3c0ba744e8 Author: Jes Sorensen jes.soren...@redhat.com Date: Tue May 27 13:43:12 2014 +0200 staging: rtl8723au: Eliminate struct HT_info_element Yet another duplicate version of struct

Re: [PATCH 2/4] Staging: rtl8192u: r8192U_wx.c Removed all C99 comments

2014-06-03 Thread Chaitanya Hazarey
On Tue, Jun 3, 2014 at 2:42 PM, Greg KH gre...@linuxfoundation.org wrote: So keep working on things, these aren't lost, I'll get to them in a few weeks. Ok will do, Chaitanya ___ devel mailing list de...@linuxdriverproject.org

[PATCH] staging: bcm: Fix out of bounds access in CmHosts.c

2014-06-03 Thread Masanari Iida
An array u8IPv6FlowLable[] is defined as 3 in cntrl_SignalingInterface.h. But in CmHosts.c, the kernel accessed to clsRule.u8IPv6FlowLable[5]. Signed-off-by: Masanari Iida standby2...@gmail.com --- drivers/staging/bcm/cntrl_SignalingInterface.h | 2 +- 1 file changed, 1 insertion(+), 1

Re: [PATCH] staging: tidspbridge: pmgr: dspapi.c: Cleaning up uninitialized variables

2014-06-03 Thread Rickard Strandqvist
Hi I send in a new patch now, hope I interpreted you correctly how you wanted the changes. Worth mention is that in mgrwrap_enum_node_info() unless you wanted to remove if (size sizeof(struct dsp_ndbprops)) then size will always be the same as sizeof(struct dsp_ndbprops) Best regards

Re: [PATCH 0/1] staging-next: rtl8723au: Fix wrong mask when determining 40MHz channel location

2014-06-03 Thread Greg KH
On Tue, Jun 03, 2014 at 11:41:21PM +0200, jes.soren...@redhat.com wrote: From: Jes Sorensen jes.soren...@redhat.com Greg, One of the patches in my last set had a bad bug which made the driver mask out the bits used to determine the correct location of the 40MHz channel location. This

[PATCH] staging: tidspbridge: pmgr: dspapi.c: Cleaning up uninitialized variable

2014-06-03 Thread Rickard Strandqvist
There is a risk that the variables will be used without being initialized. Has also improved error handling, after an email proposal from Dan Carpenter. Signed-off-by: Rickard Strandqvist rickard_strandqv...@spectrumdigital.se --- drivers/staging/tidspbridge/pmgr/dspapi.c | 64

Re: [PATCH v2 1/4] dma-mapping: Add devm_ interface for dma_map_single()

2014-06-03 Thread Joerg Roedel
On Tue, Jun 03, 2014 at 03:24:20PM -0600, Shuah Khan wrote: On 06/01/2014 01:01 AM, Eli Billauer wrote: I see the value of this interface in unmap case, this type of wrapper can release dma buffers, drivers neglected to release leaving dangling buffers. However, driver writers should give

Re: [PATCH net-next] hyper-v: make uuid_le const

2014-06-03 Thread David Miller
From: Stephen Hemminger step...@networkplumber.org Date: Tue, 3 Jun 2014 08:38:15 -0700 The uuid structure could be managed as a const in several places. Signed-off-by: Stephen Hemminger step...@networkplumber.org Applied, thanks. ___ devel mailing

Re: [patch] mm, pcp: allow restoring percpu_pagelist_fraction default

2014-06-03 Thread Oleg Drokin
Hello! On Jun 3, 2014, at 9:22 PM, David Rientjes wrote: @@ -5849,21 +5850,32 @@ int lowmem_reserve_ratio_sysctl_handler(ctl_table *table, int write, int percpu_pagelist_fraction_sysctl_handler(ctl_table *table, int write, void __user *buffer, size_t *length, loff_t *ppos) { +

[PATCH v2 0/5] staging: comedi: addi_apci_1564: fix Change-of-State interrupt functionality

2014-06-03 Thread Chase Southwood
This patchset introduces a new private data struct for this driver, adds all of the code required to support Change-of-State interrupts for the digital input subdevice, and finally fixes apci1564_interrupt() to service this type of interrupt correctly. CHANGES FROM v1: *leave the send_sig() calls

[PATCH v2 1/5] staging: comedi: addi_apci_1564: remove use of devpriv-b_OutputMemoryStatus

2014-06-03 Thread Chase Southwood
This member of the private data struct is only set at one location in the entire driver, and then never even used for anything. Let's just remove its use. Signed-off-by: Chase Southwood chase.southw...@gmail.com Cc: Ian Abbott abbo...@mev.co.uk Cc: H Hartley Sweeeten hswee...@visionengravers.com

[PATCH v2 3/5] staging: comedi: addi_apci_1564: introduce apci1564_private struct

2014-06-03 Thread Chase Southwood
The addi_private struct defined in addi-data/addi_common.h is very bloated and contains many fields which addi_apci_1564 does not require. In the interest of eventually removing this driver's dependency on addi_common.h, we can create a private data struct specifically for addi_apci_1564

[PATCH v2 4/5] staging: comedi: addi_apci_1564: add Change-of-State interrupt subdevice and required functions

2014-06-03 Thread Chase Southwood
This board supports an interrupt that can be generated by an AND/OR combination of 16 of the input channels. Create a separate subdevice to handle this interrupt. The apci1564_di_config() function is used to configure which inputs are used to generate the interrupt. Currently this function is

[PATCH v2 5/5] staging: comedi: addi_apci_1564: move apci1564_interrupt() into addi_apci_1564.c

2014-06-03 Thread Chase Southwood
On moving the function into the driver proper, also check the device is asserting the shared interrupt line. This patch also fixes the interrupt handling for the digital input change-of-state interrupts. Signed-off-by: Chase Southwood chase.southw...@gmail.com Cc: Ian Abbott abbo...@mev.co.uk

Re: [PATCH v2 1/5] gpu: ipu-v3: Move i.MX IPUv3 core driver out of staging

2014-06-03 Thread Dave Airlie
On 3 June 2014 03:06, Greg Kroah-Hartman gre...@linuxfoundation.org wrote: On Mon, Jun 02, 2014 at 06:36:22PM +0200, Philipp Zabel wrote: Am Mittwoch, den 28.05.2014, 14:13 -0700 schrieb Greg Kroah-Hartman: On Mon, May 26, 2014 at 04:19:39PM +0200, Philipp Zabel wrote: The i.MX Image