Re: [PATCH] staging: nvec: insert blank lines after declarations

2014-07-04 Thread Marc Dietrich
Am Donnerstag, 3. Juli 2014, 21:15:57 schrieb Pawel Lebioda: Hi, This patch fixes coding style warnings reported by checkpatch.pl: Missing a blank line after declarations. thanks. Looking at the checkpatch output, its requirement of at least 4 lines of help text looks like a bit overkill

[RFC] [HELP] [WMI] Media keys on MSI GE60 (patching msi_wmi for it)

2014-07-04 Thread Vadim A. Misbakh-Soloviov
Hi there! I'm trying to modify msi_wmi driver to get it work with mediakeys on my MSI GE60 laptop. By default, I get Unknown event received message. For now, I diagnosed that event, that every key press produces has 0x03 ( ACPI_TYPE_BUFFER?) type, instead of 0x01 (ACPI_TYPE_INTEGER) which

Re: [PATCH RFC] imx-drm: convert imx-drm to use the generic DRM OF helper

2014-07-04 Thread Philipp Zabel
Hi Russell, Am Donnerstag, den 03.07.2014, 17:52 +0100 schrieb Russell King: Use the generic DRM OF helper to locate the possible CRTCs for the encoder, thereby shrinking the imx-drm driver some more. Great, I especially like that now we don't go -EPROBE_DEFER anymore as soon as a single

[PATCH 5/5] imx-drm: use for_each_endpoint_of_node macro in imx_drm_encoder_get_mux_id

2014-07-04 Thread Philipp Zabel
Using the for_each_... macro should make the code bit shorter and easier to read. This patch also properly decrements the endpoint node reference count before returning out of the loop. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- drivers/staging/imx-drm/imx-drm-core.c | 9 +++--

[PATCH 3/5] of: Add for_each_endpoint_of_node helper macro

2014-07-04 Thread Philipp Zabel
Note that while of_graph_get_next_endpoint decrements the reference count of the child node passed to it, of_node_put(child) still has to be called manually when breaking out of the loop. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- include/linux/of_graph.h | 4 1 file changed, 4

[PATCH 2/5] of: Decrement refcount of previous endpoint in of_graph_get_next_endpoint

2014-07-04 Thread Philipp Zabel
Decreasing the reference count of the previous endpoint node allows to use the of_graph_get_next_endpoint function in a for_each_... style macro. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- drivers/of/base.c | 9 + 1 file changed, 1 insertion(+), 8 deletions(-) diff --git

[PATCH 4/5] drm: use for_each_endpoint_of_node macro in drm_of_find_possible_crtcs

2014-07-04 Thread Philipp Zabel
Using the for_each_... macro should make the code a bit shorter and easier to read. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- drivers/gpu/drm/drm_of.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git a/drivers/gpu/drm/drm_of.c b/drivers/gpu/drm/drm_of.c

[PATCH 0/5] Iterate of_graph endpoints using a for_each_... style macro

2014-07-04 Thread Philipp Zabel
Hi, decrementing the reference count of the previous endpoint node parameter to of_graph_get_next_endpoint allows to wrap the function in a for_each macro. This series removes the remaining workaround in imx-drm, adds the macro for_each_endpoint_of_node, and switches the current users to it. It

[PATCH 1/5] imx-drm: Drop imx_drm_of_get_next_endpoint wrapper

2014-07-04 Thread Philipp Zabel
We will decrease the prev node reference count in of_graph_get_next_endpoint instead. Signed-off-by: Philipp Zabel p.za...@pengutronix.de --- drivers/staging/imx-drm/imx-drm-core.c | 10 +- 1 file changed, 1 insertion(+), 9 deletions(-) diff --git

[PATCH 1/2] staging: dgap: remove unneccessary dgap_init_pci() function

2014-07-04 Thread Daeseok Youn
The dgap_init_pci() calls only pci_register_driver(). It doesn't need to make a function for that. Signed-off-by: Daeseok Youn daeseok.y...@gmail.com --- drivers/staging/dgap/dgap.c | 11 +-- 1 files changed, 1 insertions(+), 10 deletions(-) diff --git a/drivers/staging/dgap/dgap.c

[PATCH 2/2] staging: dgap: remove unused waitqueues

2014-07-04 Thread Daeseok Youn
dgap_dl_wait and kme_wait are not used in dgap. Signed-off-by: Daeseok Youn daeseok.y...@gmail.com --- drivers/staging/dgap/dgap.c |8 drivers/staging/dgap/dgap.h |1 - 2 files changed, 0 insertions(+), 9 deletions(-) diff --git a/drivers/staging/dgap/dgap.c

Re: [PATCH v3 3/8] component: add support for component match array

2014-07-04 Thread Sachin Kamat
by component_master_add() below). Observed this while testing linux-next kernel (next-20140704) on Exynos based board with DRM enabled. + if (IS_ERR(match)) + return PTR_ERR(match); + master = kzalloc(sizeof(*master), GFP_KERNEL); if (!master

Re: [PATCH v3 3/8] component: add support for component match array

2014-07-04 Thread Russell King - ARM Linux
by component_master_add() below). Observed this while testing linux-next kernel (next-20140704) on Exynos based board with DRM enabled. Thanks for your report. Please verify that the patch below resolves it for you. Thanks. drivers/base/component.c | 10 ++ 1 file changed, 6 insertions

Re: [PATCH v3 3/8] component: add support for component match array

2014-07-04 Thread Sachin Kamat
); ^ This gives a NULL pointer dereference error when match is NULL (as passed by component_master_add() below). Observed this while testing linux-next kernel (next-20140704) on Exynos based board with DRM enabled. Thanks for your report. Please verify that the patch below resolves

Re: [PATCH v3 3/8] component: add support for component match array

2014-07-04 Thread Russell King - ARM Linux
*/ + match = component_match_realloc(dev, match, match-num); ^ This gives a NULL pointer dereference error when match is NULL (as passed by component_master_add() below). Observed this while testing linux-next kernel (next-20140704) on Exynos based board with DRM

Re: [PATCH v3 3/8] component: add support for component match array

2014-07-04 Thread Sachin Kamat
this while testing linux-next kernel (next-20140704) on Exynos based board with DRM enabled. Thanks for your report. Please verify that the patch below resolves it for you. Thanks. Yes, the below patch fixes the crash. Thanks for the fix. Thanks. I'll add a tested-by and reported

[PATCH] staging: goldfish: Introduce the use of managed interfaces

2014-07-04 Thread Himangi Saraogi
This patch introduces the use of managed interfaces like devm_kzalloc, devm_ioremap, dmam_alloc_coherent, devm_request_irq and does away with the calls to functions to free the allocated memory in the probe and remove functions. Also, the labels are removed in the probe function. Signed-off-by:

Status of RMI4 drivers?

2014-07-04 Thread Kristina Martšenko
Hi, I'm going over some older drivers in the staging tree and wanted to ask about cptm1217 and ste_rmi4. They've been in staging for three and a half years now, waiting for the upstream Synaptics RMI4 drivers. From what I understand, the RMI4 development is happening in the synaptics-rmi4 branch

[PATCH] staging: nvec: remove unneccessary 'else' after 'return' statement

2014-07-04 Thread Pawel Lebioda
Hi, This patch fixes the following warning reported by checkpatch.pl: WARNING: else is not generally useful after a break or return #235: FILE: drivers/staging/nvec/nvec.c:235: Regards Pawel Lebioda Signed-off-by: Pawel Lebioda pawel.lebiod...@gmail.com drivers/staging/nvec/nvec.c | 3 +-- 1

[PATCH 1/1] staging: cxt1e1: remove null test before kfree

2014-07-04 Thread Fabian Frederick
Fix checkpatch warning: WARNING: kfree(NULL) is safe this check is probably not required Cc: Greg Kroah-Hartman gre...@linuxfoundation.org Cc: Daeseok Youn daeseok.y...@gmail.com Cc: de...@driverdev.osuosl.org Signed-off-by: Fabian Frederick f...@skynet.be --- drivers/staging/cxt1e1/pmcc4_drv.c

[PATCH] staging: nvec: remove unneccessary 'out of memory' message

2014-07-04 Thread Pawel Lebioda
Hi, This patch fixes the following warning reported by checkpatch.pl: WARNING: Possible unnecessary 'out of memory' message #811: FILE: drivers/staging/nvec/nvec.c:811 Regards Pawel Lebioda Signed-off-by: Pawel Lebioda pawel.lebiod...@gmail.com drivers/staging/nvec/nvec.c | 5 ++--- 1 file

[PATCH] staging: bcm: add missing blank lines after declarations

2014-07-04 Thread Pawel Lebioda
Hi, This patch fixes almost all 'missing blank line after declaration' warnings reported by checkpatch.pl for drivers/staging/bcm. Regards Pawel Lebioda Signed-off-by: Pawel Lebioda pawel.lebiod...@gmail.com drivers/staging/bcm/CmHost.c| 1 + drivers/staging/bcm/IPv6Protocol.c | 6

Re: [PATCH] staging: nvec: remove unneccessary 'else' after 'return' statement

2014-07-04 Thread Julian Andres Klode
On Fri, Jul 04, 2014 at 09:57:50PM +0200, Pawel Lebioda wrote: Hi, This patch fixes the following warning reported by checkpatch.pl: WARNING: else is not generally useful after a break or return #235: FILE: drivers/staging/nvec/nvec.c:235: Regards Pawel Lebioda Signed-off-by: Pawel