Re: [PATCH] staging: dgap: use schedule_timeout_interruptible() instead of dgap_ms_sleep()

2014-09-15 Thread Dan Carpenter
On Tue, Sep 16, 2014 at 12:33:33PM +0900, Daeseok Youn wrote: > @@ -2297,12 +2273,12 @@ static void dgap_tty_close(struct tty_struct *tty, > struct file *file) >* Go to sleep to ensure RTS/DTR >* have been dropped for modems to see it. >

[PATCH] Staging/bcm: Fix whitespace/comments in Ioctl.h

2014-09-15 Thread Martin Kelly
Cleanup whitespace and comments in Ioctl.h in a few ways: - > 80 character cleanup - Comment clarification - More consistent vertical alignment Signed-off-by: Martin Kelly --- drivers/staging/bcm/Ioctl.h | 26 +- 1 file changed, 13 insertions(+), 13 deletions(-) diff --g

[PATCH] staging: dgap: use schedule_timeout_interruptible() instead of dgap_ms_sleep()

2014-09-15 Thread Daeseok Youn
Using schedule_timeout_interruptible() is exactly same as setting a status of current process and calling schedule_timeout(). Removes dgap_ms_sleep(), because this function is used only when closing tty channel on dgap_tty_close(). And also removes ch_close_delay that is always set to 250 on dgap

Re: [PATCH] staging wlan-ng: Add missing a blank line after declarations

2014-09-15 Thread nick
On 14-09-15 10:26 PM, Nicholas Krause wrote: > Fixing trivial checkpatch warnings about missing line after > declarations. > > Signed-off-by: Nicholas Krause > --- > Tested by compilation only. > drivers/staging/wlan-ng/hfa384x.h | 3 +++ > 1 file changed, 3 insertions(+) > > diff --git a/dri

[PATCH] staging wlan-ng: Add missing a blank line after declarations

2014-09-15 Thread Nicholas Krause
Fixing trivial checkpatch warnings about missing line after declarations. Signed-off-by: Nicholas Krause --- Tested by compilation only. drivers/staging/wlan-ng/hfa384x.h | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/staging/wlan-ng/hfa384x.h b/drivers/staging/wlan-ng/hfa384x.h

[PATCH] staging wlan-ng: Add missing a blank line after declarations

2014-09-15 Thread Nicholas Krause
Fixing trivial checkpatch warnings about missing line after declarations. Signed-off-by: Nicholas Krause --- Tested by compilation only. drivers/staging/wlan-ng/hfa384x.h | 3 +++ 1 file changed, 3 insertions(+) diff --git a/drivers/staging/wlan-ng/hfa384x.h b/drivers/staging/wlan-ng/hfa384x.h

RE: [PATCH V2 0/5] Drivers: hv: vmbus: Eliminate calls to BUG_ON()

2014-09-15 Thread KY Srinivasan
> -Original Message- > From: Sitsofe Wheeler [mailto:sits...@gmail.com] > Sent: Friday, August 29, 2014 12:29 AM > To: KY Srinivasan > Cc: gre...@linuxfoundation.org; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; > jasow...@redhat.com; D

RE: [PATCH 00/11] staging: comedi: move comedi_fc functionality into core

2014-09-15 Thread Hartley Sweeten
On Monday, September 15, 2014 5:46 AM, Ian Abbott wrote: > The "comedi_fc" module contains a few functions for use by several > low-level comedi drivers. Since they are used by quite a few drivers, > it seems useful to migrate their functionality to the core "comedi" > module, renaming them in the

RE: [PATCH 05/11] staging: comedi: add comedi_handle_events()

2014-09-15 Thread Hartley Sweeten
On Monday, September 15, 2014 5:46 AM, Ian Abbott wrote: > The "comedi_fc" module contains a few functions useful to Comedi > drivers. Their functionality is being migrated to the core "comedi" > module and renamed to start with the prefix `comedi_`. As part of this > migration, move `cfc_handle_

RE: [PATCH 03/11] staging: comedi: add comedi_inc_scan_progress()

2014-09-15 Thread Hartley Sweeten
On Monday, September 15, 2014 5:46 AM, Ian Abbott wrote: > The "comedi_fc" module contains a few functions useful to Comedi > drivers. Their functionality is being migrated to the core "comedi" > module and renamed to start with the prefix `comedi_`. As part of this > migration, move `cfc_inc_sca

RE: [PATCH 01/11] staging: comedi: add comedi_bytes_per_scan()

2014-09-15 Thread Hartley Sweeten
On Monday, September 15, 2014 5:46 AM, Ian Abbott wrote: > The "comedi_fc" module contains a few functions useful to Comedi > drivers. Their functionality is being migrated to the core "comedi" > module and renamed to start with the prefix `comedi_`. As part of this > migration, move `cfc_bytes_p

RE: [PATCH 11/11] staging: comedi: remove comedi_fc module

2014-09-15 Thread Hartley Sweeten
On Monday, September 15, 2014 5:46 AM, Ian Abbott wrote: > All the exported functions in the "comedi_fc" module have been migrated > to the core "comedi" module and renamed, so it is now just a dummy > module. Remove it. > > Signed-off-by: Ian Abbott > --- > drivers/staging/comedi/Kconfig

Re: Staging: unisys: base drivers complete

2014-09-15 Thread Dan Carpenter
On Mon, Sep 15, 2014 at 12:14:49PM -0500, Romer, Benjamin M wrote: > > Have you actually ran the checkpatch.pl tool on this code? You still > > have a lot of cleanup to do (hint, typedefs for drivers are not > > allowed...) > > Yes, I've been using checkpatch.pl a lot, though admittedly I did not

RE: [PATCH 0/4] staging: comedi: addi_apci_3120: redo DMA buffer allocation

2014-09-15 Thread Hartley Sweeten
On Friday, September 12, 2014 4:20 AM, Ian Abbott wrote: > "addi_apci_3120" allocates more pages of DMA buffer than it uses, may > allocate half a double-buffer it does not use because it's the "wrong" > half that it managed to allocate (unlikely), and relies on virt_to_bus() > to treat generic ker

RE: [PATCH] staging: comedi: remove comedi_board()

2014-09-15 Thread Hartley Sweeten
On Friday, September 12, 2014 2:11 AM, Ian Abbott wrote: > All calls to the inline function `comedi_board()` in "comedidev.h" have > been removed, so remove the function. > > Signed-off-by: Ian Abbott > --- > drivers/staging/comedi/comedidev.h | 5 - > 1 file changed, 5 deletions(-) > > diff

Re: Staging: unisys: base drivers complete

2014-09-15 Thread Greg KH
On Mon, Sep 15, 2014 at 12:14:49PM -0500, Romer, Benjamin M wrote: > > Have you actually ran the checkpatch.pl tool on this code? You still > > have a lot of cleanup to do (hint, typedefs for drivers are not > > allowed...) > > Yes, I've been using checkpatch.pl a lot, though admittedly I did not

RE: [PATCH 0/3] staging: comedi: adl_pci9118: redo DMA buffer allocation

2014-09-15 Thread Hartley Sweeten
On Friday, September 12, 2014 2:05 AM, Ian Abbott wrote: > "adl_pci9118" allocates more pages of DMA buffer than it uses, may > allocate half a double-buffer it does not use because it's the "wrong" > half that it managed to allocate (unlikely), and relies on virt_to_bus() > to treat generic kernel

Re: Staging: unisys: base drivers complete

2014-09-15 Thread Romer, Benjamin M
> Have you actually ran the checkpatch.pl tool on this code? You still > have a lot of cleanup to do (hint, typedefs for drivers are not > allowed...) Yes, I've been using checkpatch.pl a lot, though admittedly I did not know about --strict. I'll start addressing the check issues as well as the w

Re: Staging: unisys: base drivers complete

2014-09-15 Thread Ken Cox
On 09/15/2014 11:03 AM, Dan Carpenter wrote: Which ones are the base drivers? I was referring to all the Unisys drivers currently in staging-next. The drivers that have not been submitted have dependencies on functionality that is provided by the current drivers in staging-next. There are st

Re: Staging: unisys: base drivers complete

2014-09-15 Thread Ken Cox
On 09/15/2014 11:04 AM, Greg KH wrote: On Mon, Sep 15, 2014 at 10:56:07AM -0500, Ken Cox wrote: Greg and other reviewers, Ben Romer and I believe that the Unisys drivers in staging-next are now complete. Are there any other changes that you are aware of that we need to make to these drivers?

Re: Staging: unisys: base drivers complete

2014-09-15 Thread Greg KH
On Mon, Sep 15, 2014 at 10:56:07AM -0500, Ken Cox wrote: > Greg and other reviewers, > > Ben Romer and I believe that the Unisys drivers in staging-next are now > complete. Are there any other changes that you are aware of that we need to > make to these drivers? Have you actually ran the checkp

Re: Staging: unisys: base drivers complete

2014-09-15 Thread Dan Carpenter
Which ones are the base drivers? There are still lots of checkpatch.pl warnings in drivers/unisys. Checkpatch.pl is a minimum requirement. It doesn't make sense to look at this this any harder when there are still obvious things to fix. Really it's better if you run checkpatch.pl with the --stri

Staging: unisys: base drivers complete

2014-09-15 Thread Ken Cox
Greg and other reviewers, Ben Romer and I believe that the Unisys drivers in staging-next are now complete. Are there any other changes that you are aware of that we need to make to these drivers? We have additional drivers to submit that are supported by this base set of drivers but want t

Re: [PATCH 9/9] staging: comedi: ni_usb6501: add counter subdevice

2014-09-15 Thread Ian Abbott
On 2014-09-15 13:59, Luca Ellero wrote: Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c | 12 +++- 1 file changed, 11 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c inde

Re: [PATCH 3/9] staging: comedi: ni_usb6501: fix response_size

2014-09-15 Thread Dan Carpenter
On Mon, Sep 15, 2014 at 02:59:33PM +0200, Luca Ellero wrote: > Fix response_size in ni6501_send_command (READ_PORT command) This isn't a fix, it's a cleanup. A fix is something that fixes a bug. We are sloppy about correcting newbies who are always writing checkpatch "fixes"... There is an endle

Re: [PATCH 5/9] staging: comedi: ni_usb6501: add ni6501_counter_command()

2014-09-15 Thread Ian Abbott
On 2014-09-15 13:59, Luca Ellero wrote: Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c | 110 +++ 1 file changed, 110 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c ind

[PATCH 6/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_config()

2014-09-15 Thread Luca Ellero
Add function for counter subdevice configuration. Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c | 28 +++ 1 file changed, 28 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501

[PATCH 9/9] staging: comedi: ni_usb6501: add counter subdevice

2014-09-15 Thread Luca Ellero
Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c | 12 +++- 1 file changed, 11 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c index c33d857..711d349 100644 --- a/drivers/stag

[PATCH 5/9] staging: comedi: ni_usb6501: add ni6501_counter_command()

2014-09-15 Thread Luca Ellero
Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c | 110 +++ 1 file changed, 110 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c index f55b9f8..cef93d2 100644 --- a/drivers/sta

[PATCH 4/9] staging: comedi: ni_usb6501: rename ni6501_send_command()

2014-09-15 Thread Luca Ellero
Rename ni6501_send_command to ni6501_port_command Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c i

[PATCH 1/9] staging: comedi: ni_usb6501: add counter commands

2014-09-15 Thread Luca Ellero
Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c | 29 ++- 1 file changed, 28 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c index 6a4f965..f0b8f11 100644 ---

[PATCH 7/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_read()

2014-09-15 Thread Luca Ellero
Add function for reading from counter subdevice. Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c | 17 + 1 file changed, 17 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c index 4e

[PATCH 8/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_write()

2014-09-15 Thread Luca Ellero
Add function for writing to counter subdevice. Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c | 14 ++ 1 file changed, 14 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c index 71631a7

[PATCH 0/9] comedi: ni_usb6501: add counter support

2014-09-15 Thread Luca Ellero
This series of patches add counter support for NI USB-6501. I tested it on my device and it works fine. Luca Ellero (9): staging: comedi: ni_usb6501: add counter commands staging: comedi: ni_usb6501: update comments staging: comedi: ni_usb6501: fix response_size staging: comedi: ni_usb6501

[PATCH 3/9] staging: comedi: ni_usb6501: fix response_size

2014-09-15 Thread Luca Ellero
Fix response_size in ni6501_send_command (READ_PORT command) Signed-off-by: Luca Ellero --- drivers/staging/comedi/drivers/ni_usb6501.c |3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb650

[PATCH 10/11] staging: comedi: migrate copyrights from "comedi_fc.c"

2014-09-15 Thread Ian Abbott
The "comedi_fc" module was originally written and copyrighted by Frank Mori Hess, but the functionality has been migrated into the core "comedi" module. Move the copyright notices over to the affected .c files in the core comedi module. Signed-off-by: Ian Abbott --- drivers/staging/comedi/comed

[PATCH 05/11] staging: comedi: add comedi_handle_events()

2014-09-15 Thread Ian Abbott
The "comedi_fc" module contains a few functions useful to Comedi drivers. Their functionality is being migrated to the core "comedi" module and renamed to start with the prefix `comedi_`. As part of this migration, move `cfc_handle_events()` into the core comedi module and rename it to `comedi_ha

[PATCH 04/11] staging: comedi: comedi_fc: use comedi_inc_scan_progress()

2014-09-15 Thread Ian Abbott
Since `cfc_inc_scan_progress()` is just an inline function that calls `comedi_inc_scan_progress()`, replace calls to the former to the latter in the "comedi_fc" module. This is part of the migration of functionality from the "comedi_fc" module to the core "comedi" module. Signed-off-by: Ian Abbot

[PATCH 02/11] staging: comedi: comedi_fc: use comedi_bytes_per_scan()

2014-09-15 Thread Ian Abbott
Since `cfc_bytes_per_scan()` is just an inline function that calls `comedi_bytes_per_scan()`, replace calls to the former to the latter in the "comedi_fc" module. This is part of the migration of functionality from the "comedi_fc" module to the core "comedi" module. Signed-off-by: Ian Abbott ---

[PATCH 06/11] staging: comedi: comedi_fc: cfc_write_array_to_buffer() data is const

2014-09-15 Thread Ian Abbott
The `data` pointer of `cfc_write_array_to_buffer()` ought to point to `const` data. Signed-off-by: Ian Abbott --- drivers/staging/comedi/drivers/comedi_fc.c | 2 +- drivers/staging/comedi/drivers/comedi_fc.h | 5 +++-- 2 files changed, 4 insertions(+), 3 deletions(-) diff --git a/drivers/stagin

[PATCH 09/11] staging: comedi: add comedi_read_array_from_buffer()

2014-09-15 Thread Ian Abbott
The "comedi_fc" module contains a few functions useful to Comedi drivers. Their functionality is being migrated to the core "comedi" module and renamed to start with the prefix `comedi_`. As part of this migration, move `cfc_read_array_from_buffer()` into the core comedi module and rename it to `

[PATCH 01/11] staging: comedi: add comedi_bytes_per_scan()

2014-09-15 Thread Ian Abbott
The "comedi_fc" module contains a few functions useful to Comedi drivers. Their functionality is being migrated to the core "comedi" module and renamed to start with the prefix `comedi_`. As part of this migration, move `cfc_bytes_per_scan()` into the core comedi module and rename it to `comedi_b

[PATCH 11/11] staging: comedi: remove comedi_fc module

2014-09-15 Thread Ian Abbott
All the exported functions in the "comedi_fc" module have been migrated to the core "comedi" module and renamed, so it is now just a dummy module. Remove it. Signed-off-by: Ian Abbott --- drivers/staging/comedi/Kconfig | 31 drivers/staging/comedi/drivers/Ma

[PATCH 07/11] staging: comedi: add comedi_write_array_to_buffer()

2014-09-15 Thread Ian Abbott
The "comedi_fc" module contains a few functions useful to Comedi drivers. Their functionality is being migrated to the core "comedi" module and renamed to start with the prefix `comedi_`. As part of this migration, move `cfc_write_array_to_buffer()` into the core comedi module and rename it to `c

[PATCH 08/11] staging: comedi: comedi_fc.h: use comedi_write_array_to_buffer()

2014-09-15 Thread Ian Abbott
Since `cfc_write_array_to_buffer()` is just an inline function that calls `comedi_write_array_to_buffer()`, replace calls to the former to the latter in the "comedi_fc.h" header. This is part of the migration of functionality from the "comedi_fc" module to the core "comedi" module. Signed-off-by:

[PATCH 03/11] staging: comedi: add comedi_inc_scan_progress()

2014-09-15 Thread Ian Abbott
The "comedi_fc" module contains a few functions useful to Comedi drivers. Their functionality is being migrated to the core "comedi" module and renamed to start with the prefix `comedi_`. As part of this migration, move `cfc_inc_scan_progress()` into the core comedi module and rename it to `comed

[PATCH 00/11] staging: comedi: move comedi_fc functionality into core

2014-09-15 Thread Ian Abbott
The "comedi_fc" module contains a few functions for use by several low-level comedi drivers. Since they are used by quite a few drivers, it seems useful to migrate their functionality to the core "comedi" module, renaming them in the process, while keeping the original function names in "drivers/c

[PATCH] staging: android: sw_sync: checkpatch fixes

2014-09-15 Thread Purnendu Kapadia
- no space after cast - allignment should match open parenthesis - remove unnecessary new line Signed-off-by: Purnendu Kapadia --- drivers/staging/android/sw_sync.c | 7 +++ drivers/staging/android/sw_sync.h | 2 +- 2 files changed, 4 insertions(+), 5 deletions(-) diff --git a/driv

Re: [PATCH] staging: lustre: lustre: libcfs: debug.c: Cleaning up unnecessary use of memset in conjunction with strncpy

2014-09-15 Thread Dan Carpenter
On Sun, Sep 14, 2014 at 06:03:16PM +0200, Rickard Strandqvist wrote: > Using memset before strncpy just to ensure a trailing null > character is an unnecessary double writing of a string > You really should make a function which pads and NUL terminates. I've said this before, of course, but you

[PATCH] staging: rtl8821ae: Remove space after unary operator in efuse.c

2014-09-15 Thread Fabien Malfoy
Several pointer declaration syntax have been fixed to match the coding style. Signed-off-by: Fabien Malfoy --- drivers/staging/rtl8821ae/efuse.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/rtl8821ae/efuse.c b/drivers/staging/rtl8821ae/e

[PATCH] staging: rtl8821ae: Remove space after unary operator in efuse.c

2014-09-15 Thread Fabien Malfoy
Several pointer declaration syntax have been fixed to match the coding style. Signed-off-by: Fabien Malfoy --- drivers/staging/rtl8821ae/efuse.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/staging/rtl8821ae/efuse.c b/drivers/staging/rtl8821ae/e