Re: [PATCH] staging: dgap: use schedule_timeout_interruptible() instead of dgap_ms_sleep()

2014-09-16 Thread Dan Carpenter
On Tue, Sep 16, 2014 at 12:33:33PM +0900, Daeseok Youn wrote: @@ -2297,12 +2273,12 @@ static void dgap_tty_close(struct tty_struct *tty, struct file *file) * Go to sleep to ensure RTS/DTR * have been dropped for modems to see it.

Re: [PATCH] staging: dgap: use schedule_timeout_interruptible() instead of dgap_ms_sleep()

2014-09-16 Thread DaeSeok Youn
Hi, 2014-09-16 15:31 GMT+09:00 Dan Carpenter dan.carpen...@oracle.com: On Tue, Sep 16, 2014 at 12:33:33PM +0900, Daeseok Youn wrote: @@ -2297,12 +2273,12 @@ static void dgap_tty_close(struct tty_struct *tty, struct file *file) * Go to sleep to ensure RTS/DTR

[PATCH V2] staging: dgap: use schedule_timeout_interruptible() instead of dgap_ms_sleep()

2014-09-16 Thread Daeseok Youn
Using schedule_timeout_interruptible() is exactly same as setting a status of current process and calling schedule_timeout(). Removes dgap_ms_sleep(), because this function is used only when closing tty channel on dgap_tty_close(). And also removes ch_close_delay that is always set to 250 on

Re: [PATCH 00/11] staging: comedi: move comedi_fc functionality into core

2014-09-16 Thread Ian Abbott
On 15/09/14 19:21, Hartley Sweeten wrote: On Monday, September 15, 2014 5:46 AM, Ian Abbott wrote: The comedi_fc module contains a few functions for use by several low-level comedi drivers. Since they are used by quite a few drivers, it seems useful to migrate their functionality to the core

Re: [PATCH] staging: dgap: use schedule_timeout_interruptible() instead of dgap_ms_sleep()

2014-09-16 Thread Joe Perches
On Tue, 2014-09-16 at 09:31 +0300, Dan Carpenter wrote: There is no point in calling signal_pending() if you don't care about the return value. So maybe make it __must_check? --- include/linux/sched.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/linux/sched.h

Re: [PATCH 3/9] staging: comedi: ni_usb6501: fix response_size

2014-09-16 Thread Luca Ellero
Hi Dan, Il 15/09/2014 15:16, Dan Carpenter wrote: On Mon, Sep 15, 2014 at 02:59:33PM +0200, Luca Ellero wrote: Fix response_size in ni6501_send_command (READ_PORT command) This isn't a fix, it's a cleanup. A fix is something that fixes a bug. We are sloppy about correcting newbies who are

Re: [PATCH 5/9] staging: comedi: ni_usb6501: add ni6501_counter_command()

2014-09-16 Thread Luca Ellero
Hi Ian, On 15/09/2014 15:11, Ian Abbott wrote: On 2014-09-15 13:59, Luca Ellero wrote: Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 110 +++ 1 file changed, 110 insertions(+) diff --git

[PATCH v2 7/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_read()

2014-09-16 Thread Luca Ellero
Add function for reading from counter subdevice. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 17 + 1 file changed, 17 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c

[PATCH v2 4/9] staging: comedi: ni_usb6501: rename ni6501_send_command()

2014-09-16 Thread Luca Ellero
Rename ni6501_send_command to ni6501_port_command Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c

[PATCH v2 3/9] staging: comedi: ni_usb6501: cleanup response_size

2014-09-16 Thread Luca Ellero
Cleanup response_size in ni6501_send_command (READ_PORT command). No logical/functional change is introduced by this patch. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c |3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff

[PATCH v2 1/9] staging: comedi: ni_usb6501: add counter commands

2014-09-16 Thread Luca Ellero
Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 29 ++- 1 file changed, 28 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c

[PATCH v2 5/9] staging: comedi: ni_usb6501: add ni6501_counter_command()

2014-09-16 Thread Luca Ellero
Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 110 +++ 1 file changed, 110 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c index

[PATCH v2 0/9] comedi: ni_usb6501: add counter support

2014-09-16 Thread Luca Ellero
This series of patches add counter support for NI USB-6501. I tested it on my device and it works fine. Changes for v2: - rewrite patch 3/9 changelog: replace fix with cleanup - avoid sparse warnings - add SDF_LSAMPL flag to counter subdevice Luca Ellero (9): staging: comedi: ni_usb6501: add

[PATCH v2 9/9] staging: comedi: ni_usb6501: add counter subdevice

2014-09-16 Thread Luca Ellero
Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 12 +++- 1 file changed, 11 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c b/drivers/staging/comedi/drivers/ni_usb6501.c index

[PATCH v2 8/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_write()

2014-09-16 Thread Luca Ellero
Add function for writing to counter subdevice. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 14 ++ 1 file changed, 14 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c

[PATCH v2 6/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_config()

2014-09-16 Thread Luca Ellero
Add function for counter subdevice configuration. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 28 +++ 1 file changed, 28 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c

RE: [PATCH 00/11] staging: comedi: move comedi_fc functionality into core

2014-09-16 Thread Hartley Sweeten
On Tuesday, September 16, 2014 12:44 AM, Ian Abbott wrote: On 15/09/14 19:21, Hartley Sweeten wrote: Other than I think the comedi_fc.c functions should be migrated to comedi_buf.c instead of drivers.c I have not problems with this. I think it's debatable. The only one of the three functions

Re: [PATCH] mmc: rtsx: add card power off during probe

2014-09-16 Thread Ulf Hansson
On 12 September 2014 03:39, micky_ch...@realsil.com.cn wrote: From: Roger Tseng rogera...@realtek.com Some platform have both UEFI driver and MFD/mmc driver, if entering linux while card in the slot, the card power is already on, and rtsx-mmc driver have no chance to make card power off.

[PATCH 20/22] staging: r8188eu: Replace strnicmp with strncasecmp

2014-09-16 Thread Rasmus Villemoes
The kernel used to contain two functions for length-delimited, case-insensitive string comparison, strnicmp with correct semantics and a slightly buggy strncasecmp. The latter is the POSIX name, so strnicmp was renamed to strncasecmp, and strnicmp made into a wrapper for the new strncasecmp to

[PATCH 1/1] staging: rtl8723au: fix sparse incorrect type assignment warnings

2014-09-16 Thread Kieron Browne
Use cpu_to_le16 to cast int for assignment to __le16 members Signed-off-by: Kieron Browne kieron.bro...@gmail.com --- drivers/staging/rtl8723au/os_dep/ioctl_cfg80211.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/staging/rtl8723au/os_dep/ioctl_cfg80211.c