Re: [PATCH 1/1] Drivers: scsi: storvsc: Get rid of warning messages

2014-09-17 Thread Olaf Hering
On Mon, Sep 08, KY Srinivasan wrote: -Original Message- From: Christoph Hellwig [mailto:h...@infradead.org] Sent: Thursday, September 4, 2014 10:40 PM To: KY Srinivasan Subject: Re: [PATCH 1/1] Drivers: scsi: storvsc: Get rid of warning messages Looks good to me. Olaf,

Re: [PATCH 1/1] staging: rtl8723au: fix sparse incorrect type assignment warnings

2014-09-17 Thread Dan Carpenter
On Tue, Sep 16, 2014 at 11:28:09PM +0100, Kieron Browne wrote: Use cpu_to_le16 to cast int for assignment to __le16 members cast is the wrong word. It's really doing a byte swap. It fixes a bug on big endian systems. But the patch is ok and matches how the other rtl drivers do it. regards,

re: staging: rtl8723au: tid is 4 bits, so we need a 16 bit value to hold a bitmap

2014-09-17 Thread Dan Carpenter
Hello Jes Sorensen, The patch 072fc84dce06: staging: rtl8723au: tid is 4 bits, so we need a 16 bit value to hold a bitmap from May 9, 2014, leads to the following static checker warning: drivers/staging/rtl8723au/core/rtw_xmit.c:964 rtw_make_wlanhdr() error: testing array offset

Re: [PATCH] mmc: rtsx: add card power off during probe

2014-09-17 Thread micky
On 09/17/2014 02:01 AM, Ulf Hansson wrote: On 12 September 2014 03:39, micky_ch...@realsil.com.cn wrote: From: Roger Tseng rogera...@realtek.com Some platform have both UEFI driver and MFD/mmc driver, if entering linux while card in the slot, the card power is already on, and rtsx-mmc driver

Re: [PATCH v2 7/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_read()

2014-09-17 Thread Ian Abbott
On 2014-09-16 12:40, Luca Ellero wrote: Add function for reading from counter subdevice. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 17 + 1 file changed, 17 insertions(+) diff --git

Re: [PATCH v2 8/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_write()

2014-09-17 Thread Ian Abbott
On 2014-09-16 12:40, Luca Ellero wrote: Add function for writing to counter subdevice. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 14 ++ 1 file changed, 14 insertions(+) diff --git

RE: [PATCH v2 0/9] comedi: ni_usb6501: add counter support

2014-09-17 Thread Hartley Sweeten
On Tuesday, September 16, 2014 4:40 AM, Luca Ellero wrote: This series of patches add counter support for NI USB-6501. I tested it on my device and it works fine. I have not taken a good look at this driver yet. I'll try to do it today and respond to this series. Thanks, Hartley

RE: [PATCH v2 4/9] staging: comedi: ni_usb6501: rename ni6501_send_command()

2014-09-17 Thread Hartley Sweeten
On Tuesday, September 16, 2014 4:40 AM, Luca Ellero wrote: Rename ni6501_send_command to ni6501_port_command Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c |8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git

RE: [PATCH v2 5/9] staging: comedi: ni_usb6501: add ni6501_counter_command()

2014-09-17 Thread Hartley Sweeten
On Tuesday, September 16, 2014 4:40 AM, Luca Ellero wrote: Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 110 +++ 1 file changed, 110 insertions(+) diff --git a/drivers/staging/comedi/drivers/ni_usb6501.c

RE: [PATCH v2 6/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_config()

2014-09-17 Thread Hartley Sweeten
On Tuesday, September 16, 2014 4:40 AM, Luca Ellero wrote: Add function for counter subdevice configuration. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 28 +++ 1 file changed, 28 insertions(+) diff

RE: [PATCH v2 7/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_read()

2014-09-17 Thread Hartley Sweeten
On Tuesday, September 16, 2014 4:40 AM, Luca Ellero wrote: Add function for reading from counter subdevice. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 17 + 1 file changed, 17 insertions(+) Ian already

RE: [PATCH v2 8/9] staging: comedi: ni_usb6501: add ni6501_cnt_insn_write()

2014-09-17 Thread Hartley Sweeten
On Tuesday, September 16, 2014 4:40 AM, Luca Ellero wrote: Add function for writing to counter subdevice. Signed-off-by: Luca Ellero luca.ell...@brickedbrain.com --- drivers/staging/comedi/drivers/ni_usb6501.c | 14 ++ 1 file changed, 14 insertions(+) Again, Ian addressed my

Re: [PATCH v2 1/2] mfd: rtsx: fix PM suspend for 5227

2014-09-17 Thread Lee Jones
On Fri, 12 Sep 2014, micky_ch...@realsil.com.cn wrote: From: Micky Ching micky_ch...@realsil.com.cn Fix rts5227 failed send buffer cmd after suspend, PM_CTRL3 should reset before send any buffer cmd after suspend. Otherwise, buffer cmd will failed, this will lead resume fail.

[PATCH] staging: rtl8192u: delete unused function CAM_read_entry

2014-09-17 Thread Benedict Boerger
Fix the sparse warning: symbol 'CAM_read_entry' was not declared. Should it be static? The function CAM_read_entry is not used and therefore deleted. --- drivers/staging/rtl8192u/r8192U_core.c | 28 1 file changed, 28 deletions(-) diff --git

[PATCH] Staging: gdm724x: gdm_usb: added error checking in do_tx()

2014-09-17 Thread Abel Moyo
Added error checking for alloc_tx_struct in do_tx() Signed-off-by: Abel Moyo abelmoyo...@gmail.com --- drivers/staging/gdm724x/gdm_usb.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/staging/gdm724x/gdm_usb.c b/drivers/staging/gdm724x/gdm_usb.c index 483185b..0c20554 100644

[PATCH 1/1] staging: rtl8192u: Move ieee80211_crypto_* declarations to ieee80211/ieee80211.h

2014-09-17 Thread Ragnar B. Johannsson
Move ieee80211_crypto*_init and _exit prototype declarations from r8192U_core.c to ieee80211/ieee80211.h. This fixes the following sparse warnings: drivers/staging/rtl8192u/ieee80211/ieee80211_crypt.c:203:12: warning: symbol 'ieee80211_crypto_init' was not declared. Should it be static?

Re: [PATCH] Staging: gdm724x: gdm_usb: added error checking in do_tx()

2014-09-17 Thread Dan Carpenter
On Wed, Sep 17, 2014 at 10:47:25PM +0200, Abel Moyo wrote: Added error checking for alloc_tx_struct in do_tx() Signed-off-by: Abel Moyo abelmoyo...@gmail.com --- drivers/staging/gdm724x/gdm_usb.c | 4 1 file changed, 4 insertions(+) diff --git a/drivers/staging/gdm724x/gdm_usb.c

Re: [PATCH 1/1] staging: rtl8192u: Move ieee80211_crypto_* declarations to ieee80211/ieee80211.h

2014-09-17 Thread Dan Carpenter
On Wed, Sep 17, 2014 at 09:24:03PM +, Ragnar B. Johannsson wrote: diff --git a/drivers/staging/rtl8192u/ieee80211/ieee80211.h b/drivers/staging/rtl8192u/ieee80211/ieee80211.h index bdad3a2..d56c3aac 100644 --- a/drivers/staging/rtl8192u/ieee80211/ieee80211.h +++

Re: [PATCH] staging: lustre: lustre: libcfs: debug.c: Cleaning up unnecessary use of memset in conjunction with strncpy

2014-09-17 Thread Rickard Strandqvist
2014-09-15 10:23 GMT+02:00 Dan Carpenter dan.carpen...@oracle.com: On Sun, Sep 14, 2014 at 06:03:16PM +0200, Rickard Strandqvist wrote: Using memset before strncpy just to ensure a trailing null character is an unnecessary double writing of a string You really should make a function which

Re: [PATCH 1/1] Drivers: scsi: storvsc: Get rid of warning messages

2014-09-17 Thread Christoph Hellwig
On Wed, Sep 17, 2014 at 09:33:24AM +0200, Olaf Hering wrote: Christoph, what does review of this mean? There are many hv related patches floating around. The removal of the warning in msgid 1409701396-20226-1-git-send-email-...@microsoft.com looks ok to me. Thanks, can you give me a

[PATCH] mfd: rtsx: fix PM suspend for 5227 5249

2014-09-17 Thread micky_ching
From: Micky Ching micky_ch...@realsil.com.cn Fix rts52275249 failed send buffer cmd after suspend, PM_CTRL3 should reset before send any buffer cmd after suspend. Otherwise, buffer cmd will failed, this will lead resume fail. Signed-off-by: Micky Ching micky_ch...@realsil.com.cn ---

Re: [PATCH] mfd: rtsx: fix PM suspend for 5227 5249

2014-09-17 Thread Lee Jones
On Thu, 18 Sep 2014, micky_ch...@realsil.com.cn wrote: From: Micky Ching micky_ch...@realsil.com.cn Fix rts52275249 failed send buffer cmd after suspend, PM_CTRL3 should reset before send any buffer cmd after suspend. Otherwise, buffer cmd will failed, this will lead resume fail.

Re: [PATCH] mfd: rtsx: fix PM suspend for 5227 5249

2014-09-17 Thread micky
On 09/18/2014 12:53 PM, Lee Jones wrote: On Thu, 18 Sep 2014, micky_ch...@realsil.com.cn wrote: From: Micky Ching micky_ch...@realsil.com.cn Fix rts52275249 failed send buffer cmd after suspend, PM_CTRL3 should reset before send any buffer cmd after suspend. Otherwise, buffer cmd will failed,