[PATCH v10 11/11] drm: bridge/dw_hdmi: add rockchip rk3288 support

2014-11-13 Thread Andy Yan
Rockchip RK3288 hdmi is compatible with dw_hdmi Signed-off-by: Andy Yan --- Changes in v10: - add more display mode support mpll configuration for rk3288 Changes in v9: - move some phy configuration to platform driver Changes in v8: None Changes in v7: None Changes in v6: None Changes in v5:

[PATCH v10 10/11] dt-bindings: Add documentation for rockchip dw hdmi

2014-11-13 Thread Andy Yan
Signed-off-by: Andy Yan --- Changes in v10: None Changes in v9: None Changes in v8: - Add documentation for rockchip dw hdmi Changes in v7: None Changes in v6: None Changes in v5: None Changes in v4: None Changes in v3: None Changes in v2: None .../devicetree/bindings/video/dw_hdmi-rockchip.t

[PATCH v10 09/11] drm: bridge/dw_hdmi: convert dw-hdmi to drm_bridge mode

2014-11-13 Thread Andy Yan
From: Yakir Yang keep the connector & birdge in dw_hdmi.c, handle encoder in dw_hdmi-imx.c, as most of the encoder operation are platform specific such as crtc select and panel format set Signed-off-by: Andy Yan Signed-off-by: Yakir Yang --- Changes in v10: None Changes in v9: None Changes i

[PATCH v10 08/11] drm: bridge/dw_hdmi: add support for multi byte register width access

2014-11-13 Thread Andy Yan
On rockchip rk3288, only word(32-bit) accesses are permitted for hdmi registers. Byte width accesses (writeb, readb) generate an imprecise external abort. Signed-off-by: Andy Yan --- Changes in v10: None Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6: - move some mod

[PATCH v10 06/11] drm: bridge/dw_hdmi: clear i2cmphy_stat0 reg in hdmi_phy_wait_i2c_done

2014-11-13 Thread Andy Yan
HDMI_IH_I2CMPHY_STAT0 is a clear on write register, which indicates i2cm operation status(i2c transfer done or error), every hdmi phy register configuration must check this register to make sure the configuration has complete. But the indication bit should be cleared after check, otherwise the corr

[PATCH v10 07/11] dt-bindings: add document for dw_hdmi

2014-11-13 Thread Andy Yan
Signed-off-by: Andy Yan --- Changes in v10: None Changes in v9: None Changes in v8: - correct some spelling mistake - modify ddc-i2c-bus and interrupt description Changes in v7: None Changes in v6: None Changes in v5: None Changes in v4: None Changes in v3: None Changes in v2: None .../device

[PATCH v10 05/11] drm: bridge/dw_hdmi:split some phy configuration to platform driver

2014-11-13 Thread Andy Yan
hdmi phy clock symbol and transmission termination value can adjust platform specific to get the best SI also add mode_valid interface for some platform may not support all the display mode Signed-off-by: Andy Yan --- Changes in v10: - split generic dw_hdmi.c improvements from patch#11 (add rk

[PATCH v10 04/11] staging: imx-drm: imx-hdmi: move imx-hdmi to bridge/dw_hdmi

2014-11-13 Thread Andy Yan
the original imx hdmi driver is under staging/imx-drm, which depends on imx-drm, so move the imx hdmi driver out to drm/bridge and rename imx-hdmi to dw_hdmi Signed-off-by: Andy Yan --- Changes in v10: None Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6: None Changes

[PATCH v10 03/11] staging: imx-drm: imx-hdmi: split imx soc specific code from imx-hdmi

2014-11-13 Thread Andy Yan
IMX6 and Rockchip RK3288 and JZ4780 (Ingenic Xburst/MIPS) use the interface compatible Designware HDMI IP, but they also have some lightly differences, such as phy pll configuration, register width, 4K support, clk useage, and the crtc mux configuration is also platform specific. To reuse the imx

[PATCH v10 02/11] staging: imx-drm: imx-hdmi: return defer if can't get ddc i2c adapter

2014-11-13 Thread Andy Yan
drm driver may probe before the i2c bus, so the driver should defer probing until it is available Signed-off-by: Andy Yan --- Changes in v10: None Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6: None Changes in v5: None Changes in v4: - defer probe ddc i2c adapter Ch

[PATCH v10 01/11] staging: imx-drm: imx-hdmi: make checkpatch happy

2014-11-13 Thread Andy Yan
CHECK: Alignment should match open parenthesis + if ((hdmi->vic == 10) || (hdmi->vic == 11) || + (hdmi->vic == 12) || (hdmi->vic == 13) || CHECK: braces {} should be used on all arms of this statement + if (hdmi->hdmi_data.video_mode.mdvi) [...] + else { [...] Sign

[PATCH v10 0/11] dw-hdmi: convert imx hdmi to bridge/dw_hdmi

2014-11-13 Thread Andy Yan
We found Freescale imx6 and Rockchip rk3288 and Ingenic JZ4780 (Xburst/MIPS) use the interface compatible Designware HDMI IP, but they also have some lightly differences, such as phy pll configuration, register width(imx hdmi register is one byte, but rk3288 is 4 bytes width and can only be access

Re: Why does ion_cma_allocate need GFP_HIGHUSER | __GFP_ZERO flags?

2014-11-13 Thread Gioh Kim
2014-11-14 오전 10:24에 Laura Abbott 이(가) 쓴 글: > On 11/12/2014 11:18 PM, Gioh Kim wrote: >> Hi, >> >> I'm wondering why dma_alloc_coherent needs GFP_HIGHUSER | __GFP_ZERO flags >> in ion_cma_allocate(). >> >> I think dma_alloc_coherent can go to __dma_alloc if the system has CMA area. >> If __GFP_W

Re: Why does ion_cma_allocate need GFP_HIGHUSER | __GFP_ZERO flags?

2014-11-13 Thread Laura Abbott
On 11/12/2014 11:18 PM, Gioh Kim wrote: > Hi, > > I'm wondering why dma_alloc_coherent needs GFP_HIGHUSER | __GFP_ZERO flags in > ion_cma_allocate(). > > I think dma_alloc_coherent can go to __dma_alloc if the system has CMA area. > If __GFP_WAIT flag is set, it allocates memory from atomic pool

Re: [PATCH 05/56] fs/lustre: support compiling out splice

2014-11-13 Thread Greg Kroah-Hartman
On Thu, Nov 13, 2014 at 10:22:42PM +0100, Pieter Smith wrote: > Compile out splice support from lustre file-system when the splice-family of > syscalls is not supported by the system (i.e. CONFIG_SYSCALL_SPLICE is > undefined). > > Signed-off-by: Pieter Smith > --- > drivers/staging/lustre/lustr

[PATCH 05/56] fs/lustre: support compiling out splice

2014-11-13 Thread Pieter Smith
Compile out splice support from lustre file-system when the splice-family of syscalls is not supported by the system (i.e. CONFIG_SYSCALL_SPLICE is undefined). Signed-off-by: Pieter Smith --- drivers/staging/lustre/lustre/llite/file.c | 10 +++--- drivers/staging/lustre/lustre/llit

Re: [RFC PATCH 00/16] Replace smp_read_barrier_depends() with lockless_derefrence()

2014-11-13 Thread Paul E. McKenney
On Thu, Nov 13, 2014 at 02:24:06PM -0500, Pranith Kumar wrote: > Recently lockless_dereference() was added which can be used in place of > hard-coding smp_read_barrier_depends(). > > http://lkml.iu.edu/hypermail/linux/kernel/1410.3/04561.html > > The following series tries to do this. > > There

[PATCH 07/16] hyperv: Replace smp_read_barrier_depends() with lockless_dereference()

2014-11-13 Thread Pranith Kumar
Recently lockless_dereference() was added which can be used in place of hard-coding smp_read_barrier_depends(). The following PATCH makes the change. Signed-off-by: Pranith Kumar --- include/linux/hyperv.h | 9 - 1 file changed, 4 insertions(+), 5 deletions(-) diff --git a/include/linux

[RFC PATCH 00/16] Replace smp_read_barrier_depends() with lockless_derefrence()

2014-11-13 Thread Pranith Kumar
Recently lockless_dereference() was added which can be used in place of hard-coding smp_read_barrier_depends(). http://lkml.iu.edu/hypermail/linux/kernel/1410.3/04561.html The following series tries to do this. There are still some hard-coded locations which I was not sure how to replace with.

[PATCH v2 3/4] staging: comedi: das6402: read analog input samples in interrupt handler

2014-11-13 Thread H Hartley Sweeten
Currently the interrupt handler just clears the interrupt. Add the code necessary to read the analog input samples when running an async command. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/das6402.c | 42 +

[PATCH v2 0/4] staging: comedi: das6402: add basic AI async command support

2014-11-13 Thread H Hartley Sweeten
This series adds support for basic AI async commands. v2: fix a debug message in PATCH 1/4 pointed out by Ian Abbott. H Hartley Sweeten (4): staging: comedi: das6402: add basic (*do_cmdtest) for AI async commands staging: comedi: das6402: introduce das6402_ai_set_mode() staging: comedi: das

[PATCH v2 2/4] staging: comedi: das6402: introduce das6402_ai_set_mode()

2014-11-13 Thread H Hartley Sweeten
Introduce a helper function to set the analog input acquisition mode. This will be needed when the (*do_cmd) function is completed to support async commands. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/das6402.c | 31 ++

[PATCH v2 1/4] staging: comedi: das6402: add basic (*do_cmdtest) for AI async commands

2014-11-13 Thread H Hartley Sweeten
Currently the async command support in this driver consists of just the stubbed in functions. Flesh out the (*do_cmdtest) function for basic support of timed analog input acquisitions. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/d

[PATCH v2 4/4] staging: comedi: das6402: add (*do_cmd) for AI async commands

2014-11-13 Thread H Hartley Sweeten
Flesh out the (*do_cmd) function to support timed analog input acquisitions. Signed-off-by: H Hartley Sweeten Reviewed-by: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/das6402.c | 20 +++- 1 file changed, 19 insertions(+), 1 deletion(-) diff --git a/dri

[PATCH 11/11] staging: unisys: small bug parser.c

2014-11-13 Thread Jeffrey Brown
Fixed small bug in parser.c by removing "cleanups:" in parser_init _guts struct. Replaced it with proper error handling code and removed the instances of rc = NULL in the code. rc = NULL is redudant Signed-off-by: Jeffrey Brown --- drivers/staging/unisys/visorchipset/parser.c | 46 ++

[PATCH] staging: unisys: get rid of channel stub

2014-11-13 Thread Benjamin Romer
The functions in channels/* aren't used in a lot of places. In fact, the functions in channel.c can be moved to uislib/uisqueue.c, and the rest of the files in channels can be eliminated. This patch deletes the channels directory and files, removes it from all Kconfigs that referenced them, remove

[PATCH] staging: unisys: fix line spacing in visorchipset_umode.h

2014-11-13 Thread Benjamin Romer
Just get rid of the extra blank lines in this file. Signed-off-by: Benjamin Romer --- drivers/staging/unisys/visorchipset/visorchipset_umode.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/unisys/visorchipset/visorchipset_umode.h b/drivers/staging/unisys/visorchipset/viso

[PATCH] staging: unisys: fix line spacing in globals.h

2014-11-13 Thread Benjamin Romer
Get rid of the extra blank lines in globals.h. Signed-off-by: Benjamin Romer --- drivers/staging/unisys/visorchipset/globals.h | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/unisys/visorchipset/globals.h b/drivers/staging/unisys/visorchipset/globals.h index 0fe1459..a1d35d

[PATCH] staging: unisys: remove testing.h

2014-11-13 Thread Benjamin Romer
Nobody is using this file so remove it and the reference to it in visorchipset_main.c. Signed-off-by: Benjamin Romer --- drivers/staging/unisys/visorchipset/testing.h | 43 -- .../unisys/visorchipset/visorchipset_main.c| 1 - 2 files changed, 44 deletions(-) de

Re: [PATCH v9 9/9] drm: bridge/dw_hdmi: add rockchip rk3288 support

2014-11-13 Thread Andy Yan
Hi ZubairLK: thanks for your review. On 2014年11月13日 21:09, Zubair Lutfullah Kakakhel wrote: On 13/11/14 12:57, Andy Yan wrote: rk3288 hdmi is compatible with Designware hdmi this patch is depend on patch by Mark Yao Add drm driver for Rockchip Socs see https://lkml.org/lkml/2014/10/8/201 S

Re: [PATCH v9 9/9] drm: bridge/dw_hdmi: add rockchip rk3288 support

2014-11-13 Thread Zubair Lutfullah Kakakhel
On 13/11/14 12:57, Andy Yan wrote: > rk3288 hdmi is compatible with Designware hdmi > > this patch is depend on patch by Mark Yao Add drm > driver for Rockchip Socs > > see https://lkml.org/lkml/2014/10/8/201 > > Signed-off-by: Andy Yan > Signed-off-by: Yakir Yang > > --- > > Changes in v9

[PATCH v9 9/9] drm: bridge/dw_hdmi: add rockchip rk3288 support

2014-11-13 Thread Andy Yan
rk3288 hdmi is compatible with Designware hdmi this patch is depend on patch by Mark Yao Add drm driver for Rockchip Socs see https://lkml.org/lkml/2014/10/8/201 Signed-off-by: Andy Yan Signed-off-by: Yakir Yang --- Changes in v9: - move some phy configuration to platform driver Changes in

[PATCH v9 8/9] dt-bindings: Add documentation for rockchip dw hdmi

2014-11-13 Thread Andy Yan
Signed-off-by: Andy Yan --- Changes in v9: None Changes in v8: - Add documentation for rockchip dw hdmi Changes in v7: None Changes in v6: None Changes in v5: None Changes in v4: None Changes in v3: None Changes in v2: None .../devicetree/bindings/video/dw_hdmi-rockchip.txt | 43 +

[PATCH v9 7/9] drm: bridge/dw_hdmi: convert dw-hdmi to drm_bridge mode

2014-11-13 Thread Andy Yan
From: Yakir Yang keep the connector & birdge in dw_hdmi.c, handle encoder in dw_hdmi-imx.c, as most of the encoder operation are platform specific such as crtc select and panel format set Signed-off-by: Andy Yan Signed-off-by: Yakir Yang --- Changes in v9: None Changes in v8: None Changes in

[PATCH v9 6/9] drm: bridge/dw_hdmi: add support for multi byte register width access

2014-11-13 Thread Andy Yan
On rockchip rk3288, only word(32-bit) accesses are permitted for hdmi registers. Byte width accesses (writeb, readb) generate an imprecise external abort. Signed-off-by: Andy Yan --- Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6: - move some modification to patch#6

[PATCH v9 3/9] staging: imx-drm: imx-hdmi: split imx soc specific code from imx-hdmi

2014-11-13 Thread Andy Yan
IMX6 and Rockchip RK3288 and JZ4780 (Ingenic Xburst/MIPS) use the interface compatible Designware HDMI IP, but they also have some lightly differences, such as phy pll configuration, register width, 4K support, clk useage, and the crtc mux configuration is also platform specific. To reuse the imx

[PATCH v9 4/9] staging: imx-drm: imx-hdmi: move imx-hdmi to bridge/dw_hdmi

2014-11-13 Thread Andy Yan
the original imx hdmi driver is under staging/imx-drm, which depends on imx-drm, so move the imx hdmi driver out to drm/bridge and rename imx-hdmi to dw_hdmi Signed-off-by: Andy Yan --- Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6: None Changes in v5: None Changes i

[PATCH v9 5/9] dt-bindings: add document for dw_hdmi

2014-11-13 Thread Andy Yan
Signed-off-by: Andy Yan --- Changes in v9: None Changes in v8: - correct some spelling mistake - modify ddc-i2c-bus and interrupt description Changes in v7: None Changes in v6: None Changes in v5: None Changes in v4: None Changes in v3: None Changes in v2: None .../devicetree/bindings/drm/bri

[PATCH v9 2/9] staging: imx-drm: imx-hdmi: return defer if can't get ddc i2c adapter

2014-11-13 Thread Andy Yan
drm driver may probe before the i2c bus, so the driver should defer probing until it is available Signed-off-by: Andy Yan --- Changes in v9: None Changes in v8: None Changes in v7: None Changes in v6: None Changes in v5: None Changes in v4: - defer probe ddc i2c adapter Changes in v3: None Cha

[PATCH v9 1/9] staging: imx-drm: imx-hdmi: make checkpatch happy

2014-11-13 Thread Andy Yan
CHECK: Alignment should match open parenthesis + if ((hdmi->vic == 10) || (hdmi->vic == 11) || + (hdmi->vic == 12) || (hdmi->vic == 13) || CHECK: braces {} should be used on all arms of this statement + if (hdmi->hdmi_data.video_mode.mdvi) [...] + else { [...] Sign

[PATCH v9 0/9] dw-hdmi: convert imx hdmi to bridge/dw_hdmi

2014-11-13 Thread Andy Yan
We found Freescale imx6 and Rockchip rk3288 and Ingenic JZ4780 (Xburst/MIPS) use the interface compatible Designware HDMI IP, but they also have some lightly differences, such as phy pll configuration, register width(imx hdmi register is one byte, but rk3288 is 4 bytes width and can only be access

Re: [PATCH 12/30] staging: comedi: dmm32at: use 8255 module for Digital I/O subdevice

2014-11-13 Thread Ian Abbott
On 12/11/14 16:46, Hartley Sweeten wrote: OK, so no change needed. Side-note... Currently the board reset also probes the board to try and "verify" that the board is actually a dmm32at. Do you think this is actually necessary? Not strictly necessary, but may help if the user configures it inc

Re: [PATCH 0/4] staging: comedi: das6402: add basic AI async command support

2014-11-13 Thread Ian Abbott
On 12/11/14 23:00, H Hartley Sweeten wrote: This driver was _really_ broken and had to be rewritten. During that rewrite the async command support was stubbed in but not completed. This series adds support for basic AI async commands. H Hartley Sweeten (4): staging: comedi: das6402: add basi

Re: [PATCH 1/4] staging: comedi: das6402: add basic (*do_cmdtest) for AI async commands

2014-11-13 Thread Ian Abbott
On 12/11/14 23:00, H Hartley Sweeten wrote: Currently the async command support in this driver consists of just the stubbed in functions. Flesh out the (*do_cmdtest) function for basic support of timed analog input acquisitions. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-H

Re: [PATCH v2 2/2] staging: rtl8188eu: Better memory clean-up in efuse_phymap_to_logical()

2014-11-13 Thread SF Markus Elfring
> You are not using the most recent version of the code. The issue has > already been fixed. Thanks for your reminder. https://git.kernel.org/cgit/linux/kernel/git/next/linux-next.git/commit/drivers/staging/rtl8188eu/core/rtw_efuse.c?id=3cfab18ce55282a85e2c7e5db15c5daf065efdb4 Regards, Markus _

Re: [PATCH v2 2/2] staging: rtl8188eu: Better memory clean-up in efuse_phymap_to_logical()

2014-11-13 Thread SF Markus Elfring
+ goto cleanup1; >>> >>> 1) Don't use GW-BASIC label names. Label names should reflect what the >>> label does such as free_fuse_word or free_fuse_tabel. >>> >>> 2) Don't use do-nothing labels. Just return directly. >> >> Does the document "CodingStyle" need any extensions for speci

Re: [PATCH v2 1/2] staging: rtl8188eu: Deletion of unnecessary checks before three function calls

2014-11-13 Thread Julia Lawall
On Wed, 12 Nov 2014, SF Markus Elfring wrote: > From: Markus Elfring > Date: Wed, 12 Nov 2014 20:25:49 +0100 > > The functions kfree(), rtw_free_netdev() and vfree() test whether their > argument is NULL and then return immediately. Thus the test around the call > is not needed. > > This issue

Re: [PATCH v2 2/2] staging: rtl8188eu: Better memory clean-up in efuse_phymap_to_logical()

2014-11-13 Thread Julia Lawall
> diff --git a/drivers/staging/rtl8188eu/core/rtw_efuse.c > b/drivers/staging/rtl8188eu/core/rtw_efuse.c > index 697876b..359f169 100644 > --- a/drivers/staging/rtl8188eu/core/rtw_efuse.c > +++ b/drivers/staging/rtl8188eu/core/rtw_efuse.c [...] > -exit: > +cleanup2: > + kfree(eFuseWord); > + >