[PATCH] Staging: media: lirc: lirc_serial: replaced printk with pr_debug

2014-11-21 Thread Abel Moyo
Replaced printk with pr_debug in dprintk Signed-off-by: Abel Moyo abelmoyo...@gmail.com --- drivers/staging/media/lirc/lirc_serial.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/media/lirc/lirc_serial.c b/drivers/staging/media/lirc/lirc_serial.c index

Re: [PATCH 01/19] staging: comedi: drivers: have core hook up default (*insn_read) for readback

2014-11-21 Thread Ian Abbott
On 20/11/14 22:07, H Hartley Sweeten wrote: Most of the comedi drivers that provide readback for write only subdevices now use the comedi core comedi_alloc_subdev_readback() helper to allocate the subdevice 'reaback' member instead of using some member in their private data. These drivers also

Re: [PATCH 00/19] staging: comedi: more comedi_subdevice 'readback' cleanup

2014-11-21 Thread Ian Abbott
On 20/11/14 22:07, H Hartley Sweeten wrote: Most of the comedi drivers that use the comedi_subdevice 'readback' use the core provided (*insn_read) function, comedi_readback_insn_read(). Modify comedi_alloc_subdev_readback() to automatically default the subdevice (*insn_read) to this function

Re: [PATCH 00/19] staging: comedi: adv_pci1724: cleanup driver

2014-11-21 Thread Ian Abbott
On 20/11/14 22:10, H Hartley Sweeten wrote: Following is the big cleanup for the adv_pci1724 driver. H Hartley Sweeten (19): staging: comedi: adv_pci1724: use subdevice readback for 'ao_value' staging: comedi: adv_pci1724: use subdevice readback for 'offset_value' staging: comedi:

[PATCH v2 0/9] Replace smp_read_barrier_depends() with lockless_derefrence()

2014-11-21 Thread Pranith Kumar
Recently lockless_dereference() was added which can be used in place of hard-coding smp_read_barrier_depends(). http://lkml.iu.edu/hypermail/linux/kernel/1410.3/04561.html The following series tries to do this. There are still some hard-coded locations which I was not sure how to replace with.

[PATCH v2 4/9] hyperv: Replace smp_read_barrier_depends() with lockless_dereference()

2014-11-21 Thread Pranith Kumar
Recently lockless_dereference() was added which can be used in place of hard-coding smp_read_barrier_depends(). The following PATCH makes the change. Signed-off-by: Pranith Kumar bobby.pr...@gmail.com --- include/linux/hyperv.h | 9 - 1 file changed, 4 insertions(+), 5 deletions(-) diff

RE: [PATCH 01/19] staging: comedi: drivers: have core hook up default (*insn_read) for readback

2014-11-21 Thread Hartley Sweeten
On Friday, November 21, 2014 3:59 AM, Ian Abbott wrote: On 20/11/14 22:07, H Hartley Sweeten wrote: Most of the comedi drivers that provide readback for write only subdevices now use the comedi core comedi_alloc_subdev_readback() helper to allocate the subdevice 'reaback' member instead of

[PATCH v2 01/19] staging: comedi: drivers: have core hook up default (*insn_read) for readback

2014-11-21 Thread H Hartley Sweeten
Most of the comedi drivers that provide readback for write only subdevices now use the comedi core comedi_alloc_subdev_readback() helper to allocate the subdevice 'reaback' member instead of using some member in their private data. These drivers also hook up the (*insn_read) callback to the

Re: [PATCH v2 01/19] staging: comedi: drivers: have core hook up default (*insn_read) for readback

2014-11-21 Thread Ian Abbott
On 21/11/2014 17:19, H Hartley Sweeten wrote: Most of the comedi drivers that provide readback for write only subdevices now use the comedi core comedi_alloc_subdev_readback() helper to allocate the subdevice 'reaback' member instead of using some member in their private data. These drivers

RE: [PATCH] hv: hv_fcopy: drop the obsolete message on transfer failure

2014-11-21 Thread KY Srinivasan
-Original Message- From: Dexuan Cui Sent: Thursday, November 20, 2014 6:41 PM To: KY Srinivasan; gre...@linuxfoundation.org; linux- ker...@vger.kernel.org; driverdev-devel@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; jasow...@redhat.com Cc: Haiyang Zhang; Vitaly

Re: [PATCH 1/1] net: Hyper-V: Deletion of an unnecessary check before the function call vfree

2014-11-21 Thread David Miller
From: SF Markus Elfring elfr...@users.sourceforge.net Date: Thu, 20 Nov 2014 15:25:27 +0100 From: Markus Elfring elfr...@users.sourceforge.net Date: Thu, 20 Nov 2014 15:15:21 +0100 The vfree() function performs also input parameter validation. Thus the test around the call is not needed.

[PATCH 05/11] staging: comedi: adv_pci1723: use comedi_subdevice readback for 'ao_data'

2014-11-21 Thread H Hartley Sweeten
Use the comedi_subdevice 'readback' member and the core provided (*insn_read) to handle the readback of the write-only analog output subdevice. Remove the then unused 'ao_data' member from the private data. The private data is now unnecessary. Remove it and the allocation. For aesthetics, rename

[PATCH 01/11] staging: comedi: adv_pci1723: tidy up register map

2014-11-21 Thread H Hartley Sweeten
For aesthetics, rename the defines used for the register map offsets and remove the unnecessary comments. Add the bit defines for the registers. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org ---

[PATCH 07/11] staging: comedi: adv_pci1723: tidy up DIO io_bits initialization

2014-11-21 Thread H Hartley Sweeten
Tidy up the code that determines the initial io_bits (direction) of the digital I/O subdevice and remove the magic numbers. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org ---

[PATCH 11/11] staging: comedi: adv_pci1723: remove comedi_device 'write_subdev' init

2014-11-21 Thread H Hartley Sweeten
The comedi_device 'write_subdev' should only be initialized if the subdevice supports async commands. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/adv_pci1723.c

[PATCH 04/11] staging: comedi: adv_pci1723: absorb pci1723_reset()

2014-11-21 Thread H Hartley Sweeten
This function is only called by the (*auto_attach) to reset all the analog output channels. For aesthetics, absorb the function. Fix the range programming for each channel. According to the users manual the range strobe register needs to be written after setting the DAC range control register in

[PATCH 03/11] staging: comedi: adv_pci1723: remove board reset during (*detach)

2014-11-21 Thread H Hartley Sweeten
The pci1723_reset() function simply resets all the analog output channels to 0V and a +/-10V range. This really isn't necessary when detaching the driver. Remove the board reset and just use comedi_pci_detach() directly for the (*detach). Signed-off-by: H Hartley Sweeten

[PATCH 09/11] staging: comedi: adv_pci1723: update the MODULE_DESCRIPTION

2014-11-21 Thread H Hartley Sweeten
Update the MODULE_DESCRIPTION to something more useful than the generic Comedi low-level driver. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/adv_pci1723.c | 2

[PATCH 00/11] staging: comedi: adv_pci1723: cleanup driver

2014-11-21 Thread H Hartley Sweeten
Following is the big cleanup for the adv_pci1723 driver. H Hartley Sweeten (11): staging: comedi: adv_pci1723: tidy up register map staging: comedi: adv_pci1723: remove private data 'da_range' staging: comedi: adv_pci1723: remove board reset during (*detach) staging: comedi: adv_pci1723:

[PATCH 08/11] staging: comedi: adv_pci1723: remove subdevice 'len_chanlist' initialization

2014-11-21 Thread H Hartley Sweeten
The subdevice 'len_chanlist' is only used by subdevices that support async commands. Remove the unnecessary initializations in this driver. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org ---

[PATCH 10/11] staging: comedi: adv_pci1723: tidy up multi-line comments

2014-11-21 Thread H Hartley Sweeten
Tidy up the multi-line comments to follow the CodingStyle. Signed-off-by: H Hartley Sweeten hswee...@visionengravers.com Cc: Ian Abbott abbo...@mev.co.uk Cc: Greg Kroah-Hartman gre...@linuxfoundation.org --- drivers/staging/comedi/drivers/adv_pci1723.c | 79 +--- 1 file

[PATCH] Staging:skein: Fix trailing whitespace error

2014-11-21 Thread Anjana Sasindran
This patch fixes the checkpatch.pl error: ERROR: trailing whitespace Signed-off-by: Anjana Sasindran anjanasasindran...@gmail.com --- drivers/staging/skein/skein_generic.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/skein/skein_generic.c

[PATCH] Drivers:Staging:rtl8188eu:hal:usb_halinit.c: Added blank lines after declarations

2014-11-21 Thread Anjana Sasindran
This patch fixes the five checkpatch.pl warnings: WARNING:Missing a blank line after declaration Signed-off-by: Anjana Sasindran anjanasasindran...@gmail.com --- drivers/staging/rtl8188eu/hal/usb_halinit.c | 6 ++ 1 file changed, 6 insertions(+) diff --git

[PATCH] Drivers:Staging:rtl8188eu:hal:usb_halinit.c: Added blank lines after declarations

2014-11-21 Thread Anjana Sasindran
This patch fixes the five checkpatch.pl warnings: WARNING:Missing a blank line after declaration Signed-off-by: Anjana Sasindran anjanasasindran...@gmail.com --- drivers/staging/rtl8188eu/hal/usb_halinit.c | 6 ++ 1 file changed, 6 insertions(+) diff --git

Re: [PATCH] Staging:skein: Fix trailing whitespace error

2014-11-21 Thread Sudip Mukherjee
On Sat, Nov 22, 2014 at 11:34:29AM +0530, Anjana Sasindran wrote: This patch fixes the checkpatch.pl error: this patch is not applying to next-20141121. ERROR: trailing whitespace but your patch is adding a blank line in the code ? thanks sudip Signed-off-by: Anjana Sasindran

[PATCH] drivers:staging:skein:skein_generic.c: Fixed a whitespace error

2014-11-21 Thread Anjana Sasindran
This patch fixes the checkpatch.pl error: ERROR: trailing whitespace Signed-off-by: Anjana Sasindran anjanasasindran...@gmail.com --- drivers/staging/skein/skein_generic.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/staging/skein/skein_generic.c