Re: [PATCH V5 1/1] hv_netvsc: Use the xmit_more skb flag to optimize signaling the host

2015-05-10 Thread Joe Perches
On Sun, 2015-05-10 at 21:08 -0700, K. Y. Srinivasan wrote: > Based on the information given to this driver (via the xmit_more skb flag), > we can defer signaling the host if more packets are on the way. This will help > make the host more efficient since it can potentially process a larger batch >

[PATCH v3 2/2] staging: MAINTAINERS: add maintainer for wilc1000 device

2015-05-10 Thread Johnny Kim
Add myself as maintainer for atmel wilc1000 Signed-off-by: Johnny Kim Signed-off-by: Rachel Kim Signed-off-by: Dean Lee Signed-off-by: Chris Park Acked-by: Nicolas Ferre --- Changes in v3: - fix the permissions. - fix the folder tree. - forget to add the mailing-list during the previous sendi

[PATCH V4] staging: sm750: Fix lynxfb_ops_imageblit() if image->depth != 1

2015-05-10 Thread Huacai Chen
If image->depth != 1, lynxfb_ops_imageblit() should fallback to call cfb_imageblit(), not return directly. Otherwise it can't display the boot logo. Cc: Teddy Wang Acked-by: Sudip Mukherjee Signed-off-by: Huacai Chen --- V2: Coding style ajustment. V3: Add TODO comments. V4: Rebase on latest

[PATCH V5 1/1] hv_netvsc: Use the xmit_more skb flag to optimize signaling the host

2015-05-10 Thread K. Y. Srinivasan
Based on the information given to this driver (via the xmit_more skb flag), we can defer signaling the host if more packets are on the way. This will help make the host more efficient since it can potentially process a larger batch of packets. Implement this optimization. Signed-off-by: K. Y. Srin

RE: [PATCH V4 net-next 1/1] hv_netvsc: Use the xmit_more skb flag to optimize signaling the host

2015-05-10 Thread KY Srinivasan
> -Original Message- > From: David Miller [mailto:da...@davemloft.net] > Sent: Sunday, May 10, 2015 2:51 PM > To: KY Srinivasan > Cc: net...@vger.kernel.org; linux-ker...@vger.kernel.org; > de...@linuxdriverproject.org; o...@aepfle.de; a...@canonical.com; > jasow...@redhat.com > Subject:

Re: [PATCH V4 net-next 1/1] hv_netvsc: Use the xmit_more skb flag to optimize signaling the host

2015-05-10 Thread David Miller
From: "K. Y. Srinivasan" Date: Wed, 6 May 2015 15:29:05 -0700 > - ret = vmbus_sendpacket_pagebuffer(out_channel, > - pgbuf, > - packet->page_buf_cnt, > -

Re: [PATCH] staging: unisys: Disable driver for UML

2015-05-10 Thread Richard Weinberger
Am 10.05.2015 um 15:02 schrieb Greg KH: > On Mon, May 04, 2015 at 09:02:10PM +0200, Richard Weinberger wrote: >> UML has no io memory nor cpuid. >> Let's disable this driver for UML. > > Doesn't apply to my tree :( I'm sorry Greg, looks like my -next tree needs updating. Will resend soon. Thanks

Re: [PATCH v2 2/7] staging: fsl_-mc: add device binding path 'driver_override'

2015-05-10 Thread Greg KH
On Wed, May 06, 2015 at 04:28:23PM -0500, J. German Rivera wrote: > From: Bharat Bhushan > > This patch is required for vfio-fsl-mc meta driver to successfully bind > layerscape container devices for device passthrough. This patch adds > a mechanism to allow a layerscape device to specify a drive

Re: [PATCH v3 03/33] staging: rtl8192e: Mark unaligned memcpy()

2015-05-10 Thread Greg KH
On Sat, May 09, 2015 at 11:18:51PM +0200, Mateusz Kulikowski wrote: > Comment unaligned memcpy() that trigger PREFER_ETHER_ADDR_COPY > checkpatch.pl warning. > It will prevent accidential "Fix" to ether_addr_copy(). What do you mean by this? Why will the comment remove the issue? ___

Re: [PATCH V3 RESEND] staging: sm750: Fix lynxfb_ops_imageblit() if image->depth != 1

2015-05-10 Thread Greg Kroah-Hartman
On Fri, May 08, 2015 at 05:04:28PM +0800, Huacai Chen wrote: > If image->depth != 1, lynxfb_ops_imageblit() should fallback to call > cfb_imageblit(), not return directly. Otherwise it can't display the > boot logo. > > Cc: Teddy Wang > Acked-by: Sudip Mukherjee > Signed-off-by: Huacai Chen > -

Re: [PATCH v3 02/33] staging: rtl8192e: Fix PREFER_ETHER_ADDR_COPY warnings

2015-05-10 Thread Greg KH
On Sat, May 09, 2015 at 11:18:50PM +0200, Mateusz Kulikowski wrote: > Replace memcpy() with ether_addr_copy() where possible to make > checkpatch.pl happy. I need proof that this is ok to do, please provide that in the changelog entry. thanks, greg k-h __

Re: [PATCH v2 1/7] staging: fsl-mc: MC bus IRQ support

2015-05-10 Thread Greg KH
On Thu, May 07, 2015 at 11:01:19PM +0300, Dan Carpenter wrote: > On Thu, May 07, 2015 at 09:51:35AM -0500, German Rivera wrote: > > I'll remove the nested #ifdef. However, as I explained before, these > > #ifdefs are needed to be able to make the code compile without the > > GIC-ITS support in plac

Re: [PATCH v4] staging: sm750fb: use arch_phys_wc_add() and ioremap_wc()

2015-05-10 Thread Greg KH
On Mon, May 04, 2015 at 05:15:51PM -0700, Luis R. Rodriguez wrote: > From: "Luis R. Rodriguez" > > The same area used for ioremap() is used for the MTRR area. > Convert the driver from using the x86 specific MTRR code to > the architecture agnostic arch_phys_wc_add(). arch_phys_wc_add() > will av

Re: [PATCH v3 1/2] staging: sm750fb: cleanup white space

2015-05-10 Thread Greg KH
On Tue, May 05, 2015 at 11:07:43PM -0400, Charles Rose wrote: > This patch fixes "space prohibited" errors reported by checkpatch.pl. > > Signed-off-by: Charles Rose > --- > drivers/staging/sm750fb/ddk750_chip.c | 12 ++-- > drivers/staging/sm750fb/ddk750_power.c | 8 > driver

Re: [PATCH] Staging: lustre: llite: Drop unneeded variables

2015-05-10 Thread Greg Kroah-Hartman
On Wed, May 06, 2015 at 04:59:42PM +0200, Julia Lawall wrote: > Drop variables made unnecessary by conversion of obd free functions > to kfree. > > Signed-off-by: Julia Lawall Someone else sent this a few hours before you did :( ___ devel mailing list

Re: [PATCH] staging: unisys: Disable driver for UML

2015-05-10 Thread Greg KH
On Mon, May 04, 2015 at 09:02:10PM +0200, Richard Weinberger wrote: > UML has no io memory nor cpuid. > Let's disable this driver for UML. Doesn't apply to my tree :( ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject

Re: [PATCH v2] staging: unisys: remove unused functions

2015-05-10 Thread Greg Kroah-Hartman
On Fri, May 08, 2015 at 01:06:19PM +0530, Sudip Mukherjee wrote: > these functions were just defined and never used. after removing the > functions the variable visorchipset_cache_buffers_in_use is becoming > unused, so removed it as well. > > Signed-off-by: Sudip Mukherjee > --- > > v2: combine

Greetings From Mr.Ho!

2015-05-10 Thread Eang Seng Ho
-- Greetings, I am Mr. Eang Seng Ho. I have no other way to reach you than these ways, please accept my apology. I am an account manager to one of our foreign late customer. It is my interest to contact you in respect of this our client who opened a draft account in my bank. This deceased clie

Re: [PATCH v3 07/33] staging: rtl8192e: Replace RTLLIB_DEBUG(DL_ERR) with netdev_*()

2015-05-10 Thread Sudip Mukherjee
On Sat, May 09, 2015 at 11:18:55PM +0200, Mateusz Kulikowski wrote: > Replace all RTLLIB_DEBUG(RTLLIB_DL_ERR, *) calls with netdev_err() > for errors that really should be reported to user. > Use netdev_warn() for the rest. > Rephrase some of the messages to make them more readable/compact. checkpa

Re: [PATCH v3 04/33] staging: rtl8192e: Fix DEEP_INDENTATION warning in rtllib_parse_info_param()

2015-05-10 Thread Sudip Mukherjee
On Sat, May 09, 2015 at 11:18:52PM +0200, Mateusz Kulikowski wrote: > Move MFIE_TYPE_GENERIC handler to rtllib_parse_mife_generic() function. > Code was not altered significantly, therefore in some places it generates > LONG_LINE checkpatch.pl warnings. apart from long line it is also giving warnin