On Thu, Jul 23, 2015 at 01:24:50PM +0300, Dan Carpenter wrote:
> On Thu, Jul 23, 2015 at 01:10:57PM +0300, Dan Carpenter wrote:
> > In this specific case, writing it as "if (ret != 0)" caused the bug. If
> > we had written it as "if (ret) return ret;" then there are no zeroes so
> > wouldn't have
struct ndis_wlan_bssid_ex is a dopelganger of
struct wlan_bssid_ex, and is used about a third as often
Switch all instances to wlan_bssid_ex
This also gets rid of a use of typedef NDIS_802_11_RATES_EX
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/rtl871x_cmd.c | 17 ++--
change instances SupportedRates to compliant and sane "rates"
This change in no way harms readability, and brings several lines
under the 80 character limit.
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/ieee80211.c | 22 +++---
drivers/staging/rtl8712/rtl87
Coding style fix.
Get rid of typedefs NDIS_802_11_RATES and NDIS_802_11_RATES_EX
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 4 ++--
drivers/staging/rtl8712/wlan_bssdef.h | 7 +--
2 files changed, 3 insertions(+), 8 deletions(-)
diff --git a/dri
r8712_get_ndis_wlan_bssid_ex_sz has a "6 * sizeof(unsigned long)"
where the underlying struct has a 6 * unsigned char.
Simplify the calculation by just subtracting the variable part from
the size of the struct.
This also gets rid of a use of typedef NDIS_802_11_RATES_EX
Signed-off-by: Joshua Clay
replace item-by-item size calculation of a struct
with the size of the struct.
This gets rid of a use of typedef NDIS_802_11_RATES_EX
Signed-off-by: Joshua Clayton
---
drivers/staging/rtl8712/rtl871x_cmd.c | 11 +--
1 file changed, 1 insertion(+), 10 deletions(-)
diff --git a/drivers/
The main goal of this series is to get rid of a needless and ugly typedef
in the rtl8712 wlan driver.
In the course of fixing that, I found a bug thati will can might (at least in
theory)
lead to a overrun during a memcpy, as well as a duplicate struct.
Finally after cleaning up the typedef, I co
On Thu, 23 Jul 2015, Jason Gunthorpe wrote:
> On Thu, Jul 23, 2015 at 02:55:52PM -0700, Moritz Fischer wrote:
> > Hi Alan,
> >
> > I saw that your socfpga driver doesn't support the partial reconfig
> > use case (not a big deal).
> > What I currently do for Zynq is if I'm doing a non-partial reco
On Fri, Jul 24, 2015 at 08:55:53AM +0900, Chaehyun Lim wrote:
> Use kmalloc and kmalloc_array instead of WILC_MALLOC.
>
> Signed-off-by: Chaehyun Lim
> ---
> V2: Use GFP_KERNEL flag instead of GFP_ATOMIC
This is probably the correct thing but how did you check that we aren't
holding a spin_lock
Return -ENOMEM if memory allocation is failed.
Signed-off-by: Chaehyun Lim
---
V2: Use ! operator instead of NULL comparison
V3: this patch is rebased by previous modification
drivers/staging/wilc1000/coreconfigurator.c | 13 -
1 file changed, 4 insertions(+), 9 deletions(-)
diff -
Use kmalloc and kmalloc_array instead of WILC_MALLOC.
Signed-off-by: Chaehyun Lim
---
V2: Use GFP_KERNEL flag instead of GFP_ATOMIC
drivers/staging/wilc1000/coreconfigurator.c | 13 +++--
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigur
Add error check if memory allocation is failed.
Signed-off-by: Chaehyun Lim
---
V2: use ! operator instead of NULL comparison
V3: this patch is rebased by previous modification
drivers/staging/wilc1000/coreconfigurator.c | 12
1 file changed, 12 insertions(+)
diff --git a/drivers/
On Thu, Jul 23, 2015 at 02:55:52PM -0700, Moritz Fischer wrote:
> Hi Alan,
>
> I saw that your socfpga driver doesn't support the partial reconfig
> use case (not a big deal).
> What I currently do for Zynq is if I'm doing a non-partial reconfig is
> that I disable input
> level shifters and asser
Hi Alan,
I saw that your socfpga driver doesn't support the partial reconfig
use case (not a big deal).
What I currently do for Zynq is if I'm doing a non-partial reconfig is
that I disable input
level shifters and assert *all* resets while reprogramming in my FPGA
manager .write_init() and .write
For all of these, you need a better subject line that shows what part of
the kernel you are modifying.
For example, this one would be:
Subject: [PATCH 1/5] staging: lustre: cl_page.c: add blank line after
variable definition
On Thu, Jul 23, 2015 at 02:21:10PM +0800, Incarnation P. Lee w
On Thu, Jul 23, 2015 at 08:19:17PM +0900, Chaehyun Lim wrote:
> Use kmalloc and kmalloc_array instead of WILC_MALLOC.
>
> Signed-off-by: Chaehyun Lim
> ---
> drivers/staging/wilc1000/coreconfigurator.c | 13 +++--
> 1 file changed, 7 insertions(+), 6 deletions(-)
>
> diff --git a/driver
Refactored rtw_free_assoc_resources to avoid sparse warnings about
different contexts for basic lock
Signed-off-by: Buţiu Alexandru Octavian
---
drivers/staging/rtl8188eu/core/rtw_ioctl_set.c | 10 +-
drivers/staging/rtl8188eu/core/rtw_mlme.c | 24
drivers/s
On Thu, Jul 23, 2015 at 08:11:03PM +0200, Jakub Sitnicki wrote:
> On Wed, Jun 24, 2015 at 07:23 AM CEST, Jakub Sitnicki
> wrote:
> > linux/ieee80211.h already defines constants for information element IDs.
> > Include it where needed, resolve discrepancies in naming, and remove the
> > duplicated
On Thu, Jul 23, 2015 at 08:10:07PM +0200, Jakub Sitnicki wrote:
> On Thu, Jun 18, 2015 at 08:31 AM CEST, Jakub Sitnicki
> wrote:
> > Flag is never set. Remove it and the code that is dead because of it.
> >
> > Signed-off-by: Jakub Sitnicki
> > ---
>
> Looks like this patch got lost in the nois
On 07/22/2015 04:42 PM, Shuah Khan wrote:
> This patch series updates ALSA driver, and au0828 core driver to
> use Managed Media controller API to share tuner. Please note that
> Managed Media Controller API and DVB and V4L2 drivers updates to
> use Media Controller API have been added in a prior p
On Wed, Jun 24, 2015 at 07:23 AM CEST, Jakub Sitnicki
wrote:
> linux/ieee80211.h already defines constants for information element IDs.
> Include it where needed, resolve discrepancies in naming, and remove the
> duplicated definitions.
>
> While at it, wrap a line that was too long and remove ex
On Thu, Jun 18, 2015 at 08:31 AM CEST, Jakub Sitnicki
wrote:
> Flag is never set. Remove it and the code that is dead because of it.
>
> Signed-off-by: Jakub Sitnicki
> ---
Looks like this patch got lost in the noise. It still applies & builds.
Cheers,
Jakub
__
On Thu, 2015-07-23 at 20:19 +0900, Chaehyun Lim wrote:
> Add error check if memory allocation is failed.
trivia:
> diff --git a/drivers/staging/wilc1000/coreconfigurator.c
> b/drivers/staging/wilc1000/coreconfigurator.c
[]
> @@ -812,6 +812,9 @@ s32 ParseNetworkInfo(u8 *pu8MsgBuffer, tstrNetworkI
On Thu, 23 Jul 2015, Greg KH wrote:
> On Fri, Jul 17, 2015 at 10:51:10AM -0500, at...@opensource.altera.com wrote:
> > From: Alan Tull
> >
> > This patchset adds two chunks plus documentation:
> > * fpga manager core: exports ABI functions that write an image to a FPGA
> > * DT Overlay support
On Wed, 22 Jul 2015, Moritz Fischer wrote:
Hi Miritz,
> Hi Alan,
>
> a couple of small things I found while reworking the Zynq version to
> match the v9 patchset:
>
> On Fri, Jul 17, 2015 at 8:51 AM, wrote:
> > From: Alan Tull
> >
...
> > + ret = mgr->mops->write_complete(mgr);
>
> Co
The return value of the `cmdtest` handler for a subdevice checks the
prospective new command in various steps and returns the step number at
which any problem was detected, or 0 if no problem was detected. It is
allowed to modify the command in various ways at each step. Corrections
for out-of-ra
The `cmdtest` and `cmd` handlers for the AO subdevice
(`usbduxsigma_ao_cmdtest()` and `usbduxsigma_ao_cmd()`) support "scan"
timing of commands with all channels updated every "scan" period. There
is some disabled code to use "convert" timing in high speed mode. That
would allow channels to be up
Fix some minor problems in the testing of asynchronous commands for the AI
and AO subdevices and remove some redundant code.
The main problem is that the testing of a new command can affect the
operation of an already running command, which it isn't supposed to do. (In
practice, applications don'
The AI subdevice `cmdtest` handler `usbduxsigma_ai_cmdtest()` ensures
that `cmd->scan_begin_src == TRIG_TIMER` by the end of step 2 of the
command checking code, so assume that this is the case for step 3
onwards and remove the redundant code.
Signed-off-by: Ian Abbott
---
drivers/staging/comedi
The return value of the `cmdtest` handler for a subdevice checks the
prospective new command in various steps and returns the step number at
which any problem was detected, or 0 if no problem was detected. It is
allowed to modify the command in various ways at each step. Corrections
for out-of-ra
`devpriv->ai_timer` is used while an asynchronous command is running on
the AI subdevice. It also gets modified by the subdevice's `cmdtest`
handler for checking new asynchronous commands
(`usbduxsigma_ai_cmdtest()`), which is not correct as it's allowed to
check new commands while an old command
`devpriv->ao_timer` is used while an asynchronous command is running on
the AO subdevice. It also gets modified by the subdevice's `cmdtest`
handler for checking new asynchronous commands,
`usbduxsigma_ao_cmdtest()`, which is not correct as it's allowed to
check new commands while an old command i
From: Vitaly Kuznetsov
Commit e513229b4c38 ("Drivers: hv: vmbus: prevent cpu offlining on newer
hypervisors") was altering smp_ops.cpu_disable to prevent CPU offlining.
We can bo better by using cpu_hotplug_enable/disable functions instead of
such hard-coding.
Reported-by: Radim Kr.má<
Signed-o
From: Vitaly Kuznetsov
As a prerequisite to exporting cpu_hotplug_enable/cpu_hotplug_disable
functions to modules we need to convert cpu_hotplug_disabled to a counter
to properly support disable -> disable -> enable call sequences. E.g.
after Hyper-V vmbus module (which is supposed to be the firs
From: Dexuan Cui
It is to fix:
hv_kvp_daemon.c:705:2: warning: format not a string literal and no format
arguments [-Wformat-security]
Signed-off-by: Dexuan Cui
Signed-off-by: K. Y. Srinivasan
---
tools/hv/hv_kvp_daemon.c |2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --gi
Changes since v6:
- Rearrange patches. [Thomas Gleixner]
- Fix a typo in PATCH 2 description [Thomas Gleixner].
- Add Reviewed-by: [Thomas Gleixner].
Changes since v5:
- Split PATCH 1 into two (PATCH 1/3 and 3/3), rewrite changelogs. [Thomas
Gleixner]
Changes since v4:
- In disable_nonboot_cpus
From: Vitaly Kuznetsov
Hyper-V module needs to disable cpu hotplug (offlining) as there is no
support from hypervisor side to reassign already opened event channels
to a different CPU. Currently it is been done by altering
smp_ops.cpu_disable but it is hackish.
Signed-off-by: Vitaly Kuznetsov
R
Hi,
On Thu, Jul 23, 2015 at 8:20 AM, Incarnation P. Lee
wrote:
> drivers/staging/lustre/lustre/obdclass/cl_page.c
It is custom that you write slightly more introductory text here. Just
a file name is pointless.
The subject should probably contain [PATCH 0/5]. This would be
automatically fixed f
Signed-off-by: Incarnation P. Lee
---
drivers/staging/lustre/lustre/obdclass/cl_page.c | 12 ++--
1 file changed, 6 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/lustre/lustre/obdclass/cl_page.c
b/drivers/staging/lustre/lustre/obdclass/cl_page.c
index 4cc17d3..428c6b2 1006
Signed-off-by: Incarnation P. Lee
---
drivers/staging/lustre/lustre/obdclass/cl_page.c | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/drivers/staging/lustre/lustre/obdclass/cl_page.c
b/drivers/staging/lustre/lustre/obdclass/cl_page.c
index c386c43..4cc17d3 100644
--- a/
Signed-off-by: Incarnation P. Lee
---
drivers/staging/lustre/lustre/obdclass/cl_page.c | 3 +--
1 file changed, 1 insertion(+), 2 deletions(-)
diff --git a/drivers/staging/lustre/lustre/obdclass/cl_page.c
b/drivers/staging/lustre/lustre/obdclass/cl_page.c
index 739814e..c386c43 100644
--- a/dr
Signed-off-by: Incarnation P. Lee
---
drivers/staging/lustre/lustre/obdclass/cl_page.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/lustre/lustre/obdclass/cl_page.c
b/drivers/staging/lustre/lustre/obdclass/cl_page.c
index 8b2c1e7..739814e 100644
--- a/driv
drivers/staging/lustre/lustre/obdclass/cl_page.c
Signed-off-by: Incarnation P. Lee
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Signed-off-by: Incarnation P. Lee
---
drivers/staging/lustre/lustre/obdclass/cl_page.c | 2 ++
1 file changed, 2 insertions(+)
diff --git a/drivers/staging/lustre/lustre/obdclass/cl_page.c
b/drivers/staging/lustre/lustre/obdclass/cl_page.c
index a7f3032..8b2c1e7 100644
--- a/drivers/staging/lu
Remove macro and use explicit case statements. Code is a little
longer but clearer. Checkpatch.pl does not complain anymore.
Signed-off-by: Ioan-Adrian Ratiu
---
drivers/staging/rtl8192e/rtllib_rx.c | 80 +++-
1 file changed, 52 insertions(+), 28 deletions(-)
dif
Den 14.07.2015 14:59, skrev Henri Chain:
This is a driver chip for 240x160 4-bit greyscale LCDs.
It is capable of 4-wire (8 bit) or 3-wire (9 bit) SPI that have both been
tested. (It also has a 6800 or 8080-style parallel interface, but I have
not included support for it.)
Signed-off-by: Henri
Add error check if memory allocation is failed.
Signed-off-by: Chaehyun Lim
---
V2: use ! operator instead of NULL comparison
drivers/staging/wilc1000/coreconfigurator.c | 12
1 file changed, 12 insertions(+)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
b/drivers/stag
Return -ENOMEM if memory allocation is failed.
Signed-off-by: Chaehyun Lim
---
V2: use ! operator instead of NULL comparison.
drivers/staging/wilc1000/coreconfigurator.c | 13 -
1 file changed, 4 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
Commit e513229b4c38 ("Drivers: hv: vmbus: prevent cpu offlining on newer
hypervisors") was altering smp_ops.cpu_disable to prevent CPU offlining.
We can bo better by using cpu_hotplug_enable/disable functions instead of
such hard-coding.
Reported-by: Radim Krčmář
Signed-off-by: Vitaly Kuznetsov
Hyper-V module needs to disable cpu hotplug (offlining) as there is no
support from hypervisor side to reassign already opened event channels
to a different CPU. Currently it is been done by altering
smp_ops.cpu_disable but it is hackish.
Signed-off-by: Vitaly Kuznetsov
Reviewed-by: Thomas Gleixn
As a prerequisite to exporting cpu_hotplug_enable/cpu_hotplug_disable
functions to modules we need to convert cpu_hotplug_disabled to a counter
to properly support disable -> disable -> enable call sequences. E.g.
after Hyper-V vmbus module (which is supposed to be the first user of
exported cpu_ho
Changes since v6:
- Rearrange patches. [Thomas Gleixner]
- Fix a typo in PATCH 2 description [Thomas Gleixner].
- Add Reviewed-by: [Thomas Gleixner].
Changes since v5:
- Split PATCH 1 into two (PATCH 1/3 and 3/3), rewrite changelogs. [Thomas
Gleixner]
Changes since v4:
- In disable_nonboot_cpus
On Thu, Jul 23, 2015 at 01:59:33PM +0300, Ioan-Adrian Ratiu wrote:
> Enclose defined macro in paranthesis to avoid checkpatch complaint
> "ERROR: Macros with complex values should be enclosed in parentheses"
>
> Signed-off-by: Ioan-Adrian Ratiu
> ---
> drivers/staging/rtl8192e/rtllib_rx.c | 2 +-
Den 15.07.2015 11:36, skrev Paul Bolle:
On di, 2015-07-14 at 14:59 +0200, Henri Chain wrote:
--- /dev/null
+++ b/drivers/staging/fbtft/fb_uc1611.c
+#define DRVNAME"fb_uc1611"
+MODULE_ALIAS("spi:" DRVNAME);
+MODULE_ALIAS("platform:" DRVNAME);
+MODULE_ALIAS("spi:uc1611");
+MODULE_
Enclose defined macro in paranthesis to avoid checkpatch complaint
"ERROR: Macros with complex values should be enclosed in parentheses"
Signed-off-by: Ioan-Adrian Ratiu
---
drivers/staging/rtl8192e/rtllib_rx.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/staging/r
On Thu, Jul 23, 2015 at 08:19:18PM +0900, Chaehyun Lim wrote:
> Add error check if memory allocation is failed.
>
> Signed-off-by: Chaehyun Lim
> ---
> drivers/staging/wilc1000/coreconfigurator.c | 12
> 1 file changed, 12 insertions(+)
>
> diff --git a/drivers/staging/wilc1000/cor
Den 15.07.2015 04:14, skrev Greg KH:
On Tue, Jun 30, 2015 at 08:43:13AM +0200, Fabio Falzoi wrote:
Use a helper function to choose which set_addr_win implementation to
use, based on the value of the setaddrwin module parameter.
Signed-off-by: Fabio Falzoi
---
drivers/staging/fbtft/flexfb.c
Add error check if memory allocation is failed.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 12
1 file changed, 12 insertions(+)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
b/drivers/staging/wilc1000/coreconfigurator.c
index 7e2b2ab41
Return -ENOMEM if memory allocation is failed.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 13 -
1 file changed, 4 insertions(+), 9 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
b/drivers/staging/wilc1000/coreconfigurator.c
Use kmalloc and kmalloc_array instead of WILC_MALLOC.
Signed-off-by: Chaehyun Lim
---
drivers/staging/wilc1000/coreconfigurator.c | 13 +++--
1 file changed, 7 insertions(+), 6 deletions(-)
diff --git a/drivers/staging/wilc1000/coreconfigurator.c
b/drivers/staging/wilc1000/coreconfigur
Den 30.06.2015 08:43, skrev Fabio Falzoi:
Use a struct flexfb_lcd_controller to holds chip properties, instead of
relying on a long 'if - else if' chain.
This allows to:
- use a simple linear search to verify if a certain LCD controller
model is supported or not.
- add support for a new LCD chip
> From: Dan Carpenter
> Sent: Thursday, July 23, 2015 18:25
> On Thu, Jul 23, 2015 at 01:10:57PM +0300, Dan Carpenter wrote:
> > In this specific case, writing it as "if (ret != 0)" caused the bug. If
> > we had written it as "if (ret) return ret;" then there are no zeroes so
> > wouldn't have bee
On Thu, Jul 23, 2015 at 01:10:57PM +0300, Dan Carpenter wrote:
> In this specific case, writing it as "if (ret != 0)" caused the bug. If
> we had written it as "if (ret) return ret;" then there are no zeroes so
> wouldn't have been any temptation to return the zero instead of the ret.
I did a sea
On Thu, Jul 23, 2015 at 03:05:16AM +, Dexuan Cui wrote:
> The kind of usage is not rare in the kernel code:
Yeah. But it's used 5% of the time. If it's under 15% then there is a
risk that we'll write a checkpatch rule to enforce the standard way...
There are some places where != 0 is idiomat
binReFQmyqq1o.bin
Description: Binary data
___
devel mailing list
de...@linuxdriverproject.org
http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel
Hi!
On Fri, Jul 17, 2015 at 04:22:07PM -0500, atull wrote:
> On Fri, 17 Jul 2015, Steffen Trumtrar wrote:
>
> > Hi!
> >
> > On Fri, Jul 17, 2015 at 10:51:13AM -0500, at...@opensource.altera.com wrote:
> > > From: Alan Tull
> > >
> > > New bindings document for simple fpga bus.
> > >
> > > Sig
On Wed, Jul 22, 2015 at 09:09:06PM +0300, Dmitry Kalinkin wrote:
> + for (level = 1; level <= 7; level++) {
> + char *level_node_name = kasprintf(GFP_KERNEL, "%d", level);
> + struct kobject *level_node = kobject_create_and_add(
> + level_node_name, k
67 matches
Mail list logo