[PATCH] improve lmk to avoid deadlock issue

2015-07-29 Thread Wang, Biao
From: "wang, biao" Date: Thu, 30 Jul 2015 14:14:44 +0800 Subject: [PATCH] improve lmk to avoid deadlock issue Consider the following case: Task A trigger lmk with a lock held, while process B try to get this lock, but unfortunately B is the very culprit Task lmk select to kill. So B will never be

Re: [PATCH 4573/4573] Staging: rtl8188eu: fixed newlines after declarations

2015-07-29 Thread Joe Perches
On Wed, 2015-07-29 at 21:34 -0400, Dave Perez wrote: > This is a patch to the rtw_debug.c file that fixes styling errors relating to > new lines after variable declarations. [] > diff --git a/drivers/staging/rtl8188eu/core/rtw_debug.c > b/drivers/staging/rtl8188eu/core/rtw_debug.c [] > @@ -219,6

Re: [PATCH 09/21] staging: wilc1000: #ifdef conditionals cover entire functions

2015-07-29 Thread tony . cho
On 2015년 07월 30일 05:54, Greg KH wrote: On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote: This patch lets preprocessor conditionals (#ifdef) related to WILC_SDIO_IRQ_GPIO to compile out the entire functions. Compiling out the entire functions is preferred rather than portions of functio

[PATCH RESEND 1/1] Staging: rtl8188eu: fixed newlines after declarations

2015-07-29 Thread Dave Perez
This is a patch to the rtw_debug.c file that fixes styling errors relating to new lines after variable declarations. Signed-off-by: Dave Perez --- drivers/staging/rtl8188eu/core/rtw_debug.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/rtl8188eu/core/rtw_debug.c

[PATCH 4573/4573] Staging: rtl8188eu: fixed newlines after declarations

2015-07-29 Thread Dave Perez
This is a patch to the rtw_debug.c file that fixes styling errors relating to new lines after variable declarations. Signed-off-by: Dave Perez --- drivers/staging/rtl8188eu/core/rtw_debug.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/rtl8188eu/core/rtw_debug.c

Re: [PATCH 09/21] staging: wilc1000: #ifdef conditionals cover entire functions

2015-07-29 Thread tony . cho
On 2015년 07월 30일 06:29, Greg KH wrote: On Thu, Jul 30, 2015 at 12:14:08AM +0300, Dan Carpenter wrote: On Wed, Jul 29, 2015 at 01:54:54PM -0700, Greg KH wrote: On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote: /** * Disable power sequencer **/ - if

Re: [PATCH 4573/4573] Staging: rtl8188eu: fixed newlines after declarations

2015-07-29 Thread Greg KH
On Wed, Jul 29, 2015 at 09:34:42PM -0400, Dave Perez wrote: > This is a patch to the rtw_debug.c file that fixes styling errors relating to > new lines after variable declarations. > > Signed-off-by: Dave Perez > --- > drivers/staging/rtl8188eu/core/rtw_debug.c | 2 ++ > 1 file changed,

Re: [PATCH 21/21] staging: wilc1000: update TODO list of WILC1000

2015-07-29 Thread Greg KH
On Thu, Jul 30, 2015 at 10:29:59AM +0900, tony.cho wrote: > > On 2015년 07월 30일 06:01, Greg KH wrote: > >On Tue, Jul 28, 2015 at 05:47:40PM +0900, Tony Cho wrote: > >>The TODO list is updated for the WILC1000 kernel driver. The TODO list > >>contains many items listed in time sequence. > >I don't u

Re: [PATCH 09/21] staging: wilc1000: #ifdef conditionals cover entire functions

2015-07-29 Thread tony . cho
On 2015년 07월 30일 06:14, Dan Carpenter wrote: On Wed, Jul 29, 2015 at 01:54:54PM -0700, Greg KH wrote: On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote: /** * Disable power sequencer **/ - if (!sdio_read_reg(WILC_MISC, ®)) { + if(!sdio_read_reg

Re: [PATCH 21/21] staging: wilc1000: update TODO list of WILC1000

2015-07-29 Thread tony . cho
On 2015년 07월 30일 06:01, Greg KH wrote: On Tue, Jul 28, 2015 at 05:47:40PM +0900, Tony Cho wrote: The TODO list is updated for the WILC1000 kernel driver. The TODO list contains many items listed in time sequence. I don't understand what you mean by "in time sequence" Sorry for unclear senten

Re: [PATCH 06/21] staging: wilc1000: remove the warnings on unnecessary braces

2015-07-29 Thread tony . cho
On 2015년 07월 30일 05:50, Greg KH wrote: On Tue, Jul 28, 2015 at 05:47:25PM +0900, Tony Cho wrote: This patch removes the warnings reported by checkpatch.pl on {} not necessary for the single statement blocks. Signed-off-by: Tony Cho Reviewed-by: Dan Carpenter --- drivers/staging/wilc1000/w

RE: [patch] staging: comedi: das16: remove a duplicate condition

2015-07-29 Thread Hartley Sweeten
On Wednesday, July 29, 2015 2:37 PM, Dan Carpenter wrote: > We checked that "it->options[3]" was non-zero on the line before so > there is no need to check again. > > Signed-off-by: Dan Carpenter v > diff --git a/drivers/staging/comedi/drivers/das16.c > b/drivers/staging/comedi/drivers/das16.c >

Re: [PATCH V4 7/7] Drivers: hv: vmbus: disable local interrupt when hvsock's callback is running

2015-07-29 Thread David Miller
From: Dexuan Cui Date: Tue, 28 Jul 2015 05:35:30 -0700 > In the SMP guest case, when the per-channel callback hvsock_events() is > running on virtual CPU A, if the guest tries to close the connection on > virtual CPU B: we invoke vmbus_close() -> vmbus_close_internal(), > then we can have trouble

Re: [PATCH V4 6/7] hvsock: introduce Hyper-V VM Sockets feature

2015-07-29 Thread David Miller
From: Dexuan Cui Date: Tue, 28 Jul 2015 05:35:23 -0700 > +/* hvsock_release() can be invoked in 2 paths: > + * 1. on process termination: > + * hvsock_sk_destruct+0x1a/0x20 > + * __sk_free+0x1d/0x130 > + * sk_free+0x19/0x20 > + * hvsock_release+0x138/0x160 > + * sock_release+0x1f/0x90 >

Re: [PATCH V4 4/7] Drivers: hv: vmbus: add APIs to register callbacks to process hvsock connection

2015-07-29 Thread David Miller
From: Dexuan Cui Date: Tue, 28 Jul 2015 05:35:11 -0700 > With the 2 APIs supplied by the VMBus driver, the coming net/hvsock driver > can register 2 callbacks and can know when a new hvsock connection is > offered by the host, and when a hvsock connection is being closed by the > host. > > Signe

Re: [PATCH 09/21] staging: wilc1000: #ifdef conditionals cover entire functions

2015-07-29 Thread Dan Carpenter
Got it, thanks. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

[patch] staging: comedi: das16: remove a duplicate condition

2015-07-29 Thread Dan Carpenter
We checked that "it->options[3]" was non-zero on the line before so there is no need to check again. Signed-off-by: Dan Carpenter diff --git a/drivers/staging/comedi/drivers/das16.c b/drivers/staging/comedi/drivers/das16.c index d7cf4b1..056bca9 100644 --- a/drivers/staging/comedi/drivers/das16

Re: [PATCH 09/21] staging: wilc1000: #ifdef conditionals cover entire functions

2015-07-29 Thread Greg KH
On Thu, Jul 30, 2015 at 12:14:08AM +0300, Dan Carpenter wrote: > On Wed, Jul 29, 2015 at 01:54:54PM -0700, Greg KH wrote: > > On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote: > > > /** > > >* Disable power sequencer > > >**/ > > > - if (!sdio_read_reg(WILC_MISC, ®)) { > > >

Re: [PATCH 09/21] staging: wilc1000: #ifdef conditionals cover entire functions

2015-07-29 Thread Dan Carpenter
On Wed, Jul 29, 2015 at 01:54:54PM -0700, Greg KH wrote: > On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote: > > /** > > * Disable power sequencer > > **/ > > - if (!sdio_read_reg(WILC_MISC, ®)) { > > + if(!sdio_read_reg(WILC_MISC, ®)) { > I noticed this style chang

Re: [PATCH] staging: wilc1000: host_interface.c: Fix build warning

2015-07-29 Thread Greg KH
On Wed, Jul 29, 2015 at 07:36:59PM +0530, Chandra S Gorentla wrote: > Fixed - warning: ‘*((void *)&strHostIFmsg+4).pu8Head’ may be used > uninitialized The warning is incorrect, look at the code, I don't see anything wrong with it. I suggest upgrading to a newer version of gcc that doesn't repo

Re: [PATCH 21/21] staging: wilc1000: update TODO list of WILC1000

2015-07-29 Thread Greg KH
On Tue, Jul 28, 2015 at 05:47:40PM +0900, Tony Cho wrote: > The TODO list is updated for the WILC1000 kernel driver. The TODO list > contains many items listed in time sequence. I don't understand what you mean by "in time sequence" > > Signed-off-by: Tony Cho > Reviewed-by: Dan Carpenter > --

Re: [PATCH 09/21] staging: wilc1000: #ifdef conditionals cover entire functions

2015-07-29 Thread Greg KH
On Tue, Jul 28, 2015 at 05:47:28PM +0900, Tony Cho wrote: > This patch lets preprocessor conditionals (#ifdef) related to > WILC_SDIO_IRQ_GPIO to compile out the entire functions. Compiling out > the entire functions is preferred rather than portions of functions or > expressions becausue doing so

Re: [PATCH 06/21] staging: wilc1000: remove the warnings on unnecessary braces

2015-07-29 Thread Greg KH
On Tue, Jul 28, 2015 at 05:47:25PM +0900, Tony Cho wrote: > This patch removes the warnings reported by checkpatch.pl on {} not > necessary for the single statement blocks. > > Signed-off-by: Tony Cho > Reviewed-by: Dan Carpenter > --- > drivers/staging/wilc1000/wilc_sdio.c | 28 ++-

Re: [PATCH V2 1/3] staging: wilc1000: coreconfigurator.c: remove WILC_MALLOC

2015-07-29 Thread Greg KH
On Fri, Jul 24, 2015 at 08:55:53AM +0900, Chaehyun Lim wrote: > Use kmalloc and kmalloc_array instead of WILC_MALLOC. > > Signed-off-by: Chaehyun Lim > --- > V2: Use GFP_KERNEL flag instead of GFP_ATOMIC Please answer Dan's question for the next time you resend this series, I can't take these as

Re: [PATCH -next] staging: most: fix aim-network build errors

2015-07-29 Thread Christian Gromm
On Tue, 28 Jul 2015 10:45:07 -0700 Randy Dunlap wrote: > From: Randy Dunlap > > Fix build errors when CONFIG_NET is not enabled by making the driver > depend on NET. > Also correct the loadable module name. > > ERROR: "__netdev_alloc_skb" [drivers/staging/most/aim-network/aim_network.ko] > un

Re: randconfig build error with next-20150729, in drivers/staging/most/aim-network/networking.c

2015-07-29 Thread Greg Kroah-Hartman
On Wed, Jul 29, 2015 at 08:07:43PM +0300, Dan Carpenter wrote: > Randy Dunlap posted a patch for this. It has to depend on NET. Yes, I should get this merged later this evening, thanks. greg k-h ___ devel mailing list de...@linuxdriverproject.org http:

Re: randconfig build error with next-20150729, in drivers/staging/most/aim-network/networking.c

2015-07-29 Thread Dan Carpenter
Randy Dunlap posted a patch for this. It has to depend on NET. regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org http://driverdev.linuxdriverproject.org/mailman/listinfo/driverdev-devel

randconfig build error with next-20150729, in drivers/staging/most/aim-network/networking.c

2015-07-29 Thread Jim Davis
Building with the attached random configuration file, warning: (INTEL_MIC_HOST && CAIF_VIRTIO && VHOST_NET && VHOST_SCSI && VHOST_NET && VHOST_SCSI) selects VHOST_RING which has unmet direct dependencies (NETDEVICES && CAIF_VIRTIO || VIRTUALIZATION) drivers/built-in.o: In function `most_nd_setup'

Re: [PATCH v4 04/46] staging: emxx_udc: add ep capabilities support

2015-07-29 Thread Felipe Balbi
On Mon, Jul 27, 2015 at 11:16:14AM +0200, Robert Baldyga wrote: > Convert endpoint configuration to new capabilities model. > > Fixed typo in "epc-nulk" to "epc-bulk". > > Signed-off-by: Robert Baldyga > --- > drivers/staging/emxx_udc/emxx_udc.c | 60 > ++--- >

Re: [PATCH] staging: wilc1000: host_interface.c: Fix build warning

2015-07-29 Thread Chandra Gorentla
On Wed, Jul 29, 2015 at 05:20:37PM +0300, Dan Carpenter wrote: > On Wed, Jul 29, 2015 at 07:36:59PM +0530, Chandra S Gorentla wrote: > > Fixed - warning: ‘*((void *)&strHostIFmsg+4).pu8Head’ may be used > > uninitialized > > > > I can't reproduce this warning and the original code looks fine to

Re: [PATCH] staging: wilc1000: host_interface.c: Fix build warning

2015-07-29 Thread Dan Carpenter
On Wed, Jul 29, 2015 at 07:36:59PM +0530, Chandra S Gorentla wrote: > Fixed - warning: ‘*((void *)&strHostIFmsg+4).pu8Head’ may be used > uninitialized > I can't reproduce this warning and the original code looks fine to me. When you say the word "fix" it means the code is buggy. Otherwise we

[PATCH] staging: wilc1000: host_interface.c: Fix build warning

2015-07-29 Thread Chandra S Gorentla
Fixed - warning: ‘*((void *)&strHostIFmsg+4).pu8Head’ may be used uninitialized Signed-off-by: Chandra S Gorentla --- drivers/staging/wilc1000/host_interface.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/wilc1000/host_interface.c b/drivers/staging/wilc10

Re: [PATCH] [dgnc] Remove dgnc_ports_state_show

2015-07-29 Thread Dan Carpenter
On Wed, Jul 29, 2015 at 02:55:30PM +0100, Salah Triki wrote: > dgnc_ports_state_show exposes ports status which help an adversary to > plan an attack. Thus, the function is removed. > > Signed-off-by: Salah Triki This file can only be read by UID zero so this doesn't seem like an issue. Have I

[PATCH V4 4/8] staging: rtl8712: removed unused wrapper structs

2015-07-29 Thread Joshua Clayton
Remove wrapper structs that just wrap struct ndis_wlan_bssid_ex, and are unused. Signed-off-by: Joshua Clayton --- drivers/staging/rtl8712/rtl871x_cmd.h | 18 -- 1 file changed, 18 deletions(-) diff --git a/drivers/staging/rtl8712/rtl871x_cmd.h b/drivers/staging/rtl8712/rtl871x

[PATCH] [dgnc] Remove dgnc_ports_state_show

2015-07-29 Thread Salah Triki
dgnc_ports_state_show exposes ports status which help an adversary to plan an attack. Thus, the function is removed. Signed-off-by: Salah Triki --- drivers/staging/dgnc/dgnc_sysfs.c | 20 1 file changed, 20 deletions(-) diff --git a/drivers/staging/dgnc/dgnc_sysfs.c b/driv

[PATCH V4 7/8] staging: rtl8712: remove typedefs

2015-07-29 Thread Joshua Clayton
Coding style fix. Get rid of typedefs NDIS_802_11_RATES and NDIS_802_11_RATES_EX Undo any casting that was done as a result of the typedef. Signed-off-by: Joshua Clayton --- drivers/staging/rtl8712/rtl871x_ioctl_linux.c | 12 ++-- drivers/staging/rtl8712/wlan_bssdef.h | 7 +-

[PATCH V4 5/8] staging: rtl8712: remove duplicate struct

2015-07-29 Thread Joshua Clayton
struct ndis_wlan_bssid_ex is a doppelganger of struct wlan_bssid_ex, and is used about a third as often. Switch all instances to wlan_bssid_ex, and remove ndis_wlan_bssid_ex This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton --- drivers/staging/rtl8712/rt

[PATCH V4 6/8] staging: rtl8712: rename function

2015-07-29 Thread Joshua Clayton
Rename r8712_get_ndis_wlan_bssid_ex_sz() to r8712_get_wlan_bssid_ex_sz(), which corresponds to the struct whose size it measures. Signed-off-by: Joshua Clayton --- drivers/staging/rtl8712/rtl871x_cmd.c | 8 drivers/staging/rtl8712/rtl871x_mlme.c | 16 drivers/

[PATCH V4 1/8] staging: rtl8712: fix buggy size calculation

2015-07-29 Thread Joshua Clayton
r8712_get_ndis_wlan_bssid_ex_sz has a "6 * sizeof(unsigned long)" where the underlying struct has a 6 * unsigned char. Simplify the calculation by just subtracting the variable part from the size of the struct. This also gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clay

[PATCH V4 8/8] staging: rtl8712: change SupportedRates to rates

2015-07-29 Thread Joshua Clayton
Change the value to a name that conforms to Linux coding style. "rates" is equally expressive in this context, and I have left alone a comment and function name that describe the rates as supported rates. Signed-off-by: Joshua Clayton --- drivers/staging/rtl8712/ieee80211.c | 25 +

[PATCH V4 2/8] staging: rtl8712: simplify size calculation

2015-07-29 Thread Joshua Clayton
replace item-by-item size calculation of a struct with the size of the struct. This gets rid of a use of typedef NDIS_802_11_RATES_EX Signed-off-by: Joshua Clayton --- drivers/staging/rtl8712/rtl871x_cmd.c | 11 +-- 1 file changed, 1 insertion(+), 10 deletions(-) diff --git a/drivers/

[PATCH V4 3/8] staging: rtl8712: fix comment

2015-07-29 Thread Joshua Clayton
The old comment refers to a typedef name which is being removed, and to a style of calculation which is no longer being used. It falsely states that IELength is variable length, instead of IEs. Change comment to simply state that the IEs field is a buffer of variable size and that IELength refers

RE: [PATCH 2/6] staging: unisys: visornic - prevent lock recursion after IO recovery

2015-07-29 Thread Sell, Timothy C
> -Original Message- > From: Dan Carpenter [mailto:dan.carpen...@oracle.com] > Sent: Wednesday, July 29, 2015 4:28 AM > To: Romer, Benjamin M > Cc: gre...@linuxfoundation.org; jes.soren...@redhat.com; *S-Par- > Maintainer; driverdev-devel@linuxdriverproject.org; Sell, Timothy C > Subject: R

Re: [PATCH 2/6] staging: unisys: visornic - prevent lock recursion after IO recovery

2015-07-29 Thread Dan Carpenter
On Tue, Jul 28, 2015 at 12:29:07PM -0400, Benjamin Romer wrote: > diff --git a/drivers/staging/unisys/visornic/visornic_main.c > b/drivers/staging/unisys/visornic/visornic_main.c > index 18b0465..d5095c9 100644 > --- a/drivers/staging/unisys/visornic/visornic_main.c > +++ b/drivers/staging/unisys/

[PATCH v2 0/4] staging: rtl8188eu: clean up duplicated WLAN_* constants

2015-07-29 Thread Jakub Sitnicki
This short series was initially a patch[1] that had to be rebased and split (patches 1 & 2). Since then it has been extended to clean up other WLAN_* constants duplicated in rtl8188eu driver's headers (patches 3 & 4). [1] http://lkml.kernel.org/g/1437750758-17120-1-git-send-email-jsitni...@gmail

[PATCH v2 1/4] staging: rtl8188eu: don't duplicate ieee80211 WLAN_EID_* constants

2015-07-29 Thread Jakub Sitnicki
linux/ieee80211.h already defines constants for information element IDs. Resolve discrepancies in naming and remove the duplicated definitions. Signed-off-by: Jakub Sitnicki --- drivers/staging/rtl8188eu/core/rtw_ieee80211.c | 2 +- drivers/staging/rtl8188eu/include/ieee80211.h | 38 --

[PATCH v2 2/4] staging: rtl8188eu: wrap a long if condition and remove extra parenthesis

2015-07-29 Thread Jakub Sitnicki
Signed-off-by: Jakub Sitnicki --- drivers/staging/rtl8188eu/os_dep/ioctl_linux.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/rtl8188eu/os_dep/ioctl_linux.c b/drivers/staging/rtl8188eu/os_dep/ioctl_linux.c index 554c04d..844ed6f 100644 --- a/drivers/stagi

[PATCH v2 4/4] staging: rtl8188eu: don't duplicate ieee80211 WLAN_HT_CAP_SM_PS_* constants

2015-07-29 Thread Jakub Sitnicki
linux/ieee80211.h already defines constants for spatial multiplexing power save modes. Remove the duplicated definitions. Signed-off-by: Jakub Sitnicki --- drivers/staging/rtl8188eu/include/wifi.h | 7 --- 1 file changed, 7 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/wifi.h

[PATCH v2 3/4] staging: rtl8188eu: don't duplicate ieee80211 WLAN_AUTH_* constants

2015-07-29 Thread Jakub Sitnicki
linux/ieee80211.h already defines constants for authentication algorithms. Remove the duplicated definitions. Signed-off-by: Jakub Sitnicki --- drivers/staging/rtl8188eu/include/ieee80211.h | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/staging/rtl8188eu/include/ieee80211.h b

Re: [PATCH] Staging : wilc1000: Remove unnecessary parentheses

2015-07-29 Thread Dan Carpenter
The original code is fine... I probably would write it the way you suggest, but I can also see why people would write it the other way. This isn't an official CodingStyle rule so I feel like the author gets to choose. Part of the reason for CodingStyle is so that we don't run into madness of chan