Re: [PATCHv6 3/5] Staging: most: hdm-usb/hdm_usb.c. Fix "missing static keyword" warnings

2015-08-07 Thread AdrianRemonda
On Thu, Aug 06, 2015 at 11:57:28PM +0200, Christian Gromm wrote: > On Thu, 6 Aug 2015 19:34:58 +0200 > Adrian Remonda wrote: > > > This is a patch to the most/hdm-usb/hdm_usb.c file. It > > makes several local functions and structures static to prevent global > > visibility. > > > > v6: fixed al

[PATCH 19/31] staging/lustre: use kmemdup rather than duplicating its implementation

2015-08-07 Thread Andrzej Hajda
The patch was generated using fixed coccinelle semantic patch scripts/coccinelle/api/memdup.cocci [1]. [1]: http://permalink.gmane.org/gmane.linux.kernel/2014320 Signed-off-by: Andrzej Hajda --- drivers/staging/lustre/lustre/obdclass/acl.c | 6 ++ 1 file changed, 2 insertions(+), 4 deletion

Re: [PATCH] staging: rtl8723au: Fix sparse warning: cast to restricted __le16

2015-08-07 Thread Johannes Postma
On 06/08/15 at 08:21am, Jes Sorensen wrote: > > Looks OK to me. Probably worth changing the *(usPtr + index) to be > usPtr[index] as well to make the code easier to read. > > Jes > Thank you for reviewing. I will make a seperate patch for that. I will send it after this one is accepted. Or s

Re: [PATCHv6 3/5] Staging: most: hdm-usb/hdm_usb.c. Fix "missing static keyword" warnings

2015-08-07 Thread Sudip Mukherjee
On Fri, Aug 07, 2015 at 09:40:03AM +0200, AdrianRemonda wrote: > On Thu, Aug 06, 2015 at 11:57:28PM +0200, Christian Gromm wrote: > > On Thu, 6 Aug 2015 19:34:58 +0200 > > Adrian Remonda wrote: > > > > > > Again, please keep the original alignment and start the second line > > of function argum

RE: [PATCH V4 7/7] Drivers: hv: vmbus: disable local interrupt when hvsock's callback is running

2015-08-07 Thread Dexuan Cui
> From: KY Srinivasan > Sent: Friday, August 7, 2015 1:50 > To: Dexuan Cui ; David Miller > Cc: o...@aepfle.de; gre...@linuxfoundation.org; jasow...@redhat.com; > driverdev-devel@linuxdriverproject.org; linux-ker...@vger.kernel.org; > step...@networkplumber.org; stefa...@redhat.com; net...@vger.ke

RE: [PATCH V4 4/7] Drivers: hv: vmbus: add APIs to register callbacks to process hvsock connection

2015-08-07 Thread Dexuan Cui
> -Original Message- > From: KY Srinivasan > Sent: Friday, August 7, 2015 2:28 > To: Dexuan Cui ; David Miller > Cc: o...@aepfle.de; gre...@linuxfoundation.org; jasow...@redhat.com; > driverdev-devel@linuxdriverproject.org; linux-ker...@vger.kernel.org; > step...@networkplumber.org; stefa.

[PATCH 1/7] staging: rtl8188eu: remove unused argument

2015-08-07 Thread Sudip Mukherjee
The function rtw_os_recv_resource_alloc() only uses the argument struct recv_frame *. So remove the other unused argument. Signed-off-by: Sudip Mukherjee --- drivers/staging/rtl8188eu/core/rtw_recv.c | 2 +- drivers/staging/rtl8188eu/include/recv_osdep.h | 3 +-- drivers/staging/rtl8188eu/o

[PATCH 2/7] staging: rtl8188eu: make function void

2015-08-07 Thread Sudip Mukherjee
The return value of rtw_os_recv_resource_alloc() is never checked, so make it as void. Moreover as of now the function can not fail. Signed-off-by: Sudip Mukherjee --- drivers/staging/rtl8188eu/core/rtw_recv.c | 2 +- drivers/staging/rtl8188eu/include/recv_osdep.h | 2 +- drivers/staging/rt

[PATCH 7/7] staging: rtl8188eu: remove multiple blank line

2015-08-07 Thread Sudip Mukherjee
Multiple blank lines is against the kernel coding style and checkpatch complains for that. Signed-off-by: Sudip Mukherjee --- drivers/staging/rtl8188eu/core/rtw_recv.c | 26 -- 1 file changed, 26 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_recv.c b/driv

[PATCH 5/7] staging: rtl8188eu: remove exit label

2015-08-07 Thread Sudip Mukherjee
An exit label which does nothing except return, is not worth having. So remove it. Signed-off-by: Sudip Mukherjee --- drivers/staging/rtl8188eu/core/rtw_recv.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_recv.c b/drivers/staging

[PATCH 6/7] staging: rtl8188eu: remove unused function

2015-08-07 Thread Sudip Mukherjee
The function rtw_init_recvframe() was not being used. Signed-off-by: Sudip Mukherjee --- drivers/staging/rtl8188eu/core/rtw_recv.c | 8 1 file changed, 8 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_recv.c b/drivers/staging/rtl8188eu/core/rtw_recv.c index c011dc8..0bb5

[PATCH 3/7] staging: rtl8188eu: rearrange code

2015-08-07 Thread Sudip Mukherjee
Re-arrange the code to directly return success or failure, thus removing the variable used in the function. Signed-off-by: Sudip Mukherjee --- drivers/staging/rtl8188eu/os_dep/recv_linux.c | 10 -- 1 file changed, 4 insertions(+), 6 deletions(-) diff --git a/drivers/staging/rtl8188eu/os

[PATCH 4/7] staging: rtl8188eu: remove unused define

2015-08-07 Thread Sudip Mukherjee
_RECV_OSDEP_C_ was only defined here but never checked anywhere. Signed-off-by: Sudip Mukherjee --- drivers/staging/rtl8188eu/os_dep/recv_linux.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/rtl8188eu/os_dep/recv_linux.c b/drivers/staging/rtl8188eu/os_dep/recv_linux.c in

[PATCH 1/5] staging: sm750fb: remove multiple blank line

2015-08-07 Thread Sudip Mukherjee
Multiple blank lines are not kernel coding style and so checkpatch complains. Remove them. Signed-off-by: Sudip Mukherjee --- drivers/staging/sm750fb/sm750.c | 26 -- 1 file changed, 26 deletions(-) diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/s

[PATCH 5/5] staging: sm750fb: simplify return

2015-08-07 Thread Sudip Mukherjee
Lets return the return value directly instead of using a variable to store the result. Signed-off-by: Sudip Mukherjee --- drivers/staging/sm750fb/sm750.c | 6 +- 1 file changed, 1 insertion(+), 5 deletions(-) diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm750fb/sm750.c ind

[PATCH 3/5] staging: sm750fb: fix multiline comment

2015-08-07 Thread Sudip Mukherjee
Multiline comments are edited to be in the kernel coding style. Signed-off-by: Sudip Mukherjee --- drivers/staging/sm750fb/sm750.c | 63 + 1 file changed, 39 insertions(+), 24 deletions(-) diff --git a/drivers/staging/sm750fb/sm750.c b/drivers/staging/sm7

[PATCH 2/5] staging: sm750fb: space around operator

2015-08-07 Thread Sudip Mukherjee
Kernel coding style says to have a space around the operators. Signed-off-by: Sudip Mukherjee --- This patch will generate checkpatch warning about longline in 2 places, those were not fixed to keep the readability. Will fix them later. The warnings were already there, this patch has not introdu

[PATCH 4/5] staging: sm750fb: rearrange code

2015-08-07 Thread Sudip Mukherjee
Rearrange the code to remove one exit label which also makes the code less indented and more readable. Signed-off-by: Sudip Mukherjee --- drivers/staging/sm750fb/sm750.c | 27 +-- 1 file changed, 13 insertions(+), 14 deletions(-) diff --git a/drivers/staging/sm750fb/sm75

Re: [PATCH] staging: rtl8723au: Fix sparse warning: cast to restricted __le16

2015-08-07 Thread Jes Sorensen
Johannes Postma writes: > On 06/08/15 at 08:21am, Jes Sorensen wrote: >> >> Looks OK to me. Probably worth changing the *(usPtr + index) to be >> usPtr[index] as well to make the code easier to read. >> >> Jes >> > > Thank you for reviewing. I will make a seperate patch for that. I will > sen

[PATCH RESEND 1/3] staging: sm7xxfb: merge sm712fb with fbdev

2015-08-07 Thread Sudip Mukherjee
Now since all cleanups are done and the code is ready to be merged lets move it out of staging into fbdev location. Signed-off-by: Sudip Mukherjee --- Hi Greg, Resending the patch series as discussed with you. Patch generated with -M, thought it will be easy for you to review. drivers/staging/

[PATCH RESEND 3/3] MAINTAINERS: update maintainers list

2015-08-07 Thread Sudip Mukherjee
Now since sm712fb has moved out of staging update the maintainers list accordingly. Signed-off-by: Sudip Mukherjee --- MAINTAINERS | 17 + 1 file changed, 9 insertions(+), 8 deletions(-) diff --git a/MAINTAINERS b/MAINTAINERS index 9289ecb..ba6c537 100644 --- a/MAINTAINERS +++ b

[PATCH RESEND 2/3] Documentation/fb: add documentation for sm712fb

2015-08-07 Thread Sudip Mukherjee
Create the documentation for SM712. Mention all the supported modes and how to use. Signed-off-by: Sudip Mukherjee --- Documentation/fb/sm712fb.txt | 31 +++ 1 file changed, 31 insertions(+) create mode 100644 Documentation/fb/sm712fb.txt diff --git a/Documentation/

[PATCH] staging: rtl8723au: rtl8723a_hal_init: Improve code readability

2015-08-07 Thread Johannes Postma
This patch improves code readability in the function rtl8723a_cal_txdesc_chksum. It improves the readability of the argument of the function le16_to_cpu. Signed-off-by: Johannes Postma --- drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) d

Re: [PATCH] staging: rtl8723au: Fix sparse warning: cast to restricted __le16

2015-08-07 Thread Johannes Postma
On 07/08/15 at 08:26am, Jes Sorensen wrote: > Johannes Postma writes: > > On 06/08/15 at 08:21am, Jes Sorensen wrote: > >> > >> Looks OK to me. Probably worth changing the *(usPtr + index) to be > >> usPtr[index] as well to make the code easier to read. > >> > >> Jes > >> > > > > Thank you for

Re: [PATCH] staging: rtl8723au: rtl8723a_hal_init: Improve code readability

2015-08-07 Thread Jes Sorensen
Johannes Postma writes: > This patch improves code readability in the function > rtl8723a_cal_txdesc_chksum. It improves the readability of the argument > of the function le16_to_cpu. > > Signed-off-by: Johannes Postma > --- > drivers/staging/rtl8723au/hal/rtl8723a_hal_init.c | 2 +- > 1 file c

[PATCH RFC v2 07/16] media: get rid of unused "extra_links" param on media_entity_init()

2015-08-07 Thread Mauro Carvalho Chehab
Currently, media_entity_init() creates an array with the links, allocated at init time. It provides a parameter (extra_links) that would allocate more links than the current needs, but this is not used by any driver. As we want to be able to do dynamic link allocation/removal, we'll need to change

[PATCH 01/14] staging: comedi: addi_tcw.h: prefer using the BIT macro

2015-08-07 Thread H Hartley Sweeten
Use the BIT macro to define the register bits. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi_tcw.h | 48 +++ 1 file changed, 24 insertions(+), 24 deletions(-) diff --git a/drivers/staging/comedi/drive

[PATCH 00/14] staging: comedi: hwdrv_apci1564: tidy up code

2015-08-07 Thread H Hartley Sweeten
The hwdrv_apci1564.c file is included by the addi_apci_1564 driver to provide the support code for the timer and counter subdevices. The code in this file is broken with respect to how comedi works with subdevices. Tidy it up so that it can be fixed. H Hartley Sweeten (14): staging: comedi: add

[PATCH 02/14] staging: comedi: hwdrv_apci1564: remove unused defines

2015-08-07 Thread H Hartley Sweeten
These defines are not used. Remove them. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c | 5 - 1 file changed, 5 deletions(-) diff --git a/drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c b/dri

[PATCH 03/14] staging: comedi: addi_apci_1564: define the APCI1564_DO_INT_CTRL_REG bits

2015-08-07 Thread H Hartley Sweeten
Define the bits in this register. Remove the old defines in hwdrv_apci1564.c. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c | 6 -- drivers/staging/comedi/drivers/addi_apci_1564.c | 2 ++ 2 fil

[PATCH 05/14] staging: comedi: addi_apci_1564: define the APCI1564_DO_IRQ_REG bits

2015-08-07 Thread H Hartley Sweeten
Define the bits in this register. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi_apci_1564.c | 1 + 1 file changed, 1 insertion(+) diff --git a/drivers/staging/comedi/drivers/addi_apci_1564.c b/drivers/staging/comedi/drivers/add

[PATCH 04/14] staging: comedi: addi_apci_1564: define the APCI1564_DO_INT_STATUS_REG bits

2015-08-07 Thread H Hartley Sweeten
Define the bits in this register. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi_apci_1564.c | 2 ++ 1 file changed, 2 insertions(+) diff --git a/drivers/staging/comedi/drivers/addi_apci_1564.c b/drivers/staging/comedi/drivers/a

[PATCH 07/14] staging: comedi: addi_apci_1564: tidy up APCI1564_EEPROM_REG bit defines

2015-08-07 Thread H Hartley Sweeten
Use the BIT() macro to define the bits. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi_apci_1564.c | 10 +- 1 file changed, 5 insertions(+), 5 deletions(-) diff --git a/drivers/staging/comedi/drivers/addi_apci_1564.c b/d

[PATCH 06/14] staging: comedi: addi_apci_1564: define the APCI1564_DI_IRQ_REG bits

2015-08-07 Thread H Hartley Sweeten
Define the bits in this register. Remove the old defines in hwdrv_apci1564.c. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- .../comedi/drivers/addi-data/hwdrv_apci1564.c| 8 drivers/staging/comedi/drivers/addi_apci_1564.c | 20 ++-

[PATCH 10/14] staging: comedi: hwdrv_apci1564: remove magic number in apci1564_timer_insn_read()

2015-08-07 Thread H Hartley Sweeten
Use the bit define from addi_tcw.h to remove the magic number. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c | 3 ++- 1 file changed, 2 insertions(+), 1 deletion(-) diff --git a/drivers/staging/comedi/drive

[PATCH 08/14] staging: comedi: hwdrv_apci1564: use addi_tcw.h defines

2015-08-07 Thread H Hartley Sweeten
Use the ADDI_TCW_CTRL_REG bit defines in addi_tcw.h to remove the "magic" numbers. Add some missing bit defines and mask defines to addi_tcw.h to help cleanup the code. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- .../comedi/drivers/addi-data/hwdrv_apci1564.c

[PATCH 09/14] staging: comedi: hwdrv_apci1564: tidy up apci1564_timer_insn_write()

2015-08-07 Thread H Hartley Sweeten
Clear the gate and trig bits in the common code path. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git a/drivers/staging/comedi/drivers/add

[PATCH 11/14] staging: comedi: hwdrv_apci1564: remove useless code in apci1564_counter_insn_config()

2015-08-07 Thread H Hartley Sweeten
The gate, trig, and ena, bits in the 'ctrl' are cleared at the start of the function. There is no reason clear these bits for each step. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c | 11 +-- 1 file

[PATCH 12/14] staging: comedi: hwdrv_apci1564: fix counter "mode" setting

2015-08-07 Thread H Hartley Sweeten
According to the (broken) original driver, data[4] passed to this function is the "timer mode". It appears the original code used the wrong shift to set the bits. Use the ADDI_TCW_CTRL_MODE() macro so that the correct bits get set. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-

[PATCH 13/14] staging: comedi: hwdrv_apci1564: tidy up apci1564_counter_insn_write()

2015-08-07 Thread H Hartley Sweeten
Clear the gate and trig bits in the common code path. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git a/drivers/staging/comedi/drivers/addi-d

[PATCH 14/14] staging: comedi: hwdrv_apci1564: remove magic numbers in apci1564_counter_insn_read()

2015-08-07 Thread H Hartley Sweeten
Use the bit defines from addi_tcw.h to remove the magic numbers in this function. Add the missing define for ADDI_TCW_STATUS_HARDWARE_TRIG. Signed-off-by: H Hartley Sweeten Cc: Ian Abbott Cc: Greg Kroah-Hartman --- drivers/staging/comedi/drivers/addi-data/hwdrv_apci1564.c | 8 driver

Re: [PATCHv6 3/5] Staging: most: hdm-usb/hdm_usb.c. Fix "missing static keyword" warnings

2015-08-07 Thread Christian Gromm
On Fri, 7 Aug 2015 09:40:03 +0200 AdrianRemonda wrote: > On Thu, Aug 06, 2015 at 11:57:28PM +0200, Christian Gromm wrote: > > On Thu, 6 Aug 2015 19:34:58 +0200 > > Adrian Remonda wrote: > > > > > This is a patch to the most/hdm-usb/hdm_usb.c file. It > > > makes several local functions and stru

Re: [PATCH] ion: Handle the memory mapping correctly on x86

2015-08-07 Thread Laura Abbott
On 08/03/2015 05:21 PM, Radhakrishna, Pradeep wrote: From b4069e7fe1b2aa1660b3f944e246c13b4947db21 Mon Sep 17 00:00:00 2001 From: Zhebin Jin Date: Wed, 8 Jul 2015 10:35:06 +0800 Subject: [PATCH] ion: Handle the memory mapping correctly on x86 This patch modifies the ion page pool code to addre

[GIT PULL] Staging driver fixes for 4.2-rc6

2015-08-07 Thread Greg KH
The following changes since commit cbfe8fa6cd672011c755c3cd85c9ffd4e2d10a6f: Linux 4.2-rc4 (2015-07-26 12:26:21 -0700) are available in the git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git/ tags/staging-4.2-rc6 for you to fetch changes up to fb1de5a4c825a

Re: [PATCH 03/14] staging: comedi: addi_apci_1564: define the APCI1564_DO_INT_CTRL_REG bits

2015-08-07 Thread Sudip Mukherjee
On Fri, Aug 07, 2015 at 11:45:03AM -0700, H Hartley Sweeten wrote: > Define the bits in this register. Remove the old defines in hwdrv_apci1564.c. > > Signed-off-by: H Hartley Sweeten > Cc: Ian Abbott > Cc: Greg Kroah-Hartman > --- The #defines that are introduced in this patch and the next 2 p

[PATCH] Staging: media: davinci_vpfe: Fix over 80 characters coding style issue

2015-08-07 Thread Junsu Shin
This is a patch to the dm365_ipipe.c that fixes over 80 characters warning detected. Signed-off-by: Junsu Shin --- drivers/staging/media/davinci_vpfe/dm365_ipipe.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/staging/media/davinci_vpfe/dm365_ipipe.c b/drivers

Re: [PATCH 1/1] Staging: media: davinci_vpfe: fix over 80 characters coding style issue.

2015-08-07 Thread Junsu Shin
On 08/06/2015 11:45 PM, Sudip Mukherjee wrote: > On Thu, Aug 06, 2015 at 09:55:54PM -0500, Junsu Shin wrote: >> This is a patch to the dm365_ipipe.c that fixes over 80 characters warning >> detected by checkpatch.pl. >> Signed-off-by: Junsu Shin > please do not use whitespace before Signed-off