[PATCH] staging: dgap: fix memory leak in dgap_parsefile()

2015-09-29 Thread Ronit Halder
In dgap_parsefile() char pointers are set with kstrdup() without checking that some string is allocated to that char pointer before. This patch frees the memory if already allocated and then set the poniter with kstrdup(). Signed-off-by: Ronit halder --- drivers/staging/dgap/dgap.c | 12

Re: [staging:staging-testing 959/962] drivers/staging/wilc1000/wilc_sdio.c:584:2: error: implicit declaration of function 'memset'

2015-09-29 Thread Greg Kroah-Hartman
On Wed, Sep 30, 2015 at 01:15:51PM +0800, kbuild test robot wrote: > tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git > staging-testing > head: 7477929566b65f692b79974b784ee59e8b2b9f18 > commit: e215a871255f9256de77e1b9c32b84d3a80122c1 [959/962] staging: wilc1000: > re

[PATCH 1/1] staging: ion: Fix error handling in ion_buffer_create

2015-09-29 Thread Rohit kumar
This patch fixes error handling case when buffer->pages allocation fails. Also, it removes unreachable code of checking ret variable although it is not updated. Signed-off-by: Rohit kumar --- drivers/staging/android/ion/ion.c | 14 +- 1 file changed, 5 insertions(+), 9 deletions(-)

Re: [PATCH] staging: rtl8712: remove dead code

2015-09-29 Thread Joshua Clayton
On Monday, September 28, 2015 10:52:33 PM Luis de Bethencourt wrote: > The while() loop will only exit in a return or a goto ask_for_joinbss, > which means it will never break and execute the return after it. > Removing return _FAIL since it is dead code. > > Signed-off-by: Luis de Bethencourt >

[PATCH 6/6] staging: sm750fb: remove unused enable{ZVPort, SSP, PWM} functions

2015-09-29 Thread Mike Rapoport
The functions that enable/disable power for some sub-devices are not used and therefore they can be removed. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_power.c | 61 -- drivers/staging/sm750fb/ddk750_power.h | 15 - 2 files changed, 76

[PATCH 0/6] staging: sm750fb: remove dead code

2015-09-29 Thread Mike Rapoport
Hi, These patches remove some functions and macros that are never used in the sm750fb driver. There is still lots of dead code, for instance, the driver compiles without ddk750_sii.o and ddk750_dvi.o. These two seem required to enable particular DVI transmitter and, apparently, they should not be

[PATCH 4/6] staging: sm750fb: remove unused macros

2015-09-29 Thread Mike Rapoport
Several macros defined in sm750.h and sm750_help.h are not used and therefore they can be removed Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/sm750.h | 7 --- drivers/staging/sm750fb/sm750_help.h | 33 - 2 files changed, 40 deletions(-) dif

[PATCH 5/6] staging: sm750fb: staticize getPowerMode function

2015-09-29 Thread Mike Rapoport
The getPowerMode function is not used outside ddk750_power, make it static. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_power.c | 2 +- drivers/staging/sm750fb/ddk750_power.h | 2 -- 2 files changed, 1 insertion(+), 3 deletions(-) diff --git a/drivers/staging/sm750fb/ddk750_

[PATCH 2/6] staging: sm750fb: remove unused calcPllValue2 function

2015-09-29 Thread Mike Rapoport
The calcPllValue2 function is never called and therefore it can be removed. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 100 -- drivers/staging/sm750fb/ddk750_chip.h | 1 - 2 files changed, 101 deletions(-) diff --git a/drivers/stag

[PATCH 1/6] staging: sm750fb: staticize local functions in ddk750_chip

2015-09-29 Thread Mike Rapoport
Several functions in ddk750_chip are not used elsewhere, let's make them static. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c | 12 ++-- drivers/staging/sm750fb/ddk750_chip.h | 5 - 2 files changed, 6 insertions(+), 11 deletions(-) diff --git a/drivers/sta

[PATCH 3/6] staging: sm750fb: remove unused ddk750_initDVIDisp function

2015-09-29 Thread Mike Rapoport
The ddk750_initDVIDisp function is never used and therefore it can be removed. Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_display.c | 33 drivers/staging/sm750fb/ddk750_display.h | 1 - 2 files changed, 34 deletions(-) diff --git a/drivers/

[staging:staging-testing 959/962] drivers/staging/wilc1000/wilc_sdio.c:584:2: error: implicit declaration of function 'memset'

2015-09-29 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-testing head: 7477929566b65f692b79974b784ee59e8b2b9f18 commit: e215a871255f9256de77e1b9c32b84d3a80122c1 [959/962] staging: wilc1000: remove wilc_platform include file config: openrisc-allmodconfig (attached as .c

Re: [PATCH] staging: vt6655: Fixed two lines over 80 characters

2015-09-29 Thread Greg KH
On Tue, Sep 29, 2015 at 10:37:24PM +0530, Arjun Krishna Babu wrote: > Two lines of code that were over 80 characters long is fixed by > splitting them into multiple lines. > > This way, the lines of code are now easier to read. > > Issue found by checkpatch. > > Signed-off-by: Arjun Krishna Babu

[PATCH RESEND 1/2] staging: wilc1000: remove define WILC_PARSE_SCAN_IN_HOST

2015-09-29 Thread Glen Lee
The define WILC_PARSE_SCAN_IN_HOST is always used in the driver, so just delete ifdef WILC_PARSE_SCAN_IN_HOST line, ifndef WILC_PARSE_SCAN_IN_HOST line and it's related codes. Finally, remove define in Makefile. Signed-off-by: Glen Lee --- drivers/staging/wilc1000/Makefile | 1 - driver

[PATCH RESEND 2/2] staging: wilc1000: remove define CONNECT_DIRECT

2015-09-29 Thread Glen Lee
The driver use CONNECT_DIRECT define as always. No need to provide as feature. This patch removes ifdef/ifndef CONNECT_DIRECT line and it's related codes inside ifndef CONNECT_DIRECT. Signed-off-by: Glen Lee --- drivers/staging/wilc1000/Makefile | 2 +- drivers/staging/wilc1000/corec

can we discuss?

2015-09-29 Thread Darren Williams
Hey, How are you today? We would love to be your marketing partners. Our email marketing can generate new leads to a number of businesses. We can help your business reach the next level and increase your business sales 2-4 times than now. If you would require more information please contact us t

Re: [PATCH] staging:rtl8188eu style fix

2015-09-29 Thread Greg KH
On Tue, Sep 29, 2015 at 08:16:52PM -0600, BryanSPaul wrote: > style fix: Comparison moved to right What does this mean? > Signed-off-by: Bryan Paul This name doesn't match up with your "From:" line in your email header :( ___ devel mailing list de...

[PATCH] staging:rtl8188eu style fix

2015-09-29 Thread BryanSPaul
style fix: Comparison moved to right Signed-off-by: Bryan Paul --- drivers/staging/rtl8188eu/core/rtw_cmd.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/staging/rtl8188eu/core/rtw_cmd.c b/drivers/staging/rtl8188eu/core/rtw_cmd.c index 89b5e48..9b7026e 1006

[PATCH 1/2] staging: wilc1000: remove wilc_platform include file

2015-09-29 Thread Chaehyun Lim
This patch removes wilc_platform.h include file in wilc_oswrapper.h wilc_platform.h have several standard header files so that some header files should be included to avoid compilation errors. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/coreconfigurator.c | 1 + drivers/staging/wilc

[PATCH 2/2] staging: wilc1000: delete wilc_oswrapper.h

2015-09-29 Thread Chaehyun Lim
This patch deletes wilc_oswrapper.h that has nothing inside. Signed-off-by: Chaehyun Lim --- drivers/staging/wilc1000/wilc_oswrapper.h | 16 drivers/staging/wilc1000/wilc_wlan.h | 1 - drivers/staging/wilc1000/wilc_wlan_if.h | 1 - 3 files changed, 18 deletions(-) dele

Re: [PATCH] Staging: rtl8712: rtl871x_ioctl_linux.c Move constant to right side of the comparision

2015-09-29 Thread Tillmann Heidsieck
On Mon, Sep 28, 2015 at 09:56:19AM -0500, Larry Finger wrote: > The primary requirement for moving a driver out of staging is that it use > mac80211. No amount of cosmetic fixing will ever make that change for > rtl8712u! As I am pretty sure someone has done something like this before, is there a

[PATCH] staging/wlan-ng: Fix potential buffer overflow in firmware handling

2015-09-29 Thread Tillmann Heidsieck
This patch fixes a potential buffer overflow detected by smatch. pda16 has length 512, while processing an element with index < 512 we are checking for an end marker in the next element. This poses a potential buffer overflow if no end marker is present. --- drivers/staging/wlan-ng/prism2fw.c | 4

[PATCH staging v2 2/2] wilc1000 : Use BIT() macro where possible

2015-09-29 Thread Anish Bhatt
Replace (1 << x) by BIT(x) as recommended by checkpatch.pl Signed-off-by: Anish Bhatt --- drivers/staging/wilc1000/host_interface.c | 4 +- drivers/staging/wilc1000/host_interface.h | 38 +++ drivers/staging/wilc1000/linux_wlan_common.h | 8 ++-- drivers/staging/wilc1000/w

[PATCH staging v2 0/2] wilc1000 code cleanups

2015-09-29 Thread Anish Bhatt
Patchset removes extraneous macro defines and cleans some code as recommended by checkpatch.pl v2 : Do not change code formatting when removing comment delimiters Anish Bhatt (2): wilc1000 : Remove leftover comment delimiters wilc1000 : Use BIT() macro where possible drivers/staging/wilc100

[PATCH staging v2 1/2] wilc1000 : Remove leftover comment delimiters

2015-09-29 Thread Anish Bhatt
Remove leftover comment delimiters that were only partially removed in a previous cleanup. Fixes : c3ca63728ad8 ("staging: wilc1000: remove useless comment") Signed-off-by: Anish Bhatt --- drivers/staging/wilc1000/wilc_wlan.c | 13 ++--- 1 file changed, 6 insertions(+), 7 deletions(-) d

Re: [PATCH 04/38] IB/ehca: fix handling idr_alloc result

2015-09-29 Thread Doug Ledford
On 09/21/2015 09:33 AM, Andrzej Hajda wrote: > The function can return negative value. > > The problem has been detected using proposed semantic patch > scripts/coccinelle/tests/unsigned_lesser_than_zero.cocci [1]. > > [1]: http://permalink.gmane.org/gmane.linux.kernel/2038576 > > Signed-off-by:

Re: [PATCH 1/2] Staging: iio: cdc: Prefer using the BIT macro

2015-09-29 Thread Jonathan Cameron
On 27/09/15 20:39, Shraddha Barke wrote: > > > On Sun, 27 Sep 2015, Jonathan Cameron wrote: > >> On 26/09/15 18:14, Lars-Peter Clausen wrote: >>> On 09/25/2015 07:23 PM, Shraddha Barke wrote: Replace bit shifting on 1 with the BIT(x) macro Signed-off-by: Shraddha Barke >>> >>> Ac

[PATCH] staging: vt6655: Fixed two lines over 80 characters

2015-09-29 Thread Arjun Krishna Babu
Two lines of code that were over 80 characters long is fixed by splitting them into multiple lines. This way, the lines of code are now easier to read. Issue found by checkpatch. Signed-off-by: Arjun Krishna Babu --- drivers/staging/vt6655/baseband.c | 13 +++-- 1 file changed, 11 inse

Re: [PATCH 0/3] scsi: Some miscellaneous fixes

2015-09-29 Thread Vitaly Kuznetsov
"K. Y. Srinivasan" writes: [...] > > Vitaly Kuznetsov (2): > scsi_scan: don't dump trace when scsi_prep_async_scan() is called > twice > scsi: introduce short_inquiry flag for broken host adapters James, I'm sorry for the annoyance but when I asked about these patches last time you sai

Re: [PATCH] hyperv: Fix build failure with HYPERVISOR_GUEST=y && KEXEC_CORE=n

2015-09-29 Thread Ben Hutchings
On Tue, Sep 29, 2015 at 01:52:39PM +0200, Vitaly Kuznetsov wrote: > Ben Hutchings writes: > > > On Tue, 2015-09-29 at 10:47 +0200, Vitaly Kuznetsov wrote: > >> Ben Hutchings writes: > >> > >> > Currently with this configuration I get: > >> > > >> > arch/x86/built-in.o: In function `hv_machine_

Re: [PATCH] hyperv: Fix build failure with HYPERVISOR_GUEST=y && KEXEC_CORE=n

2015-09-29 Thread Vitaly Kuznetsov
Ben Hutchings writes: > On Tue, 2015-09-29 at 10:47 +0200, Vitaly Kuznetsov wrote: >> Ben Hutchings writes: >> >> > Currently with this configuration I get: >> > >> > arch/x86/built-in.o: In function `hv_machine_crash_shutdown': >> > mshyperv.c:(.text+0x29656): undefined reference to >> > `nat

[PATCH v2] staging: comedi: ni_tiocmd: remove unused code

2015-09-29 Thread Luis de Bethencourt
Code after a return will never run, removing this dead code. Suggested-by: Greg Kroah-Hartman Signed-off-by: Luis de Bethencourt --- Hi, This is a better fix than the previous patch: http://lkml.iu.edu/hypermail/linux/kernel/1509.3/02741.html Suggestion of just removing the dead code was in:

Re: [PATCH] hyperv: Fix build failure with HYPERVISOR_GUEST=y && KEXEC_CORE=n

2015-09-29 Thread Ben Hutchings
On Tue, 2015-09-29 at 10:47 +0200, Vitaly Kuznetsov wrote: > Ben Hutchings writes: > > > Currently with this configuration I get: > > > > arch/x86/built-in.o: In function `hv_machine_crash_shutdown': > > mshyperv.c:(.text+0x29656): undefined reference to > > `native_machine_crash_shutdown' > >

Re: [PATCH] staging: comedi: cb_pcidas64: remove unused code

2015-09-29 Thread Luis de Bethencourt
On 29/09/15 02:23, Greg KH wrote: > On Mon, Sep 28, 2015 at 10:10:42PM +0100, Luis de Bethencourt wrote: >> Remove the disabled code, for now, with #if 0. >> >> Signed-off-by: Luis de Bethencourt >> --- >> >> Hi, >> >> The code after the return is dead code. There is a comment saying it is >> disa

Re: [PATCH] hyperv: Fix build failure with HYPERVISOR_GUEST=y && KEXEC_CORE=n

2015-09-29 Thread Vitaly Kuznetsov
Ben Hutchings writes: > Currently with this configuration I get: > > arch/x86/built-in.o: In function `hv_machine_crash_shutdown': > mshyperv.c:(.text+0x29656): undefined reference to > `native_machine_crash_shutdown' https://lkml.org/lkml/2015/9/23/183 ... https://lkml.org/lkml/2015/9/7/440 ...

[PATCH] staging: sm750fb: remove dead code

2015-09-29 Thread Mike Rapoport
Remove the code enclosed in '#if 0' Signed-off-by: Mike Rapoport --- drivers/staging/sm750fb/ddk750_chip.c| 53 --- drivers/staging/sm750fb/ddk750_display.h | 54 --- drivers/staging/sm750fb/ddk750_help.h| 9 +- drivers/staging/sm750fb/ddk750_reg.h | 244 -