Re: [PATCH 1/1] staging: cleanup: Fix incompatible type comparison in wilc1000/host_interface.c

2015-12-02 Thread Mario J. Rugiero
OK. Since the maintainers are CC'd, I guess I should wait for a clarification about this? El 02/12/15 a las 10:29, Dan Carpenter escribió: Put v2 in the subject. Also the subsystem prefix is: [PATCH v3] staging: wilc1000: ... On Mon, Nov 30, 2015 at 09:09:04PM -0300, Mario J. Rugiero wrote:

[PATCH 5/5] staging/rdma/hfi1: Add page lock limit check for SDMA requests

2015-12-02 Thread ira . weiny
From: Mitko Haralanov The driver pins pages on behalf of user processes in two separate instances - when the process has submitted a SDMA transfer and when the process programs an expected receive buffer. When pinning pages, the driver is required to observe the

[PATCH 4/5] staging/rdma/hfi1: Detect SDMA transmission error early

2015-12-02 Thread ira . weiny
From: Mitko Haralanov It is possible for an SDMA transmission error to happen during the processing of an user SDMA transfer. In that case it is better to detect it early and abort any further attempts to send more packets. Reviewed-by: Ira Weiny

[PATCH 3/5] staging/rdma/hfi1: Clean-up unnecessary goto statements

2015-12-02 Thread ira . weiny
From: Mitko Haralanov Clean-up unnecessary goto statements based on feedback from the mailing list on previous patch submissions. Reviewed-by: Ira Weiny Signed-off-by: Mitko Haralanov ---

[PATCH 1/5] staging/rdma/hfi1: Convert to use get_user_pages_fast

2015-12-02 Thread ira . weiny
From: Mitko Haralanov Convert hfi1_get_user_pages() to use get_user_pages_fast(), which is much fatster. The mm semaphore is still taken to update the pinned page count but is for a much shorter amount of time. Signed-off-by: Mitko Haralanov

[PATCH 0/5] staging/rdma/hfi1: Clean up SDMA engine code

2015-12-02 Thread ira . weiny
From: Ira Weiny Various improvements to the SDMA engine code. Mitko Haralanov (5): staging/rdma/hfi1: Convert to use get_user_pages_fast staging/rdma/hfi1: Unconditionally clean-up SDMA queues staging/rdma/hfi1: Clean-up unnecessary goto statements

[PATCH 2/5] staging/rdma/hfi1: Unconditionally clean-up SDMA queues

2015-12-02 Thread ira . weiny
From: Mitko Haralanov There is no need to cleck if the packet queue is allocated when cleaning up a user context. The hfi1_user_sdma_free_queues() function already does all the required checks. Reviewed-by: Ira Weiny Signed-off-by: Mitko

[PATCH] staging: sm750fb: Fix comments style

2015-12-02 Thread sebastian . lawniczak
From: Sebastian Lawniczak Fix warnings reported by checkpatch.pl in block comments. Signed-off-by: Sebastian Lawniczak --- drivers/staging/sm750fb/ddk750_chip.c | 70 +++ 1 file changed, 39

[PATCH v3 bis 12/25] mtd: nand: use the mtd instance embedded in struct nand_chip

2015-12-02 Thread Boris Brezillon
struct nand_chip now embeds an mtd device. Patch all drivers to make use of this mtd instance instead of using the instance embedded in their private struct or dynamically allocated. Signed-off-by: Boris Brezillon Cc: Julia Lawall ---

[PATCH v3 17/25] mtd: nand: remove useless mtd->priv = chip assignments

2015-12-02 Thread Boris Brezillon
mtd_to_nand() now uses the container_of() approach to transform an mtd_info pointer into a nand_chip one. Drop useless mtd->priv assignments from NAND controller drivers. Signed-off-by: Boris Brezillon --- Patch generated with the following coccinelle script:

Re: [PATCH v2 17/25] mtd: nand: remove useless mtd->priv = chip assignments

2015-12-02 Thread Boris Brezillon
Hi Brian, On Tue, 1 Dec 2015 14:17:47 -0800 Brian Norris wrote: > On Tue, Dec 01, 2015 at 12:03:14PM +0100, Boris Brezillon wrote: > > mtd_to_nand() now uses the container_of() approach to transform an > > mtd_info pointer into a nand_chip one. Drop useless

[PATCH 2/6] staging: rtl8188eu: don't cast to void* when calling memset()

2015-12-02 Thread Luca Ceresoli
The first argument to memset() is (void *), the explicit typecasts are not needed. They just make code less readable. Signed-off-by: Luca Ceresoli Cc: Larry Finger Cc: Greg Kroah-Hartman ---

[PATCH 5/6] staging: rtl8188eu: rename camelcase bAcceptAddbaReq

2015-12-02 Thread Luca Ceresoli
There is such a field both in struct mlme_ext_info and in struct registry_priv. Rename both. Also fix checkpatch issue in the lines touched: WARNING: line over 80 characters Signed-off-by: Luca Ceresoli Cc: Larry Finger Cc: Greg Kroah-Hartman

[PATCH 6/6] staging: rtl8188eu: rtw_mlme_ext.c: simplify call to issue_action_BA()

2015-12-02 Thread Luca Ceresoli
Using the ternary operator allows to more concisely write the same code, and to stay within 80 characters without even increasing the number of lines. Signed-off-by: Luca Ceresoli Cc: Larry Finger Cc: Greg Kroah-Hartman ---

[PATCH 1/6] staging: rtl8188eu: add spaces around binary '*'

2015-12-02 Thread Luca Ceresoli
Fix checkpatch issue: CHECK: spaces preferred around that '*' (ctx:VxV) Signed-off-by: Luca Ceresoli Cc: Larry Finger Cc: Greg Kroah-Hartman --- drivers/staging/rtl8188eu/core/rtw_efuse.c | 4 ++-- 1 file changed, 2

[PATCH 3/6] staging: rtl8188eu: rtw_mlme_ext.c: remove commented code

2015-12-02 Thread Luca Ceresoli
This line is connented since the initial import in commit 7b464c9fa5cc ("staging: r8188eu: Add files for new driver - part 4") and there's no comment stating how it could ever be useful. Signed-off-by: Luca Ceresoli Cc: Larry Finger Cc: Greg

[PATCH 4/6] staging: rtl8188eu: remove useless variable rtw_AcceptAddbaReq

2015-12-02 Thread Luca Ceresoli
rtw_AcceptAddbaReq is a static variable, it is set once and never modified. It is referenced only once, to assign its value to a member of struct registry_priv with practically the same name. Get rid of the variable, and move the meaningful part of the comment near the declaration of the relevant

RE: [PATCH v6 0/7] PCI: hv: New paravirtual PCI front-end for Hyper-V VMs

2015-12-02 Thread Jake Oshins
> -Original Message- > From: ja...@microsoft.com [mailto:ja...@microsoft.com] > Sent: Monday, November 2, 2015 1:33 PM > To: gre...@linuxfoundation.org; KY Srinivasan ; linux- > ker...@vger.kernel.org; de...@linuxdriverproject.org; o...@aepfle.de; > a...@canonical.com;

Attention Please!,

2015-12-02 Thread UNITED NATION.
Attention Please!, This is to official inform you that we have been having meetings for the past Three (3) Weeks which ended two days ago with Mr. Jim Yong Kim the World Bank president and other seven continent presidents on the Congress we treated on solution to Scam victim problems.

Re: [PATCH v6 4/7] PCI: Add fwnode_handle to pci_sysdata

2015-12-02 Thread Jiang Liu
On 2015/11/3 5:33, ja...@microsoft.com wrote: > From: Jake Oshins > > This patch adds an fwnode_handle to struct pci_sysdata, which is > used by the next patch in the series when trying to locate an > IRQ domain associated with a root PCI bus. > > Signed-off-by: Jake Oshins

Re: [PATCH v6 7/7] PCI: hv: New paravirtual PCI front-end for Hyper-V VMs

2015-12-02 Thread Jiang Liu
On 2015/11/3 5:33, ja...@microsoft.com wrote: > From: Jake Oshins > > This patch introduces a new driver which exposes a root PCI bus whenever a PCI > Express device is passed through to a guest VM under Hyper-V. The device can > be single- or multi-function. The interrupts

Re: [PATCH 19/40] staging: lustre: copy out libcfs ioctl inline buffer

2015-12-02 Thread Dan Carpenter
On Fri, Nov 20, 2015 at 06:35:55PM -0500, James Simmons wrote: > From: Liang Zhen > > - libcfs_ioctl_popdata should copy out inline buffers. > - code cleanup for libcfs ioctl handler > - error number fix for obd_ioctl_getdata > - add new function libcfs_ioctl_unpack

END OF YEAR PACKAGE

2015-12-02 Thread Telekom Malaysia Berhad
Telekom Malaysia Berhad G.03B, Ground Floor, Kompleks Antarabangsa, Jln Sultan Ismail, Off Jalan Ampang 50088 50250 Kuala Lumpur. NOTIS RASMI HADIAH TELEKOM MALAYSIA Pihak Telekom Malaysia @Program Kemenangan yang telah diadakan pada 1 Dec 2015 di mana alamat email anda yang disertakan

Re: [PATCH 14/40] staging: lustre: fix crash due to NULL networks string

2015-12-02 Thread Dan Carpenter
This feels like we are fixing a bug introduce in PATCH 11 when we removed a NULL check. Don't introduce bugs and then fix them in the same patchset; the fix has to be folded into the original patch. regards, dan carpenter ___ devel mailing list

Re: [PATCH 20/40] staging: lustre: fix kernel crash when network failed to start

2015-12-02 Thread Dan Carpenter
Fold this into the original patch. (Which you're going to have to redo anyway to fix the other bug and because of the GW-BASIC label names). regards, dan carpenter ___ devel mailing list de...@linuxdriverproject.org

Re: [PATCH 21/40] staging: lustre: improve LNet clean up code and API

2015-12-02 Thread Dan Carpenter
Actually we're going to have to redo so much code that it's not worth it for me to review the rest of these patches. Please just look over everything again: BAD: return -1; GOOD: return -EINVAL; BAD: failed0: GOOD: free_something: BAD: if (rc != 0) GOOD: if (rc) Do one thing per

Re: [PATCH 14/15] staging: unisys: fix alignment in visornic_main.c

2015-12-02 Thread Dan Carpenter
On Mon, Nov 30, 2015 at 02:46:14PM -0500, Benjamin Romer wrote: > @@ -1651,7 +1651,7 @@ service_resp_queue(struct uiscmdrsp *cmdrsp, struct > visornic_devdata *devdata, >* netif_wake_queue() >*/ > if

Re: [PATCH 1/1] staging: cleanup: Fix incompatible type comparison in wilc1000/host_interface.c

2015-12-02 Thread Dan Carpenter
Put v2 in the subject. Also the subsystem prefix is: [PATCH v3] staging: wilc1000: ... On Mon, Nov 30, 2015 at 09:09:04PM -0300, Mario J. Rugiero wrote: > This patch replaces an "if (ptr > 0)" comparison that seems to be a > confusing way to check for null by a simpler "if (ptr)" check. > >

Re: [lustre-devel] [PATCH 21/40] staging: lustre: improve LNet clean up code and API

2015-12-02 Thread Dan Carpenter
On Wed, Dec 02, 2015 at 04:20:59PM +0300, Alexander Zarochentsev wrote: > > BAD: if (rc != 0) > > GOOD: if (rc) > > The latest suggestion is not correct, > from http://wiki.lustre.org/Lustre_Coding_Guidelines : > Conditional boolean (if (expr)), scalar (if (val != 0)) and pointer > (if (ptr