Re: Re: [PATCH v3] staging/android/ion : fix a race condition in the ion driver

2016-03-01 Thread EunTaik Lee
> From: Laura Abbott [mailto:labb...@redhat.com] > Sent: Friday, February 26, 2016 7:12 AM > To: eun.taik@samsung.com; gre...@linuxfoundation.org; a...@android.com; > riandr...@android.com; sumit.sem...@linaro.org; dan.carpen...@oracle.com; > Rohit Kumar ;

[staging:staging-next 1186/1234] drivers/staging/lustre/lustre/llite/file.c:2749:7: error: 'F_SETLKW64' undeclared

2016-03-01 Thread kbuild test robot
tree: https://git.kernel.org/pub/scm/linux/kernel/git/gregkh/staging.git staging-next head: 5a9ff74d8e681f9ac6af6cc1444a812b74e7c2de commit: caa88c26575c9be856e5a801abd121d7ff0808f8 [1186/1234] staging/lustre: F_SETLKW64 F_SETLK64 F_GETLK64 are always defined config: alpha-allmodconfig

[PATCH 2/2 v2] staging: dgnc: use tty_alloc_driver instead of kcalloc

2016-03-01 Thread Daeseok Youn
the tty_alloc_driver() can allocate memory for ttys and termios. And also it can release allocated memory easly with using put_tty_driver(). Signed-off-by: Daeseok Youn --- v2 : typo in subject, changed from dgap to dgnc drivers/staging/dgnc/dgnc_tty.c | 86

CISCO AND AVAYA IP Phones

2016-03-01 Thread Laison Computech Inc
Hi, Clean tested working pulls CPUs and QTYs in stock. 115 X X5650 65 X E5410 75 X X5660 145 X E5530 100 X E5645 40 X X5680 75 X X5690 Brand new sealed IP phones and QTYs in stock. 55 x CP-7937G 77 x CP-7942G 54 x CP-7945G 75 x CP-7962G .. 45 x Avaya 9630 65 x Avaya 9641 55 x Avaya 9640

[PATCH 1/3] staging: unisys: visorbus: fix payload memory usage in controlvm channel

2016-03-01 Thread David Kershner
From: Tim Sell Previously if controlvm message payloads (indicated in controlvm message via struct controlvm_message.hdr.payload_vm_offset) were contained within the bounds of the channel memory, we would fail to process any controlvm message that contained payload data.

[PATCH 2/3] staging: unisys: visorbus: tolerate larger-than-expected controlvm channel

2016-03-01 Thread David Kershner
From: Tim Sell Use the dynamic size of the controlvm channel (struct channel_header.size) instead of the statically computed sizeof(struct controlvm_channel) when determining the valid bounds for visorchannel_read() and visorchannel_write(). This prevents an observed

[PATCH 0/3] staging: unisys: fix kdump with Unisys s-Par virtual storage

2016-03-01 Thread David Kershner
This patchset fixes an issue when visorhba device serves as a kdump target, e.g., to provide the dumping filesystem for /var/crash/ when running a crash kernel (is_kdump_kernel()). Tim Sell (3): staging: unisys: visorbus: fix payload memory usage in controlvm channel staging: unisys:

[PATCH 3/3] staging: unisys: visorbus: allow visorhba device to be used for kdump

2016-03-01 Thread David Kershner
From: Tim Sell This patch saves off the create_bus and create_device controlvm messages for the visorhba device, so that they can be resurrected and used in the kdump kernel. After this patch, a crash dump can be generated using: # service kdump start # echo 1

Re: [PATCH RESEND v3 5/6] staging/rdma/hfi1: adding per SDMA engine stats to hfistats

2016-03-01 Thread Jubin John
> > diff --git a/drivers/staging/rdma/hfi1/sdma.c > > b/drivers/staging/rdma/hfi1/sdma.c > > index 1d38be5..cb66bd0 100644 > > --- a/drivers/staging/rdma/hfi1/sdma.c > > +++ b/drivers/staging/rdma/hfi1/sdma.c > > @@ -1061,7 +1061,6 @@ int sdma_init(struct hfi1_devdata *dd, u8 port) > >

[RFC PATCH 2/2] staging: iio: adc7192: use iio_{claim|release}_direct_mode()

2016-03-01 Thread Alison Schofield
Replace the code that guarantees the device stays in direct mode with iio_{claim|release}_direct_mode() which does same. Signed-off-by: Alison Schofield --- drivers/staging/iio/adc/ad7192.c | 24 +--- 1 file changed, 9 insertions(+), 15 deletions(-)

[RFC PATCH 1/2] iio: core: implement iio_{claim|release}_direct_mode()

2016-03-01 Thread Alison Schofield
It is often the case that the driver wants to be sure a device stays in direct mode while it is executing a task or series of tasks. To accomplish this today, the driver performs this sequence: 1) take the device state lock, 2)verify it is not in a buffered mode, 3) execute some tasks, and 4)

[RFC PATCH 0/2] iio: introduce iio_{claim|release}_direct_mode()

2016-03-01 Thread Alison Schofield
This patchset introduces two helper functions to simplify driver code requiring the device to be locked in direct mode during execution of a code path. The staging driver ad7192 is updated to demonstrate usage. This could be applied to approximately 18 known cases where the driver is holding the

[PATCH] Staging: vt6655: remove unnecessary blank lines from card.c

2016-03-01 Thread Ben Marsh
This a patch to card.c to remove unnecessary blank lines in order to remove a checkpatch.pl warning. Signed-off-by: Ben Marsh --- drivers/staging/vt6655/card.c | 4 1 file changed, 4 deletions(-) diff --git a/drivers/staging/vt6655/card.c

Re: [PATCH] staging: rtl8723au: Fix line longer than 80 columns.

2016-03-01 Thread Edward Lipinsky
On Sat, Feb 27, 2016 at 10:48:56AM -0800, Joe Perches wrote: > On Sat, 2016-02-27 at 10:28 -0800, Edward Lipinsky wrote: > > This patch fixes the checkpatch.pl warning: > > WARNING: line over 80 characters > [] > > diff --git a/drivers/staging/rtl8723au/core/rtw_ap.c > >

Re: [PATCH net-next] hv_netvsc: add ethtool support for set and get of settings

2016-03-01 Thread Ben Hutchings
On Mon, 2016-02-29 at 17:50 -0500, David Miller wrote: > From: Ben Hutchings > Date: Mon, 29 Feb 2016 22:34:38 + > > > On Mon, 2016-02-29 at 17:09 -0500, David Miller wrote: > >> From: Simon Xiao > >> Date: Thu, 25 Feb 2016 15:24:08 -0800 > >>  >

[PATCH v2 0/3] staging: rtl8723au: use list_first_entry*

2016-03-01 Thread Geliang Tang
On Mon, Feb 22, 2016 at 09:39:15PM -0500, Jes Sorensen wrote: > Geliang Tang writes: > > Use list_first_entry*() instead of container_of() to simplify the code. > > > > Signed-off-by: Geliang Tang > > --- > > drivers/staging/rtl8723au/core/rtw_recv.c |

[PATCH v2 3/3] staging: rtl8723au: core: rtw_recv: use list_first_entry()

2016-03-01 Thread Geliang Tang
Use list_first_entry() instead of container_of() to simplify the code. Signed-off-by: Geliang Tang Acked-by: Jes Sorensen --- drivers/staging/rtl8723au/core/rtw_recv.c | 5 ++--- 1 file changed, 2 insertions(+), 3 deletions(-) diff --git

Re: [PATCH RESEND v3 5/6] staging/rdma/hfi1: adding per SDMA engine stats to hfistats

2016-03-01 Thread Doug Ledford
On 01/11/2016 06:30 PM, Jubin John wrote: > From: Vennila Megavannan > > Added the following per sdma engine stats: > - SendDmaDescFetchedCnt > - software maintained count of SDMA interrupts >(SDmaInt, SDmaIdleInt, SDmaProgressInt) > - software

[PATCH] staging: rtl8723au: fix static checker warning

2016-03-01 Thread Geliang Tang
Fix the following static checker warning: drivers/staging/rtl8723au/core/rtw_sta_mgt.c:365 rtw_get_stainfo23a() error: potential NULL dereference 'psta'. Fixes: e280d71("staging: rtl8723au: use list_for_each_entry*()") Signed-off-by: Geliang Tang ---

[PATCH v5 5/5] staging/android: add flags member to sync ioctl structs

2016-03-01 Thread Gustavo Padovan
From: Gustavo Padovan Play safe and add flags member to all structs. So we don't need to break API or create new IOCTL in the future if new features that requires flags arises. v2: check if flags are valid (zero, in this case) v3: return -EINVAL if flags are

[PATCH v5 2/5] staging/android: rename SYNC_IOC_FENCE_INFO

2016-03-01 Thread Gustavo Padovan
From: Gustavo Padovan We don't use the 'fence' name to refer to sync_file anymore. So rename it to SYNC_IOC_FILE_INFO. Signed-off-by: Gustavo Padovan Reviewed-by: Maarten Lankhorst ---

[PATCH v5 3/5] staging/android: remove redundant comments on sync_merge_data

2016-03-01 Thread Gustavo Padovan
From: Gustavo Padovan struct sync_merge_data already have documentation on top of the struct definition. No need to duplicate it. Signed-off-by: Gustavo Padovan Reviewed-by: Maarten Lankhorst

[PATCH v5 4/5] staging/android: refactor SYNC_IOC_FILE_INFO

2016-03-01 Thread Gustavo Padovan
From: Gustavo Padovan Change SYNC_IOC_FILE_INFO behaviour to avoid future API breaks and optimize buffer Now num_fences can be filled by the caller to inform how many fences it wants to retrieve from the kernel. If the num_fences passed is greater than zero

[PATCH v5 1/5] staging/android: add num_fences field to struct sync_file_info

2016-03-01 Thread Gustavo Padovan
From: Gustavo Padovan Inform userspace how many fences are in the sync_fence_info field. Signed-off-by: Gustavo Padovan Reviewed-by: Maarten Lankhorst --- drivers/staging/android/sync.c

Re: [PATCH] staging/android: refactor SYNC_IOC_FILE_INFO

2016-03-01 Thread Gustavo Padovan
Hi Maarten, 2016-03-01 Maarten Lankhorst : > Op 29-02-16 om 23:08 schreef Gustavo Padovan: > > Hi Maarten, > > > > 2016-02-29 Maarten Lankhorst : > > > >> Op 26-02-16 om 22:00 schreef Gustavo Padovan: > >>> From: Gustavo

Re: [PATCH v4 1/5] staging/android: add num_fences field to struct sync_file_info

2016-03-01 Thread Gustavo Padovan
2016-03-01 Dan Carpenter : > This breaks userspace. You used to be able to figure it out from > info->len - sizeof(struct sync_file_info). It does. We are breaking this on purpose to clean up the API for de-staging. Gustavo

[PATCH] Staging: slicoss: changes comparisons to NULL in slicoss.c

2016-03-01 Thread Ben Marsh
This is a patch to slicoss.c to change the style of NULL comparisons in order to remove checkpatch.pl warnings. Signed-off-by: Ben Marsh --- drivers/staging/slicoss/slicoss.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git

[PATCH] Staging: slicoss: removes unnecessary blank lines in slicoss.c

2016-03-01 Thread Ben Marsh
This is a patch to slicoss.c to remove unnecessary blank lines as found by checkpatch.pl Signed-off-by: Ben Marsh --- drivers/staging/slicoss/slicoss.c | 2 -- 1 file changed, 2 deletions(-) diff --git a/drivers/staging/slicoss/slicoss.c b/drivers/staging/slicoss/slicoss.c

[PATCH] Staging: slicoss: change memory allocation style in slicoss.c

2016-03-01 Thread Ben Marsh
This is a patch to slicoss.c to change the memory allocation style in slicoss.c as found by checkpatch.pl Signed-off-by: Ben Marsh --- drivers/staging/slicoss/slicoss.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/slicoss/slicoss.c

[PATCH] Staging: slicoss: changes the style of memory allocation in slicoss.c

2016-03-01 Thread Ben Marsh
This is a patch to slicoss.c to change the memory allocation style as identified by checkpatch.pl Signed-off-by: Ben Marsh --- drivers/staging/slicoss/slicoss.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/staging/slicoss/slicoss.c

Re: [PATCH] staging/android: refactor SYNC_IOC_FILE_INFO

2016-03-01 Thread Maarten Lankhorst
Op 29-02-16 om 23:08 schreef Gustavo Padovan: > Hi Maarten, > > 2016-02-29 Maarten Lankhorst : > >> Op 26-02-16 om 22:00 schreef Gustavo Padovan: >>> From: Gustavo Padovan >>> >>> Change SYNC_IOC_FILE_INFO behaviour to avoid